Troubleshooting a T1 or E1 Interface Using a Loopback Test

Version 7

    While high-speed, efficient, and low price Ethernet and fiber lengths have started to become more of the norm in modern networks, the T1 link is still commonplace at many businesses because of its advantages over Ethernet. A T1 interface provides guaranteed bandwidth and does not have the distance limitations of other protocols making it ideal for certain networks.

     

    When a T1 connection does not seem to be working properly, the most efficient way to troubleshoot the router's physical T1 interface is to run a T1 Loopback Test. By running a quasi-random pattern through the T1 interface, a user can see with certainty if the unit is functioning properly while segmented from the rest of the T1 connection from the provider.

     

    It is recommended that prior to using this document, you read the document Troubleshooting Layer 2 Protocols over T1 with CLI to make sure you understand what types of problems with a T1 warrant consideration of the ADTRAN hardware as a possible issue. If provisioning a T1 connection for the first time, please see the Useful Links section of this document to find the proper document to verify your configuration. If you would like to a video demonstrating the troubleshooting steps in this document, please see [video] - AOS T1 Testing and Troubleshooting.

     

    Note: The E1 is a international equivalent of the T1 interface with some slight differences. However, this document does also apply to the E1 as well provided you substitute the "T1" in the commands given with "E1".

     

    Sections Included in this Document

     

    Hardware and Software Requirements

    Equipment Needed to Perform Loopback Test

    Performing the Loopback Test Using the CLI

    Actions to Take Based on Test Results

    Useful Links

     

     

    Hardware and Software Requirements


    The T1 Loopback test is only relevant to units utilizing a T1 or E1 interface that has been inserted into a Network Interface Module (NIM) slot or a built in T1 interface on a Total Access or NetVanta 6000 Series unit.. Please see the AOS Feature Matrix - Product Feature Matrix for products that support a NIM interface or built in T1 modules.


    Equipment Needed to Perform Loopback Test


    A loopback test is performed by sending a quasi-random test pattern from the router and looping it physically back to its own receive lines. To perform this test, a T1 "loopback plug" is required. One can be made from a piece of Ethernet cable using the Loopback Adapters and Crossover Cables for T1 and DDS Circuits document. If this is not possible, you can contact ADTRAN Technical Support and a loopback plug can be provided.


    Performing the Loopback Test Using the CLI


    The T1 Loopback test can only be administered using the CLI. However, it is considered beginner level as it only requires a few simple commands. For help accessing the AOS unit's CLI, please see the Accessing the Command Line Interface in AOS.



    To run the T1 loopback test, you will need to unplug the T1 connection from the network, meaning that any services that use it will be down for the entirety of the testing. If you have multiple T1s linked together in the same PPP or Frame-relay bundle, this will just result in loss in the bandwidth of the individual T1 you are testing and not your entire network connection.


    Before beginning the test, use the show run interface t1 <slot/port> command to view the current clock setting on the interface. This may need to be changed during the loopback test so it is important to take note of the setting before starting the test as to make sure it is set back correctly afterward. If this is not done, the T1 interface could take errors from clock-slips or clock mismatching between the separate ends of the T1 connection. This command is shown below:


    #show run interface t1 1/1

    Building Configuration

    !

    !

    interface t1 1/1

    tdm-group 1 timeslots 1-24 speed 56

    clock source line

    no shutdown

    !

    !


    Notice in the above output, the clock source is set to line. In this example, this would need to be set back to line after the completion of the test.


    Note: If you do not know the <slot> and <port> numbers in the above command, examine the back of your unit. Slots are numbered left to right and the ports are numbered left to right on the individual NIMs in each slot. On Total Access Units and NetVanta 6000 Units, these ports are built in by default. Therefor the slot will always be "0".



    Before beginning the test, insert the connector coming out of the T1 port on the back of the unit into the loopback plug you created or received. Once it is connected, you should see the associated light for the T1 (this will either be a "net" light or a "wan" light) turn Green. On the CLI, you should see an event (if events are enabled) showing the T1 interface coming up. If you do not, there could be a problem with the loopback piece. If the T1 was not coming up at all with the normal T1 connection inserted, provided the loopback piece is wired correctly, this could mean the T1 interface is not functioning properly.


    Once the T1 is up with the loopback plug inserted, enter configuration mode using the configuration terminal command while in privileged mode as shown below:


    #configure terminal

    (config)#


    If your prompt now ends with (config)# you are properly in configuration mode. Now enter the T1 interface configuration mode using the interface t1 <slot/port> command as shown below:


    (config)#interface t1 1/1

    (config-t1 1/1)#


    You should see the prompt above after entering the command.  Now, change the clock source to "internal" using the clock source internal command.


    (config-t1 1/1)#clock source internal

    (config-t1 1/1)#

     

    Now enter the following commands to initiate the test pattern and clear the current results so that the output from the test is relevant.

     

    (config-t1 1/1)#test-pattern qrss

    (config-t1 1/1)#test-pattern clear

     

    After entering the above commands you should see an event stating the T1 is now in "test mode" assuming events are enabled. The test is now running. To see results, use the test-pattern errors command.

     

    (config-t1 1/1)#test-pattern errors

    Qrss Errored Seconds: 0

     

    Some Errored Seconds may be incremented above when the test is initiated. If the output increments over time this means there may be a hardware issue with the T1 interface and ADTRAN Technical Support needs to be consulted.

     

    If the output is "0", continue letting the test run for up to 10 minutes while checking the errors every minute to make sure the counter does not increment.  Once done with the test, continue to the section Resetting the Unit Back to Normal Operation.

     


    To reset the unit back to its normal operating condition, use the no test-pattern command to disable the testing sequence. Also, make sure to set the clock back to its original setting under the T1 interface. This is shown below:


    (config-t1 1/1)#no test-pattern

    (config-t1 1/1)#clock source line


    You should see an event showing the T1 changing back to the "UP" status. Once these commands have been entered, reattach the cable from the T1 interface back into the normal network connection.


    Actions to Take Based on Test Results


    If the above test showed errors on the T1 circuit or the T1 interface would not come up with the loopback piece inserted, please contact ADTRAN Technical Support for further examination. If the loopback test does not produce any errors, this means the local hardware is working properly. Further troubleshooting of cabling and/or an extended Demarc on-site may need to also be troubleshot. Please contact your T1 service provider for help in determining the issue you are experiencing and provide them with the results of this test.


    Useful Links


    For help provisioning a T1 using PPP, please see Configuring PPP in AOS.


    For help provision a T1 using Frame-relay, please see Configuring Frame-Relay in AOS Quick Start Guide


    For help creating a T1 loopback plug, please see Loopback Adapters and Crossover Cables for T1 and DDS Circuits


    For information on troubleshooting T1 circuits properly, please see Troubleshooting Layer 2 Protocols over T1 with CLI