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Server Configuration Guide

1.1  Introduction
This guide is written for installers to configure UC Server™ at the customer site. It 
assumes that you have experience installing and programming PBXs and voice mail 
systems. It does not assume extensive knowledge of computer networks.
Before you run the UC Server Configuration Wizard, make sure you follow all the 
instructions in the Objectworld Server Installation Guide, including running the 
Server Installation Wizard.
This guide covers the following main topics:
• Preparing to Start the Server Configuration Wizard
• Starting the Server Configuration Wizard

1.2  Preparing to Start the Server Configuration Wizard
Before you start the UC Server Configuration Wizard, you can further prepare your 
system by doing the following:
• Obtaining Network and Security Information
• Verifying Requirements and Recommendations
• Incorporating the Server into the Customer Domain
• Gathering Server Configuration Wizard Information
• Creating an Authorization Store to Enable Active Directory Roles

Obtaining Network and Security Information
Obtain network and server information from the customer prior to configuration, 
such as service accounts and administrative passwords.

NOTE: For Objectworld documents, see the Objectworld web site at 
www.objectworld.com/support/documentation.
Objectworld Unified Communications Server Standard Edition 1
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1 Server Configuration Guide
For security reasons, some customers might be reluctant to provide passwords and 
network information in this manner. If that is the case, the customer should make 
sure that this information is readily available when you arrive on site to do the 
configuration.

Verifying Requirements and Recommendations
The UC Server application runs on the following operating systems:
• Microsoft Windows Server 2008 (x86, x64)

• Deployment on Server Core or Hyper-V is not supported.
• Microsoft Windows Server 2003 R2 SP2
• Microsoft Windows Server 2003 SP1, SP2
• Microsoft Windows Small Business Server 2003 SP1 or later SP
• Microsoft Windows XP Professional SP2 or later SP

To ensure security, UC Server accounts are given minimal permissions on the 
computer. The Server must be installed onto an NTFS partition on this server 
computer to make sure that proper security is in place.

The Exchange Server and UC Server computer must be members of the same 
Windows domain.
Consult the UC Server support website for additional up-to-date application or 
configuration notes.

Incorporating the Server into the Customer Domain
Incorporating the UC Server into the customer domain is required for Active 
Directory and Microsoft Exchange integration.

To incorporate the UC Server

1 On the desktop, right-click My Computer.

2 Click Properties.

3 Select the Computer Name tab.

4 Click the Change... button.

5 In the Member of section, select Domain, and enter the domain name.

NOTE: It is not recommended that you run UC Server and the 
Exchange Server on the same system.

NOTE: You require a domain administrator user name and password 
to complete this procedure.
2 Objectworld Unified Communications Server Standard Edition



Preparing to Start the Server Configuration Wizard
Gathering Server Configuration Wizard Information
The UC Server Configuration Wizard provides a step-by-step guide for configuring 
your server. The Server Configuration Wizard is customized to configure the server 
according to the needs of your particular network configuration.
It is recommended that you have the information ready that you might need before 
you start the wizard. You need to know the following:

Creating an Authorization Store to Enable Active Directory Roles

The authorization store is typically created prior to running the Server Configuration 
Wizard.

Message store type Local only or
Local and Exchange or
Lotus Notes/IMAP

Computer names Includes Networking information and computer 
names

Server Account The dedicated account for running the Server
Microsoft Exchange names Microsoft Exchange Server computer name

Mailbox name for Service Account
UC Server administrator 
password

The password that is used to configure the 
system. The default administrator login name is 
“admin.”

PBX type Avaya Communication Manager or DEFINITY, 
Merlin Magix, Nortel Norstar, IP Office or generic 
analog

CTI link options
(Merlin Magix)

Used to configure advanced PBX integration for 
calling line ID

Port Name and Identity Used to configure all the ports that are connected 
to the PBX

User information Used to create and configure all the user accounts
E-mail configuration Used to configure the services when sending 

notification by e-mail. If you do not have 
Exchange, you can configure an SMTP Server for 
e-mail notification.

NOTE: Creating an authorization store is an optional step that applies 
to UC Server installations that are integrated with Active Directory. You 
can skip this step if you are configuring UC Server as stand-alone.
Objectworld Unified Communications Server Standard Edition 3
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The following conditions must be satisfied in order to create an authorization store:
• The UC Server computer platform must be integrated with the customer’s 

network.
• The UC Server Active Directory account must already be created on the 

customer’s domain.
• The user creating the authorization must be authenticated with the domain.

If users were already created prior to creating an authorization, the administrator 
must assign a role to each configured Windows User. Users added after the 
authorization store is created have a default role “Standard User” assigned to their 
user profile.

To create an authorization store

1 Log in to the UC Server computer as a domain administrator.

2 Click Start > Run > CMD to launch a CMD window.

3 Navigate to the UC Server installation directory:
\Objectworld\UC Server\bin

4 Type the following:
manageazman +createxmlstore +admin <DOMAIN>\<UC 
SERVER SERVICE ACCOUNT>

5 Stop and restart the UC Server application service by doing the following:
• Open the service control panel application.
• Restart the service named Objectworld UC Server Application Services.

NOTE: If you have already followed the instructions in the UC Server 
Planning and Deployment Guide for creating an authorization store, 
then you do not need to repeat the same steps below.

NOTE: You can create the custom authorization store at any time, 
before, during or after installation. However, any Active Directory users 
and their associated authentications will have to be modified to include 
a role from the role list. Consult the UC Server Administrator Guide for 
details on how to change the authentication role for individual user 
authentications.
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Starting the Server Configuration Wizard
1.3  Starting the Server Configuration Wizard

Login Requirements
Make sure that a computer account is created in the customer’s network. If you are 
integrating with Microsoft Exchange, make sure that you are logged on as a domain 
user that has:
• Domain administrator privileges—must be able to add users to the domain
• Exchange Server administrator privileges—must be able to create mailboxes and 

set permissions on the Exchange server

Server Configuration Wizard Overview
The Server Configuration Wizard consists of several wizards that each become 
available after the successful completion of the previous wizard. The wizards are 
listed below:

1 Product Licensing Wizard — enter your product and license key information

2 Windows Network Integration Wizard — configure Windows Firewall, 
service account, and service connection point

3 Communication Systems Wizard — configure your communications systems

4 Messaging Systems — select message store type and configure account

5 Users — add new or import existing users

6 Final System Configuration — configure e-mail notification system; create 
default user, operator and default mailbox; specify dialing rules and location

To start the Server Configuration Wizard
• Click Windows Start > Programs > Objectworld UC Server > Server 

Configuration Wizard.
The main wizard screen guides you through the rest of the configuration.

Product Licensing Wizard
Run this wizard to specify your product and license key information for UC Server. 
You can paste the product and license key, and the machine ID, into the appropriate 
wizard boxes. The product key is shipped with the product CD.

NOTE: The view of the UC Server Configuration Wizard changes after 
entering a license key for UC Server Standard Edition, as only those 
items applicable to the Standard edition are visible.
Objectworld Unified Communications Server Standard Edition 5
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Windows Network Integration Wizard
You can configure your Windows account to work with UC Server. Create a service 
account: assign permissions to the directory, and assign the account to UC Server.
Create a service connection point. A service connection point is an advertised name 
that can be used to locate UC Server. When you start UC Client for the first time, the 
service connection point contains the name and IP address of the UC Server. The 
user does not have to type a name, the name automatically appears in the list.

Communication Systems Wizard

You can define and configure new communication systems. Select a communication 
system type from the list provided. The communication systems listed have the 
required hardware and a valid license. You cannot create a communication system 
that is invalid. 
You can select an existing PBX, which you can connect to UC Server through a 
Dialogic Media Gateway. For a list of PBXs supported by Dialogic, and for gateway 
configuration information, see the Dialogic Web site at www.dialogic.com. For more 
information on configuring the gateway to connect UC Server to an existing PBX, 
see TN088 - Dialogic Media Gateway Configuration Guide, available from the 
Objectworld Web site at www.objectworld.com.
The options that are available depend on the communications system type selected, 
but may include configuring message waiting, configuring the CTI link, selecting 
and configuring ports, and selecting a network adapter for the communication 
services.
The Port Configuration page allows you to choose a device ID, to enable and attach 
a name and an extension number to.

Messaging Systems
Use the Messaging Systems Wizard to select a message store type, such as 
Exchange, IMAP, or SMTP, and to configure the message store account.

NOTE: Communication systems refers to PBXs.
6 Objectworld Unified Communications Server Standard Edition
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Starting the Server Configuration Wizard
Users
Use this wizard to add new users and import existing users from Active Directory, 
Microsoft Exchange Server, or from text files. The wizard allows you to select a 
location to import users from. You can also change user information before you 
create users. For more information see the following sections:
• Importing users from Active Directory
• Importing users from Exchange Server
• Importing users from text files

Importing users from Active Directory
You can select a group of users to import from Active Directory, and you can also 
automatically assign an extension number for each user. 

User naming convention
If you import users with a display name only, without specifying the first and last 
name, then users are imported as follows:
• If a display name is delimited with spaces, then the last 'word' is the last name, 

for example, "Bob Jeff Thompson"
lastname = Thompson
firstname = Bob Jeff

• If a display name is delimited with commas, then everything after the comma is 
the first name, for example, "Thompson, Bob J.”

lastname = Thompson
firstname = Bob J.

To import Active Directory users

1 From the drop-down list, select the Active Directory domain from which you 
want to import users.

2 Click Browse to search Containers on your system for the users that you want 
to import. 

3 If you specify a name prefix, the wizard imports users with names that begin 
with that prefix (this feature is not case sensitive). 

4 Enable the Create "Windows-enabled" Active Directory users check box if 
you want users to be able to use the single sign-on Active Directory feature.

5 Enable the Use Active Directory for messaging configuration check box to 
link users' mailboxes to their corresponding Exchange mailboxes.

NOTE: If you are importing a large number of users, the process takes 
some time, and a progress page shows you how many users have 
been found so far.
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To change users’ specifications
• To return the wizard to the specification page, click Stop search and refine 

criteria.

To stop importing users
• To stop the import, click Stop search and process users. 

The configuration page appears with only those users that were imported up to 
that point.

Importing users from Exchange Server

To import users from Exchange Server

1 From the list, select the location of the Microsoft Exchange Server from which 
you want to import users. 

2 If you specify a name prefix, the wizard imports users with names that begin 
with that prefix (this feature is not case sensitive). 
With the list of users, you can assign the Identities (typically extensions). The 
wizard extracts the first name and last name from the Exchange Server. The 
users are associated with the Personal Assistant (PA) user profile, and have the 
system operator as the default dial "0" location. 

3 Select whether you want the users that you are importing to be linked to Active 
Directory.

To change users’ specifications
• To return the wizard to the specification page, click Stop search and refine 

criteria.

To stop importing users
• To stop the import, click Stop search and process users. 

The configuration page appears with only those users that were imported up to 
that point.

NOTE: If you are importing a large number of users, the process takes 
some time, and a progress page shows you how many users have 
been found so far.
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Starting the Server Configuration Wizard
Importing users from text files
You can use Microsoft Excel to create a tab-separated text file to import Windows-
enabled or local users. A Windows-enabled user is associated with an Active 
Directory user, while a local user is not. Local users are configured to use local 
message store (LMS), while Windows-enabled users are configured to use Microsoft 
Exchange Server if one exists. Some fields are required and others are optional, 
depending on whether you're importing local or Active Directory users. 
For more information see the following sections:
• Importing local users from text files
• Importing Windows-enabled users from text files

Importing local users from text files
To import users, enter the information for each user in a tab-separated text file. The 
format of the tab-separated file must be similar to the following example, which 
shows all possible headings for local users. The order of the headings does not 
matter, and the headers are not case sensitive. To import local users, provide the 
displayname at a minimum.
Table 1–1: Tab-separated file format

TIP: For more information on importing users from text files, see 
TN094 - Importing Users to UC Server, available on the Objectworld 
Web site at www.objectworld.com. A corresponding zip file also 
includes a Microsoft Excel file for importing users.

displayname extension givenname sn userfax pbx answeringmode
First1 Last1 3000 First1 Last1 PA
First2 Last2 3001 First2 Last2 PBA
First3 Last3 3002 First3 Last3
Objectworld Unified Communications Server Standard Edition 9
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1 Server Configuration Guide
To create a tab-separated file for importing local users using Microsoft 
Excel

1 Create a Microsoft Excel spreadsheet that has some or all of the following 
headings. At a minimum, the DisplayName must be specified.

2 Enter the customer-provided information into the relevant headings.

3 In Microsoft Excel, click File > Save As.

4 Type a name for the file.

5 In the Save as type list, select Text (Tab delimited)(*.txt).

6 Click Save.

7 Close Excel.

To import the user text file

1 When you run the User Import Wizard, choose to import user information from 
a text-based file.

2 Click Browse to select the location of the file.

3 The following options are valid only for importing Windows-enabled users, so 
for local users the check boxes are disabled:
• Create “Windows-enabled” Active Directory users
• Use Active Directory for messaging configuration

displayname Name that appears in the Administration Users pane

extension Identity that is associated with the user. If this value is entered, 
it must be unique for each user, and cannot correspond to an 
existing identity.

givenname First name of the user

sn Last name of the user

userfax Incoming identity associated with DID fax. This is the fax 
number that callers dial to send faxes to the user. The user 
receives incoming faxes in their Inbox.

pbx Display name of the PBX that the user is associated with.

answeringmode Call answering mode, either PA for Personal Assistant or PBA 
for Personal Business Assistant. If no value is specified, then 
the user becomes a PA user by default. PA and PBA are not 
case sensitive.

NOTE: If you are importing a large number of users, the process takes 
some time, and a progress page shows you how many users have 
been found so far.
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Starting the Server Configuration Wizard
To stop importing users from a text file
• To return the wizard to the specification page, click Stop search and refine 

criteria.
• To stop the import, click Stop search and process users. The configuration 

page appears with only those users that were imported up to that point.

Importing Windows-enabled users from text files
To import Windows-enabled users, enter the information for each user in a tab- 
separated text file. For Windows-enabled users, the format of the tab-separated file 
headings must be similar to the following examples. The order of the headings does 
not matter, and the headers are not case sensitive. Include all of the required fields, 
and any of the optional fields that you want, into one file.
Table 1–2: Required fields for Windows-enabled users

Table 1–3: Optional fields for Windows-enabled users

displayname givenname sn legacyexchangedn objectguid objectsid userprincipalname

First1 Last1 First1 Last1
First2 Last2 First2 Last2
First3 Last3 First3 Last3

NOTE: If you do not include all the required information for a Windows-
enabled user, then a user will be imported as a local user instead.

extension userfax pbx answeringmode

3000 PA
3001 PBA
3002
Objectworld Unified Communications Server Standard Edition 11
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To create a tab-separated file for importing Windows-enabled users 
using Microsoft Excel

1 Create a Microsoft Excel spreadsheet that has the following headings (some are 
optional as noted above):

2 Enter the customer-provided information into the relevant headings.

3 In Microsoft Excel, click File > Save As.

4 Type a name for the file.

5 In the Save as type list, select Text (Tab delimited)(*.txt).

6 Click Save.

7 Close Excel.

To import the user text file

1 When you run the User Import Wizard, choose to import user information from 
a text-based file.

2 Click Browse to select the location of the file.

displayname Name that appears in the Administration Users pane

extension Identity that is associated with the user. If this value is 
entered, it must be unique for each user, and cannot 
correspond to an existing identity.

givenname First name of the user

sn Last name of the user

userfax Incoming identity associated with DID fax. This is the fax 
number that callers dial to send faxes to the user. The user 
receives incoming faxes in their Inbox.

pbx Display name of the PBX that the user is associated with. 

legacyexchangedn Identifying string for the user’s Exchange Server, as defined 
in Active Directory

objectguid GUID of the object in Active Directory

objectsid SID of the user in Active Directory, in S-1-5... format

userprincipalname The user e-mail address, for example, 
jmciverson@objectworld.com.

answeringmode Call answering mode, either PA for Personal Assistant or 
PBA for Personal Business Assistant. If no value is 
specified, then the user becomes a PA user by default. PA 
and PBA are not case sensitive.
12 Objectworld Unified Communications Server Standard Edition
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3 If you’ve included all the required field headings, then Create "Windows-
enabled" Active Directory users is enabled for users to be able to use the 
single sign-on Active Directory feature.

4 Enable the Use Active Directory for messaging configuration check box to 
link users' mailboxes to their corresponding Exchange mailboxes.

To stop importing users from a text file
• To return the wizard to the specification page, click Stop search and refine 

criteria.
• To stop the import, click Stop search and process users. The configuration 

page appears with only those users that were imported up to that point.

Final System Configuration
The Final System Configuration Wizard allows you to configure the e-mail 
notification system. You can use the wizard to create default users and operators, and 
default mailboxes. Run the wizard also to specify dialing rules and location.

NOTE: If you misspell, or omit, any of the required headers in the tab-
separated file, the check boxes noted above are unavailable and users 
can only be imported as local users.

NOTE: If you are importing a large number of users, the process takes 
some time, and a progress page shows you how many users have 
been found so far.
Objectworld Unified Communications Server Standard Edition 13
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Appendix A

2.1  Manually Configure Accounts and Permissions

Before the installer arrives at your site, ensure that the required files for the 
configuration have already been installed on the UC Server computer. 
The following sections describe the manual procedures for some tasks that are 
typically performed automatically by the UC Server Configuration Wizard. These 
procedures may be required to be performed manually, since there may be some 
information about your network and hardware that the wizard cannot determine 
automatically. The procedures are described below in case some manual 
configuration is required.
• Configuring the UC Server User Account
• Configuring the Exchange Server Account and Permissions

Configuring the UC Server User Account
The Server Configuration Wizard typically creates a new user account on the 
computer network for UC Server. If this was not done automatically, then follow the 
steps below to create the account manually.

To manually create a user account for UC Server on the local machine 
(UC Server is not part of a domain)

1 Right-click My Computer on the desktop.

2 Select Manage.

3 Select Local Users and Groups.

NOTE: The information in this appendix is intended as reference 
material for the network administrator.

NOTE: It is only necessary to follow the manual procedures below if 
the Server Configuration Wizard failed to do so automatically, or if you 
chose to do so manually in order to implement a custom configuration. 
Objectworld Unified Communications Server Standard Edition 15
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4 Right-click Users.

5 Select New User.

6 In the New User dialog, enter the required user account information. 
The User name can be “UC Server” or a name that you choose.

7 Click Create.

To manually create a user account for UC Server in Active Directory 
(UC Server is part of a domain)

1 Select Start > Programs > Administrative Tools > Active Directory Users 
and Computers.

2 In the left pane, select Users > Action > New > User.

3 In the New User dialog box, enter the required user account information. 
The Logon Name can be “UC Server” or a name that you choose.

4 Click Next.

5 Enter the user password information, and click Next.

6 If you have Exchange on the computer, enable Create an Exchange Mailbox.

7 Click Next, and then click Finish.

Configuring the Exchange Server Account and Permissions
The UC Server user account provides a separate security context that does not 
require administrative permissions on the local computer or in the Domain 
Administrators Active Directory group. 
The UC Server account’s administrative privileges are limited to Microsoft 
Exchange Server mailboxes. The account must access Exchange user mailboxes in 
an administrative capacity because it uses them to store and retrieve messages.
Follow the relevant instructions below for configuring Exchange Server 2007, or 
configuring Exchange Server 2003/2000.
• Configuring Exchange Server 2007
• Configuring Exchange Server 2003/2000
16 Objectworld Unified Communications Server Standard Edition



Manually Configure Accounts and Permissions
Configuring Exchange Server 2007
To create a mailbox logon to the Exchange Server 2007 console with a 
Windows account with Recipient Permissions

1 Select Start > Program > Exchange Server 2007 > Exchange Management 
Console. 

2 Navigate to Microsoft Exchange > Recipient Configuration. 

3 Right click on Mailbox and select New Mailbox. 

4 Select User Mailbox and click Next. 

5 Select New user and click Next. 

6 Enter the information for the new user, enable the option User must change 
password at next logon, and click Next.

7 Click Next again, and click New.

To grant permissions to the Exchange Server 2007 message store from 
UC Server

• Type the following script replacing <SERVICE_ACCOUNT> with the 
Service Account name:

Get-MailboxServer | Add-ADPermission -User <SERVICE_ACCOUNT> -
AccessRights GenericRead, GenericWrite -ExtendedRights Send-As, Receive-
As, ms-Exch-Store-Admin

Configuring Exchange Server 2003/2000

To create an Exchange mailbox for an existing account on Exchange 
Server 2003/2000

1 Select Start > Programs > Administrative Tools > Active Directory Users 
and Computers.

2 In the left pane, click Domain and select the Users folder.

NOTE: To integrate with Exchange Server 2007, A Microsoft Exchange 
Server MAPI client be installed on the UC Server platform to permit 
connection. Objectworld recommends using Microsoft Exchange 
Server MAPI Client and Collaboration Data Objects 1.2. Microsoft 
Outlook 2007 SP2 is not supported.

NOTE: The Exchange Role of “Server Data Permissions” is required 
when running the Server Configuration Wizard, in order to grant 
permissions to the Exchange Server 2007 message store from UC 
Server. If you do not have access to a Windows account with “Server 
Data Permissions,” then an Exchange Server Administrator must run 
the following script on the Exchange Server.
Objectworld Unified Communications Server Standard Edition 17
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3 In the right pane, right-click the UC Server account.

4 Select Exchange Tasks to start the Exchange Tasks Wizard.

5 From the list of tasks, select Create Mailbox.

6 Click Next, and then click Finish.

To manually set rights and privileges on Exchange Server 2003/2000 

1 Select Start > Programs > Microsoft Exchange > System Manager.

2 In the left pane of the Exchange System Manager window, select the Exchange 
Server that you want to integrate with.

3 Click Action > Properties to open the Exchange Server Properties dialog box.

4 Select the Security tab, and click Add to open the Select Users, Computer or 
Groups dialog box.

5 From the Look In list box, select each of the following:
• the Domain name
• the UC Server account name

6 Click Add, and then click OK.

7 From the Permissions: Allow Deny list box, select Full control for the account 
that was just added.

8 Make sure that Allow inheritable permissions from parent to propagate to 
this object is enabled.

9 Click OK and then close the Exchange System Manager window.
18 Objectworld Unified Communications Server Standard Edition



Configuration Guide — Feedback
2.2  Configuration Guide — Feedback

Note to the installer: 
Please take a moment to fill out this form by circling the appropriate number on the 
scale for each question.

1 Does this guide provide all the information that you need to do the 
configuration?

1 2 3 4 5 6
Yes No

2 Is the language of this guide easy to understand?
1 2 3 4 5 6
Yes No

3 Is the information presented in this guide technically accurate?
1 2 3 4 5 6
Yes No

4 Is it easy to find information in this guide?
1 2 3 4 5 6
Yes No

5 Does this document help you to do your job?
1 2 3 4 5 6
Yes No

Comments:

Return mail address:
Documentation/User Survey Fax: 613-599-7457
Objectworld Communications Corp.
308 Legget Drive 
Ottawa, Ontario
K2K 1Y6
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