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Conventions

Notes provide additional useful information.

Cautions signify information that could prevent service interruption or damage to 
equipment.

Warnings provide information that could prevent injury or endangerment to human 
life.
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1 Getting Started

Overview

ucCompanion Versions
ucCompanion is a client program used within the ucCompanion system. ucCompanion is available in two 
versions:

The ucCompanion - Live Attendant and ucCompanion versions are very similar. The ucCompanion - Live 
Attendant version was used to create this document. Note that several features that are specific to the 
ucCompanion - Live Attendant are not available with the ucCompanion version. Any differences between 
ucCompanion - Live Attendant and ucCompanion are noted.

About ucCompanion
The following are not available in the ucCompanion version:

• There is no Console menu.
• There are no call filtering options.
• The Caller ID of connected call is displayed for your own extension only.
You may not set the status note for an extension other than your own.

The following sections are included in this chapter:

• Connecting to the ucCompanion Server on page 7
• Setting your Area Code on page 7
• Setting your Password on page 8
• Selecting Audio Devices on page 9

ucCompanion Designed for office workers who need a graphical interface to control calls at their 
extension, and to see the real-time status of others in their organization.

ucCompanion 
- Live Attendant

Designed for operators, executive assistants and department secretaries that need 
to provide call coverage for others. Allows users to view and control calls on all 
devices in the system.

The ucCompanion - Outlook Plug-in is not currently supported. 

ADTRAN recommends a minimum 1024 x 768 screen resolution, with a 16-bit color 
palette.
 6 Copyright © 2009 ADTRAN, Inc. 619510005-1A
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• Launching ucCompanion - Soft Phone on page 10
• Keyboard Shortcuts on page 10

Connecting to the ucCompanion Server
When your ucCompanion client starts for the first time, the ucCompanion PCE Connection dialog box 
appears, where you must identify the name of the ucCompanion server. If you see a menu requesting the 
host name of the server, contact your system administrator.

Host – Enter the IP address of the main ucCompanion server. 

Setting your Area Code
Your system administrator may have already configured external dialing for you. However, if this has not 
yet been done, then you can configure it yourself following the steps below. 

In order to make external calls using ucCompanion or ucCompanion – Live Attendant, you must configure 
the phone and modem dialing properties in ucCompanion Client, such as setting your location’s area code.

To configure dialing properties

1. From ucCompanion or ucCompanion – Live Attendant, select Settings > Options.

2. Select the Number Format tab. 

If you mistakenly enter a wrong IP address, you can modify it later in the Settings > 
Options dialog. For more information, refer to Server Options on page 81. 

If you are using Windows Vista and your computer goes into sleep mode, then you may 
lose the connection to the Server. To regain the server connection, close ucCompanion 
and restart it. To prevent this issue from occurring, you may want to adjust your power 
options accordingly on Windows Vista. For more information, refer to Connection to the 
Server is Lost on page 75.

If your administrator has already configured external dialing for you, then do not modify 
the settings unless instructed to do so.

Do not change the maximum number length from the default value of 4, or the length of 
local phone numbers from the default value of 7.
619510005-1A Copyright © 2009 ADTRAN, Inc. 7
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3. Select Dialing Properties.

4. If your area code is not already set then select Edit, and select the Area Code Rules tab.

5. Select New, and enter your area code.

6. If your area has 10 digit dialing in effect, then enable Include the area code. If your area has 7 digit 
dialing in effect, then do not enable Include the area code.

7. Select OK.

8. Select Apply, and select OK on the Area Code Rules tab.

9. Select Apply, and select OK on the Dialing Rules tab.

10. Select OK on the Options dialog.

Setting your Password

Creating your Password
The first time you start ucCompanion, you should create a personal password. Setting a personal password 
is not required, but it is recommended. It prevents another person from controlling your extension number. 

To create your password

1. From the menu bar, select Settings > Options. The Options dialog box appears. 

2. Select the My Extensions tab. If you are logged in as administrator, none of the fields will be grayed 
out in the My Extensions tab.

3. Select the ... button next to the Enter Password box. The text boxes at the bottom of the dialog box 
will no longer be grayed out.

4. In the New Password box, enter a password. Then type the new password again in the Re-enter 
Password box. 

5. Select the Change Password button, and select OK to save the settings.

The personal password is not the same thing as the system administrator password, 
which is explained in Logging in as Administrator on page 79.
 8 Copyright © 2009 ADTRAN, Inc. 619510005-1A
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Changing your Password

To change your password

1. From the menu bar, select Settings > Options. The Options dialog box appears. 

2. Select the My Extension tab. If you are not logged in as administrator, you can gain access to the 
grayed out settings by entering your personal password in the New Password field and the Re-Enter 
New Password field. If you are logged in as administrator, then the password change options will 
already be available. 

3. Enter your personal password in the Enter Password field, and then select the ... button. 

4. Enter a new password in the New Password box. Then type the new password again in the Re-enter 
Password box. 

5. Select the Change Password button, and select OK to save the settings.

Selecting Audio Devices
The ucCompanion - Soft Phone uses the sound devices as configured on your desktop computer. Refer to 
your system's documentation for audio device configuration. If the system sound devices are configured 
properly, you can access them from the ucCompanion - Soft Phone menu options. You can select the 
microphone, speaker, and ringer (speaker) devices to use with the ucCompanion- Soft Phone. 

By default, ucCompanion uses the maximum volume level that is already selected for your system 
configuration, for example, for the volume control settings from your system tray, and the volume knob on 
your speakers. Because these settings are already configured on your system, they should also be sufficient 
for use with ucCompanion. However, if you find that the volume levels require adjustment, you can enable 
Automatically adjust audio level. Enabling this check box enables Automatic Gain Control (AGC) which 
automatically adjusts the volume levels for the devices selected.

If you do not have speakers connected to your computer, you can have ucCompanion ring your PC directly. 
For more information, refer to Adjusting the Volume on page 43.

To select audio devices

1. Right-click on the ucCompanion - Soft Phone icon in the system tray, and select Options.

2. Select the microphone, speaker, or ringing (speaker) devices from the drop down list of audio devices 
available.

3. Check Automatically adjust audio level if you want to enable AGC to automatically adjust the volume 
level for the device selected.

4. Check Also ring the PC speaker if your computer does not have speakers.
619510005-1A Copyright © 2009 ADTRAN, Inc. 9
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Launching ucCompanion - Soft Phone
The ucCompanion - Soft Phone is used in conjunction with ucCompanion and ucCompanion - Live 
Attendant. In order to use some of the ucCompanion features available, such as making a call, the 
ucCompanion - Soft Phone must be running. For more information on the ucCompanion - Soft Phone, refer 
to ucCompanion - Soft Phone Overview on page 27.

To launch the ucCompanion - Soft Phone
Select Start > Programs > ucCompanion - Soft Phone. The soft phone launches and you should see the 
ucCompanion - Soft Phone icon in the system tray in the lower right section of your monitor.

Keyboard Shortcuts

Standard Microsoft keyboard commands can also be used, in conjunction with the commands above, to 
process calls in ucCompanion and ucCompanion - Live Attendant.

Key Function Key Function

F1 Open online help CTRL + A Select all

F2 Hang up call CTRL + C Copy

F3 Make call CTRL + F Find

F4 Answer call CTRL + I Send instant message

F6 Supervised transfer CTRL + L Recent Call Log

CTRL + F6 Cancel Supervised 
transfer

CTRL + M Add comment to call

F7 Blind transfer CTRL + T Change status note

F8 Send to voicemail CTRL + T Time and date stamp (within a status note)

F9 Hold call CTRL + V Paste

F10 Unhold call CTRL + X Cut

CTRL + F9 Park call CTRL + Y Redo

CTRL + F10 Unpark call CTRL + Z Undo

F12 Clear stuck call CTRL + SHIFT + T Change another’s status note.

CTRL + F4 Call pickup + (on keypad) Answer call

ESC Cancel mouse drag * (on keypad) Hold/Unhold

UP arrow Select next item up / (on keypad) Move focus to call list

DOWN arrow Select next item down - (on keypad) Blind transfer 

TAB Move focus to next . (on keypad) Send to voicemail
 10 Copyright © 2009 ADTRAN, Inc. 619510005-1A
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Some commands and keyboard shortcuts may not always be available, depending on the state of calls and 
depending on how your system is configured.
619510005-1A Copyright © 2009 ADTRAN, Inc. 11
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2 Navigating ucCompanion

Overview of the Main Window

The following topics are covered in this chapter:

• The Main Title Bar on page 12
• Menus on page 13
• Toolbars on page 18
• Call List Panel on page 20
• Extensions Panel on page 22
• ucCompanion - Soft Phone Overview on page 27

The Main Title Bar
The title bar is the topmost part of the main window. The title bar displays your name and the extension 
that the application is associated with.
 12 Copyright © 2009 ADTRAN, Inc. 619510005-1A
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Menus
The following menus are described in this section:

• File Menu
• Edit Menu
• View Menu
• Calls Menu
• Extensions Menu
• Settings Menu
• Console Menu
• Help Menu

File Menu

The following commands are available in this menu:

Edit Menu
The following commands are available in this menu:

Admin login Displays the Administrative login dialog box. Some commands are not available 
unless you are logged in as an administrator.

Admin logout When logged in as administrator, this option becomes available. Selecting Admin 
logout automatically logs you out of the administrator profile, and returns you to the 
previous user profile.

Exit Shuts down the program.

Undo Provides the ability to undo certain recent actions. The following actions may be 
undone:
Resizing an extension cell
Cutting or pasting an extension cell
Changing the text in an extension cell or the call box
Updating a status note

Redo Provides the ability to redo an action that was undone. Refer to Undo above.

Cut Removes something and places it into memory. An item that has been cut can be 
retrieved using the Paste command. 

Copy Places a copy of an item into memory. An item that has been copied can be retrieved 
using the Paste command. 

Paste Retrieves an item that was placed in memory using the Cut or Copy commands. 

Clear Call On occasion due to network issues, the screen will show that you are still connected to 
a call after you have hung up. Use this Clear Call command to reset the screen.
619510005-1A Copyright © 2009 ADTRAN, Inc. 13
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View Menu
The following commands are available in this menu:

Toolbars Menu

Extensions Menu

The following extension settings apply only for the extension group that is currently selected. 

Select All Used to select all of something. Depending on which area of the window has focus (is 
currently activated), the following may be selected:
Text, when in a text edit field.
Extensions, when the focus is on the extension status area.
Extension groups.
Since only one call may be selected at a time in the call list, Select All is not available in 
the call list.

Find Causes the focus to jump to the extension search box, so an extension search may be 
done. Refer to Searching for an Extension on page 59 for more information.

Call List Panel Check this option to display the call list panel in the main window. (The scripting 
area is also displayed, if it is enabled.) This performs the same function as the - 
button on the section title area of the call list. 

Extensions Panel Check this option to display the extensions panel (including the Extension 
Groups and the Search fields). 

Reset Layout Restores the default layout of the main window, including the following: main 
window size and position, toolbar positions and visibility, and window divider 
positions. The following are not reset: display of extensions and extension 
groups, and customization of the toolbars. To reset toolbar buttons, use the 
Reset All button, which is accessed by choosing View > Toolbars > 
Customize > Toolbars tab.

Main Enable this option to display the main toolbar, which contains all the call control 
buttons. 

Calling Enable this option to display the calling toolbar, which contains the Number to 
Call field and the Call button.

User Enable this option to display the user toolbar, which contains the Recent call 
log, Send IM, and Add comment buttons.

Custom Enable this option to display the custom toolbar, which contains any custom 
buttons that have been set up. Refer to Customizing Toolbars on page 68 for 
more information.

Customize Allows you to customize many aspects of the main window. Refer to Overview 
of Customization on page 68 for more information.

Show Name Check this option to display extension names in extension cells.
 14 Copyright © 2009 ADTRAN, Inc. 619510005-1A
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Calls Menu
The availability of these commands depends on the state of the call that is currently selected in the call list. 
The following commands are available in this menu:

Show Dept Check this option to display department names in extension cells. No 
department name will be shown if none has been set for this extension.

Show Connected 
Party

Check this option to display caller ID in extension cells for active calls (if Caller 
ID is available in your system). This option is available in the ucCompanion - 
Live Attendant version only.

Show Line Check this option to display which keyline is being used on a call. This option is 
only available in ucCompanion - Live Attendant.

List View If selected, the extension status area will be presented in a detailed list view, 
similar to Windows Explorer. Refer to Extension Status Area on page 24 for 
more information.

Icon View If selected, extensions will be displayed as a rectangular grid of cells. This is 
the default setting. Refer to Extension Status Area on page 24 for more 
information.

Make call Calls the number in the call box. For more information, refer to Searching for 
Caller Information on page 33.

Send IM Allows you to send an Instant Message to the selected extension cells. For 
more information, refer to Using ucCompanion Instant Messaging on page 63.

Answer Answers the call that is currently selected in the call list. For more information, 
refer to Answering Calls on page 29.

Hang up Disconnects the call that is currently selected in the call list. For more 
information, refer to Disconnecting a Call on page 37.

Call pickup Retrieves the call that is selected in the call list. Refer to Ringing Call Pickup 
on page 32 for more information.

Hold Places the call on hold that is currently selected in the call list. For more 
information, refer to Holding Calls on page 39.

Unhold Takes the call off hold that is currently selected in the call list. For more 
information, refer to Holding Calls on page 39.

Park Place a call where it may be retrieved by other extensions.

Unpark Retrieve a parked call.

Send to voicemail Places the currently selected call in the call list directly into the mailbox 
number that is entered in the call box. For more information, refer to Sending 
to Voicemail on page 42.

Supervised transfer Performs a supervised or consultative transfer of the currently selected call in 
the call list to the destination specified in the call box. For more information, 
refer to Transferring Calls on page 40.

Transfer Performs a blind or direct transfer of the currently selected call in the call list to 
the destination specified in the call box. For more information, refer to 
Transferring Calls on page 40.
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Extensions Menu
The following commands are available in this menu:

Settings Menu
The following commands are available in this menu:

Add comment to call Adds a comment to the currently selected call in the call list, so that when you 
transfer the call, the recipient of the call has background information about the 
call. Refer to Attaching Comments on page 45 for more information.

Cancel supervised 
transfer

Cancels a supervised transfer before the person answers. For more 
information, refer to Transferring Calls on page 40.

Recent call log Displays the last 64 calls (both inbound and outbound) on your extension. 
Calls that are unanswered or not completed are also included. Double-clicking 
an entry in the recent call list places the number in the call box. To dial that 
number, select Call. For more information, refer to Making a Call using the 
Recent Call Log on page 35.

New Group Displays a dialog box that allows you to create a new extension group. This 
custom group is only visible on your computer. For more information, refer to 
Creating Personal Extension Groups on page 53.

Edit Group Allows you to change extension group settings.

Delete Group Deletes the currently-selected group in the extensions group list. Only groups 
that you have created or search results groups may be deleted this way. Refer 
to Deleting Personal Extension Groups on page 58 for more information.

New Extension Displays a dialog box that allows you to create a new extension in the selected 
extension group. You may create a new extension only in an extension group 
you have created. For more information, refer to Creating Personal Extension 
Cells on page 55.

Edit Extension Allows you to edit or modify a particular extension. You may only edit 
extensions in extension groups you have created yourself, not in system-wide 
extension groups.

Delete Extension Deletes an extension. You may only delete extensions in extension groups you 
have created yourself, not in system-wide extension groups.

Arrange Extensions Allows you to sort extensions by extension number, last name, or first name for 
the currently displayed extension (BLF) group.

Set My Status Note Allows you to set a status note. Refer to Setting your Status Note on page 77 
for more information. 

Skins Allows you to change the colors used in ucCompanion. Refer to Changing 
Interface Colors on page 80 for more information.

Options Refer to Setting Options on page 81 for more information.
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Administration Options

Console Menu

The commands in the Console menu are only available if you are logged in as Administrator. Refer to 
Logging in as Administrator on page 79. 

The following commands are available in the Console menu:

Help Menu
The following commands are available in this menu:

You must be logged in as an Administrator to access these menu options. Refer to 
Logging in as Administrator on page 79 for more information. 

Edit CPS This command displays the CPS Editor used to create and modify call 
processing scenarios. Only skilled JAVA and VBScript developers should 
access this feature.

Busy Lamp Field Displays the BLF Admin tool allowing administrators to setup and maintain 
BLF Groups. For more information, refer to the ucCompanion Installation and 
Administration Guide.

The Console menu appears only in the ucCompanion - Live Attendant version of 
ucCompanion. 

Edit Status Note Allows you to edit the status note of the selected cell.

Delete All Status 
Notes

Caution: This option deletes all status notes for all users in the ucCompanion 
system.

Call Filtering Displays the Call Filtering dialog box, allowing you to setup filters that 
displays activity at other extensions. Refer to Call Filtering on page 46 for 
more information.

Show Calls for My 
Extension

Set this to have only calls connected to your extension displayed in the call list. 
Refer to Call Filtering on page 46 for more information.

Show Filtered Calls Set this to have only calls that match certain criteria displayed in the call list. 
Refer to Call Filtering on page 46 for more information. 

Show Calls for All 
Extensions

Displays all calls being monitored by the ucCompanion system. This also 
allows you to view and manipulate these calls. Refer to Call Filtering on 
page 46 for more information. USE THIS COMMAND WITH CAUTION. You 
can accidentally disconnect or re-route another user’s call.

ucCompanion Help Displays online help. ucCompanion help can be navigated using the mouse or 
standard Microsoft keyboard commands.
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Toolbars 
The following topics are discussed in this section:

• Call Control Toolbar
• Calling Toolbar and Call Box
• User Toolbar
• Custom Toolbar

Call Control Toolbar
The following table shows toolbar buttons and their equivalent shortcut keys.

Keypad commands Displays keyboard commands and shortcuts.

Icon legend Displays a description of icons used in the program.

Color legend Displays the default colors and icons used for extension cell states.

Telephone keypad Displays a numeric keypad. As you select the buttons with the mouse, the 
numbers will be entered in the call box.

About ucCompanion Displays program information.

Button Description

Answer the ringing call (F4). Refer to Answering Calls on page 29 for more 
information.

Put the call that is selected in the call list on hold (F9). Refer to Holding 
Calls on page 39 for more information.

Retrieve the call that is selected in the call list (F10). Refer to Holding Calls 
on page 39 for more information.

Transfers the selected call to the number in the call box (F6), allowing you 
to speak with the person being called, before transferring the call to them. 
Once the transfer has initiated, the button changes to Cancel Transfer. 
Refer to Transferring Calls on page 40 for more information. 

Transfer the selected call blindly, or directly to the number in the call box 
(F7). Once the transfer has initiated, the button changes to Cancel 
Transfer. Refer to Transferring Calls on page 40 for more information. 
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You can drag this toolbar and dock it vertically, rather than using it in the default horizontal position.

Calling Toolbar and Call Box
The following table shows the contents of the Calling Toolbar, and the equivalent shortcut keys.

You can drag this toolbar and dock it vertically, rather than using it in the default horizontal position.

Hangs up on the destination party, and returns to the original call (CTRL + 
F6). Refer to Transferring Calls on page 40for more information.

End the call that is selected in the call list (F2). Refer to Disconnecting a 
Call on page 37 for more information.

Pickup a call that is ringing at another extension. Refer to Ringing Call 
Pickup on page 32 for more information.

Send the selected call to voicemail for the extension in the call box (F8). 
Refer to Sending to Voicemail on page 42 for more information. 

Park a call. Refer to Parking Calls on page 44 for more information.

Unpark call. Refer to Parking Calls on page 44 for more information.

Name Button Description

Call Box Enter a phone number, then select Make call. When 
you select an extension cell, its number is entered in 
this call box. Refer to Searching for Caller 
Information on page 33 for more information.

Make call Dials the number entered in the call box (F3). Refer 
to Searching for Caller Information on page 33 for 
more information.

Button Description
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User Toolbar
The following table shows the contents of the User Toolbar, and the equivalent shortcut keys.

You can drag this toolbar and dock it vertically, rather than using it in the default horizontal position.

Custom Toolbar
Custom toolbars can be created to provide access to other features and services. Once created, you need to 
select from the list the toolbars that you wish displayed.

Example of Smart Buttons in the Custom Toolbar

Call List Panel
The Call List panel contains the following:

• Call List Title Bar
• CPS Scripting Box (if enabled)
• Call List
• Call List Status Bar

Name Button Description

Recent call log View the list of recent incoming and outgoing calls 
(Ctrl+L). Refer to Making a Call using the Recent Call 
Log on page 35for more information.

Send IM Starts an instant message (Ctrl+I).Refer to Using 
ucCompanion Instant Messaging on page 63 for more 
information.

Add comment Annotate a call (Ctrl+M). Refer to Attaching Comments 
on page 45 for more information.

Filtered Note: This option is available in ucCompanion - Live 
Attendant only. Refer to Call Filtering on page 46 for 
more information.
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Call List Title Bar
The call list title bar is the topmost part of the Call List. This title bar contains a Minimize button that 
allows you to hide the call list. This title bar also displays status messages for your extension.

The Call List Title Bar

CPS Scripting Box
The CPS Scripting box, when displayed, can show text messages that have been associated with a call by 
custom scripts. Scripts must have first been created on your system. 

To display the CPS Scripting box, go to Settings > Options > Display tab, and check the option Show 
CPS scripting. If configured to do so, you will see a greeting displayed in this window for the call that is 
ringing your extension.

Call List
The call list shows a list of current calls and their status. You can select calls here and manipulate them. To 
work with a call, select it in the call list. In many cases a call will remain selected in the call list, even if the 
focus moves to another part of the main window. 

Each call consists of two legs, that is, two persons (or devices) participating in the conversation. When you 
use ucCompanion - Live Attendant in the non-filtered mode, you see both legs for all conversations. Each 
leg has an owner displayed in the Internal Number column and a remote party displayed in the Caller ID 
column. For external calls, (an external incoming call to your company, or someone from your company 
making an external outgoing call), you see one only leg. No leg is shown for the remote party, since 
ucCompanion does not monitor the remote party.

For more information about working with calls, refer to Working with Calls on page 29.

Timers in the Call List

The Timer column indicates the duration of calls.
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• The timer starts from zero when a call (either outgoing or incoming) begins ringing. 
• When the call is answered, the timer starts again at zero.
• The timer resets to zero when you place a call on hold. When you take the call off hold, the timer starts 

again at zero.
• When you first switch to Show Calls for All Extensions mode, timers for all calls reset to zero, even 

for calls that are already in progress. New calls that begin after this point will start at zero and will 
increment normally. Show Calls for All Extensions mode is only available in the ucCompanion - Live 
Attendant version.

When a call at your extension is completed, the duration of the call is recorded in the recent call log. The 
total duration of the call is recorded - the sum of the ringing, connected, and hold times.

Call List Status Bar
This area displays the comment attached to the call, if there is one. Refer to Attaching Comments on 
page 45 for more information.

Extensions Panel

Overview of Extensions
The extensions panel shows information about extensions (and phone trunks).

The Extensions Panel

Extension groups are shown in the left part of the window.

In the extension status area (the right part of the extensions panel), each extension is displayed as a cell.
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The extension Search box is located in the bottom, left part of the window. It can be used to search for an 
extension by the name of the extension owner.

Extensions Panel Title Bar
The extensions area title bar is located at the top of the extensions area. It contains a Minimize button that 
lets you hide the whole extensions panel. This title bar also indicates which extension group is currently 
being displayed in the extension status area. 

Extensions Panel Title Bar

Extension Groups
The extension groups area shows the extension groups in the system. These groups are set up by the system 
administrator, and are visible to all users of the ucCompanion system.

You can also create your own groups, which are only visible on your computer. Refer to Deleting Personal 
Extension Groups on page 58 for more information.
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Extension Status Area
The extension status area shows the extensions (and phone trunks) that are being monitored by 
ucCompanion. Extension cells in the extension status area show the extension number, the person the 
extension is assigned to, the status of the extension (busy, on hold, etc.), and whether the person is 
currently running ucCompanion (and can therefore receive an Instant Message).

Extension Status Area displayed in Icon View

The extension status area can also be displayed in list view as seen here:

Extension Status Area displayed in List View

If an extension has been set up to be monitored by ucCompanion but is now out of 
service or disconnected, that extension cell will be gray.
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States of Extension Cells

Extension cells change colors, depending on their state. A description of the states can be seen in the Color 
Legend window, which is accessed by selecting Help > Color Legend from the main menu.

Color Legend showing the Default color scheme

If you change the interface colors, the Color Legend automatically updates to show your current settings. 
For information about changing colors, refer to Changing Interface Colors on page 80.

Icons in an Extension Cell

Example: Icons for Ringing and IM in an Extension Cell
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The following icons can appear in an extension cell, when your display is set to Icon view (this is the 
default view).

Outbound and Inbound Call Icons

In an extension Cell (in the ucCompanion - Live Attendant version only), different icons represent inbound 
calls and outbound calls.

Inbound call (from 1004 to extension 6016)

Outbound call (from extension 6016 to 1005)

Icon Description

Idle 

In use

Ringing

Hold 

ucCompanion IM (user is logged in and available to receive a ucCompanion Instant 
Messages)

Status Note (extension has a status note attached)

(no icon) The extension is not being monitored by ucCompanion. 
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Extension Search Box
The extension search box is located in the lower left of the extensions panel, below the extensions gGroup 
list box. This search box is used to quickly find an employee using their first and/or last name as well as 
first few letters of their first or last name. For more information, refer to Searching for an Extension on 
page 59.

ucCompanion - Soft Phone Overview
UC client includes the ucCompanion - Soft Phone that is to be used in conjunction with ucCompanion - 
Live Attendant, UC server's presence-based console. The ucCompanion - Soft Phone is automatically 
installed with the UC client software, and uses the same authentication profile as configured for the UC 
client end user. For more information on using the ucCompanion - Soft Phone features, refer to Selecting 
Audio Devices on page 9, Adjusting the Volume on page 43, and Muting Calls on page 40.

Launching the ucCompanion - Soft Phone
Once launched from the Start menu, the ucCompanion - Soft Phone is available from a system tray icon. 
The ucCompanion - Soft Phone displays the current call status, and any errors that may exist, for example 
sign-on errors. For more information, refer to ucCompanion - Soft Phone Call Status on page 50.

To launch the ucCompanion - Soft Phone

1. Select Start > Programs > ucCompanion - Soft Phone. The soft phone launches and you should see 
the ucCompanion - Soft Phone icon in the system tray in the lower right section of your monitor.

2. To open the ucCompanion - Soft Phone keypad, double-click on the phone icon in the system tray . 
Once a call has connected, the keys are enabled on the keypad.

ucCompanion - Soft Phone System Tray Icon

Logging into the ucCompanion - Soft Phone
Logging into the ucCompanion - Soft Phone is automatic according to UC client sign-on methods. If single 
sign-on or Microsoft Outlook for Exchange profile is not enabled, then a default login dialogue prompts 
you for a user name and a password for authentication.
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Using the ucCompanion - Soft Phone

Once a call has connected, you can use the ucCompanion - Soft Phone to enter digits or letters, for 
example, when prompted by an auto attendant. For more information, refer to Entering Digits or Letters on 
a Connected Call on page 37

The ucCompanion - Soft Phone must be used in conjunction with ucCompanion. From 
ucCompanion, use the Number to call field to dial numbers. Refer to Making a Call on 
page 34 for more information.
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3 Working with Calls
The following options are available when working with calls:

• Answering Calls on page 29
• Making Calls on page 34
• Disconnecting a Call on page 37
• Holding Calls on page 39
• Muting Calls on page 40
• Transferring Calls on page 40
• Sending to Voicemail on page 42
• Adjusting the Volume on page 43
• Parking Calls on page 44
• Attaching Comments on page 45
• Call Filtering on page 46
• ucCompanion - Soft Phone Call Status on page 50
• Working with the Notification Window on page 50

Answering Calls
The ucCompanion - Live Attendant and ucCompanion applications were designed to provide users with 
flexibility when processing their calls. In high volume call processing scenarios it is not feasible to use a 
mouse for processing calls. Therefore, keyboard shortcuts also known as accelerator keys have been 
implemented for every call processing feature you may need to use. These make it possible for you to 
quickly answer and process calls using just your computer’s keyboard.

To answer a call

When a call rings your extension, the call appears in the call list and the call status shows as offering. The 
incoming call is automatically selected.

Select the Answer button
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Alternatively, do one of the following

• Press F4 on your keyboard
• Double-click on the call in the call list
• Right-click on the call in the call list and select Answer
• From your keyboard’s numeric keypad, press +.

To answer a second call using the keyboard

If you are already connected to a call and a second call comes in, do the following to answer the second 
call:

1. Use the Up or Down arrows keys to move to the second call in the call list.

2. Press F4 to answer the second call. The first call is automatically put on hold.
Alternatively, using your keyboard’s numeric keypad, press + to answer the call.

To answer a second call using the mouse

While still connected to your first call, double-click on the second call. This automatically places the 
current caller on hold and connects you to the second caller.

To answer a call when running in Tray Icon mode

You can choose to have your ucCompanion - Live Attendant or ucCompanion application minimized to 
your computer’s tray (the far right side of the tasks bar). When configured this way, your ucCompanion 
application alerts you of new calls by displaying a small dialog in the lower right portion of your screen.

1. If you are running in Tray Icon mode, when a call comes into your extension, a notification window 
appears. 

2. Select the Answer icon in the popup window to answer a call.

3. When you hang up, another notification popup appears indicating that you are now disconnected.

To place the second caller on hold and return to the first caller, simply double-click on 
the first call. This places the caller you are connected to on hold and reconnects you to 
the first caller. You can use this feature to jump back and forth between many calls.

The Notification Window only appears if it is enabled. To enable the Notification 
Window select Settings > Options > Misc > Enable Notification Window. For more 
information, refer to Working with the Notification Window on page 50.

For more information on Tray Icon mode, refer to Overview of Tray Icon Mode on 
page 81.
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Retrieving Parked Calls
When a call is parked it is assigned a parking position number by ucCompanion. This parking position 
number briefly displays in the title bar of your call list when a call is parked for you.

Example: The user at extension 3370 has a call parked for them in parking position 1

Depending on the settings of the user who parked the call, you may automatically receive notification that 
a call is parked for you. 

Example: The user at extension 3370 has parked a call at parking position 1

To retrieve a parked call

1. In the call box, enter the position number where the call was parked. 

The Call Box

You need the position number of the parked call in order to retrieve the call.

For more information, refer to Parking Calls on page 44.
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2. Select the Unpark button in the main toolbar. Alternatively, you can press CTRL + F10, or select 
Calls > Unpark from the main menu.

Ringing Call Pickup
Ringing Call Pickup, or call grab, allows you to answer a call that is ringing on another extension. Besides being 
used on offering (ringing) calls, Ringing Call Pickup may also be performed on calls that are offered to extensions 
that are not monitored by ucCompanion (extensions that do not have an extension cell). 

To answer a call ringing on another extension

1. When a call rings at an extension other than your own, look for the extension cell for the number that 
is ringing.

2. Select the extension cell. This enters that extension’s number into the call box. You can also enter the 
number directly in the call box using the keyboard.

3. Select the Call pickup button, or press CTRL + F4. You will be connected to the call.

Alternatively, you can right-click on the extension that is ringing, and select Call pickup.

Ringing Call Pickup is not the same as picking up a parked call. For instructions on 
picking up parked calls, refer to Retrieving Parked Calls on page 31.

If you do not have a Call pickup button, contact your system administrator. The Ringing 
Call Pickup feature must be turned on by your administrator.

If Ringing Call Pickup is performed on a call that has a comment attached, the 
comment will be lost
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Searching for Caller Information
You can enable ucCompanion to search for information on incoming callers using Windows Desktop 
Search and/or LinkedIn. When enabled, you can configure the search windows to open automatically when 
incoming calls are ringing, when incoming calls are answered, or not at all. 

Using Windows Desktop Search to Find Caller Information

You can enable ucCompanion to automatically open Windows Desktop Search to search for information 
about incoming callers. You can configure Windows Desktop Search to open and search when incoming 
calls are ringing, when incoming calls are answered, or not at all.

To enable Windows Desktop Search

1. From the ucCompanion - Soft Phone system tray icon, right -click and select Options.

2. Select the Screen Pops tab.

3. From the drop down list, select whether the screen pops should be displayed automatically when an 
incoming call rings, when an incoming call is answered, or not at all. This also applies to LinkedIn 
searches if enabled.

4. If Enable Windows Desktop Search is grayed out, then Windows Desktop Search 3.x or later is not 
installed. Select the link to Microsoft's website to install it, and follow the instructions. When 
Windows Desktop Search has finished installing, you will see a search box in your system tray. Select 
OK on the Screen Pops dialog to close it. Repeat steps 1 and 2 above. Enable Windows Desktop 
Search should now be available.

5. Check Enable Windows Desktop Search.

6. Select OK.

Using LinkedIn to Search for Caller Information

You can enable ucCompanion to access LinkedIn, a professional networking tool, in order to locate 
information about incoming callers. If you enable LinkedIn searches, you can select the Search field and 
sort type. If Caller ID provides a name, then this name is passed to LinkedIn to do a search on the name. If 
the Caller ID name is unavailable, then no search is performed. You can configure searches to occur 
automatically when incoming calls are ringing, when incoming calls are answered, or not at all.

To enable LinkedIn Search

1. From the ucCompanion - Soft Phone system tray icon, right -click and select Options.

2. Select the Screen Pops tab.

3. From the drop down list, select whether the search window should open automatically when an 
incoming call rings, when an incoming call is answered, or not at all. This also applies to Windows 
Desktop Search if enabled.

4. Check Enable LinkedIn search.

5. Select the Search field, from Name, Keyword, or Current Company.
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6. Select the sort type from Degrees of separation, Keyword relevance, Number of connections, or 
Number of endorsements.

7. Select OK.

Making Calls

To launch the ucCompanion - Soft Phone

Select Start > Programs > ucCompanion - Soft Phone. The soft phone launches and you should see the 
ucCompanion - Soft Phone icon in the system tray in the lower right section of your monitor.

Making a Call

To make a call using the keyboard

1. Be sure that your Num Lock key is locked. Using your numeric keypad, enter the number you want to 
dial in the call box. When you begin entering numbers, they will appear in the call box. It is not 
necessary to select the call box before entering digits with the keypad. 
You can also double-click on the extension cell of the number you want to call (refer to To make a call 
using the mouse on page 34 for more information). The number will be entered in the call box and 
place the call to the selected device. 

2. You can also copy and paste telephone numbers from a third party application into the call box. To 
place a call to the number entered, select the Make call button, located to the right of the call box, or 
press F3. The call is initiated.

To make a call using the mouse

1. In the extensions panel, locate the extension cell containing the number you want to call. This can be 
an extension or off-site telephone number.

2. Right-click on the extension cell, and choose Dial Extension from the pop-up menu.

The ucCompanion - Soft Phone must be running in order for you to make calls. For more 
information on ucCompanion - Soft Phone, refer to ucCompanion - Soft Phone Overview 
on page 27.
 34 Copyright © 2009 ADTRAN, Inc. 619510005-1A



NetVanta ucCompanion  Making Calls
3. Alternatively, double-click on a Busy Lamp Field (BLF) cell to intiate a call.

The call is initiated.

Making a Call using the Recent Call Log
The Recent Call Log displays the most recent calls (both inbound and outbound) on your extension. Calls 
that are not answered or not completed are also included. Double-clicking an entry in the recent call list 
will dial the number shown in the far-end number column. 
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To make a call using the Recent Call Log

1. In the main toolbar, select the Recent Call Log button to open the Recent Call Log. 

2. In the Recent Call Log, double-click an entry (or select the entry and select the Dial button). This puts 
the number in the call box in the main window, where you can edit the number if needed.

Recent Call Log

Call Box

3. To make the call, select the Make call button, or press F3.

4. The number in the call box is dialed.
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Entering Digits or Letters on a Connected Call 

The ucCompanion - Soft Phone keypad can be used to enter digits or letters once a call is connected. For 
example, if your call is answered by an auto attendant, you can enter numbers or letters on the keypad to 
access a menu option or to enter a name to search in the company directory.

To enter digits or letters using the ucCompanion - Soft Phone keypad

1. Double-click on the phone icon in the system tray to open the ucCompanion - Soft Phone keypad. 
Once a call has connected, the keys are enabled on the keypad.

2. Using the ucCompanion - Soft Phone keypad, enter the numbers or letters as prompted by an auto 
attendant. For example, to locate "Smith" in the company directory, you would select 7-6-4-8-4, as the 
letters appear on the keypad.

Troubleshooting Making Calls
If you are having trouble making calls, check the following:

Is ucCompanion - Soft Phone Running?

The ucCompanion - Soft Phone works in conjunction with ucCompanion and ucCompanion - Live 
Attendant, and must be running in order to make calls. If ucCompanion - Soft Phone is running, you should 
see the ucCompanion - Soft Phone icon in your system tray. For more information, refer to ucCompanion - 
Soft Phone Overview on page 27.

To launch ucCompanion - Soft Phone 

Select Start > Programs > ucCompanion - Soft Phone.

Can you Make Internal Calls but not External Calls?

If you are having trouble making external calls after initially installing or upgrading ucCompanion or 
ucCompanion - Live Attendant, then check that the dialing properties have been configured to specify your 
location's area code. Refer to Setting your Area Code on page 7 for information on how to set the dialing 
properties.

Disconnecting a Call
You can disconnect or hang up a call, which removes the call from your menu. If you have disconnected a 
call, and it still appears on your menu, refer to Clearing Calls on page 38 for more information.

The ucCompanion - Soft Phone is used in conjunction with ucCompanion. To dial 
numbers, use the Number to Call field in ucCompanion.
619510005-1A Copyright © 2009 ADTRAN, Inc. 37



 Disconnecting a Call NetVanta ucCompanion
To disconnect a call

1. In the Call List, select the call that you want to disconnect.

2. If the call is on hold, take it off hold (select Unhold or press F10).

3. Select the Hang up button (or press F2, or right-click on the call and choose Hang Up).

Clearing Calls
Occasionally, due to network issues, the screen may show that you are still connected to a call after you 
have hung up. Use the Clear Call command to reset the screen.

You cannot disconnect a trunk in the call list. If you are using ucCompanion - Live 
Attendant in unfiltered mode (enabled in Console > Show Calls for All Extensions) you 
may see trunk lines included in the call list, if your administrator has configured your 
system to monitor trunks. Look for a name such as “Trunk1” in the Caller Name column 
(ask your administrator for the actual trunk names in your system).

If you have disconnected a call, but it still appears on your menu, refer to ucCompanion 
- Soft Phone Call Status on page 50 for more information.

Clear call is not the same as disconnecting a call. That is, if the call was not previously 
disconnected, then selecting Clear Call does not disconnect the call, but it removes it 
from your screen.
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To clear calls from your screen

From the Edit menu, select Clear Call. Any calls that were shown as connected on your screen, are 
removed.

Holding Calls

To place a call on hold

1. In the Call List, select the call you want to hold, if it is not already selected. To select a call, select it 
or use the Up Arrow or Down Arrow key.

A connected call in the Call List

Alternatively, right-click on your extension cell, and select Clear All Calls. The 
keyboard shortcut to clear calls is F12.
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2. Select the Hold button, or press F9.

The call is put on hold.

A call on hold in the Call List

To take the call off hold, select the Unhold button. You can also double-click on the call in the call 
list, select the Answer button, or press F10.

Muting Calls
When you are on an active call, you can mute the call so that the caller can no longer hear you.

To mute a call

Right-click on the ucCompanion - Soft Phone icon in the system tray, and select Mute. The caller will no 
longer be able to hear sound from your end of the call.

To unmute a call

Right-click on the ucCompanion - Soft Phone icon in the system tray, and select Unmute. The caller will 
be able to hear you again.

Transferring Calls
ucCompanion and ucCompanion - Live Attendant were designed to facilitate call processing. Thus, there 
are several methods of transferring callers, including:

Drag and Drop Allows you to drag and drop the caller from the call list onto any Cell. This can 
be an extension or outside number such as a cell phone.

Numeric Keypad Accelerator keys provide the fastest way to answer and process calls in high 
volume offices.
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You can perform blind or supervised transfers. 

• A blind transfer transfers the call directly, without you speaking to the person that you're transferring 
the call to. 

• A supervised transfer allows you to speak with the person being called, before transferring the call to 
them.

To transfer calls using drag and drop

1. Make sure the extension you want to transfer to is visible in the extension status area.

2. To transfer a call:
• To perform a blind transfer, drag the call from the call list, and drop it onto the extension cell of the 

extension you want to transfer to. The call is automatically transferred.
• To perform a supervised transfer, press and hold the CTRL key, while dragging the call from the 

call list, and dropping the call onto the extension cell of the extension you want to transfer to.

Dragging and dropping a call to transfer it

3. To complete the supervised transfer, hang-up the call.

To transfer calls using the keyboard

Be sure that the NUM LOCK key is depressed on your numeric keypad, while connected to the call you 
want to transfer.

For more information on transferring calls using the menu, refer to Calls Menu on 
page 15. For more information on transferring calls using the toolbar button, refer to 
Call Control Toolbar on page 18.

To cancel the transfer before the person answers, select the Cancel Transfer button on 
the toolbar. 
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1. In the call list, select the call you want to transfer, using the up or down arrow keys.

2. In the call box, use the numbers on your keyboard to type the number where you want to transfer the 
call.

3. To make a blind transfer, select the Transfer button or press F7. 

4. To make a supervised transfer, select Supervised Transfer, or press F6. The call is placed on 
supervised hold, and the destination extension rings. Remain on the line to introduce the caller.

5. To complete either type of transfer, hang up.

Sending to Voicemail

To send a call to voicemail

1. You must be connected to a call.

2. Make sure the call you will send to voicemail is selected in the call list. To select a call, select it or use 
the Up Arrow or Down Arrow keys. If you just answered an incoming call it is already selected 
automatically.

3. In the call box, enter the voicemail box number where you want to send the call. You can do this by 
selecting the extension in the extension status area, or by typing the number directly into the call box 
using the numeric keypad.

4. Select the Send to Voicemail button, or press F8. The call is immediately sent to voicemail. There is 
no need to hang up the call.

If you enter the wrong number in the call box, use the BACKSPACE key to edit the 
number.

To cancel the transfer before the person answers, press CTRL + F6 or select the Cancel 
Supervised Transfer button on the toolbar.

If you mistakenly enter the wrong number in the call box, you can use the BACKSPACE 
key to edit the number.
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Adjusting the Volume
By default, ucCompanion uses the maximum volume level that is already selected for your system 
configuration, for example, for the volume control settings from your system tray, and the volume knob on 
your speakers. Because these settings are already configured on your system, they should also be sufficient 
for use with ucCompanion.

If you find that the volume levels require adjustment, you can adjust the microphone, speaker, and ringer 
volumes from ucCompanion. You can automatically adjust the volume levels for the devices selected, or 
you can manually adjust the audio device volumes using slider bars. For more information, refer to 
Selecting Audio Devices on page 9, and Muting Calls on page 40.

To automatically adjust the microphone or speaker volume

1. Right-click on the ucCompanion - Soft Phone icon in the system tray, and select Options.

2. Check Automatically adjust audio level to enable Automatic Gain Control (AGC) to automatically 
adjust the volume level for the device selected. 

3. Select OK.

To manually adjust the microphone or speaker volume

1. Right-click on the ucCompanion - Soft Phone icon in the system tray, and select Show Audio 
Controls.

2. Use the slider bars to adjust the microphone or speaker volume. Note that by default the volume levels 
are set to the maximum level already configured for your system.

3. To mute an active call, select Mute so that the caller cannot hear you. Select Unmute to enable the 
caller to hear you again.

4. Close the ucCompanion Audio Controls dialog.

To adjust the ring volume

1. Right-click on the ucCompanion - Soft Phone icon in the system tray, and select Options.

2. Use the slider bars to adjust the ring or ring-back volume.

3. Select OK.
619510005-1A Copyright © 2009 ADTRAN, Inc. 43



 Parking Calls NetVanta ucCompanion
Parking Calls
The Call Park feature in ucCompanion allows you to put a call on hold and place it where it may be 
retrieved by another extension. When you park a call, ucCompanion automatically selects a parking 
location number and assigns it to the call. To retrieve a parked call, the user enters the number of the 
parking location.

You can enable ucCompanion to automatically notify users when a call is parked for them. When you park 
a call, you are then prompted for the extension number of the person for whom the call is being parked. 
The user is then notified that a call is parked for them, so they can unpark it.

To automatically notify users when a call is parked for them

1. Select Settings > Options > Misc tab.

2. Enable Notify call parking destination (user), and select OK.

To park a call

1. You must first be connected to a call.

2. Select the Park button in the main toolbar. Alternatively, you can press CTRL + F9, or select Calls > 
Park from the main menu.

The call will be parked in the next available parking location. The number where the call is parked 
will briefly display in the title bar of the call list. 

Example: The user at extension 3370 has parked a call at parking position 1

If you have enabled the setting to automatically notify users when a call is parked for them, then the parked 
call also briefly appears in your call list.

For information on retrieving parked calls, refer to Retrieving Parked Calls on 
page 31.

The notification appears only if the user is configured to use Instant Messaging (IM). If 
a user is not configured for IM, then they will not receive a notification.
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Attaching Comments

To add a comment to a call

1. Select the call in the call list. To select a call, select it or use the Up Arrow or Down Arrow key.

2. Select the Add Comment button, or press CTRL+M.

The Add Comment to Call dialog box appears.

3. Enter the comment.

4. Select OK. The comment appears in the call list, both in the Comment column and in the Status Bar.

The Add Comment feature may not be available through your phone system.

If a call is transferred to you and it already has a comment attached, do not attach 
another comment to the call.
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Call Filtering

Overview of Call Filtering
ucCompanion - Live Attendant allows you to set which types of calls will appear in your call list. This is 
useful for when there are a lot of calls in the system. These call filtering options are not available in the 
ucCompanion version.

Each call consists of two legs, that is, two persons (or devices) participating in the conversation. When you 
use ucCompanion - Live Attendant in the Show Calls for All Extensions mode, you see both legs for all 
conversations. For external calls, (an external incoming call to your company, or someone from your 
company making an external outgoing call), you see one only leg. No leg is shown for the remote party, 
since ucCompanion does not monitor the remote party.

Call filtering options are accessed through the Console menu. The filter mode is also reflected in the 
calling toolbar (refer to Calling Toolbar and Call Box on page 19 for more information).

Call Filter Modes
The Call Filtering option in the Console menu opens the Call Filtering dialog box (refer to the next 
section, Custom Call Filter Rules on page 47, for more information).

The three filtering settings at the bottom of the Console menu are described in the table below. 

Call filtering is available for ucCompanion - Live Attendant only.

Setting in Console Menu Toolbar Shows What It Does

Show Calls for My Extension
 (the default setting)

The Filtered button is not 
pressed.

The call list displays only the calls 
that are connected to your extension. 
Calls that do not involve your 
extension are filtered out.

Show Filtered Calls The Filtered button is 
pressed.

Your custom filtering rules are used. 
The call list displays only calls that 
meet the criteria set in the Call 
Filtering dialog box. Refer to 
Custom Call Filter Rules on page 47 
for more information.

Show Calls for All Extensions The Filtered button is not 
pressed.

No filtering at all is used. The call list 
displays all calls throughout the 
system (all calls that are monitored 
by ucCompanion). This also allows 
you to view and manipulate these 
calls. 
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The default setting in the Console menu is Show Calls for My Extension, which means the Filtered 
button is not pressed down on the toolbar. In this default state, no special filtering is used. All calls 
connected to your extension will appear in your call list. Other calls in the system in which your extension 
is not involved are not shown.

Custom Call Filter Rules
When the Filtered button in the toolbar is in the pressed down state, the settings in the Call Filtering 
dialog box will be used to determine which calls appear in the call list. 

To bring up the Call Filtering dialog box, select Console > Call Filtering from the main menu.

The “Always Show My Extensions Calls” Setting

The check box labeled Always Show My Extension Calls is located at the bottom of the Call Filtering 
dialog box. If you want to be able to see all the calls on your extension number, make sure this box is 
checked.

By default, Always Show My Extension Calls is checked and nothing else is checked. When the dialog 
box is in this default state, it is the same as if Show Calls for My Extensions were set in the Console 
menu—no special filtering is used. 

The Four Main Categories for Filtering

The Call Filtering dialog box contains four major categories: Show By Type, Show By Caller ID Mask, 
Show By Group, and Show By Department. 

To enable the settings in a category, the main checkbox above that category must also be checked. For 
example, to show internal calls select the Internal checkbox, which is located in the Show By Type 
category. But you also must make sure that the main Show By Type checkbox is checked. 

If none of the main categories is enabled, and Always Show My Extension Calls is also not checked, no 
calls will ever appear in the call list while the Filtered button is pressed down. If you try to set this dialog 
box this way, you will get a message warning you that the current filter setting will hide all calls in your 
call list.

Filtering Settings are Inclusive

The call filtering criteria in the Call Filtering dialog box are inclusive. If a call matches any of the criteria 
specified in the this dialog box, then the call is shown in the call list. In other words, the feature uses “OR 
logic”—if either this or that condition is met, then the call will be shown.

Use the Show Calls for All Extensions setting with caution. You can accidentally 
disconnect or re-route another user’s call.
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Setting up Call Filtering
This section shows the steps to set specific call filtering criteria. For more general information about Call 
Filtering, refer to the previous sections.

To use specific call filtering criteria

1. Go to the main toolbars, and select the Filter button to set it to the pressed down state (or select 
Console > Show Filtered Calls from the main menu).

2. From the main menu, select Console > Call Filtering. The Call Filtering dialog box appears.

3. If you want to see all the calls on your extension, regardless of what other criteria may be set in the 
Call Filtering dialog box, make sure the Always Show My Extension Calls check box is checked. 

4. There are four main categories or areas in the Call Filtering dialog box. You can set criteria in one or 
more of the categories. Only one of the criteria needs to be met for a call to appear in the call list. Set 
one or more criteria in the four categories:

Show By Type Check the main Show By Type checkbox. Then check one or more 
criteria. For example, to show only calls that are ringing or on hold, 
check On Hold and Offering.

Show By Caller ID Mask Check the main Show By Caller ID Mask checkbox.Then select the 
New button at the top of the category. 
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A new blank field will appear. Now enter the Caller ID pattern you want to match. Use question marks to 
indicate wildcard digits. For example, to show only calls that come from four-digit extensions and that 
begin with “20”, you would enter “20??”.

5. Select OK. Call Filtering is now set on your extension. Now only those calls that match at least one of 
the filter criteria you have set will appear in your call list. If you want to go back to the un-filtered 
view, use the Filtered button on the toolbar. Refer to Call Filter Modes on page 46 for more 
information.

Show By Group Check the Show By Group check box. Then check off one or more extension 
groups in the list. For example, to see only calls that involve extensions in the 
extension group named “Sales,” you would check that check box.

Show By Department Check the main Show By Department checkbox. Then check a 
department from the list. The department entries come from the 
Department (or Comment) setting in extension cells. If no departments 
are listed in the show by department area, then nothing for this field is 
currently set in any extension cells. 
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ucCompanion - Soft Phone Call Status
The ucCompanion - Soft Phone is managed through a system tray icon. The icon changes colors to 
represent different states, such as waiting for a call, incoming call, or active call. If you point your mouse 
over the ucCompanion - Soft Phone icon, then a tooltip appears to show the current state. Some of the icon 
colors and their corresponding states are shown below.

You also see a notification window to alert you to call states, if this option has been enabled. For more 
information refer to the following section.

Working with the Notification Window

Overview of the Notification Window
The Notification window provides a convenient way to do basic call control when you do not want to have 
the full ucCompanion main window open.

System Tray Icon ucCompanion - Soft Phone Status
Waiting for calls

Incoming call

Active call

Mute

Logging in

Error (for example, not logged in)
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Information Displayed in the Notification Window

The Notification window shows your name and extension information, as they are set in the Options menu 
for ucCompanion.

Depending on the state of your extension and calls, icons and buttons will appear in the Notification 
Window to indicate the following: dial tone/off hook, voicemail, ring-back, or busy. Call control buttons 
will appear that allow you to answer, hold, unhold, hang up, or cancel transfer. To find out what a button or 
icon does, hold the mouse cursor over it until the ToolTip appears.

Depending on the state of calls, other information may also be displayed, including the number of active 
calls, call state, and Caller ID.

Displaying the Notification Window

Enabling the Notification Window

The notification window feature is disabled by default. To enable this option select Settings > Options > 
Misc, and select Enable Notification Window. Refer to Enabling Tray Icon Mode on page 81 for 
information about enabling and disabling these options.

Showing the Notification Window

If the Notification Window feature is enabled but the Notification Window is not currently displayed, you 
can show it by double-clicking the System Tray icon. Or you can right-click on the ucCompanion icon in 
the Windows System Tray and choose Notification Window.

If the notification window is not enabled, double-clicking the tray icon will restore the application window.

Keeping the Notification Window Open

You can “pin” the Notification Window to set it permanently in “always on top” mode. To do this select 
the pin icon until it points down. The icon toggles between “pinned” and “unpinned” when you select it 
repeatedly.

Pinned Open

Unpinned
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Controlling Calls Using the Notification Window
You can use buttons that appear in the Notification Window to control calls. If a function is available for 
the call state you are in, a button will appear for it, such as to hang up, hold the call, etc. The buttons work 
the same way as the call control buttons in the main toolbar. 
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4 Working with Extensions

Overview of Working with Extensions
You work with extensions in the extensions panel. Refer to Extensions Panel on page 22 for a description 
of the parts of the extensions panel.

The Extensions Panel

The following topics are covered in this chapter:

• Creating Personal Extension Groups on page 53
• Creating Personal Extension Cells on page 55
• Creating Speed Dial Buttons on page 56
• Deleting Personal Extension Cells on page 57
• Deleting Personal Extension Groups on page 58
• Changing Extension Views on page 58
• Searching for an Extension on page 59
• Sorting Extension Groups on page 60
• Sorting Extensions on page 61
• Expanding the Extensions Panel on page 62

Creating Personal Extension Groups
The system administrator sets up system-wide (global) groups of extensions. These system-wide extension 
groups automatically show up in the extensions group list, found in the extensions panel. 
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The Extension Groups List

You can also create your own personal extension groups, and then add extension cells to them. The 
personal extension groups and extension cells that you create are visible on your computer only. 

To create a personal Extension Group

1. Right-click in the extension groups area. 

2. Choose New Group from the menu that appears.

3. The Group Properties dialog box appears.

4. Enter a name for the new group, and select OK.
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5. The new group appears in the extension groups area. You can now add personal extensions to the 
group you created. Refer to the next section for more information.

Creating Personal Extension Cells
The extension cells that you create are visible on your computer only. You can create a new extension cell 
only in a personal extension group that you have created. Refer to Creating Personal Extension Groups on 
page 53.

You cannot create new extension cells in the extension groups that already existed when you opened 
ucCompanion for the first time. These are system-wide extension groups that were set up by your system 
administrator. 

The Extensions you create can also serve as speed dial buttons, since whenever you double-click on an 
Extension it is automatically dialed. 

To create a personal Extension Cell

1. In the extension groups area, select the extension group where you want to add a new extension cell. 
This selects the extension group and displays any extension cells that are already in the group.

2. Right-click on the blank (gray) area in the Extensions area, and choose New Extension. 

You can create a new extension cell only in an extension group that you have created. 
Refer to Creating Personal Extension Groups on page 53 for more information.
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3. The Add Extension dialog box appears. Fill in the Add Extension dialog box as follows:

4. Select OK in the Add Extension dialog box. The new personal extension cell has now been added to 
your personal extension group.

Creating Speed Dial Buttons
When you add an extension to a personal extension group you have created, this extension cell can 
function as a speed dial button. You can double-click on the cell to quickly call a pre-set number.

Extension # Enter a number for the new Extension, up to nine digits.
This does not need to be a valid extension number; however, it must be a number 
you have not already used in any other extension cell you have created.

First Name Enter the first name, as you want it to be displayed in the extension cell.

Last Name Enter the last name, as you want it to be displayed in the extension cell.

Department 
(or a Comment) 

(Optional) Enter a department name, company name, or other information you 
want to display in this cell. This will be displayed in the cell below the first and last 
name. A maximum of 12 characters is allowed. 

Dialable Address Enter a valid telephone or extension number. Enter digits, *, or # only (no other 
characters, spaces, hyphens, or parentheses). For outside numbers include the 
digits required to dial out, such as 9 and 1 and an area code; for example 
916175551212. (Your system may use a number other than 9.)
When you select this extension cell once, the number you enter here will be 
placed in the call box, and you can then select Make Call to call the number. 
When you double-click this extension cell, the number you enter for Dialable 
Address will be dialed automatically.
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Example of a speed button

The numbers used for speed dial buttons can be either internal or external telephone numbers. Extension 
numbers used in speed dial buttons do not need to be monitored by ucCompanion. In other words, you can 
create a speed dial button to dial an extension, even if the Extension does not appear in the system-wide All 
Groups extension group. 

Speed dial extension cells are gray (unless you have changed the default color).

The steps to create a speed dial button are the same as the steps to create a new extension cell. Refer to 
Creating Personal Extension Cells on page 55 for more information.

Deleting Personal Extension Cells
You can only delete personal extensions that you have created. You cannot delete the system-wide 
extensions set up by your system administrator.

To delete a personal Extension

1. Select the extension group that contains the extension you want to delete.

2. Right-click on the extension you want to delete, and choose Delete Extension.

3. Answer Yes in the confirmation box that appears.
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Deleting Personal Extension Groups

To delete an Extension Group

1. Right-click on the group in the extension groups that you want to delete. 

2. Choose Delete Group.

3. Select Yes in the message box that appears, to confirm that you want to delete the group.

Changing Extension Views
Extensions can be displayed in either Icon view or List view. Icon view is the default.

Extension Status Area displayed in Icon View

You can only delete personal groups that you have created, not system-wide groups. You 
also cannot delete the group that results from a search.
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Extension Status Area displayed in List View

To change extension views

1. If starting in Icon view, right-click in an empty (gray) part of the extension status area.

If starting in List view, right-click in the right-most part of the extension status area, to the right of the 
status note column. Reduce the size of the status note column if needed.

2. In the menu that appears, select either View > List View or View > Icon View. The display will 
change accordingly.

Searching for an Extension
You can search for an extension by using the first or last name that is associated with that extension.

To search extensions

1. Go to the Search By Name box, found at the bottom of the extension groups area.

2. In the Search By Name box, enter one or more letters from the name (case does not matter).
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3. The search finds all names (both first and last names) that begin with those letters, across all extension 
groups. The results are displayed in the extension status area.

Sorting Extension Groups

To sort the list of Extension Groups

1. Right-click anywhere in the extensions group area.

2. Choose Sort Alphabetically or Sort Reverse Alphabetically from the menu that appears.

3. The list of extension groups is sorted accordingly.
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Sorting Extensions

To sort extensions while in Icon View

1. Select the extension group that contains the extensions you want to sort.

2. Right-click in the extension status area, in a gray area (not on an extension cell). 

3. In the menu that appears, move the mouse cursor to Arrange Extensions. A submenu appears. Select 
a sort option from the submenu. The extensions are sorted accordingly.

To sort extensions while in List View

1. With the extension status area set to List view (select View > Extensions > List View), select a 
column head, for example first name.

2. Extensions are sorted in descending order. If you select the heading again, it sorts in ascending order. 
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Expanding the Extensions Panel
You can choose to expand the Extensions Panel by hiding the Call List and the CPS panel (if it is open). 

To expand the Extensions Panel

1. Go to the Call List title bar and select the Minimize button on the right end. This hides the Call List 
panel.

The Call List title bar, with the Minimize button

2. To show the Call List panel again, select the Maximize button on the end of the call list title bar.
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5 Instant Messaging

Using ucCompanion Instant Messaging

Overview of ucCompanion Instant Messaging
ucCompanion Instant Messaging provides an easy way to send and receive text messages from within 
ucCompanion clients. You can tell when ucCompanion IM has been enabled by looking at extension cells 
in the extension status area:

For more information refer to the following sections:

• Sending an Instant Message on page 63
• Replying to a Message on page 66
• Clearing the History on page 67
• Sticky Notes on page 67

Sending an Instant Message

To send a message using ucCompanion Instant Messaging

1. Make sure ucCompanion Instant Messaging is enabled in your system. Refer to Using ucCompanion 
Instant Messaging on page 63 for more information.

2. Before you send the instant message, check that the ucCompanion IM icon appears at the top of the 
recipient’s extension cell. 

ucCompanion Instant Messenger icon

Instant Messaging Icon Icon as Seen in Extension 
Cell

ucCompanion Instant Messaging
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ucCompanion Instant Messenger icon in an Extension Cell

The IM icon shows that the person has launched a ucCompanion program and is able to receive 
ucCompanion instant messages. If no IM icon appears, you can still send the IM, but the user will not 
receive it until they start up ucCompanion. This is called a Sticky Note.

3. To begin an instant message, right-click on an extension cell and choose Send IM or enter the 
extension number in the call box, and then do any one of the following:
• Select the Send IM button.

• Press CTRL + I.
• Choose Calls > Send IM.

4. When the Network Instant Message window appears, type your message in the lower portion of the 
window. Then select the Send button. 

You can send a single instant message to more than one person. First select all the 
recipients by holding down the CTRL or SHIFT keys while selecting their extensions. 
Use SHIFT + click to select a group of consecutive extensions. Use CTRL + click to 
pick out individual (non-consecutive) extensions. To send the instant message select the 
Send IM button, or use one of the other methods described above.
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5. The message is instantly popped onto the recipient’s screen (if they are logged on), allowing them to 
respond. The following example shows how the recipient will see your instant message:

6. If the person replies to you, the Network Instant Message window will pop up again. The example 
below shows how a reply will appear on your computer. You can now type a response and select Send 
again, if you wish.

Instant Messages should be less that 255 characters. Otherwise only the first line of the 
message will be sent.
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Replying to a Message

To reply to a message sent through ucCompanion Instant Messenger

1. When you receive an instant message, the Network Instant Message window will appear.

2. Type a reply in the bottom pane of the Network Instant Message box.

3. If more than one person (sender) appears in the top part of the window, select the person to whom you 
want to reply.

4. Select the Reply button. (The Reply button will not become active until you type some text).
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Clearing the History

To clear the IM history

To delete past messages from the Network Instant Message window, select the Clear button at the bottom 
of the window.

Sticky Notes
If you send an Instant Message to someone who is not logged into ucCompanion, your message 
immediately pops up the next time they log in. This is called a Sticky Note. Sticky Notes are a good way to 
make sure someone gets a message when they begin work for the day or when they return to their 
computer.
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6 Customizing the Interface

Overview of Customization
You can customize the toolbar and keyboard commands. Customization options are accessed through 
selecting View > Toolbars > Customize. Refer to the following sections for information on customizing 
ucCompanion:

• Customizing Toolbars on page 68
• Customizing Key Assignments on page 70
• Customizing Menus on page 70
• Customizing Miscellaneous Options on page 71

Customizing Toolbars
The following sections describe how to customize your toolbars.

Changing Buttons

To add buttons to the toolbar

1. Choose View > Toolbars > Customize > Commands tab.

2. Select a category of commands in the Categories area. These categories correspond to the standard 
menus.

3. In the commands area, select and drag a command to a toolbar, and release the mouse. A new button 
appears on the toolbar for that command. 

4. Select the Close button.

To move or remove buttons from the toolbar

1. Choose View > Toolbars > Customize > Commands tab.

2. As long as the Customize dialog box remains open, you can freely move and remove buttons. To 
move a button, drag it to a new location on the toolbars. To remove a button, drag it over the 
Customize dialog box and release the button. The button disappears.

3. When you are finished, select the Close button.
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Changing Toolbars

To hide a toolbar

1. Choose View > Toolbars > Customize > Toolbars tab.

2. Uncheck the box next to the toolbar you want to hide. The toolbar disappears from the main window.

3. Select Close. 

To create a new toolbar

1. Choose View > Toolbars > Customize > Toolbars tab.

2. Select the New button. The Toolbar Name dialog box appears.

3. Type a name for the toolbar, and select OK. An empty, truncated toolbar appears.

4. Drag the new toolbar to a position with the other toolbars. 

5. Select Close. 

6. Add buttons to the toolbar, as desired. Refer to Changing Buttons on page 68.

You cannot hide the Menu Bar toolbar. Also, you cannot uncheck/check the Calling and 
Custom toolbars.
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Customizing Toolbar Tips
To add a space between buttons, open the Customize dialog box and drag the button slightly away from its 
neighbor. To remove the spacer, hold down the Alt key while dragging slightly toward the neighbor 
button.

To copy a button, hold down CTRL while dragging the button slightly to the left or right.

Use the Rename and Delete buttons in the Customize dialog box to rename and delete toolbars.

Customizing Key Assignments

To change the keystrokes for a command

1. Select View > Toolbars > Customize > Keyboard tab.

2. Select a category from the Category list. These categories correspond to the standard menus, and 
contain all the commands in that menu.

3. Select a command from the Commands list. This is the command for which you will change the 
keystrokes. If there is currently a keystroke set to invoke that command, it will appear in the Current 
Keys box on the right in the dialog box.
To assign new (additional) keystrokes to this key, select the Press New Shortcut Key box. Then press 
the key or combination of keys you want to use to invoke that command. Select the Assign button. If 
the keys are already assigned to another command, the name of that command will be displayed 
below. You cannot use those keystrokes until you remove them from the command that is already 
using them.
To remove keystrokes for that command, select the command in the Current Keys box and select the 
Remove button.
To reset all key assignments back to the original defaults, select the Reset All button.

4. When you are finished, select the Close button.

Customizing Menus

To customize the menus

1. Select View > Toolbars > Customize > Menu tab.

2. Many of the features in this dialog box are not currently available. However you can do the following:
Use the Reset button to set menus back to defaults.
Use the Menu Animations list to change menu animations.
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Use the Menu Shadows check box to enable/disable display of shadows behind menus when they are 
displayed. You can add, move, or delete the commands that appear in menus. To do this, switch to the 
Commands tab, open a menu, and change drag commands to and from the Commands tab.

Customizing Miscellaneous Options

To change options

1. Select View > Toolbars > Customize > Options tab.

2. Check or uncheck the following options in this dialog box:

3. Select Close when you are finished.

While the Customize dialog box is open, you can remove entire menus. However, this is 
not recommended. Never remove the View menu, which would prevent you from 
accessing the Customize dialog box and prevent you from resetting back to the defaults.

Show ScreenTips on Toolbars Shows tool tips over a button, when the mouse is left 
to hover over the button.

Show Shortcut Keys in ScreenTips Includes the key assignment for a command as part of 
button tool tips.

Large Icons Displays larger buttons in the toolbars.
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7 Troubleshooting

Overview
Occasionally problems may occur where ucCompanion, ucCompanion - Live Attendant, or 
ucCompanion - Soft Phone do not work as expected. Refer to the following sections to determine possible 
causes and solutions for errors that may occur. 

• Unable to Manage Calls on page 72
• Unable to Make Calls on page 73
• Unable to Remove Calls on page 74
• Connection to the Server is Lost on page 75

Unable to Manage Calls

Windows Firewall Prevents Users from Managing Calls

Symptoms
• You can launch ucCompanion or ucCompanion - Live Attendant.
• You can launch ucCompanion - Soft Phone, and it registers.
• You can see incoming ringing calls, but you are unable to answer them.
• You cannot make calls.

Cause

Occasionally, Windows Firewall may prevent users from being able to manage their calls. This is most 
likely to occur following an initial installation or upgrade of ucCompanion. For security reasons, Windows 
Firewall blocks programs and services from running on your machine, except for those programs or 
services which have been enabled as exceptions and thus are allowed to run. 

If Windows Firewall is enabled on your local computer, and ucCompanion - Soft Phone is launched for the 
first time by a user without administrative privileges, or with prompting turned off, then Windows Firewall 
prevents ucCompanion - Soft Phone from running, which results in the user not being able to manage calls. 

The possible causes and solutions noted are not an exhaustive list.
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Solution

To configure Windows Firewall to allow ucCompanion - Soft Phone

1. Select Start > Settings > Control Panel.

2. Double-click on Windows Firewall.

3. Select the Exceptions tab.

4. Enable ucCompanion - Soft Phone, and select OK.

Unable to Make Calls
If you are having trouble making calls, check the following sections for possible causes and solutions.

Unable to Make Any Calls

ucCompanion - Soft Phone isn’t Running

Symptoms

You cannot make any calls, internal or external.

Cause

The ucCompanion - Soft Phone works in conjunction with ucCompanion and ucCompanion - Live 
Attendant, and must be running in order to make calls. If ucCompanion - Soft Phone is running, you should 
refer to the ucCompanion - Soft Phone icon in your system tray. For more information refer to 
ucCompanion - Soft Phone Overview on page 27.

Solution

To launch ucCompanion - Soft Phone 

Select Start > Programs > ucCompanion - Soft Phone.

Unable to Make External Calls

Area Code has not been Configured

Symptoms

You can make internal calls, but not external calls.
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Cause

If you are able to make internal calls, but not external calls, then it’s possible that the area code has not 
been configured in the dialing properties. This is most likely to occur after initially installing or upgrading 
ucCompanion or ucCompanion - Live Attendant. Refer to Setting your Area Code on page 7 for more 
information on dialing properties.

Solution

To configure dialing properties

1. From ucCompanion or ucCompanion – Live Attendant, select Settings > Options.

2. Select the Number Format tab. 

3. Select Dialing Properties.

4. If your area code is not already set then select Edit, and select the Area Code Rules tab.

5. Select New, and enter your area code.

6. If your area has 10 digit dialing in effect, then enable Include the area code. If your area has 7 digit 
dialing in effect, then do not enable Include the area code.

7. Select OK.

8. Select Apply, and select OK on the Area Code Rules tab.

9. Select Apply, and select OK on the Dialing Rules tab.

10. Select OK on the Options dialog.

Unable to Remove Calls

Symptoms

You have disconnected from a call, but it still appears on the screen.

If your administrator has already configured external dialing for you, then do not modify 
the settings unless instructed to do so.

Do not change the maximum number length from the default value of 4, or the length of 
local phone numbers from the default value of 7.
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Cause

Occasionally, due to network issues, the screen may show that you are still connected to a call after you 
have hung up. Use the Clear Call command to reset the screen.

Solution

To clear calls from your screen

Select Edit > Clear Call. Any calls that were shown as connected on your screen are removed.

Connection to the Server is Lost

Connection to the Server is Lost when Windows Vista goes into Sleep 
Mode

Symptoms
• ucCompanion displays that it has lost the connection to the Server
• All Busy Lamp Fields (BLFs) have been removed
• You are running Windows Vista
• This occurs after your computer has gone into sleep mode and then has been reactivated

Cause

If you are using Windows Vista and your computer goes into sleep mode, then you may lose the 
connection to the Server, and it does not automatically reconnect when the computer is reactivated.

Solution

To regain the server connection, close ucCompanion and restart it. 

Clear call is not the same as disconnecting a call. That is, if the call was not previously 
disconnected, then selecting Clear Call does not disconnect the call, but it removes it 
from your screen.

Alternatively, right-click on your extension cell, and select Clear All Calls. The keyboard 
shortcut to clear calls is F12.
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Prevention

To prevent this issue from occurring, go to the Windows Vista Control Panel, and adjust the power options 
to avoid going into sleep mode.

For more information, refer to Connecting to the ucCompanion Server on page 7.
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8 Other Features
Refer to the following sections for information on other features:

• Setting your Status Note on page 77
• Editing a User’s Status Note on page 78
• Logging in as Administrator on page 79
• Changing Interface Colors on page 80
• Minimizing the Program to the System Tray on page 80
• Running in Tray Icon Mode on page 81
• Setting Options on page 81

Setting your Status Note
You can insert a text status note into your extension cell that is visible to all ucCompanion users. 

Status Note in an Extension Cell

To set a Status Note

1. Right-click on your extension cell and select Edit status note
Alternatively:
• Select Settings > Set My Status Note from the menu bar.
• Press CTRL + T
The status note window appears. 

2. Enter a new message, or select an existing message:
• Type a short message, up to 250 characters, in the lower portion of the window. 
• Select an existing message from the Predefined Notes section. The message automatically appears 

in the lower portion of the window.
619510005-1A Copyright © 2009 ADTRAN, Inc. 77



 Editing a User’s Status Note NetVanta ucCompanion
3. To add a time and date stamp to the message, press CTRL + T.

4. Select OK. The status note is added to your extension cell, and is visible to all users in the system.

An icon also appears in your extension cell, indicating that you have a status note.

Status Note icon

5. To change or delete your status note, repeat the steps above to open the status note window again, and 
change or delete the text.

Editing a User’s Status Note
In ucCompanion - Live Attendant you can edit the status notes of other users. You can edit the status notes 
for global speed dials, that is, extensions of any group type (for example, tenant, system-wide, or normal) 
that are created using the Busy Lamp Field (BLF) Administration. However, you cannot edit the status 
note for extensions created in local extension groups, for example, local speed dials that you have created.

To edit a user's Status Note 

1. Right-click on the extension cell of the user whose status note you want to edit, and select Edit status 
note.

2. Enter a new message, or select an existing message:
• Type a short message, up to a maximum of 250 characters, in the lower portion of the window.
• Select an existing message from the Predefined Notes section. The message automatically appears 

in the lower portion of the window.
 78 Copyright © 2009 ADTRAN, Inc. 619510005-1A



NetVanta ucCompanion  Logging in as Administrator
3. If you want to add a time and date stamp, press CTRL-T. 

4. Select OK. The status note is added to the extension cell, and is visible to all users in the system. An 
icon also appears in the extension cell, indicating that the user has a status note. 

5. To change or delete the status note, repeat the steps above to open the status note window, and change 
or delete the text. 

Logging in as Administrator
Logging in as the administrator provides access to restricted features, such as changing your extension 
number, global extension administration, and server connection options. 

To log in as administrator

1. On the menu bar, select File > Admin login. If Admin login is grayed out, you are already logged in 
as administrator. This displays the Administrative login dialog box.

2. Enter the Server password in the Enter Password box. If you do not know the administrative 
password, contact your system administrator. 

To change the Administrative Password

1. From the menu bar, select File > Admin login. 

2. Enter the current administrative password in the Enter Password box. This is the password that was 
created when the ucCompanion Server (PCE server) was installed.

3. Enter a password in the New Password box. Then re-enter the same password in the Re-Enter 
Password box. 

4. Select the Change Password button. 

5. Select OK in the confirmation box that appears.

To Log Out as Administrator

Select File > Admin logout.
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Changing Interface Colors
You can customize the colors used in ucCompanion - Live Attendant. The color scheme used is called a 
skin.

To change interface colors

1. In the ucCompanion Console menu, select Settings > Skins. The Skin Editor dialog box appears.

2. If you want to use a pre-configured skin, go to the Choose Skin drop-down list and choose a scheme 
other than Default. Select OK to close the Skin Editor and apply the new scheme. If you want to make 
general changes to the colors of extension cells only, go to Choose Skin and choose Standard. Select 
OK to close the Skin Editor. Then choose Help > Color Legend. In the Color Legend, double-click 
on the cells to change their colors. Select OK to close the Color Legend and apply the new cell colors.
If you want to use your own custom colors, and you want to change individual component colors 
throughout the window, choose a skin other than Default (the Standard scheme is recommended). 
Select each part of the interface in turn in the Color Property drop-down list. Then select the button to 
the right, to change the color of that property. Refer to Overview of the Main Window on page 12 for a 
description of various parts of the window. Within the names of the color properties, Bk means 
background color. For example, CallQueueBkColor is the background of the call list. Some of the 
non-default skins also have different icons from the Default icons. Select OK to set your changes..

Minimizing the Program to the System Tray

To minimize the program

1. Select the Minimize button in the top, right part of the title bar. 

2. If the Minimize Application to Tray option is enabled, the program is minimized to the system tray. 
The Minimize Application to Tray setting is set in Settings > Options > Misc tab. 

3. To maximize the program again, double-click on the ucCompanion icon, or right-click on it and select 
Open ucCompanion or Open ucCompanion-Live Attendant. 

ucCompanion icon in the Windows System Tray

If the Minimize Application to Tray option is not enabled, the program is minimized to the task bar. 
To maximize the program, select it in the task bar.

To reset all colors back to default, select Settings > Skins, and then set the Choose Skin 
to Default.
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Running in Tray Icon Mode

Overview of Tray Icon Mode
If you want to use the minimum desktop space for ucCompanion you can run in Tray Icon mode. In this 
mode, the program appears as an icon in the System Tray. When call activity occurs on your extension, it 
will be displayed as a small notification popup window that appears from the System Tray, if the 
notification window is enabled.

Notification Popup Window

Enabling Tray Icon Mode

To enable Tray Icon mode

1. In ucCompanion, select Settings > Options. The Options dialog box appears. 

2. Select the Misc tab.

3. Check Minimize Application to Tray. 

4. Check Enable Notification Window, and select OK. Tray Icon mode is now enabled. Whenever you 
want to disable Tray Icon mode, open the Options dialog box again and uncheck Minimize 
Application to Tray.

Setting Options

Server Options

To set server connection options

1. From the menu bar, select Settings > Options. The Options dialog box appears.

2. In the Server tab, select the Connection Parameters button. The ucCompanion PCE Connection 
dialog box appears.
Host – Enter the IP address of the ucCompanion server. Ask your system administrator for this 
information. 

3. Select OK to save the settings.
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My Extension Options
The My Extension tab allows you to set the name and extension number you will use in the ucCompanion 
system. You can also set a personal password, to restrict changes to your name and extension number 
settings.

To set My Extension options

1. From the menu bar, select Settings > Options. The Options dialog box appears. 

2. Select the My Extensions tab. Refer to Logging in as Administrator on page 79 for more information. 
If you are not logged in as administrator, you can gain access to the grayed out settings by entering 
your personal password in the New Password field and the Re-Enter New Password field.

3. Configure the settings in this tab as desired:

4. If you have not yet created a personal password, you may do so in the My Extensions tab. This 
prevents another user from using your extension number or name. To set a new personal password, do 
the following: enter a new password in the New Password box. Then type the new password again in 
the Re-enter Password box. Then select the Change Password button.

5. Select OK to save the settings.

Number Format Options

To set Number Format options

1. From the menu bar, select Settings > Options. The Options dialog box appears. 

2. Select the Number Format tab.

Enter New My Extension Enter the extension number that you will access on this computer. This 
number will be displayed in your main title bar. This is the only setting 
in the My Extension tab that does not require a personal password.
If the extension number you enter is protected by a personal password, 
you must enter that password in the Enter Password box.

Enter Password Enter your personal password in this field and select the ... button. If 
you are logged in as administrator, you are already logged in here 
automatically.
If you have not yet set a personal password on this computer, leave the 
Enter Password box blank and just select the ... button.

My Extension Name Enter a new first and last name in this box. This is the name that will 
identify you to other users, such as when you send an instant 
message. However, this does not set the name that appears in your 
extension cell; that is set up by your system administrator.
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3. Configure the settings in this tab, as desired:
• In the first box in this tab, enter the number of digits used for extensions in your phone system. 
• In the second box, enter the number of digits required to dial a local phone number, not including 

trunk prefixes such as 9.
• In the CallerID Format field, use the default setting of “(???) ???-????” for most systems.
• Select the Dialing Properties button to bring up a Windows dialog box that allows you to set your 

local dialing options.

4. Select OK to save the settings.

Display Options

To set Display options

1. From the menu bar, select Settings > Options. The Options dialog box appears. 

2. Select the Display tab.

3. Configure the settings in this tab, as desired:

4. Select OK to save the settings.

Miscellaneous Options

To set Miscellaneous options

1. From the menu bar, select Settings > Options. The Options dialog box appears. 

2. Select the Misc tab.

Show CPS Scripting Area Check this option to show the CPS Scripting panel above the call 
list. This option is disabled by default, and should remain unchecked 
unless CPS scripts are being used. Refer to your administrator for 
more information.

Color Coded Extension Cell 
Bars

When this option is checked, call activity on extensions (and trunks) 
is indicated in the extension status area by color changes in the 
extension cells. Refer to Extension Status Area on page 24 for more 
information. This option is checked by default.
Uncheck this option to make extension cells always remain the 
default color. The default color is blue, when using the default “skin.” 
Refer to Changing Interface Colors on page 80 for more 
information. 
After you change this setting, you must change to a different 
extension group or restart the program before the change will take 
effect. 

Show Line Column Displays the Line column in the call list. The line column shows 
which line a call came in on.

Use Bold Font for Status Note Enable this option to make all status note text bold, as it displays on 
your computer.
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3. Configure the settings in this tab as desired:

4. Select OK to save the settings.

Custom Toolbar
You can add custom smart buttons to the main toolbar. You can configure these buttons to launch 
programs or perform some other programming task.

To create a custom button to launch an external program

1. Make sure the Custom toolbar is displayed. Enable it by selecting View > Toolbars > Custom from 
the menu bar.

2. From the menu bar, select Settings > Options > Custom Toolbar tab.

3. Select the New (Insert) button.

New button

4. Enter a name for the custom button, and press the Enter key. An entry for the custom button appears 
in the Toolbar Items box.

5. While the new entry is selected, make sure the command drop-down list is set to External Program.

Bring to Foreground on Ring Check this option to make the main window come to the front of all 
other programs when your extension rings. 

Minimize Application to Tray Check this option to make ucCompanion go to the Windows system 
tray when you minimize it. To restore the program, double-click the 
icon in the system tray.
If this option is not checked, minimizing the program causes it to 
appear in the Windows task bar rather than in the system tray. 

Ring the PC on Incoming Call Check this option to make your PC speakers ring when a call comes 
into your extension. This requires that your PC has speakers and a 
sound card installed.

Flash Icon on Activity When this is enabled, the ucCompanion will flash when it is 
minimized to the system tray, if there is activity in ucCompanion.

Enable Notification Window Shows a small popup window from the system tray whenever call 
activity occurs on your extension.

Notify call parking destination 
(user)

When parking a call, enabling this option prompts you to enter the 
extension number of the user for whom the call is being parked. The 
user is then notified that a call is parked for them, so they can unpark 
it. Refer to To automatically notify users when a call is parked for 
them on page 44 for more information.

Call Processing Scenario 
Scripting

For use in creating CPS scripts.
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6. In the Parameters area at the bottom of the dialog box, select the ... button next to the command box. 
Browse and select an executable file.

7. Enter settings in the Argument field as needed. 
Arguments are additional parameters that must be included with the initial command to execute the 
program.

8. Enter settings in the Working Directory field as needed. 
The working directory is the location where the program will look to find any related files it needs.

9. Select OK to close the Options dialog box. The new custom button now appears in the custom 
toolbar in the main window.
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