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Unified Communication Server  Conventions
Conventions

Notes provide additional useful information.

Cautions signify information that could prevent service interruption or damage to 
equipment.

Warnings provide information that could prevent injury or endangerment to human 
life.
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1 Server Configuration Guide

Introduction
This guide is written for installers to configure the NetVanta Unified Communications Server at the 
customer site. It assumes that you have experience installing and programming PBXs and voicemail 
systems. It does not assume extensive knowledge of computer networks.

Microsoft® Before you run the UC Server Configuration Wizard, make sure you follow all the instructions 
in the NetVanta Unified Communications Software Installation Guide available on ADTRAN’s Support 
Forum at https://supportforums.adtran.com (article number 4394).

This guide covers the following main topics:

• Preparing to Start the Server Configuration Wizard on page 7

• 26092610Starting the Server Configuration Wizard on page 10

Preparing to Start the Server Configuration Wizard
Before you start the UC Server Configuration Wizard, you can further prepare your system by doing the 
following:

• Obtaining Network and Security Information on page 7

• Verifying Requirements and Recommendations on page 8

• Incorporating the Server into the Customer Domain on page 8

• Gathering Server Configuration Wizard Information on page 9

• Creating an Authorization Store to Enable Active Directory Roles on page 9

Obtaining Network and Security Information
Obtain network and server information from the customer prior to configuration, such as service accounts 
and administrative passwords.

For security reasons, some customers might be reluctant to provide passwords and network information in 
this manner. If that is the case, the customer should make sure that this information is readily available 
when you arrive on site to do the configuration.

For additional ADTRAN documents, refer to the ADTRAN Support Forum at https://
supportforums.adtran.com. 
619500001-29A Copyright © 2012 ADTRAN, Inc. 7
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 Preparing to Start the Server Configuration Wizard Unified Communication Server
Verifying Requirements and Recommendations
The UC Server application runs on the following operating systems:

• Microsoft Windows Server 2008 (x86, x64)
• Deployment on Server Core or Hyper-V is not supported.

• Microsoft Windows Server 2003 R2 SP2

• Microsoft Windows Server 2003 SP1, SP2

• Microsoft Windows Small Business Server 2003 SP1 or later SP

• Microsoft Windows XP Professional SP2 or later SP

To ensure security, UC Server accounts are given minimal permissions on the computer. The Server must 
be installed onto an NTFS partition on this server computer to make sure that proper security is in place.

The Exchange Server and UC Server computer must be members of the same Windows domain.

Consult the UC Server support website for additional up-to-date application or configuration notes.

Incorporating the Server into the Customer Domain
Incorporating the UC Server into the customer domain is required for Active Directory and Microsoft 
Exchange integration.

To incorporate the UC Server

1. On the desktop, right-click My Computer.

2. Select Properties.

3. Select the Computer Name tab.

4. Select the Change... button.

5. In the Member of section, select Domain, and enter the domain name.

It is not recommended that you run UC Server and the Exchange Server on the same system.

You require a domain administrator user name and password to complete this procedure.
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Unified Communication Server  Preparing to Start the Server Configuration Wizard
Gathering Server Configuration Wizard Information
The UC Server Configuration Wizard provides a step-by-step guide for configuring your server. The 
Server Configuration Wizard is customized to configure the server according to the needs of your 
particular network configuration.

It is recommended that you have the information ready that you might need before you start the wizard. 
You need to know the following:

Creating an Authorization Store to Enable Active Directory Roles

The authorization store is typically created prior to running the Server Configuration Wizard.

The following conditions must be satisfied in order to create an authorization store:

• The UC Server computer platform must be integrated with the customer’s network.

• The UC Server Active Directory account must already be created on the customer’s domain.

• The user creating the authorization must be authenticated with the domain.

Message store type Local only or
Local and Exchange or
Lotus Notes/IMAP

Computer names Includes Networking information and computer names
Server Account The dedicated account for running the Server
Microsoft Exchange names Microsoft Exchange Server computer name

Mailbox name for Service Account
UC Server administrator 
password

The password that is used to configure the system. The default 
administrator login name is “admin.”

PBX type Avaya Communication Manager or DEFINITY, Merlin Magix, Nortel 
Norstar, IP Office or generic analog

CTI link options
(Merlin Magix)

Used to configure advanced PBX integration for calling line ID

Port Name and Identity Used to configure all the ports that are connected to the PBX
User information Used to create and configure all the user accounts
Email configuration Used to configure the services when sending notification by email. If 

you do not have Exchange, you can configure an SMTP Server for email 
notification.

Creating an authorization store is an optional step that applies to UC Server installations 
that are integrated with Active Directory. You can skip this step if you are configuring UC 
Server as stand-alone.
619500001-29A Copyright © 2012 ADTRAN, Inc. 9



 26092610Starting the Server Configuration Wizard Unified Communication Server
If users were already created prior to creating an authorization, the administrator must assign a role to each 
configured Windows User. Users added after the authorization store is created have a default role Standard 
User assigned to their user profile.

To create an authorization store

1. Log in to the UC Server computer as a domain administrator.

2. Select Start > Run > CMD to launch a CMD window.

3. Navigate to the UC Server installation directory:
\ADTRAN\NetVanta UC Server\bin

4. Type the following:
manageazman +createxmlstore +admin <DOMAIN>\<UC SERVER SERVICE 
ACCOUNT>

5. Stop and restart the UC Server application service by doing the following:
• Open the service control panel application.
• Restart the service named NetVanta UC Server Application Services.

26092610Starting the Server Configuration Wizard

Login Requirements
Make sure that a computer account is created in the customer’s network. If you are integrating with 
Microsoft Exchange, make sure that you are logged on as a domain user that has:

• Domain administrator privileges—must be able to add users to the domain

• Exchange Server administrator privileges—must be able to create mailboxes and set permissions on the 
Exchange Server

Server Configuration Wizard Overview
The Server Configuration Wizard consists of several wizards that each become available after the 
successful completion of the previous wizard. The wizards are listed below:

If you have already followed the instructions in the NetVanta Unified Communication 
Server Planning and Deployment Guide for creating an authorization store, then you do 
not need to repeat the same steps below.

You can create the custom authorization store at any time, before, during or after 
installation. However, any Active Directory users and their associated authentications will 
have to be modified to include a role from the role list. Consult the NetVanta Enterprise 
Communications Server Administrator Guide for details on how to change the 
authentication role for individual user authentications.
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Unified Communication Server  26092610Starting the Server Configuration Wizard
1. Product Licensing Wizard on page 11 — enter your product and license key information

2. Windows Network Integration Wizard on page 11 — configure Windows Firewall, service account, 
and service connection point

3. Communication Systems Wizard on page 11 — configure your communications systems

4. Messaging Systems on page 12 — select message store type and configure account

5. Users on page 17 — add new or import existing users

6. Final System Configuration on page 23 — configure email notification system; create default user, 
operator and default mailbox; specify dialing rules and location

To start the Server Configuration Wizard
• Select Windows Start > Programs > NetVanta UC Server > Server Configuration Wizard.
The main wizard screen guides you through the rest of the configuration.

Product Licensing Wizard
Run this wizard to specify your product and license key information for UC Server. You can paste the 
product and license key, and the machine ID, into the appropriate wizard boxes. The product key is shipped 
with the product CD.

Windows Network Integration Wizard
You can configure your Windows account to work with UC Server. Create a service account: assign 
permissions to the directory, and assign the account to UC Server.

Create a service connection point. A service connection point is an advertised name that can be used to 
locate UC Server. When you start UC Client for the first time, the service connection point contains the 
name and IP address of the NetVanta UC Server. The user does not have to type a name, the name 
automatically appears in the list.

Communication Systems Wizard

You can define and configure new communication systems. Select a communication system type from the 
list provided. The communication systems listed have the required hardware and a valid license. You 
cannot create a communication system that is invalid. 

The view of the UC Server Configuration Wizard changes after entering a license key for 
UC Server Standard Edition, as only those items applicable to the Standard edition are 
visible.

Communication systems refers to PBXs.
619500001-29A Copyright © 2012 ADTRAN, Inc. 11
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You can select an existing PBX, which you can connect to NetVanta UC Server through a Dialogic Media 
Gateway. For a list of PBXs supported by Dialogic, and for gateway configuration information, refer to the 
Dialogic website at www.dialogic.com. For more information on configuring the gateway to connect 
NetVanta UC Server to an existing PBX, refer to Configuring the Dialogic Media Gateway technical note, 
available on ADTRAN’s Support Forum at https://supportforums.adtran.com (article number 2681).

The options that are available depend on the communications system type selected, but may include 
configuring message waiting, configuring the CTI link, selecting and configuring ports, and selecting a 
network adapter for the communication services.

The Port Configuration page allows you to choose a device ID, to enable and attach a name and an 
extension number to.

Messaging Systems
Use the Messaging Systems Wizard to select a message store type, such as Microsoft Exchange Server, an 
Internet Message Access Protocol (IMAP) server, or a Simple Mail Transfer Protocol (SMTP) server, and 
to configure the message store account. For more information about configuring the desired message store 
account, refer to the following sections:

• Configuring Microsoft Exchange Server on page 12

• IMAP Server on page 16

• SMTP Server on page 16

Configuring Microsoft Exchange Server
When configuring Microsoft Exchange Server, there are several options available to consider. The 
following sections describe these options.

Selecting the Exchange Server version
NetVanta UC Server can connect to several versions of Microsoft Exchange Server. NetVanta UC Server 
version 5.1.0 automatically detects the version of the Exchange Ssrver connected to the NetVanta UC 
Server and configures the connection settings accordingly.  However, you can manually override the 
Exchange Server version selected by NetVanta UC Server using the Version drop-down menu of the 
Configure Exchange Server window. 

Connecting to Exchange Server 2010
The Client Access server (CAS) role was introduced in Exchange Server 2007 to accept client connections 
to services such as Outlook Web Access, much like the Exchange Server 2003 front-end server. 
Nevertheless, NetVanta UC Server (and other exchange clients) connect directly to the Mailbox server via 

Each time NetVanta UC Server connects to Microsoft Exchange Server it will detect the 
Exchange Server’s version. If the version of Microsoft Exchange Server selected in 
NetVanta UC Server does not match the version detected, an error is logged. If the 
detected version of Microsoft Exchange Server is later than the current configuration, 
then the later version will be used for connectivity settings. For more information on how 
to access error logs, refer to Using Logs in the NetVanta UC Server available on 
ADTRAN’s Support Forum at http://supportforums.adtran.com (article number 2605).
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Unified Communication Server  26092610Starting the Server Configuration Wizard
Messaging Application Programming Interface (MAPI) when connecting to either Exchange Server 2003 
or Exchange Server 2007.

In Exchange Server 2010, the RPC Client Access service was introduced to allow the CAS to handle all 
MAPI connections. Instead of Exchange clients (including NetVanta UC Server) connecting to the 
Mailbox server directly, they must connect to the CAS via MAPI to access the Mailbox server. Because 
NetVanta UC Server integrates with Exchange Server using MAPI, this change can affect which physical 
server should be designated as the Server when configuring an Exchange Server 2010 connection in 
NetVanta UC Server.  You must designate a physical server that hosts the CAS role as the Server. If, for 
example, the CAS role and Mailbox server role are hosted on separate physical servers, the server hosting 
the CAS role should be designated as the Exchange Server.  If multiple physical servers host the CAS role 
in a CAS array, any one of these servers can be designated as the Server when configuring the connection. 

Configuring message delivery
When you configure Exchange Server, you can set the system-wide message delivery mode to determine 
whether voice and fax messages are sent from the system mailbox or are stored directly in users’ 
mailboxes. This setting affects whether:

• User defined message rules in Microsoft Outlook® or Microsoft Exchange Server are applied.
• Messages are sent to third-party applications such as BlackBerry® Enterprise Server.
• The caller's phone number appears in the From line of the message.

The message delivery modes are as follows:

NetVanta UC Server does not provide failover for Microsoft Exchange Server 
configurations with CAS arrays. If  the CAS server designated as the Server fails, 
NetVanta UC Server will not redirect to another CAS server in the array.

Send messages 
from system mailbox

Voice and fax messages are sent from the system mailbox.  This mode has the 
following effects:
• Any user defined message rules set in Outlook or Exchange Server are 

applied. For example, a user's rule might direct messages from a particular 
contact to a specific folder.

• Messages are sent to any third-party applications such as BlackBerry 
Enterprise Server.

• The message appears to be from the system mailbox, and the From line 
does not include the caller's phone number.
619500001-29A Copyright © 2012 ADTRAN, Inc. 13



 26092610Starting the Server Configuration Wizard Unified Communication Server
Synchronizing message waiting indicators for messages accessed through the 
Web or mobile devices
You can configure Exchange Server to monitor users’ mailboxes to determine when a new message arrives 
or is read, or when a message is marked as read or unread. The advantage is that when a user accesses their 
voicemail messages through Microsoft Outlook Web Access or a mobile device, the NetVanta UC Server 
adjusts the message waiting indicator on the user’s phone accordingly (to turn it on or off). Without 
mailbox monitoring, the NetVanta UC Server is unaware when a user accesses their voicemail messages 
through Outlook Web Access or a mobile device. For example, even after a user has accessed all their new 
messages, the message waiting indicator on their desk phone may continue to flash. 

However, mailbox monitoring can negatively impact system performance. Therefore, you may want to 
enable mailbox monitoring only for those users who require it.

The mailbox monitoring options are as follows:

Impersonate caller 
and store to mailbox

Voice and fax messages are stored directly in the user's mailbox, rather than 
being sent.  This mode has the following effects:
• User defined message rules in Outlook or Exchange Server are not applied. 

For example, a user's rule directing messages from a particular contact to 
a specific folder is not applied. 

• Messages are not sent to any third-party applications such as BlackBerry 
Enterprise Server.

• The From line includes the caller's phone number, or the caller's name from 
a contact that matches the phone number. 

Enable mailbox monitoring Opens the Exchange Server mailboxes of selected users at system start 
up. The NetVanta UC Server monitors each mailbox for changes such as 
a new message has arrived or is read, or a message is marked as read or 
unread. This applies only to the Inbox; other folders are not monitored. 
When a user accesses messages through Outlook Web Access or a 
mobile device, depending on the message waiting indicator (MWI) 
settings selected, the MWI turns on or off accordingly.

Default setting for users If mailbox monitoring is enabled, then this mode turns mailbox 
monitoring for users on or off by default.

Mailbox monitoring works in conjunction with the MWI options set. For example, the 
MWI options determine if the message waiting indicator is turned off when the first 
message is read, or when all new messages have been read. 
 14 Copyright © 2012 ADTRAN, Inc. 619500001-29A



Unified Communication Server  26092610Starting the Server Configuration Wizard
Configuring a Microsoft Exchange Server Message Store
To configure a Microsoft Exchange Server message store, follow these steps:

1. Select Microsoft Exchange Server in the Select Messaging Servers window and select Next. The 
Configure Exchange Server window will appear. 

2. Use the Select the Exchange Server drop-down menu to select an Exchange Server that has been 
detected by NetVanta UC Server. If the server name does not appear in the list, a server name can be 
entered in the field. The server name is the name of the physical Exchange Server to which the 
NetVanta UC Server will be connected. If you are adding a Microsoft Exchange Server 2010 
(including service pack versions), you must select a server with the CAS role. Refer to Connecting to 
Exchange Server 2010 on page 12 for information on selecting the appropriate Microsoft Exchange 
Server 2010 server. 

3. If the version of the selected Exchange Server differs from the version in the Select Exchange 
Version field, use the drop-down menu to select the appropriate version of Microsoft Exchange 
Server. You may receive one of the following error messages when manually selecting the version of 
Microsoft Exchange Server:
• Selected version differs from autodetected version
• The selected Exchange server has changed and no longer reflects the existing home mailbox 

configuration for the service account.

4. In the Service mailbox name field, enter the Microsoft Exchange Server mailbox name for the 
NetVanta UC Server service account. This mailbox is the Microsoft Exchange Server mailbox that has 
special access privileges in Exchange Server.  

5. In the Message delivery mechanism section, select one of the following options:

Mailbox monitoring could negatively impact system performance. Mailbox monitoring 
increases the traffic between the Exchange Server and the NetVanta UC Server. On 
systems with more than 100 users, system design and engineering must consider the 
increased load of mailbox monitoring on the Exchange Server. Monitoring more than 500 
mailboxes requires careful consideration and should not be done without a slow roll-out 
procedure to validate the performance of both Exchange Server and NetVanta UC Server 
in the specific customer environment. If your Exchange Server is at or near maximum 
capacity, then you may want to disable mailbox monitoring.

If the service account has a mailbox defined for it in Active Directory, the associated 
mailbox name displays automatically and cannot be changed.

Send messages from 
system mailbox

Voice and fax messages are sent from the system mailbox.

Impersonate caller and 
store to mailbox

Voice and fax messages are stored directly in the user's mailbox, 
rather than being sent.
619500001-29A Copyright © 2012 ADTRAN, Inc. 15



 26092610Starting the Server Configuration Wizard Unified Communication Server
6. Select Enable mailbox monitoring if you want to enable mailbox monitoring for specific or all users.

IMAP Server
Internet Message Access Protocol (IMAP) is a method of accessing and storing email messages. The 
NetVanta UC Server can integrate with IMAP version 4 revision 1 servers conforming to RFC 2060. For 
more information on IMAP version 4 revision 1, refer to www.ietf.org/rfc/rfc2060.txt. Add an IMAP server 
when you need to integrate NetVanta UC Server with Lotus Notes, Lotus Domino, Novell GroupWise, 
Google Mail (Gmail), or other servers. For more information on integrating NetVanta UC Server with 
Gmail, refer to the IMAP Integration with Google Mail technical note available on ADTRAN’s Support 
Forum at https://supportforums.adtran.com (article number 2768).

The NetVanta UC Server can use mailboxes on an IMAP server to store voice and fax messages in order to 
provide users with unified messaging functionality. In addition, users licensed for text-to-speech (TTS) can 
listen to their email messages from their mailbox over the telephone. 

To configure an IMAP server message store, follow these steps:

1. Select IMAP in the Select Messaging Servers window, and select Next. The Configure an IMAP 
Server window will appear. 

2. Enter the host name or IP address of the IMAP server in the Enter the network address for the 
IMAP server field. In some cases, such as Gmail, this can point to a proxy instead.

3. If you would like to select a service port for the IMAP server other than the default (port 143), select 
the Other radio button and enter a port number in the adjacent field. The port number is the IP port 
number of the IMAP service on the target server.

4. Select the Test button to verify that the host name or IP address that you specified is listening and 
displays the IMAP banner.

SMTP Server
The SMTP server is used to send emails, and is only required if you are not integrating with Microsoft 
Exchange. To configure an SMTP server, follow these steps:

Enable mailbox monitoring Opens the Exchange Server mailboxes of selected users at system 
start up. The NetVanta UC Server monitors each mailbox for 
changes in new message status, and depending on the MWI 
settings, adjusts the MWI accordingly.

Default setting for users If Enable mailbox monitoring is selected, you can use the On or 
Off radio buttons to turn mailbox monitoring for users on or off by 
default.

Depending on your server configuration, further configuration may be required from the 
NetVanta UC Server Administrator application to configure the appropriate message 
retrieval method. For more information refer to the NetVanta Unified Communications 
Server Administrator Guide available on ADTRAN’s Support Forum at  https://
supportforums.adtran.com (article number 1252).
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Unified Communication Server  26092610Starting the Server Configuration Wizard
1. Select SMTP in the Select Messaging Servers window, and select Next. The Configure an SMTP 
Server window will appear. 

2. Enter the host name or IP address of the SMTP server in the Enter the network address for the 
SMTP server field.

3. If you would like to select a service port for the SMTP server other than the default (port 25), select 
the Other radio button and enter a port number in the adjacent field. The port number is the IP port 
number of the SMTP service on the target server.

4. Select the Test button to verify that the host name or IP address that you specified is listening and 
displays the SMTP banner.

5. Enter the display name for outoging email in the provided field. This display name is sent with the 
email and appears on the recipient's email client.

6. Enter the outgoing email address in the provided field.  This address is the physical email address that 
is used to send email. The email account must exist with your service provider for SMTP to function 
correctly. An example of a sender email address is: myemailname@serviceprovider.com.

7. Select Send a test email to send a test email using the defined display name and outgoing email 
address of the SMTP server. The Enter email address window will appear. In the provided field, 
enter a valid email address that you would like to receive the test email.  Then, select OK to send the 
test email.

Users
Use this wizard to add new users and import existing users from Active Directory, Microsoft Exchange 
Server, or from text files. The wizard allows you to select a location to import users from. You can also 
change user information before you create users. For more information refer to the following sections:

• Importing users from Active Directory on page 17

• Importing users from Exchange Server on page 18

• Importing users from text files on page 19

Importing users from Active Directory
You can select a group of users to import from Active Directory, and you can also automatically assign an 
extension number for each user. 

User naming convention
If you import users with a display name only, without specifying the first and last name, then users are 
imported as follows:

• If a display name is delimited with spaces, then the last 'word' is the last name, for example, "Bob Jeff 
Thompson"

lastname = Thompson
firstname = Bob Jeff
619500001-29A Copyright © 2012 ADTRAN, Inc. 17



 26092610Starting the Server Configuration Wizard Unified Communication Server
• If a display name is delimited with commas, then everything after the comma is the first name, for 
example, "Thompson, Bob J.”

lastname = Thompson
firstname = Bob J.

To import Active Directory users

1. From the drop-down list, select the Active Directory domain from which you want to import users.

2. Select Browse to search Containers on your system for the users that you want to import. 

3. If you specify a name prefix, the wizard imports users with names that begin with that prefix (this 
feature is not case sensitive). 

4. Enable the Create "Windows-enabled" Active Directory users check box if you want users to be 
able to use the single sign-on Active Directory feature.

5. Enable the Use Active Directory for messaging configuration check box to link users' mailboxes to 
their corresponding Exchange mailboxes.

To change users’ specifications
• To return the wizard to the specification page, select Stop search and refine criteria.

To stop importing users
• To stop the import, select Stop search and process users. 

The configuration page appears with only those users that were imported up to that point.

Importing users from Exchange Server

To import users from Exchange Server

1. From the list, select the location of the Microsoft Exchange Server from which you want to import 
users. 

2. If you specify a name prefix, the wizard imports users with names that begin with that prefix (this 
feature is not case sensitive). 
With the list of users, you can assign the Identities (typically extensions). The wizard extracts the first 
name and last name from the Exchange Server. The users are associated with the Personal Assistant 
(PA) user profile, and have the system operator as the default dial "0" location. 

If you are importing a large number of users, the process takes some time, and a progress 
page shows you how many users have been found so far.
 18 Copyright © 2012 ADTRAN, Inc. 619500001-29A



Unified Communication Server  26092610Starting the Server Configuration Wizard
3. Select whether you want the users that you are importing to be linked to Active Directory.

To change users’ specifications
• To return the wizard to the specification page, select Stop search and refine criteria.

To stop importing users
• To stop the import, select Stop search and process users. 

The configuration page appears with only those users that were imported up to that point.

Importing users from text files
You can use Microsoft Excel to create a tab-separated text file to import Windows-enabled or local users. 
A Windows-enabled user is associated with an Active Directory user, while a local user is not. Local users 
are configured to use local message store (LMS), while Windows-enabled users are configured to use 
Microsoft Exchange Server if one exists. Some fields are required and others are optional, depending on 
whether you're importing local or Active Directory users. 

For more information refer to the following sections:

• Importing local users from text files on page 19

• Importing Windows-enabled users from text files on page 21

Importing local users from text files
To import users, enter the information for each user in a tab-separated text file. The format of the tab-
separated file must be similar to the following example, which shows all possible headings for local users. 
The order of the headings does not matter, and the headers are not case sensitive. To import local users, 
provide the displayname at a minimum.

Table 1-1. Tab-separated file format

If you are importing a large number of users, the process takes some time, and a progress 
page shows you how many users have been found so far.

For more information on importing users from text files, refer to the Importing Users to UC 
Server technical note available from ADTRAN’s Support Forum at https://
supportforums.adtran.com (article number 2766). A corresponding zip file also includes a 
Microsoft Excel file for importing users.

displayname extension givenname sn userfax pbx answeringmode
First1 Last1 3000 First1 Last1 PA
First2 Last2 3001 First2 Last2 PBA
First3 Last3 3002 First3 Last3
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To create a tab-separated file for importing local users using Microsoft Excel

1. Create a Microsoft Excel spreadsheet that has some or all of the following headings. At a minimum, 
the DisplayName must be specified.

2. Enter the customer-provided information into the relevant headings.

3. In Microsoft Excel, select File > Save As.

4. Type a name for the file.

5. In the Save as type list, select Text (Tab delimited)(*.txt).

6. Select Save.

7. Close Excel.

To import the user text file

1. When you run the User Import Wizard, choose to import user information from a text-based file.

2. Select Browse to select the location of the file.

displayname Name that appears in the Administration Users pane

extension Identity that is associated with the user. If this value is entered, it must be unique for 
each user, and cannot correspond to an existing identity.

givenname First name of the user

sn Last name of the user

userfax Incoming identity associated with DID fax. This is the fax number that callers dial to 
send faxes to the user. The user receives incoming faxes in their Inbox.

pbx Display name of the PBX that the user is associated with.

answeringmode Call answering mode, either PA for Personal Assistant or PBA for Personal Business 
Assistant. If no value is specified, then the user becomes a PA user by default. PA and 
PBA are not case sensitive.
 20 Copyright © 2012 ADTRAN, Inc. 619500001-29A



Unified Communication Server  26092610Starting the Server Configuration Wizard
3. The following options are valid only for importing Windows-enabled users, so for local users the 
check boxes are disabled:
• Create “Windows-enabled” Active Directory users
• Use Active Directory for messaging configuration

To stop importing users from a text file
• To return the wizard to the specification page, select Stop search and refine criteria.
• To stop the import, select Stop search and process users. The configuration page appears with 

only those users that were imported up to that point.

Importing Windows-enabled users from text files
To import Windows-enabled users, enter the information for each user in a tab- separated text file. For 
Windows-enabled users, the format of the tab-separated file headings must be similar to the following 
examples. The order of the headings does not matter, and the headers are not case sensitive. Include all of 
the required fields, and any of the optional fields that you want, into one file.

Table 1-2. Required fields for Windows-enabled users

Table 1-3. Optional fields for Windows-enabled users

If you are importing a large number of users, the process takes some time, and a progress 
page shows you how many users have been found so far.

displayname givenname sn legacyexchangedn objectguid objectsid userprincipalname

First1 Last1 First1 Last1
First2 Last2 First2 Last2
First3 Last3 First3 Last3

If you do not include all the required information for a Windows-enabled user, then a user 
will be imported as a local user instead.

extension userfax pbx answeringmode

3000 PA
3001 PBA
3002
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To create a tab-separated file for importing Windows-enabled users using Microsoft Excel

1. Create a Microsoft Excel spreadsheet that has the following headings (some are optional as noted 
above):

2. Enter the customer-provided information into the relevant headings.

3. In Microsoft Excel, select File > Save As.

4. Type a name for the file.

5. In the Save as type list, select Text (Tab delimited)(*.txt).

6. Select Save.

7. Close Excel.

To import the user text file

1. When you run the User Import Wizard, choose to import user information from a text-based file.

2. Select Browse to select the location of the file.

3. If you’ve included all the required field headings, then Create "Windows-enabled" Active 
Directory users is enabled for users to be able to use the single sign-on Active Directory feature.

displayname Name that appears in the Administration Users pane

extension Identity that is associated with the user. If this value is entered, it must be unique 
for each user, and cannot correspond to an existing identity.

givenname First name of the user

sn Last name of the user

userfax Incoming identity associated with DID fax. This is the fax number that callers dial 
to send faxes to the user. The user receives incoming faxes in their Inbox.

pbx Display name of the PBX that the user is associated with. 

legacyexchangedn Identifying string for the user’s Exchange Server, as defined in Active Directory

objectguid GUID of the object in Active Directory

objectsid SID of the user in Active Directory, in S-1-5... format

userprincipalname The user email address, for example, jmciverson@adtran.com.

answeringmode Call answering mode, either PA for Personal Assistant or PBA for Personal 
Business Assistant. If no value is specified, then the user becomes a PA user by 
default. PA and PBA are not case sensitive.
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4. Enable the Use Active Directory for messaging configuration check box to link users' mailboxes to 
their corresponding Exchange mailboxes.

To stop importing users from a text file
• To return the wizard to the specification page, select Stop search and refine criteria.
• To stop the import, select Stop search and process users. The configuration page appears with 

only those users that were imported up to that point.

Final System Configuration
The Final System Configuration Wizard allows you to configure the email notification system. You can use 
the wizard to create default users and operators, and default mailboxes. Run the wizard also to specify 
dialing rules and location.

 2610)

If you misspell, or omit, any of the required headers in the tab-separated file, the check 
boxes noted above are unavailable and users can only be imported as local users.

If you are importing a large number of users, the process takes some time, and a progress 
page shows you how many users have been found so far.
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The information in this appendix is intended as reference material for the network administrator.

Before the installer arrives at your site, ensure that the required files for the configuration have already 
been installed on the UC Servfer computer. 

The following sections describe the manual procedures for some tasks that are typically performed 
automatically by the UC Server Configuration Wizard. These procedures may be required to be performed 
manually, since there may be some information about your network and hardware that the wizard cannot 
determine automatically. The procedures are described below in case some manual configuration is 
required.

• Configuring the UC Server User Account on page 25
• Configuring the Exchange Server Account and Permissions on page 26

Configuring the UC Server User Account
The Server Configuration Wizard typically creates a new user account on the computer network for UC 
Server. If this was not done automatically, then follow the steps below to create the account manually.

To manually create a user account for UC Server on the local machine (UC Server is not 
part of a domain)

1. Right-click My Computer on the desktop.

2. Select Manage.

3. Select Local Users and Groups.

4. Right-click Users.

5. Select New User.

6. In the New User dialog, enter the required user account information. 
The User name can be “UC Server” or a name that you choose.

7. Select Create.

To manually create a user account for UC Server in Active Directory (UC Server is part of a 
domain)

1. Select Start > Programs > Administrative Tools > Active Directory Users and Computers.

2. In the left pane, select Users > Action > New > User.

It is only necessary to follow the manual procedures below if the Server Configuration 
Wizard failed to do so automatically, or if you chose to do so manually in order to implement 
a custom configuration. 
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3. In the New User dialog box, enter the required user account information. 
The Logon Name can be “UC Server” or a name that you choose.

4. Select Next.

5. Enter the user password information, and select Next.

6. If you have Exchange on the computer, enable Create an Exchange Mailbox.

7. Select Next, and then select Finish.

Configuring the Exchange Server Account and Permissions
The UC Server user account provides a separate security context that does not require administrative 
permissions on the local computer or in the Domain Administrators Active Directory group. 

The UC Server account’s administrative privileges are limited to Microsoft Exchange Server mailboxes. 
The account must access Exchange user mailboxes in an administrative capacity because it uses them to 
store and retrieve messages.

Follow the relevant instructions below for configuring Exchange Server 2007, or configuring Exchange 
Server 2003/2000.

• Configuring Exchange Server 2007 on page 26
• Configuring Exchange Server 2003/2000 on page 27

Configuring Exchange Server 2007
To create a mailbox logon to the Exchange Server 2007 console with a Windows account 
with Recipient Permissions

1. Select Start > Program > Exchange Server 2007 > Exchange Management Console. 

2. Navigate to Microsoft Exchange > Recipient Configuration. 

3. Right select on Mailbox and select New Mailbox. 

4. Select User Mailbox and select Next. 

5. Select New user and select Next. 

6. Enter the information for the new user, enable the option User must change password at next logon, 
and select Next.

7. Select Next again, and select New.

To integrate with Exchange Server 2007, A Microsoft Exchange Server MAPI client be 
installed on the UC Server platform to permit connection. We recommend using Microsoft 
Exchange Server MAPI Client and Collaboration Data Objects 1.2. Microsoft Outlook 2007 
SP2 is not supported.
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To grant permissions to the Exchange Server 2007 message store from UC Server
• Type the following script replacing <SERVICE_ACCOUNT> with the Service Account name:
Get-MailboxServer | Add-ADPermission -User <SERVICE_ACCOUNT> -AccessRights 
GenericRead, GenericWrite -ExtendedRights Send-As, Receive-As, ms-Exch-Store-Admin

Configuring Exchange Server 2003/2000

To create an Exchange mailbox for an existing account on Exchange Server 2003/2000

1. Navigate to Start > Programs > Administrative Tools > Active Directory Users and Computers.

2. In the left pane, select Domain and select the Users folder.

3. In the right pane, right-click the UC Server account.

4. Select Exchange Tasks to start the Exchange Tasks Wizard.

5. From the list of tasks, select Create Mailbox.

6. Select Next, and then select Finish.

To manually set rights and privileges on Exchange Server 2003/2000 

1. Navigate to Start > Programs > Microsoft Exchange > System Manager.

2. In the left pane of the Exchange System Manager window, select the Exchange Server that you want 
to integrate with.

3. Select Action > Properties to open the Exchange Server Properties dialog box.

4. Select the Security tab, and select Add to open the Select Users, Computer or Groups dialog box.

5. From the Look In list box, select each of the following:
• the Domain name
• the UC Server account name

6. Select Add, and then select OK.

7. From the Permissions: Allow Deny list box, select Full control for the account that was just added.

8. Make sure that Allow inheritable permissions from parent to propagate to this object is enabled.

9. Select OK and then close the Exchange System Manager window.

To manually delegate the administrator role

The Exchange Role of “Server Data Permissions” is required when running the Server 
Configuration Wizard, in order to grant permissions to the Exchange Server 2007 message 
store from UC Server. If you do not have access to a Windows account with “Server Data 
Permissions,” then an Exchange Server Administrator must run the following script on the 
Exchange Server.
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1. Navigate to Start > Programs > Microsoft Exchange > System Manager.

2. In the left pane of the Exchange System Manager window, right-click the root level of the Exchange 
server, and select Delegate control from the menu that appears. The 
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