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Trademarks
Any brand names and product names included in this manual are trademarks, registered trademarks, or 
trade names of their respective holders.

To the Holder of the Manual
The contents of this manual are current as of the date of publication. ADTRAN reserves the right to change 
the contents without prior notice.
In no event will ADTRAN be liable for any special, incidental, or consequential damages or for 
commercial losses even if ADTRAN has been advised thereof as a result of issue of this publication. 

Software Licensing Agreement
Access to the features of the NetVanta Unified Communications software are restricted by license keys 
based on your licensed configuration. Pursuant to the Licensing Agreement, you may: (a) use the server 
software on one device only and (b) use the client software on an unlimited number of computers for use 
by configured users of the software product. In addition, certain ADTRAN systems may contain additional 
conditions for obtaining software upgrades. 

Toll Fraud Liability
Be advised that certain security risks are inherent in the use of any telecommunications or networking 
equipment, including but not limited to, toll fraud, Denial of Service (DoS) attacks, loss or theft of data, 
and the unauthorized or illegal use of said equipment. ADTRAN OFFERS NO WARRANTIES, EITHER 
EXPRESSED OR IMPLIED, REGARDING THE PREVENTION, DETECTION, OR DETERRENCE 
OF TOLL FRAUD, NETWORKING ATTACKS, OR UNAUTHORIZED, ILLEGAL, OR IMPROPER 
USE OF ADTRAN EQUIPMENT OR SOFTWARE. THEREFORE, ADTRAN IS NOT LIABLE FOR 
ANY LOSSES OR DAMAGES RESULTING FROM SUCH FRAUD, ATTACK, OR IMPROPER USE, 
INCLUDING, BUT NOT LIMITED TO, HUMAN AND DATA PRIVACY, INTELLECTUAL 
PROPERTY, MATERIAL ASSETS, FINANCIAL RESOURCES, LABOR AND LEGAL COSTS. 
Ultimately, the responsibility for securing your telecommunication and networking equipment rests with 
you, and you are encouraged to review documentation regarding available security measures, their 
configuration and implementation, and to test such features as is necessary for your network.

Service and Warranty
For information on the service and warranty of ADTRAN products, visit the Support section of the 
ADTRAN website at http://www.adtran.com

901 Explorer Boulevard
P.O. Box 140000

Huntsville, AL 35814-4000
Phone: (256) 963-8000

Copyright © 2013 ADTRAN, Inc.
All Rights Reserved.

http://www.adtran.com/web/page/portal/Adtran/wp_support_landing
http://www.adtran.com
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Conventions

Warnings provide information that could prevent injury or endangerment to human 
life.

Cautions signify information that could prevent service interruption or damage to 
equipment.

Notes provide additional useful information.

Below is a list of naming conventions used in this document. The first example shows the naming 
convention used for the first occurrence; the second example shows the naming convention used for 
subsequent occurrences. 
Type Convention Example 

Operating System* Microsoft ® Windows Server ® 2008 operating system version R2 or later  

or Windows Server 2008 R2 or later 

Server Software NetVanta Unified Communications Server software or NetVanta UC Server software

NetVanta Unified Communications Live Attendant Server or Live Attendant Server

Client Software NetVanta Unified Communications Client software or NetVanta UC Client software

NetVanta ucCompanion Desktop Presence client software or ucCompanion

NetVanta ucCompanion Live Attendant or Live Attendant

NetVanta ucCompanion Soft Phone or Soft Phone

Hardware Server computer - the computer on which the server software is installed.

Client computer - the computer on which the client software is installed.

NetVanta Unified  
Communication Products

NetVanta Unified Communications Server or NetVanta UC Server

NetVanta Business Communications System or NetVanta BCS

NetVanta Enterprise Communications Server or NetVanta ECS

NetVanta Business Application Server or NetVanta BAS

NetVanta UC Live Attendant Server or Live Attendant Server

*   Other operating systems may be mentioned in this document. They will follow a format similar to the one provided.
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Introduction
The NetVanta ucCompanion Desktop Presence is a client application providing a presence-based console 
designed to work in conjunction with the following NetVanta Unified Communications (UC) Server 
products:

• NetVanta Business Communications System (BCS)
• NetVanta Enterprise Communications Server (ECS)
• NetVanta Unified Communications Server (UCS)

Both the NetVanta BCS and NetVanta ECS provide the full spectrum of features described in this user 
guide. The NetVanta UCS has partial feature support, excluding the telephone presence and dialing 
capability. 

NetVanta ucCompanion is installed on a client computer automatically during the NetVanta Unified 
Communications (UC) Client software installation process. It requires connectivity to a server computer 
installed and configured as a NetVanta UC Server. Refer to documentation available online from 
ADTRAN’s support forums at https://supportforums.adtran.com. This user guide assumes all installation 
and configurations steps have been completed. 

Hardware and Software Requirements and Limitations
NetVanta ucCompanion is only available with installations of the NetVanta UC Server version 5.0 or later.

Minimum system requirements exist for installing NetVanta UC Server software. Refer to the applicable 
NetVanta Unified Communications Release Notes available online at https://supportforums.adtran.com to 
determine the system requirements for the version of NetVanta UC Server software you are installing.

A Quick Tour
This section provides an introduction to ucCompanion and the basic sections of the application window. 
We begin with logging into the application, followed by descriptions of the Main Menu Bar, Search Field, 
and Contact List. Additional features are accessible from the menu and provided in greater detail later in 
this guide. 

Logging In
When ucCompanion is launched for the first time, you are prompted to enter the name or IP address of the 
server computer with NetVanta UC Server software installed. The network administrator can provide this 
information to you. Once the name or IP address is entered, it will automatically display in the drop-down 
menu for any future login attempts. 

If your installation of the NetVanta UC Server software is integrated with Active Directory, 
your administrator could have configured a service connection point which includes a list of 
all the NetVanta UC Servers currently available on the network. If this is the case, just select 
the appropriate server from the drop-down list. 

https://supportforums.adtran.com
https://supportforums.adtran.com
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To log in:
1. Launch the NetVanta ucCompanion Desktop Presence client software by selecting Start > Programs 

> ADTRAN > NetVanta ucCompanion. The login menu displays as one of the options shown below 
depending on your network configuration.

Typical Sign-on (Local Authentication) Single Sign-on (Active Directory Authentication) 
requires username and password. allows automatic login.

Figure 1.  Login Menu

If Active Directory is integrated in your network configuration, you can use your network 
credentials to automatically log in (single sign-on) by selecting Sign In. 

2. Enter the name or IP address of the server computer with the NetVanta UC Server software, or select it 
from the drop-down list.

3. Enter your user name or select it from the drop-down list. Any user previously logged into the 
application is retained in the drop-down list.

4. Enter your password. You can select the option to save your password for future access. This is only 
recommended if you are the only user to log into the application from this computer. 

5. Select Sign In.

Once logged into the application, the main NetVanta ucCompanion menu appears. Many of the features 
and settings available on this menu are also accessible from other locations throughout the application. See 
Figure 2 on page 9 for an explanation of the main areas of this menu.



Main Menu bar 
(disabled by default) 
provides access to 
functions and settings.

Your desktop presence 
status as it appears to 
other users.

Search field allows you 
to search for contacts.

Contact list, displays 
contacts and groups.

Your status note displays 
additional information to 
other users. 
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Figure 2.  NetVanta ucCompanion Menu

The Main Menu bar is disabled by default and can be enabled by pressing the Alt key or 
selecting Main Menu Always Visible from the Personal options section of the Settings 
menu. Refer to Personal Options on page 19 for more information. 

Main Menu Bar
The Main Menu bar provides the following three menu selections:

• File menu - Provides access to your status settings, contact sorting options, rejoining a conversation, 
signing out, and closing the application. Refer to the following sections for more information about 
using these features: Setting Your Status on page 11, Sorting Contacts on page 14, Using Contact 
Groups on page 14, and Signing Out on page 24.

• Tools menu - Provides a method for adding a new group for your contacts. Refer to Using Contact 
Groups on page 14 for more information about this feature.

• About menu - Provides the currently loaded version of ucCompanion software and copyright 
information.

Search Field
The search field allows you to search for contacts either by name or phone number. To start a new search, 
begin entering either text or numbers in the search field. Possible matches appear below the search field 
(see Figure 3 on page 10). To clear the search, select the X on the right side of the search field. A message 
displays if no matches are found.



Enter text or numbers to begin 
searching for contacts by name 
or phone number. 

Contacts matching the search 
parameters display, as well as 
their current status. 

Call and IM icons appear when you 
hover over the search results. 

The Note icon indicates the 
user has entered a text 
description for their status. 

Select the menu arrow 
to filter your search to 
include users, 
extensions, or both. 
You can also configure 
the search to include 
the local NetVanta UC 
Server, remote trusted 
NetVanta UC Servers, 
or both.

Hover over the search field 
to display the menu arrow.
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Figure 3.  Search for Contacts

Once a contact is found through the search, several actions are presented by hovering over the results or 
right-clicking the contact name. These actions allow you to add the contact to your groups, remove the 
contact from a group, send an instant message, or place a call. Refer to the following sections for more 
details about these functions:

• Using Contact Groups on page 14
• Sending and Receiving Instant Messages on page 15
• Placing Calls on page 16

Contact List
The contact list displays the people you can contact through ucCompanion, as well as their current status. 
By adding contacts to your list, you can view their status quickly and initiate a call or instant message with 
a few clicks of the mouse. By default, the All and Recent contact groups are already created. Every contact 
you add to your contact list will appear in the All group. Personalized groups can also be added to sort your 
contacts. Refer to Using Contact Groups on page 14 for more information about creating and using groups.

Right-click a contact to add it to 
a group, remove from a group, 
send an instant message, or 
place a call. 

The current status of each 
contact is represented by 
an icon. 

Figure 4.  Contact List
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Setting Your Status
Your status is a visual representation to other users on ucCompanion of your availability for phone calls or 
instant messages. Your status is displayed to users who have added you to their contact list, as well as in 
the search results. 

You can set your status manually using the File > My Status menu or by selecting the option arrow just to 
the right of your Current Status icon in ucCompanion. Select the status that best fits your needs. Both of 
these methods are shown in Figure 5. 

The status options are Available, Busy, Be Right Back, Do Not Disturb, Away, and Reset Status. The 
Reset Status option resets your status and allows ucCompanion to automatically update your status 
according to your telephone and desktop activity.

Examples of the Status icons as displayed to users in ucCompanion and their descriptions are shown in 
Table 1 on page 12.

 

Select File > My Status 
and select a status from 
the drop-down menu. 

Hover over the Status 
icon to reveal the hidden 
menu arrow. 

OR

Select the arrow just to 
the right of your Current 
Status icon and select a 
status from the drop-
down menu. 

Figure 5.  Setting Your Current Status



Table 1. Status Icon Examples

Status Icon Description

Available User is logged in and at least one of their identities* is 
available.

Busy User is logged in and at least one of their identities* is busy. 

Be Right Back User is logged in and has manually set their status to Be 
Right Back.

Do Not Disturb User is logged in, and has manually set their identity to Do 
Not Disturb. 

Away
User is logged in and has manually set their status to Away, 
or user desktop has been idle for the time specified in user 
Settings.

Offline - Available User is not logged in but at least one of their identities is 
available, this could mean only their extension is available. 

Offline - Busy User is not logged in and at least one of their identities is 
busy.

Offline - Out Of Service User is not logged in and none of their identities are 
available. 
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Working with Contacts
There are three types of contacts that can be displayed in your contact list: a user, an identity, and a phone 
number. Each of these are represented by an icon and explained in Table 2.

Table 2. Contact Types

Type Icon Description

User

A user has a display name, first name, and last name. This type of contact 
can have one or more identities, each with a separate telephone presence. 
The desktop presence for users can be determined automatically by the 
system or set manually by the user. The telephone and desktop presence 
are combined to present a single presence status and description for the 
user in ucCompanion.

Identity
An identity has a display name and address (extension). This type of 
contact has only a telephone presence, determined by the communication 
system.

Phone number A phone number has the actual phone number and display name. This 
type of entry does not display presence information in ucCompanion.

*Users can have more than one identity in ucCompanion. An identity can be a user or their phone extension.
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The desktop presence displays the status for each of your contacts as Available, Busy, Do Not Disturb, 
Away, Inactive, Offline, or Unknown. Individual users can also display an editable text description of 
their status which is displayed as a Note icon in your contact list. (See Figure 6.) By hovering over the 
Note icon, the text status description displays. For example, a user can display a text description Attending 
Webinar. 

Call and IM icons appear when the 
cursor hovers over the contact. 

The Note icon indicates the 
user has entered a text 
description for their status. 

Figure 6.  Note, Call, and IM Icons in Contact List

Searching for Contacts
Contacts are found using the search field within ucCompanion. Use this field to search by either contact 
name or phone number. You can specify whether to include only users, only extensions, or both in your 
search. Also, you can specify whether to include only the local NetVanta UC Server, only remote trusted 
NetVanta UC Servers, or both. To do this, display the search options by hovering over the search field and 
selecting the arrow that appears. Choose the options to include by selecting Include users, Include 
extensions, Include All Servers, Local Server, or Remote Site using the check boxes shown in Figure 7. 

Enable these search options to 
expand your search to include 
users and/or extensions. You can 
also configure the search to 
include the local NetVanta UC 
Server, remote trusted NetVanta 
UC Servers, or both.

Figure 7.  Expand Search Options

Search types can include internal phone numbers (such as, 4-digit extension) and partial information (such 
as, the first few letters of a name or the first few numbers of a phone number). Figure 8 shows examples of 
some of the possible searches and their results.

Search result for extension 
only.

Search result by extension, 
displaying an assigned user 
name. 

Search result for 10-digit 
phone number.

Figure 8.  Contact Search Results

After a search is completed, select the X in the right end of the search field to clear the results. 
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Adding a Contact to Your List
Once a contact is found using the search methods described in Searching for Contacts on page 13, they can 
be added to your contact list. Right-click on the contact name or number and select Add from the drop-
down menu. You can choose to add them to the default All group or any other group configured in your 
application. A contact can appear in more than one group. For more information on creating groups, refer 
to Using Contact Groups on page 14.

Right-click the contact and select 
Add from the menu to add to 
your contact list.

Figure 9.  Add Contact to your Contact List

Sorting Contacts
Contacts can be sorted so they appear in the contact list (within a group) based on certain criteria. 

To sort contacts: 
Select File > Sort Contacts By. Select the method by which to sort the contacts: Type, Presence, Display 
Name, Phone Number, First Name, and Last Name.

 

Figure 10.  Sort Contact List

Using Contact Groups
Contacts can be arranged in groups. A contact can appear in more than one group. There are two 
predefined default groups: the All group that includes all contacts in your list, and the Recent group that 
displays contacts that you have recently called. You can also create your own Contact group.

To create a group:
1. Select either Tools > Add New Group from the menu bar or right-click anywhere in the blank area of 

the contact list and select Create Insert from the menu.

2. Enter a name for the new group in the field provided and press Enter. The new group appears in your 
contact list.

To add a contact to a group:
1. Right-click the contact from the search results field or in the contact list.

2. Select Add.



To add a contact to a specific 
group, right-click the contact, then 
select Add and the group name 
from the drop-down menu.
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3. Select the group name from the drop-down menu.

Figure 11.  Add Contact to a Group

Sending and Receiving Instant Messages
Conversations through instant messaging are accomplished using a separate dialog menu that displays 
once you initiate an instant message with another contact or a contact sends a message to you. In either 
case, the options available are the same and shown in Figure 12. 

Select Save icon to save the 
conversation.

Conversation pane displays 
the previous messages in this 
conversation.

Enter text for each new 
conversation entry. 

Contacts participating in the 
current conversation.

Figure 12.  Instant Message Conversation Menu

To initiate a conversation:
1. Right-click a contact from your contact list and select Send an Instant Message from the drop-down 

menu. 

2. Alternatively, you can hover over the contact and select the Instant Message icon. The instant message 
conversation dialog box appears.

Both methods are shown in Figure 13 on page 16. 



To initiate an instant message, 
right-click the contact and select 
Send an Instant Message. 

You can also hover over a 
contact and select the IM icon 
that appears.
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Figure 13.  Initiate an Instant Message

To rejoin a conversation:
After a conversation becomes idle or if you close the conversation window, you can rejoin it by selecting 
Actions > Rejoin from the Instant Message Conversation menu, or select File > (Re)join conversation 
from the main menu. You can also rejoin a conversation by selecting the icon that appears next to your own 
presence in the main menu, shown in Figure 14.

Once a conversation has 
started, you can rejoin it 
by selecting the (Re)join 
Conversation icon.

Figure 14.  (Re)join Conversation Icon

To save a conversation:
1. Save a conversation by selecting File > Save as from the Instant Message Conversation menu, or 

select the Save icon in the bottom left as shown in Figure 12 on page 15.

2. Enter a name and a location to save the file in the dialog box that appears. Select Save. Conversations 
are saved in rich text or plain text format, depending on the file type selected. 

Placing Calls
Calls can be placed to a contact from the Contact list or from the Conversation menu. This is accomplished 
by either selecting the contact from the list and using the Call icon (shown in Figure 15 on page 17), or 
right-clicking the contact and selecting Call from the drop-down menu.
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To place a call:
1. Right-click a contact in the contact list, then select Call from the drop-down menu. 

Right-click a contact and select 
Call from the drop-down menu.

Or 

You can also hover over a 
contact and select the Call icon 
that appears.

2. Alternatively, you can hover over the contact and select the Call icon.

Figure 15.  Call Contact from List

Using the Click-to-dial Feature
The click-to-dial feature is a function within the NetVanta UC Client software that allows users to place 
calls from the desktop. There are two ways a user can click-to-dial a phone number or contact:

1. Use the Microsoft Outlook plug-in installed with the NetVanta UC Client software. This plug-in 
provides custom buttons in email messages and contact records that allow users to click-to-dial 
contacts in their personal address book.

2. Highlight and copy a text-based phone number from any application on the desktop. 

In the second method, ucCompanion monitors your system clipboard for possible phone numbers to dial 
automatically. When the application detects a number string in the copied text placed on the clipboard, a 
notification dialog box appears with the phone number. You are then prompted to initiate a voice call to the 
phone number. The notification dialog box launches from the Windows task bar. It can appear in two 
different sizes as shown in Figure 16.

Large, default clipboard notification 
dialog box.

Small clipboard 
notification dialog box.

Figure 16.  Click-to-Dial Notification

Refer to Notification Options on page 21 to change the notification settings when a number is copied to the 
clipboard. See Table 4 on page 22 to change the settings for monitoring the clipboard. 
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Customizing Your Settings
There a number of optional settings that you can set from ucCompanion. The most often used setting is 
your current status. This is the presence that is presented to other contacts and shows your availability for 
conversations by phone or instant messaging. Refer to Setting Your Status on page 11 for more 
information.

You can also set your personal, notification, and advanced options through the Settings menu. This menu is 
accessed by selecting the Settings icon shown to the right of the search field (see Figure 17). Refer to the 
following sections for more information about these options: 

• Personal Options on page 19
• Notification Options on page 21
• Advanced Options on page 23

Select the Settings icon to 
access the Personal, 
Notification, and Advanced 
Options menus. 

Figure 17.  Accessing the Settings Menu
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Personal Options
The Personal options include settings for starting the application at logon, showing tips, Main Menu 
visibility, detection of inactivity behavior, search options, dialing behavior, and clipboard monitoring. To 
set your personal options:

1. Select the Settings icon shown to the right of the search field (see Figure 17 on page 18). 

Select Save to 
accept the new 
settings. 

Select Personal 
options to display 
available settings. 

2. Select Personal options from the NetVanta ucCompanion Settings menu shown in Figure 18. 

3. Make changes to your settings and select Save to accept the new settings. A list of the available 
options and their descriptions are provided in Table 3 on page 19.

Figure 18.  Personal Options

Table 3. Personal Options Menu

Option Description

Start application at logon Launches the ucCompanion application immediately after 
you log on to your computer.

Sign in automatically on startup Automatically signs in to ucCompanion upon starting the 
application.

Show introductory tip when 
minimizing to tray

Displays a series of introductory tips on using ucCompanion 
when you minimize the application.

Main Menu Always Visible Enabling this option makes the main menu options (File, 
Tools, and About) visible. Disabled by default.
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Automatic inactivity detection Automatically set your presence to Inactive or Away after a 
period of desktop inactivity. 
By default, your status is set to Inactive after 5 minutes of 
desktop inactivity, and the valid range is 5 to 30 minutes. 
By default, your status is set to Away an additional 15 
minutes after your status becomes Inactive, and the valid 
range is 10 to 60 minutes. For example, if Automatic 
inactivity detection is set to 5 minutes for Inactive and 20 
minutes for Away, after 5 minutes of desktop inactivity, your 
presence status would automatically be set to Inactive, and 
after an additional 20 minutes of desktop inactivity (25 
minutes total), your presence status would automatically be 
set to Away. 

Search behavior Specifies the amount of time to wait after the last keystroke 
before initiating a search request. Default is 1 second with a 
valid range of 1 to 30 seconds.

Dialing behavior Enabling the option Wait for call to be selected when 
dialing from plugins allows you the option to edit or confirm 
a phone number prior to dialing using ucCompanion. This 
behavior is currently used only with the Microsoft Outlook 
plugin. Disabling this option permits ucCompanion to initiate 
a call without waiting for confirmation and also allows setting 
the Dialing notifications.
Dialing notifications specifies whether to display 
notifications when placing calls from plugins (such as 
Microsoft Outlook). When enabled, the click-to-dial 
notification displays when a call is initiated from the plugin. 
The settings for this option also indicates the amount of time 
to display outgoing calls. The default for calls without an 
extension is 3 seconds and for calls with an extension is 5 
seconds. 

Clipboard monitoring Specifies monitoring the clipboard for number strings to use 
as phone numbers to dial. If enabled, the contents of a copy 
action can be used to dial a number through ucCompanion.

Table 3. Personal Options Menu

Option Description
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Notification Options
The Notification options include notification settings for dialing, clipboard monitoring, and instant 
messages. To set notification options:

1. Select the Settings icon shown to the right of the search field (see Figure 17 on page 18). 

Select Save to 
accept the new 
settings. 

Select 
Notification 
options to 
display available 
settings. 

2. Select Notification options from the NetVanta ucCompanion Settings menu shown in Figure 19. 

3. Make changes to your settings and select Save to accept the new settings. A list of the available 
options and their description is provided in Table 4 on page 22.

Figure 19.  Notification Options



Table 4. Notification Options Menu 

Clipboard monitoring 
notifications

Specifies the size and amount of time to display the notification 
dialog box for the click-to-dial feature when Monitor clipboard 
is enabled (see Personal Options on page 19). 
By selecting the Use smaller clipboard notification check box, 
a small dialog box is displayed instead of the default larger 
dialog box (shown in Figure 16 on page 17).
By default, the amount of time for the notification to display is 8 
seconds. The time period can be set using the Display time for 
notification field. Valid range for this field is 2 to 20. 
Refer to Using the Click-to-dial Feature on page 17 for more 
information about this feature.

Message notifications Specifies display and sound notifications when a new instant 
message is received. 
Select Show notification if conversation window is not open 
to display a notification when new message arrives. 
• Enable Use smaller message notification to determine the 

size of the notification message. 
• Enable Show notification unless my status is Do Not 

Disturb to prevent a notification from displaying based on a 
DND status. 

Select Always play sound for notification when new 
message arrives to play a default sound. 
• Enable Except when the new message is open to prevent 

the sound notification.
• Enable Except when my status is Busy to prevent the 

sound notification. 
• Enable Except when my status is Do Not Disturb to 

prevent the sound notification. 
All of these settings apply only when the conversation window is 
not already open. 
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Option Description
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Advanced Options
The Advanced options include settings controlling the clipboard monitoring for text during a copy and 
paste action on your desktop. Monitoring the clipboard is a function of the click-to-dial feature which is 
explained in Using the Click-to-dial Feature on page 17. To set advanced options:

1. Select the Settings icon shown to the right of the search field (see Figure 17 on page 18). 

Select Save 
to accept the 
new settings. 

Select Advanced 
options to display 
available settings. 

2. Select Advanced options from the NetVanta ucCompanion Settings menu shown in Figure 20. 

3. Make changes to your settings and select Save to accept the new settings. A list of the available 
options and their description is provided in Table 5.

Figure 20.  Advanced Options

Table 5. Advanced Options Menu 

Option Description

Maximum text size that will be 
scanned for phone numbers

Specifies the length of text to review for numbers to dial using 
the click-to-dial feature. The default is 80 characters. Valid range 
is 10 to 1000.

Minimum digits in a phone 
number

Specifies the minimum number of digits required for a string of 
numbers to be considered a phone number for the click-to-dial 
feature. Default is 4 digits. Valid range is 2 to 20.
Refer to Using the Click-to-dial Feature on page 17 for more 
information about this feature.
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Signing Out
Since any user can log into ucCompanion from any client connected to NetVanta UC Server, it is important 
to sign out from the application when you are finished. Only one user can be logged into the application on 
a computer at a time.

To sign out:
From the Main Menu bar, select File > Sign out. Alternatively, you can right-click the ucCompanion icon 
in the system tray, and select Exit from the pop-up menu.  
Your account is logged out and returned to the login screen. 

Selecting Close is not the same as selecting Sign out from the File menu. Selecting Close 
only minimizes the application to the system tray. The application continues to run with your 
login active.

Ignore identical consecutive 
clipboard strings

Specifies whether to ignore copy and paste action if the text 
copied includes a phone number that has been copied already to 
the clipboard. If this option is enabled, copying a number to the 
clipboard will not be repeated. 

Display Language Specifies the language used in the ucCompanion interface. 
Changes to the display language will not take effect until 
ucCompanion is restarted.
• System Language specifies that ucCompanion will use the 

format setting in Windows to determine the display language. 
For example, if the Windows format setting is 
French (Canada), the ucCompanion display language will 
be Canadian French. If any other format is specified, the 
display language will be American English. To change the 
format setting in Windows, navigate to Control Panel > 
Clock, Language and Region > Change Display 
Language or Control Panel > Region and Language.  In 
the Region and Language menu that appears, select the 
Formats tab and use the Format drop-down menu to change 
the Format setting.  

• English (United States) specifies that the ucCompanion 
display language will be American English.

• French (Canadian) specifies that the ucCompanion display 
language will be Canadian French.

In order for the French spell checker to function in the ucCompanion instant messaging, the 
.NET Framework 4.0 French Language Pack must be installed on you computer.  For more 
information on installing the language pack, refer to  on page 24.

Table 5. Advanced Options Menu (Continued)

Option Description
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Appendix A - Installing the .NET Framework French Language Pack
In order for the French spell checker to function in the ucCompanion instant messaging feature, the .NET 
Framework 4.0 French Language Pack must be installed on you computer.  The language pack can be 
installed during the NetVanta UC Client installation; however, it is not installed by default. Consequently, 
you may need to manually install the language pack if you require the French spell checker.  To install the 
.NET Framework 4.0 French Language Pack using the ADTRAN NetVanta UC Client Setup Wizard 
after NetVanta UC Client has been installed, follow these steps:

1. Navigate to the folder that contains the NetVanta UC Server software that was used to install NetVanta 
UC Client on you computer.  

If you do not have the NetVanta UC Server installation software, you will need to obtain 
it from your system administrator.

2. Double-click CAAutoRun.exe. 

3. In the NetVanta Unified Communications CD Menu window that appears, select the Install Client 
button. The Welcome menu for the ADTRAN NetVanta Unified Communications Client Setup 
Wizard will appear.

4. In the Welcome menu, select Next. The Change, repair, or remove installation menu will appear.

5. In the Change, repair, or remove installation menu select the Change button. The Custom Setup 
menu will appear.

6. In the Custom Setup menu, select the plus symbol next to Clients to expand the components of the 
Clients feature. If the .NET Framework 4.0 French Language Pack was not installed during the 
original NetVanta UC Client installation, a red X will appear next to the .NET Framework French 
Language Pack component. 
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7. Select the down arrow next to the red X next to .NET Framework French Language Pack, and 
select Will be installed on local hard drive from the drop-down menu. Then select Next. 

8. In the menu that appears, select Change. The .NET Framework French Language Pack installation 
wizard will start. Follow the directions in this wizard to install the language pack.

9. Once the language pack has been installed, select Finish in the ADTRAN NetVanta Unified 
Communications Client Setup Wizard.

Troubleshooting the French Spell Checker in ucCompanion
In order for the ucCompanion French spell checker to operate, the Windows Default input language 
setting must be set to French (Canada) - Canadian Multilanguage Standard.  To change the Default 
input language setting, follow these steps:

1. Navigate to Control Panel > Clock, Language and Region > Change Display Language or  
Control Panel > Region and Language.  

2. In the Region and Language menu that appears, select the Keyboards and Languages tab.  Select 
the Change keyboards button. 

3. In the Text Services and Input Languages menu that appears, select the General tab.

4. In the General tab, use the Default input language drop-down menu to select French (Canada) - 
Canadian Multilanguage Standard. 

5. Select Apply, then select OK.

Additional Resources
Additional documentation and resources for NetVanta UC Server and NetVanta ucCompanion are 
available online from ADTRAN’s support forums at https://supportforums.adtran.com. 

The .NET Framework 4.0 French Language Pack must be installed on your computer for 
French (Canada) - Canadian Multilanguage Standard input language option to be 
available. For more information on installing the language pack, refer to Appendix A - 
Installing the .NET Framework French Language Pack on page 25.

https://supportforums.adtran.com
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Appendix B - Using the NetVanta UC Client Outlook Add-in
The NetVanta UC Client add-in for Microsoft Outlook allows users to use the NetVanta ucCompanion 
click-to-dial feature directly from Outlook. The add-in allows users to launch NetVanta UC Client, call 
contacts from a contact page, and call email participants from an email message or from the content area.

You must be signed in to NetVanta ucCompanion in order to use the NetVanta ucCompanion 
click-to-dial feature from Outlook.

Launching NetVanta UC Client from Outlook 2010
To launch NetVanta UC Client from Outlook 2010, follow these steps:

1. Select the Home tab.

2. Select NetVanta UC Client in the Launch column.

Calling an Outlook Contact Using NetVanta ucCompanion Click-to-Dial
To call an Outlook contact using the NetVanta ucCompanion click-to-dial feature, follow these steps:

1. Open the Outlook contact you would like to call using NetVanta ucCompanion click-to-dial.

2. Select Call in the ucCompanion column and select the number you would like to call. NetVanta 
ucCompanion will dial the selected number. 
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Calling an Email Participant from an Open Email
To call an email participant from an open email using the NetVanta ucCompanion click-to-dial feature, 
select Call in the ucCompanion column and select the number of the email participant you would like to 
call. 

Calling an Email Participant from the Content Area
To call an email participant from the content area using the NetVanta ucCompanion click-to-dial feature, 
right-click the email with the email participant you would like to call, hover over Call with 
ucCompanion, then select the email participant you would like to call.
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