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Unified Communications Server  Conventions
Conventions

Notes provide additional useful information.

Cautions signify information that could prevent service interruption or damage to 
equipment.

Warnings provide information that could prevent injury or endangerment to human 
life.
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1 Introduction
ucCompanion is an optional desktop application that provides customers with a presence-based console, an 
integrated soft phone and a suite of collaboration features. Direct calls quickly with visual call routing to 
the right employee the first time using ucCompanion - Live Attendant™ — UC server’s presence-based 
console. ucCompanion delivers presence right down the desktop. Integrated Busy Lamp Fields (BLF), 
name searching, and high volume desktop telephony reduce the amount of time operators spend directing 
calls. Employees can see which of their co-workers are available to take a call. ucCompanion enhances 
productivity with desktop telephony, click to call, contact integration, screen pops, an integrated soft-
phone and more. 

Use of the ucCompanion -Live Attendant application is optional. However, if you wish to use 
ucCompanion - Live Attendant then you must install the UC Server Presence and Control Components, 
which consists of the UC Server Presence and Control Engine (PCE), and the Server Interface Module 
(SIM). The UC Server Presence and Control Components interact with NetVanta UC Server via the CSTA 
bridge software, which is automatically installed as part of UC server.

This guide is written for installers and maintainers of NetVanta UC Server and NetVanta ucCompanion 
products. It assumes familiarity with general hardware and software installation procedures. This guide is 
also intended for Microsoft Professionals and trained professionals to install and configure the NetVanta 
Unified Communications Server.

Key Features
• Integrated with ucCompanion soft phone

• ucCompanion – Live Attendant (Console)

• ucCompanion Instant Messaging 

• Enterprise Busy Lamp Field (BLF)

• New call notification

• Call logs

• Add comments to calls

• Make calls

• Answer calls

• Hang up Calls

• Swap calls

• Hold / Un-hold

• Transfer – Assisted

Currently only ucCompanion - Live Attendant is available for general deployment. 
619510006-1A Copyright © 2009 ADTRAN, Inc. 3
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• Transfer – Blind

• Call Pickup (Ringing Call Pickup)

• Call Park / Call Park Pickup

• Status Notes

• Send to Voicemail
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2 Prerequisites

Installation and Configuration Sequence
Installing and using the ucCompanion - Live Attendant application is optional. However, if you wish to use 
ucCompanion - Live Attendant, then you must install the UC Server Presence and Control Components, 
which consists of the UC Server Presence and Control Engine (PCE), and the Server Interface Module 
(SIM).

The installation and configuration of UC server and the UC Server Presence and Control Components must 
occur in the following order:

1. Start the UC server installation. Refer to the NetVanta Unified Communications Server Installation 
Guide for instructions. 

2. When prompted, install the UC Server Presence and Control Components. Refer to the installation 
instructions for either Installing UC Server Presence Components on page 10 for a standalone server, 
or Installing UC Server Presence Components on the Associate UC Server on page 15 for a 
centralized SIM environment.

3. Configure Windows firewall. For more information refer to Configuring Windows Firewall on 
page 10

4. Continue installing UC server as described in the NetVanta Unified Communications Server 
Installation Guide.

5. Configure the UC Server SIM. Refer to the relevant section, either Configuring UC Server SIM on 
page 11 for a standalone server or Configuring UC Server SIM on the Associate UC Server on 
page 16.

6. Configure the CSTA Bridge. Refer to the relevant section, either Configuring CSTA Bridge on 
page 12 for a standalone server, or Configuring CSTA Bridge on page 16 for an associate server.

7. Configure UC server with a SIP PBX, using the Server Configuration Wizard. For more information 
refer to the NetVanta Unified Communications Server Configuration Guide.

8. Stop and restart the CSTABridge and UC Server SIM services in the order recommended. Refer to the 
relevant section, either Restarting the CSTABridge and UC Server SIM Services on page 13 for a 
standalone server, or Restarting the CSTABridge and UC Server SIM Services on page 17 for an 
associate server.

9. Set the ucCompanion Administrator and Tenanting passwords. Refer to Setting the ucCompanion 
Administrative Passwords on page 13.

Server Requirements
For a standalone installation, both the UC Server PCE and the SIM are installed on the same hardware 
platform as UC server. If you are installing on an associate server, you need to install only the SIM on the 
associate UC server hardware platform.
619510006-1A Copyright © 2009 ADTRAN, Inc. 5
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3 Installing and Configuring NetVanta UC 
Server Presence and Control

Overview
Refer to the following sections for information on deploying UC Server Presence and Control in a 
standalone or a distributed environment.

• Standalone Deployment on page 7

• Distributed or Associate Deployment on page 8

Standalone Deployment
UC Server Presence and Control can be configured to operate in a standalone environment. The required 
components of the standalone environment include the following:

• NetVanta UC Server

• CSTA Bridge

• NetVanta Presence and Control Engine (PCE)

• UC Server SIM

The UC server and CSTA bridge software are included within the UC server installation media. The 
Presence and Control Engine and SIM are included on the UC Server Presence and Control installation 
media.

UC Client
ucCompanion

Client(s)

UC Server
SIM

Presence and Control
Engine (PCE)

NetVanta UC Server

Standalone or Central UC Server
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Distributed or Associate Deployment
UC server can provide centralized, enterprise wide presence and collaboration services by using the UC 
Server Presence and Control Engine (PCE) on a centralized UC server to support associate UC servers in a 
distributed system. Such satellite UC servers can be used to build larger co-located systems for scalability, 
or physically distributed where UC servers are typically located in branch offices. Within distributed 
organizations a single, centralized server can support presence and collaboration services on multiple co-
located or remotely located associate UC servers. Since associate UC servers employ the PCE on a 
centralized server, the PCE component is not installed on associate UC servers, and is used to send 
presence and call control information from the associate UC server to the central UC server. 

ucCompanion clients connected to associate UC servers are automatically configured to connect the UC 
Server Presence and Control engine at the main location by the SIM in their associate UC server.

When UC server is configured to operate in the associate mode of operation, it does not need the Presence 
Control Engine (PCE) or the Database Server installed, as it employs the PCE at the central UC server. 
Only the SIM component of the UC Server Presence and Control Components must be installed on the 
associate UC server to mediate the connection to the PCE at the central UC server. When you install the 
SIM in the associate UC server, change the IP address so that it connects to the PCE at the central UC 
server rather than to the associate UC server. The installation instructions for installing UC server are the 
same for both the central UC server site and the associate UC server. See the graphic below for the 
differences between installing UC Server Presence and Control in a central UC server, and an associate UC 
server.
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Unified Communications Server  Installing on a Standalone NetVanta UC Server
ucCompanion is configured somewhat differently depending on whether it is installed on a standalone or 
on an associate UC server. Follow the appropriate instructions for your particular environment.

Installing on a Standalone NetVanta UC Server 
After you start the UC server installation, you are prompted to install the UC Server Presence Components. 
The UC Server Presence Components installation requires the following steps:

1. Installing UC Server Presence Components on page 10

2. Configuring Windows Firewall on page 10

3. Installing NetVanta UC Server on page 11

4. Configuring UC Server SIM on page 11

5. Configuring CSTA Bridge on page 12

UC Client
ucCompanion

Client(s)

UC Server
SIM

Presence and Control
Engine (PCE)

NetVanta UC Server

Standalone or Central UC Server

UC Client
ucCompanion

Client(s)

UC Server
SIM

NetVanta UC Server

Associate UC Server
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6. Configuring UC Server with a SIP PBX on page 12

7. Restarting the CSTABridge and UC Server SIM Services on page 13

8. Setting the ucCompanion Administrative Passwords on page 13

Installing UC Server Presence Components
Install the UC Server Presence Components on the same computer as the UC server software.

1. Log on to UC server, locally or using Remote Desktop, using a local administrator account or an 
account with the equivalent permissions.

2. Insert the UC server media. 

3. Enable Install Presence Components to provide ucCompanion Live Attendant clients 
connectivity to UC Server.

4. Select Install Presence Components.

5. On the Welcome page click Next. 

6. Read the license agreement and if you agree then enable I accept the terms in the License 
Agreement, and click Next. 

7. On the Custom Setup page click Next. 

8. On the Install page click Install. 

9. On the Completion page click Finish.

Configuring Windows Firewall
On Windows systems, Windows Firewall is typically enabled by default, with the exception of Windows 
Server 2003 where Windows Firewall is typically disabled. Windows Firewall controls access to server 
processes from programs running on other computers. For Presence Components you must manually 
configure the firewall on the computer running Presence Components to allow access from other 
computers. Specifically, you must enable an exception in the firewall to allow VistaTDS.exe to be accessed 
from external computers.

If you are installing and configuring the PCE on a system where UC server already exists, 
and a SIP PBX has already been installed and configured, then the PCE services are set to 
Manual and stopped. In this situation you must change the services to Automatic and start 
them.

If Windows Firewall checking is enabled on the server, and an exception for VistaTDS is not 
enabled, then ucCompanion running on external computers will be unable to access the 
Presence Components.
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Follow the steps below to modify the firewall from the command line using netsh. 

To configure Windows Firewall from the command line using netsh

1. Open a command prompt. For example, depending on the operating system the path will be the same 
or similar to Start > Programs > Accessories > Command Prompt.

2. In the command line type the following command as one line:

netsh firewall add allowedprogram "C:\Program
Files\ADTRAN\NetVanta ucCompanion\Server\VistaTDS.exe" VistaTDS ENABLE

Installing NetVanta UC Server
Install NetVanta UC Server, but do not start configuring UC server. For more information refer to the 
NetVanta Unified Communications Server Installation Guide.

Configuring UC Server SIM
UC server SIM maintains the connection between the ucCompanion server and UC server. For a 
standalone UC server the default values are normally correct and do not need to be changed. However, if 
you have two or more network interface cards (NICs), then ensure that the settings below are pointing to 
the correct network interface.

To verify the SIM Startup and connection options

1. Select Start > Programs > ucCompanion > PCE Administration.

2. Select the SIM tab.

Alternatively, you can configure Windows Firewall through the Control Panel. 

To modify Windows Firewall, you must be logged into an account with the necessary 
privileges.

If VistaTDS.exe is installed in a different location, then adjust the command line above 
accordingly.
619510006-1A Copyright © 2009 ADTRAN, Inc. 11
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3. In the Server Address field, verify that the default is the host name or IP address of the Presence and 
Control Engine Server.

4. In the Telephony Server section, verify the UC server host name or IP address.

5. In the Server Port field, verify the port is set to 6055.

6. If any changes were made to the default settings then click Save.

7. Close the dialog.

Configuring CSTA Bridge
1. Navigate to the following directory on the UC server: 

\Program Files\ADTRAN\UC Server\bin

2. Open the CstaBridge.exe config file using a text editor, such as Notepad.

3. Locate the following sections and make the changes as shown below. 
a. Replace 127.0.0.1 with the IP address of the UC server computer.

<setting name="SoapInterfaceUrl" serializeAs="String">
     <value>http://127.0.0.1:8445/axis/servlet/AxisServlet</value>
</setting>

b. Replace localhost with the IP address of the UC server computer. 
<setting name="ResourceManagerHost" serializeAs="String">
     <value>localhost</value>
</setting>

4. Select File > Save. This saves the file with the config file extension.

5. Select File > Exit.

Configuring UC Server with a SIP PBX
Configure UC server using the Server Configuration Wizard. Complete all the steps in the wizard 
including configuring the UC server communication system. For more information refer to the NetVanta 
Unified Communications Server Configuration Guide.

Ensure that the address you specify is correct, as no direct feedback is provided if an 
incorrect name or address is entered.
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Unified Communications Server  Installing on a Standalone NetVanta UC Server
Restarting the CSTABridge and UC Server SIM Services
All services will appear started and set to Automatic. In order to enable the configuration changes for the 
CSTA Bridge, stop and restart the following services in the order listed below.

To stop the services

1. Using the Services.msc, stop the ADTRAN UC Server CSTA Bridge service. 

2. Select Start > Programs > ucCompanion > PCE Administration.

3. Select the Presence and Control Engine tab.

4. Select Stop. This also stops the Database Access service.

5. Select the SIM tab.

6. Select Stop. This stops the UC server SIM service.

To restart the services

1. Using the Services.msc, start the ADTRAN UC Server CSTA Bridge service. 

2. Select Start > Programs > ucCompanion > PCE Administration.

3. Select the Database Access tab.

4. Select Start. This starts the UC Server Database Access service, as well as the Presence and Control 
Engine service.

5. Select the SIM tab.

6. Select Start. This starts the UC Server SIM service.

Setting the ucCompanion Administrative Passwords
The ucCompanion Administrative Passwords provide management and configuration of ucCompanion 
client behavior, and are configured after the installation. To configure the passwords, follow the steps 
below.

To set the ucCompanion Administrator password

1. Select Start > Programs > ucCompanion > PCE Administration.

2. Select the Database Access tab.

3. From the Database Maintenance drop-down list select Reset administrator password.

4. Select Perform.

If you are installing and configuring the PCE on a system where UC server already exists, 
and a SIP PBX was already installed and configured, then the PCE services are set to 
Manual and stopped. In this situation, if you have not already done so, then you must change 
the services to Automatic and start them.
619510006-1A Copyright © 2009 ADTRAN, Inc. 13
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5. Type a password in the System Administrator New password field, and then re-type the password to 
confirm.

6. Select OK.

To set the ucCompanion Tenanting Administrator password

1. From the Database Maintenance drop-down list select Reset tenanting administrator password.

2. Select Perform.

3. Type a password in the System Tenant New password field, and then re-type the password to confirm.

4. Select OK.
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Installing on an Associate NetVanta UC Server
The associate UC server installation requires the following steps:

1. Installing UC Server Presence Components on the Associate UC Server on page 15 – select the SIM 
only

2. Installing NetVanta UC Server on page 15

3. Configuring UC Server SIM on the Associate UC Server on page 16

4. Configuring CSTA Bridge on page 16

5. Configuring NetVanta UC Server with a SIP PBX on page 17

6. Restarting the CSTABridge and UC Server SIM Services on page 17

Installing UC Server Presence Components on the Associate UC 
Server
On the same computer as the associate UC server, install the UC Server Presence and Control 
Components, selecting the UC SIM component only, using the following steps.

1. Log on to UC server, locally or using Remote Desktop, using a local administrator account or an 
account with the equivalent permissions.

2. Insert the UC server CD. 

3. Enable Install Presence Components to provide ucCompanion Live Attendant clients 
connectivity to UC server.

4. Select Install Presence Components.

5. On the Welcome page click Next. 

6. Read the license agreement and if you agree then enable I accept the terms in the License 
Agreement, and click Next. 

7. On the Custom Setup page select the UC SIM component only, and click Next. 

8. On the Install page click Install. 

9. On the Completion page click Finish.

Installing NetVanta UC Server
Install UC server, but do not start configuring UC server. For more information refer to the NetVanta 
Unified Communications Server Installation Guide.

If you are installing and configuring the PCE on a system where UC server already exists, 
and a SIP PBX has already been installed and configured, then the PCE services are set to 
Manual and stopped. In this situation you must change the services to Automatic and start 
them.
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Configuring UC Server SIM on the Associate UC Server
UC server SIM maintains the connection between the ucCompanion server and UC server. 

To configure and verify the SIM Startup and connection options

1. Select Start > Programs > ucCompanion > PCE Administration.

2. Select the SIM tab.

3. For the Server Address, change the default value to the IP address or host name of the central UC 
server.

4. For the telephony server, verify the IP address or host name of the associate UC server. 
This is the IP address or host name of the CSTA bridge on the associate UC server. The default value 
is normally correct and does not need to be changed. However, if you have two or more network 
interface cards (NICs), then verify this setting to ensure that it points to the correct network interface.

5. In the Server Port field, verify the port is set to 6055.

6. Select Save, and close the dialog.

Configuring CSTA Bridge
1. Navigate to the installation folder on the UC server: the default location is:

\Program Files\ADTRAN\UC Server\bin

2. Open the CstaBridge.exe config file with a text editor, such as Notepad

3. Locate the following sections and make the changes as shown below. 
a. Replace 127.0.0.1 with the IP address of the associate UC server computer.

<setting name="SoapInterfaceUrl" serializeAs="String">
     <value>http://127.0.0.1:8445/axis/servlet/AxisServlet</value>
</setting>

b. Replace localhost with the IP address of the UC server computer. 
<setting name="ResourceManagerHost" serializeAs="String">
     <value>localhost</value>
</setting>

4. Select File > Save. This saves the file with the config file extension.

5. Select File > Exit.

Ensure that the address you specify is correct, as no direct feedback is provided if an 
incorrect name or address is entered.
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Configuring NetVanta UC Server with a SIP PBX
Configure UC server using the Server Configuration Wizard. Complete all the steps in the wizard 
including configuring the UC server communication system. For more information refer to the NetVanta 
Unified Communications Server Configuration Guide.

Restarting the CSTABridge and UC Server SIM Services
All services will appear started and set to Automatic. In order to enable the configuration changes for the 
CSTA Bridge, stop and restart the following services in the order listed below.

To stop the services

1. Using the Services.msc, stop the ADTRAN UC Server CSTA Bridge service. 

2. Select Start > Programs > ucCompanion > PCE Administration.

3. Select the Presence and Control Engine tab.

4. Select Stop. Stopping the Presence and Control Engine service also stops the Database Access 
service.

5. Select the SIM tab.

6. Select Stop. This stops the UC server SIM service.

To restart the services

1. Using the Services.msc, start the ADTRAN UC Server CSTA Bridge service. 

2. Select Start > Programs > ucCompanion > PCE Administration.

3. Select the Database Access tab.

4. Select Start. This starts the UC server Database Access service, as well as the Presence and Control 
Engine service.

5. Select the SIM tab.

6. Select Start. This starts the UC server SIM service.

If you are installing and configuring the PCE on a system where UC server already exists, 
and a SIP PBX has already been installed and configured, then the PCE services are set to 
Manual and stopped. In this situation, if you have not already done so, then you must change 
the services to Automatic and start them.
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4 Upgrading UC Server Presence and Control 
Components

Install the UC Server Presence and Control components on the same computer as the UC server software.

1. Log on to UC server, locally or remotely, using a local administrator account or an account with the 
equivalent permissions.

2. Insert the UC server media. 

3. Close the installation launcher if it starts automatically. The launcher is not used for this upgrade.

4. Select Start > Run.

5. Enter cmd, and click OK to open a command prompt window.

6. Change the directory to the folder \Server folder of the installation media.

7. At the command prompt type the following command:
msiexec /i “NetVanta Unified Communications Server - Presence 
Components.msi” REINSTALL=ALL REINSTALLMODE=vomus

8. On the Resuming the NetVanta UC Server Presence and Control Components Setup Wizard page, 
click Install. 

9. On the Completed the NetVanta UC Server Presence and Control Components Setup Wizard page, 
click Finish.

10. At the UC Server SIM : ucCompanion Connection dialog, confirm your server information. Select 
OK.
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5 ucCompanion Client Software Deployment

Overview
For successful ucCompanion client software deployment, refer to the following sections:

• Prerequisites on page 21

• Installing ucCompanion Client Software on page 21

• Configuring ucCompanion - Live Attendant on page 22

• Configuring ucCompanion – Soft Phone on page 23

• Configuring External Dialing on page 24

• ucCompanion - Live Attendant Display on page 24

• Troubleshooting ucCompanion Client Software Deployment on page 25

Prerequisites

Licenses
You must have the sufficient client licenses for each instance of the client software that you plan on 
deploying. UC server separately licenses ucCompanion – Live Attendant. 

To confirm the available client licenses

1. Login to UC Client as an administrator.

2. Navigate to Help > License Information.

UC Client Installation
NetVanta UC Client must be installed on the client computer prior to installing ucCompanion or 
ucCompanion – Live Attendant.

Installing ucCompanion Client Software
Ensure that you only select ucCompanion – Live Attendant. 

• ucCompanion – Live Attendant is designed for operators, and enables them to view and control calls on 
all extensions in the system.

ucCompanion and ucCompanion - Plug-in for Outlook are for previewing only. They are in 
beta format and are not currently supported.
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The ucCompanion - Live Attendant client software is located on the NetVanta UC Server installation 
media:

1. Log on to the client computer using a local administrator account or an account with the equivalent 
permissions.

2. Insert the UC server media. 

3. If the installation launcher starts automatically, it may be closed because it is not used for this 
installation.

4. Navigate to the \Client folder, and then double-click ADTRAN ucCompanion.msi.

5. On the Welcome page click Next. 

6. On the License Agreement page, read the license agreement, and if you agree then enable I accept the 
terms in the License Agreement, and click Next.

7. On the Custom Setup page click Next. 

8. On the Ready to install NetVanta ucCompanion page click Install. 

9. When the installation is completed, click Finish.

Configuring ucCompanion - Live Attendant
Follow the steps below to configure ucCompanion – Live Attendant.

1. Select Start > Programs > ucCompanion > ucCompanion – Live Attendant.
When the ucCompanion – Live Attendant client launches for the first time, it prompts for user 
information. 

2. In the User Information dialog, enter your extension in the My Extension Number field.

3. Enter your name in the My User Name field, and click OK. 

4. At the ucCompanion: ucCompanion Connection dialog, enter the server IP address or host name in 
the “Host” field. 

5. Select OK. 
ucCompanion – Live Attendant launches and displays your name @ extension in the title bar.

6. To do administrative tasks, select File > Admin login to login as your tenanting administrator or 
administrator. Refer to the section on Setting the ucCompanion Administrative Passwords on page 13.

In a multiple server environment, enter the IP address or host name of the primary UC 
server.
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Configuring ucCompanion – Soft Phone
To use ucCompanion – Live Attendant, you must also run ucCompanion - Soft Phone. 

To launch ucCompanion – Soft Phone
Select Start > Programs > ucCompanion – Soft Phone. The ucCompanion - Soft Phone icon appears in 
the system tray.

To use the ucCompanion - Soft Phone, you must configure the following:

• Configuring Windows Firewall to Unblock ucCompanion – Soft Phone on page 23

• Configuring Server and User Login Information on page 24

Configuring Windows Firewall to Unblock ucCompanion – Soft Phone
If Windows firewall is enabled, then a user with administrative privileges must unblock ucCompanion – 
Soft Phone. When ucCompanion - Soft Phone is launched for the first time, typically a dialog appears to 
unblock the application, and requesting the addition of an exception to allow it through the firewall. 

If ucCompanion – Soft Phone is not allowed as an exception for Windows Firewall, then when a user 
without administrative privileges, or with prompts turned off, logs into ucCompanion – Soft Phone, the 
ucCompanion - Soft Phone registers, but they will be unable to answer or make calls.

If the application is installed and configured using administrative privileges, and the ucCompanion - Soft 
Phone isn’t launched at this time, then the exception is never requested. When users without administrative 
privileges then launch their ucCompanion - Soft Phone, they are unable to answer or make calls.

If Windows Firewall is enabled on the client, then launch ucCompanion - Soft Phone, and enable the 
firewall exception, so that users are not prevented from managing their calls due to firewall restrictions. 
Alternatively, you can manually configure Windows firewall on the client to accept ucCompanion – Soft 
Phone.

To configure Windows Firewall to allow ucCompanion – Soft Phone

1. Select Start > Programs > ucCompanion – Soft Phone.
The ucCompanion - Soft Phone icon appears in the system tray.

2. If you are launching the soft phone for the first time, and Windows Firewall is enabled, then you will 
be prompted to unblock ucCompanion – Soft Phone. Select Unblock. 
In the Windows Firewall Settings dialog, Exceptions tab, ucCompanion – Soft Phone is now enabled 
as an exception.

Refer to the NetVanta ucCompanion User Guide for more information.
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Configuring Server and User Login Information
1. Select Start > Programs > ucCompanion – Soft Phone. 

The ucCompanion - Soft Phone icon appears in the system tray.

2. If you are launching ucCompanion – Soft Phone for the first time, the ucCompanion – Select Server 
dialog appears. Enter the server information in the Server Name or IP Address field, or select one of 
the Registered Servers” from the list. 

3. At the ucCompanion – Login dialog, enter the user name and password information in the Username 
and Password fields. Select OK.

Configuring External Dialing
In order to make external calls using ucCompanion – Live Attendant, you must configure the user’s phone 
and modem dialing properties in ucCompanion Client, such as setting your location’s area code.

1. From ucCompanion – Live Attendant, select Settings > Options.

2. Select the Number Format tab.

3. Select Dialing Properties.

4. If your area code is not already set, then click Edit, and select the Area Code Rules tab.

5. Select New, and enter your area code.

6. If your area has 10 digit dialing in effect, then enable Include the area code. 
If your area has 7 digit dialing in effect, then do not enable Include the area code.

7. Select OK.

8. Select Apply, and click OK on the Area Code Rules tab.

9. Select Apply, and click OK on the Dialing Rules tab.

10. Select OK on the Options dialog.

ucCompanion - Live Attendant Display
The steps above should now be completed including:

• Launching UC Client

• Launching ucCompanion - Live Attendant, and configuring the appropriate user/server settings

• Launching the softphone and authentication

Do not change the maximum extension number length from the default value of 4, or the 
length of local phone numbers from the default value of 7.
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Registered users’ busy lamp fields (BLFs) will appear either blue or grey depending on their status.

• Registered users with a device will appear as idle (blue).

• Until the softphone logs in, the BLF of a sofphone user appears inactive (grey).

• After a softphone has logged in the status changes to idle (blue).

Troubleshooting ucCompanion Client Software Deployment
Occasionally problems may occur where ucCompanion - Live Attendant, or ucCompanion - Soft Phone do 
not work as expected. Refer to the following section to determine a possible cause and solution for errors 
that may occur. Note that the possible causes and solutions noted are not an exhaustive list.

Unable to Connect to Server

Symptoms
ucCompanion - Live Attendant is unable to connect to the server.

Cause
Windows Firewall is enabled on the server, and an exception has not been enabled for VistaTDS, so 
ucCompanion - Live Attendant running on external computers are unable to access Presence Components.

Solution
Follow the instructions in the section Configuring Windows Firewall on page 10.

BLFs Turn Grey After Appearing Registered and Connected

Symptoms
Initially when ucCompanion - Live Attendant is launched, the Busy Lamp Fields (BLFs) appear as 
registered and connected. After approximately 20 seconds, all BLFs turn grey. This pattern occurs each 
time ucCompanion or the softphone are launched.

Cause
An incorrect host name or IP address was entered when configuring the SIM. Initially the status appears 
connected when actually it is not. Once the failed connection occurs, the BLFs turn grey.

Attendants, ring groups, and hunt groups appear as idle (grey). Phantom users (that are 
directed to voicemail only and not to a particular phone) do not appear in the BLF.
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Solution
Ensure that the correct host name or IP address is entered when configuring the SIM. For information on 
configuring the SIM in a standalone environment refer to Configuring UC Server SIM on page 11. For 
information on configuring the SIM in an associate environment refer to Configuring UC Server SIM on 
the Associate UC Server on page 16.
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UC Client must already be installed.

1. Log on to client computer using a local administrator account or an account with the equivalent 
permissions.

2. Insert the UC server media. 

3. If the installation launcher starts automatically, it may be closed because it is not used for this 
installation.

4. Select Start > Run.

5. Enter cmd, and click OK to open a command prompt window.

6. Change the directory to the \Client folder of the installation media.

7. At the command prompt type the following command:
msiexec /i “NetVanta ucCompanion.msi” REINSTALL=ALL 
REINSTALLMODE=vomus

8. On the Resuming the NetVanta ucCompanion Setup Wizard page click Install. 

9. On the Completed the NetVanta UC Server Presence and Control Components Setup Wizard page 
click Finish.
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7 Administering Extensions

Overview of Administering Extensions
The Extensions Panel in the ucCompanion clients provides an easy way to view and work with phone 
extensions in the system. 

The Extensions Panel in the ucCompanion Client

The Extension Cells that client users see in their Main Windows are administered using the BLF 
Administrator (the Busy Lamp Field Administration window). This is accessed through ucCompanion - 
Live Attendant or ucCompanion. 

Make changes to Extension Cells and Extension Groups only during off-hours. If you make 
changes while users are connected, it may disrupt their call control or their interface 
display.
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BLF Administrator

For example, you might create an Extension Group called TECHSUPPORT that includes all the extensions 
for technical support. Grouping extensions in this manner helps users to quickly locate an extension, rather 
than having to scroll through all available extensions. 

Important Notes about the BLF Administrator
• Before using the BLF Administrator, all ucCompanion SIMs must be configured correctly. 

• Only one person should be using the BLF Administrator at any one time. If more than one person tries to 
modify system extensions, it could cause ucCompanion database errors.
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• The BLF Administrator can be run on any computer on the network. It is not necessary to run it on the 
main server (PCE) computer.

• If an extension has been set up to be monitored by ucCompanion but is currently out of service, its 
Extension Cell is gray. This allows instant feedback when a PBX connection goes down, when a user 
unplugs their telephone, and so on.

For more information on administering extensions, refer to the following sections:

• Creating Global Extension Groups and Adding Extension Cells on page 31

• Creating New Extension Cells on page 36

• Editing Extension Cell Settings on page 38

• Setting Tenant Extension Access Rights on page 39

• Sorting Extension Groups on page 41

• Changing How Extension Cells are Displayed on page 41

• Deleting Extension Groups on page 42

• Deleting Extension Cells on page 42

• Resetting the Password for an Extension on page 42

Creating Global Extension Groups and Adding Extension 
Cells
When ucCompanion is first installed, an Extension Group named All Groups appears in the Extension 
Groups list. This contains all the extensions and trunks that have been set up in the SIM to be monitored by 
ucCompanion.

You can create additional system-wide (global) Extension Groups, which contain a subset of monitored 
extensions. These system-wide Extension Groups are visible to all users. The procedure to create a system-
wide Extension Group in the BLF Administrator is similar to how you create a local-only Extension Group 
in the ucCompanion - Live Attendant or ucCompanion.

For more information on creating global extension groups and adding extension cells, refer to Creating 
Tenant Extension Groups and Adding Extension Cells on page 33.

In addition to the system-wide Extension Groups that you create using the BLF 
Administrator, clients can also create local Extension Groups that are visible on their clients 
only. 
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To create a system-wide Extension Group

1. In ucCompanion or ucCompanion - Live Attendant, log in as administrator. To do this, select File > 
Admin Login. Enter the Server (PCE) password. This is the password that was set when the Server 
component was installed.

2. In ucCompanion or ucCompanion - Live Attendant, select Settings > Administration > Busy Lamp 
Field. 

3. The BLF Administrator opens. Right-click in the Extension Group Panel and select New Group.

4. In the Group Type box, select Regular-System Wide.

5. In the Group Name box, type a name for the Extension Group.

6. Select OK. The new Extension Group is added to the list of Extension Groups.

7. The new Extension Group is empty, and you now need to add Extension Cells to it. Select the All 
groups group, and select all the extensions that you want to include in your new group. To select 
multiple items, Shift + click to select a block of cells, or Ctrl + click to select individual cells. 

For an extension or trunk to be visible in the BLF Administrator, it must already have been 
added in the SIM component.
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8. After you have selected all the cells, drag and drop the Extension Cells you selected onto the new 
Extension Group. The cells have now been added to the Extension Group.

9. Select OK to save your changes and exit the BLF Administrator.

Creating Tenant Extension Groups and Adding Extension Cells
When ucCompanion is first installed, an Extension Group called All groups appears in the Extension 
Groups list. This contains all the extensions and trunks that have been set up in the SIM to be monitored by 
ucCompanion.

You can create additional Extension Groups that contain a subset of monitored extensions. There are two 
type of extension groups, both of which are created using the BLF Administrator:

• Tenant extension groups. Extensions in a tenant group can only see extensions that are in their same 
tenant group.

• Global system-wide groups. These are for extensions that are visible to all users of the ucCompanion 
system. These groups are non-tenanting groups and are explained in the section Creating Global 
Extension Groups and Adding Extension Cells on page 31.

When you create a new Extension Group, you must then add at least one Extension Cell into 
the group. If the new group is empty (zero cells), it is not saved when you click OK in the 
BLF Administrator.
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This section describes how to set up tenanting extension groups. There are two types of tenant extension 
groups: parent (called Tenant Parent) and tenant child (called Normal). All extensions within a Tenant 
Parent group can see all other extensions inside that same Tenant Parent group, regardless of which 
Normal (tenant child) group the extensions are in. 

To create Tenant Parent groups, the system-wide admin password is required. To create Normal (tenant 
child) groups, the tenanting password may be used. Both these passwords are set up when the system is 
first installed, and may be modified thereafter. 

The Tenant Administrator must be logged in within the tenant group they wish to change. If logged in with 
the tenant admin password, the Tenant Admin can create Normal groups within their tenant group and 
administers their tenant groups. The Tenant Admin also sees any system-wide groups. But their tenant 
parent or child group that they belong to must be created first by the system-wide BLF Administrator. If 
system-wide groups already exist, the tenant admin can delete and add extensions to them. If the Tenant 
Admin accidentally deletes an extension from their tenant group, only the system-wide BLF Admin can 
add it back. 

To create a Tenant Extension Group

1. In ucCompanion - Live Attendant or ucCompanion, log in by selecting File > Admin Login. 
If you will be creating Tenant Parent groups and Normal (tenant child) groups, enter the system-wide 
admin password. 
If you will be creating Normal (tenant child) groups only, you may log in using the just the tenanting 
password.

2. In ucCompanion or ucCompanion - Live Attendant, select Settings > Administration > Busy Lamp 
Field. 

3. The BLF Administrator opens. Right-click in the Extension Group Panel and select New Group. The 
Group Properties dialog box appears.

You may use the tenant admin password if the Tenant parent groups have already been 
created by the system-wide admin password and your extension is a member. This allows a 
tenant admin to create normal child groups within their tenant only and allows 
administration of their tenant groups. The tenant admin cannot create system-wide or tenant 
parent groups.

For an extension or trunk to be visible in the BLF Administrator, it must already have been 
added in the SIM component.
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4. In the Group Type box, select either Normal or Tenant Parent. Normal groups must be children 
(contained within) a Tenant Parent group. 
If using the tenant admin password, you will see only your tenant and system-wide groups, along with 
any extensions not belonging to any group. You are not be allowed to create Tenant Parent or system-
wide groups.

5. If you selected Normal as the Group Type, now you must also choose an already-existing Tenant 
Parent group, from the Parent Group Name box.

6. In the Group Name box, type a unique name for the group, and click OK.

7. The new tenant Extension Group is added to the list of Extension Groups in the left pane.

8. At this point, the new Tenant Extension Group is empty. You now need to add Extension Cells to it. 
You must add at least one extension, or the new group is not saved. The Extension Cells you add to 
the tenant group are only able to see Extension Cells that are also in their same tenant group.
Select the All groups group in the left pane, and select all the extensions that you want to include in 
your new group. To select multiple items, Shift + click to select a block of cells, or Ctrl + click to 
select individual cells. 

All extensions within a Tenant Parent group can see all other extensions inside that same 
Tenant Parent group, regardless of which Normal (tenant child) group the extensions are in.

After creating a Tenant Parent group or Normal group, you MUST add at least one extension 
to the new group before clicking OK in BLF Administrator, otherwise the new group will not 
be created.
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9. After you have selected all the cells, drag and drop the cells you selected onto the new tenant 
Extension Group. This adds the cells to the group.

10. Select OK to save your changes and exit the BLF Administrator.

Creating New Extension Cells
In addition to the cells that are created when devices are loaded from the PBX, you can add new cells and 
assign dialable numbers to them. These extensions cells provide access to frequently called numbers, both 
internal and external. These cells thus function as global speed dial buttons. 

If you create an extension cell while in a tenant group (either a Normal or Parent group), the 
extension is only visible to users in that Parent tenant group.
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To create a new Extension Cell

1. Select the Extension Group where you want to add a new cell. For information about creating a new 
Extension Group, refer to Creating Global Extension Groups and Adding Extension Cells on page 31.

2. Right-click on the blank (gray) area in the right pane, and select New Extension. 
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3. The Edit Extension dialog box appears. 
Fill in the Edit Extension dialog box as follows:

4. Select OK in the Add Extension dialog box. The new Extension Cell will now be added to the 
Extension Group.

5. Select OK in the message boxes that appear. The database will be updated with the changes to the 
extension.
Within the BLF Administrator, an asterisk (*) will be added in all fields in this cell. The asterisks 
indicate that these are new (or modified) fields in the system, rather than information that originally 
came from the PBX. The asterisks appear in the Extension Cell in the Busy Lamp Field 
Administration window, and also appear in the Edit Extension dialog box within the BLF 
Administrator. The asterisks are visible in users’ client interfaces. 

Editing Extension Cell Settings
You can edit settings for extensions or trunks using the BLF Administrator. These changes are remembered 
by ucCompanion, even if they differ from what is set in the PBX.

To modify the contents of an Extension Cell

1. Select the Extension Group that contains the device (extension or trunk) you wish to modify. 

2. Right-click on the Extension Cell for the device you want to modify, and select Edit Extension. 

3. The Edit Extension dialog box appears.

ID Number This is a read-only field, which shows the unique ID for this cell.

First Name Enter the first name, as you want it to be displayed in the Extension Cell.

Last Name Enter the last name, as you want it to be displayed in the Extension Cell.

Department 
(or a comment) 

 (Optional) Enter a department name, company name, or other information you want 
to display in this cell. This is displayed in the cell below the first and last name. A 
maximum of 12 characters is allowed. 

Dialable 
Address

Enter a valid telephone or extension number. Enter digits only (no characters, spaces, 
hyphens, or parentheses). For outside numbers include the digits required to dial out, 
such as "9" and "1" and an area code; for example "916175551212." Note: Your 
system may use a number other than 9.
When users click this Extension Cell once, this number is placed in the client’s Call 
Box, and users can then click Make Call to call the number. When users double-click 
this Extension Cell in the client, this number is dialed automatically. 

You can also edit devices in the PBX/phone system, and then the changes are read by the 
SIM.
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Fill in the fields in this dialog box as desired. The Dialable Address field is the number to be dialed in 
order to access the extension, feature, or telephone number that this cell belongs to.

4. Select OK in the message boxes that appear. The database is updated with the changes to the 
extension.
Within the BLF Administrator, an asterisk (*) is added in fields that have been modified. The asterisk 
appears in the Extension Cell in the Busy Lamp Field Administration window, and also appears in the 
Edit Extension dialog box within the BLF Administrator. The asterisks are not visible in users’ client 
interfaces. 

Example: An asterisk shows the Department field has been modified

Setting Tenant Extension Access Rights
If you are using tenant groups, you can set the access rights for each extension, to change which tenant 
groups in the system the extension can see. For more about tenanting, refer to Creating Tenant Extension 
Groups and Adding Extension Cells on page 33.

The default access rights for an extension is that the extension can see all extensions within the extension’s 
Tenant Parent group. If an extension is not part of any tenant group, the extension can see all other 
extensions in the system.
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To change the access rights for an extension

1. In the left pane of the BLF Administrator, click the Extension Group that contains the extension you 
wish to modify. 

2. Right-click on the Extension Cell for the extension you want to modify, and select Set Access Rights. 
The Set Access Rights dialog box appears. 
Change the settings in this dialog box as desired:

Group All extension groups that are monitored by ucCompanion are listed in this column, 
whether they are Regular System-Wide (global), Tenant Parent, or Normal (tenant 
child) groups.
Regular System-Wide groups are shown in gray text. Your tenant group, parent and 
normal groups are also grayed. They are also enabled, meaning you have access 
rights to view the groups and extensions within these groups. If you are logged in with 
system-wide BLF admin account, other parent groups are visible and not grayed. If 
you are logged in with tenant admin, no other parent groups but your own are visible 
here.

Parent ID This column displays only those parent groups that contain child groups. The Tenant 
Parent group is displayed in the Parent ID column, and the child ("Normal") group 
appears in the Group column.
If the Parent ID column is empty for a group, that group is either a Tenant Parent 
group, or it is a Regular System-Wide group. 

Visible This column sets the individual groups this extension has access to. A check mark 
next to a group means this extension is allowed to view all extensions inside that 
group.
To quickly set an extension to see all extension groups in the system, check the 
Visible check box in the column heading. To set access back to the default, uncheck 
the Visible check box.
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Sorting Extension Groups

To sort Extension Groups
• Right-click in the Extension Groups list, and choose Sort alphabetically or Sort reverse 

alphabetically.

The groups are sorted accordingly.

Changing How Extension Cells are Displayed

To change how Extension Cells are displayed in the BLF Admin window

1. Right-click in the Extension Cell area, in the gray area (not on a cell).

2. Select Arrange Extensions or View from the menu. 
The choices in this menu are the same as when you are working in the Extension Panel in the 
ucCompanion - Live Attendant. Refer to the Netvanta ucCompanion Users Guide for detailed 
information.
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Deleting Extension Groups

To delete a system-wide Extension Group

1. In the BLF Administrator, right-click on the Extension Group you want to delete, and select "Delete 
Group." 

2. A confirmation dialog appears. Select Yes to delete the group.

Deleting Extension Cells

To delete Extension Cells

1. Decide whether you want to delete the cell from only one Extension Group or from all Extension 
Groups.
To delete a cell from only one group: Select the group to open it, and then choose the cell you want to 
delete in that group. 
To delete the cell from all groups: Select All groups, and then select the cell.

All Groups

2. Right-click on the selected cell(s). Select Delete Extension from the menu. The cells have now been 
deleted from all Extension Groups. 

Resetting the Password for an Extension
Users of ucCompanion and ucCompanion - Live Attendant can set personal passwords (by selecting 
Settings > Options > My Extension tab). This password prevents another user from connecting using the 
same name or extension number.

Deleting a group does not delete the Extension Cells that were in that group. Refer to 
Deleting Extension Cells on page 42.

To select multiple cells, use Shift + click to select a block of cells, or Ctrl + click to pick 
individual cells.
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To reset the personal password for an extension

1. In the BLF Administrator, right-click on the extension you want to reset, and select Reset Extension 
Password. 
The User Password dialog box appears.

2. Enter a new password, and then re-enter it. This serves as a temporary password. Communicate this 
password to the user, so they can log in and change it to a password they choose.
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Glossary
BLF
Busy Lamp Field; Extension Cell.

BLF Administrator
The Busy Lamp Field Administration window. Refer to Overview of Administering Extensions on page 29.

Call List
The area in ucCompanion client software where call activity is displayed.

Client
End-user software that, using client/server network architecture, connects to a main central computer (a 
server).

Device
Extension or trunk that is set up in the PBX or phone system, and can be monitored by ucCompanion.

Extension Cells
In ucCompanion client software, each extension or trunk can have a cell in the Extension Status area. This 
is the Extension Cell, or BLF. Extension Cells show their status, such as idle, connected, holding, calling, 
available for instant messages, etc.

Extension Groups
In ucCompanion client software, groups of extensions that are in the same department or other category. 
System-wide Extension Groups are set up by the administrator, and client users can also add their own 
local Extension Groups.

Extension Status Area
In ucCompanion client software, the part of the main window where Extension Cells are displayed. 

Handset
The physical, desktop telephone unit though which users dial and speak.

IM
Instant Message

IP Address
The unique address for a device on a network, using the Internet Protocol standard.
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LAN
Local Area Network.

MWI
Message Wait Indicator. This indicates you have voicemail messages.

NIC
Network Interface Card.

PCE 
Presence and Control Engine. The central component of the ucCompanion Software Suite. Provides a real-
time database and distribution of presence, telecommunications status, events, and commands. 

Server Component
The Server component of ucCompanion includes the PCE engine, the database, and the licensing server.

SIM
Systems Interface Module. A component of ucCompanion software that interfaces to a particular PBX. 
The layer of software between the PCE and the PBX.

UC
ucCompanion, the software suite from ADTRAN.

ucCompanion Presence and Control Engine
Refer to PCE.

ucCompanion Server
The central component of ucCompanion that includes the PCE, licensing, system database, and central 
logs.
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