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NetVanta Unified Communications Technical Note 
 ___________________________________________________________________________________  

Installing and Configuring the Quintum 

Survivable SIP Gateway 

Introduction 

Quintum’s Survivable SIP Gateway (SSG) serves as a signaling intermediary between local Session 

Initiation Protocol (SIP) phones and the NetVanta Unified Communications Server. SSG technology 

provides site survivability for branch offices in a single, integrated access solution. The SSG acts as an 

outbound proxy – all IP endpoints register to the SIP server via SSG and all SIP signaling passes through 

it. It is an intelligent local agent that gathers and maintains routing information for all endpoints passing 

registrations and call signaling through it to the UC server. 

In the event that the UC server is down, the SSG gateway takes control of the local telephony functions 

and routing between the local and remote sites. The routing information is automatically obtained from 

the registration and signaling information passed through the SSG acting as an outbound proxy. 

 

 

 

 

 

 

 

 

 

 



 

 

2 

Configuring a New Gateway 

Instructions for initial configuration are available in Installing and Configuring Quintum Tenor DX 

Gateway technical note or  Installing and Configuring the Quintum Tenor AS Gateway technical note, 

available online at http://kb.adtran.com. 

Upgrading your Current Quintum Gateway for SSG 

To enable SSG on an existing gateway, you must obtain the SSG software and a license key from 

Quintum Technical Support. 

Obtaining the Latest SSG Software 

Ensure you have the latest SSG software loaded using the instructions below. To find Quintum's latest 

firmware versions, please visit: http://www.quintum.com/support. 

1. Download the firmware from the Quintum web site and unzip the file (for example, using a 

program such as WinZip). Save the files to a new, empty directory on your hard drive. 

2.  From your PC select Start > All Programs > Accessories > Command Prompt. The Command 

Prompt window is displayed. 

3. Use the CD command (cd\) to change to the directory containing the unzipped firmware files on 

your local hard drive. 

4. Type ftp followed by the IP address of the unit. Press Enter. 

5. Log in with the user name and password. The default for both is admin. 

6. Enter the following commands: 

 bin <Enter> 

 hash <Enter> 

 prompt <Enter> 

 mput *.* <Enter> 

 get reset.sys <Enter> (In order for the upgrade to take effect, you must reset the unit. 

You can reset now or wait until the next time you login). 

7. To confirm the upgrade, initiate a telnet session with the unit and use the command show –v. The 

system software should reflect the upgraded firmware version. 

Upgrading your Current License File for SSG 

If you would like to upgrade your current unit (Tenor AS, Tenor AF, or Tenor DX) to include the 

Survivable SIP Gateway (SSG) functionality, you must install the applicable license file. A license file 

http://kb.adtran.com/
http://www.quintum.com/support
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contains configuration information that is used to enable features and options in the Tenor, such as SSG 

functionality.  

This section outlines the process of manually upgrading a Quintum Tenor gateway with a new license file 

which enables the SSG functionality. 

Prerequisites 

Before attempting to install the new license file, ensure that you have the following components readily 

available: 

 “license.dat” file (obtained from Quintum Technical Support) 

 IP address of target Tenor VoIP device 

 Admin Password for target Tenor VoIP device 

Getting Started 

You should receive an e-mail confirmation of the enabled license SSG feature. This e-mail also contains 

one or more attachments, the most important of which is the license.dat file. This file is the actual license 

generated for a particular Quintum Tenor VoIP device. 

The license file must be installed on the appropriate Quintum Tenor VoIP device (for example, a Tenor 

AX) via FTP. The license.dat file should be placed in the /cfg/sys/ directory in the target device. You may 

use any FTP client in order to accomplish this; the examples shown in this document are for using MS 

DOS. After FTP’ing the license.dat file to the Tenor VoIP device, the device must be reset for the new 

license to become active. 

 

NOTE: The license file will only work in the Quintum Tenor VoIP device with the serial number that 

matches the one provided when the license file was generated. The license file is not interchangeable 

among devices. 

 

Applying the License 

1. Obtain the license file from Quintum Technical Support. 

2. Save the license.dat file to your hard drive, and note the file location. This license file is a small 

binary encoded file that contains the licensed SSG feature. 

3. From your Windows PC select Start > All Programs > Accessories > Command Prompt. The 

Command Prompt window is displayed. 

4. Use the CD command to change to the directory on your PC in which you saved the license.dat 

file. 

5. Type ftp followed by the IP address of the unit. Press Enter. 

6. Log in with the user name and password. The default for both is admin. 
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7. Use the CD command to change to the cfg/sys directory (this is the directory on the Tenor into 

which you will copy the license.dat file). Depending upon the product type and software 

revision, the directory structure you see in your Tenor VoIP device may be different. 

8. Type bin <Enter>. 

9. Type put license.dat <Enter> 

10. Type get reset.sys <Enter> (In order for the upgrade to take effect, you must reset the unit. You 

can reset now or wait until the next time you log in). 

Configuring SSG 

To configure your gateway with SSG, you must use the Quintum Tenor Configuration Manager. 

 

WARNING: When configuring the SSG, you must configure the SIP Server (Primary, Secondary, or 

both) even if you are not using the FXO/FXS interfaces. 

1. Launch the Tenor Configuration Manager and connect to the Tenor in which the SSG feature is 

supported. 

2. Select the Advanced Explore tab. 

3. From the main panel select VoIP Configuration > Survivability Parameters. The Survivability 

Parameters window is displayed. 

4. In the Listening Port field enter a port number. The default port is 5060. 

5. Ensure the Use My Gateway radio box is checked. If you choose to disable this option, the Default 

Route IP address field is displayed. (The Default Route IP Address is a static route destination for 

calls when Use My Gateway is disabled.) 

6. Enter a Default Route Port (the default is 5061). 

7. In the Endpoint Expires Time enter 4800. This ensures that the gateway does not drop phone 

registrations prematurely. 

8. Select Confirm/OK. 
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9. From the main panel, select VoIP Configuration > SIP Signaling Group -1. The SIP Signaling 

Group window is displayed. 

10. In the Primary SIP Server box, enter the IP address for the Primary SIP Server (in the 

Secondary SIP Server box, enter the IP address for the Secondary SIP Server, if required). 

Configure the SIP Server Ports for both. 

11. Enter 300 in the Register Expiry Time box. 

12. Ensure the Primary Outbound Use Local Survivable Gateway box is checked. 

13. Select Confirm/OK. 
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14.  To enable the IVR, from the main panel select Circuit Configuration > Trunk Circuit Routing 

Group-line. 

Note: This step is optional, depending on the configuration. IVR is only required in a 

survivability scenario when the UC server is down and there is no secondary UC server for 

failover, in which case the IVR on the gateway will handle incoming calls. If there is a secondary 

server then incoming calls will be routed to that server, and then the gateway IVR does not need 

to be enabled. 

15. From the Type dropdown box, choose Type 8: Message Before 2nd Dial Tone. 
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16. From the main menu bar, select File > Submit Changes to submit the changes to the Tenor SSG. 

Recording an IVR Prompt 

To use the Quintum Interactive Voice Response (IVR), you must record a prompt and upload via FTP to 

the gateway. 

To record a custom prompt 

1. Click Windows Start. 

2. Navigate to All Programs > Accessories > Entertainment. 

3. Click Sound Recorder. 

4. Press the record button. 

5. When finished, press the stop button. 

6. Click File > Save As. 

7. In the file name box, enter dtprompt.wav. 

8. Beside Format click Change. 

9. Under format choose CCITT u-Law. 

10. Under Attributes choose 8.000 kHz, 8 Bit, Mono. 

11. Click OK in the sound selection dialog. 

12. Click Save. 
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13. Using an FTP program, upload this file to /ivr/English on the gateway. 

14. Reboot the gateway. 

Configuring the Phones 

To configure the phones to use the SSG gateway, the outbound proxy must be set in the configuration file 

or manually configured on the phone’s web interface. Depending on the architecture of the survivability 

solution, you may need to modify either the per-phone config file or the all phone config file. 

Aastra SIP Telephones 

1. Navigate to C:\Program Files\ADTRAN\NetVanta UC 

Server\Data\System\PhoneTypes\Aastra. 

2. In Notepad, open template.cfg. 

3. Find sip outbound proxy: and enter the IP address of the gateway after the colon. 

 

For example: sip outbound proxy: 192.168.8.49 

 

4. Save and close the file. 

5. Restart the NetVanta UC Server Application Service. 

a. Start > Control Panel > Administrative Tools > Services. 

b. Scroll down and select NetVanta UC Server Application Services. 

c. Right-click the entry and select Restart. 

6. Restart the phones either manually or from the UC client. 

Cisco SIP Telephones 

Cisco 7940, 7960 SIP Telephones 

1. Navigate to C:\Program Files\ADTRAN\NetVanta UC Server\Data\System\PhoneTypes\Cisco 

(7940, 7960).  

2. In Notepad, open SIPDefault.cnf. 

3. Find outbound_proxy: "" and enter the IP address of the gateway between the quotes. 

 

For example: outbound_proxy: "192.168.8.49” 

 

4. Save and close the file. 
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5. Restart the NetVanta UC Server Application Service. 

a. Start > Control Panel > Administrative Tools > Services. 

b. Scroll down and select NetVanta UC Server Application Services. 

c. Right-click the entry and select Restart. 

6. Restart the phones either manually or from the UC client. 

Cisco 7912 SIP Telephones 

1. Find the IP address of the phone: 

a. Press the Menu button. 

b. Choose Settings > Network Configuration. 

c. Scroll to IP Address 

2. Enter this IP address in your web browser. 

3. In the pane on the left under Change Configuration, click SIP Parameters. 

4. In the OutBoundProxy field, enter the IP address of the gateway. 

5. Click Apply. 

6. Restart the phones either manually or from the UC client. 

Linksys SIP Telephones 

1. Navigate to C:\Program Files\ADTRAN\NetVanta UC 

Server\Data\System\PhoneTypes\Linksys. 

2. In Notepad, open spa-template.cfg. 

3. Find <Use_Outbound_Proxy_1_ ua="na">No</Use_Outbound_Proxy_1_>. Change No to 

Yes. 

4. Find <Outbound_Proxy_1_ ua="na"></Outbound_Proxy_1_>. Between >< enter the IP 

address of the gateway. 

 

For example: <Outbound_Proxy_1_ ua="na">192.168.8.49</Outbound_Proxy_1_>. 

 

5. Save and close the file. 

6. Restart the NetVanta UC Server Application Service. 

a. Start > Control Panel > Administrative Tools > Services. 

b. Scroll down and select NetVanta UC Server Application Services. 

c. Right-click the entry and select Restart. 

7. Restart the phones either manually or from the UC Client. 
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snom SIP Telephones 

1. Navigate to C:\Program Files\ADTRAN\NetVanta UC 

Server\Data\System\PhoneTypes\snom3x0.  

2. In Notepad, open template.htm. 

3. Find user_outboundX: (for each line). After the colon, enter the IP address of the gateway and the 

port. 

 

For example: user_outbound1: 192.168.8.49:5060 

 

4. Save and close the file. 

5. Restart the NetVanta UC Server Application Service. 

a. Start > Control Panel > Administrative Tools > Services. 

b. Scroll down and select NetVanta UC Server Application Services. 

c. Right-click the entry and select Restart. 

6. Restart the phones either manually or from the UC client. 

Polycom SIP Telephones 

1. Navigate to C:\Program Files\ADTRAN\NetVanta UC 

Server\Data\System\PhoneTypes\Polycom. 

2. In Notepad, open allphones.cfg for all models except the 320/320. For the 320/330, open 

allphones-320_330.cfg. 

3. Find outboundProxy voIpProt.SIP.outboundProxy.address="" and enter the IP address of the 

gateway between the quotes. 

 

For example: outboundProxy voIpProt.SIP.outboundProxy.address="192.168.8.49” 

 

4. Save and close the file. 

5. Restart the NetVanta UC Server Application Service. 

a. Start > Control Panel > Administrative Tools > Services. 

b. Scroll down and select NetVanta UC Server Application Services. 

c. Right-click the entry and select Restart. 

6. Restart the phones either manually or from the UC client. 
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Grandstream SIP Telephones 

1. Navigate to C:\Program Files\ADTRAN\NetVanta UC 

Server\Data\System\PhoneTypes\Grandstream.  

2. In Notepad, open the template file for the model you are modifying.  

 

For Example: Open the cfg_template_bt for the BudgeTone series. 

 

3. Find P48 = and enter the IP address of the gateway. 

 

For example: P48 = 192.168.8.49 

 

4. Save and close the file. 

5. Restart the NetVanta UC Server Application Service. 

a. Start > Control Panel > Administrative Tools > Services. 

b. Scroll down and select NetVanta UC Server Application Services. 

c. Right-click the entry and select Restart. 

6. Restart the phones either manually or from the UC client. 

CounterPath X-Lite and eyeBeam Softphones 

1. Open the softphone.  

2. Right-click anywhere on the softphone and choose SIP Account Settings. 

3. Double-click the account. A new dialog will pop up. 

4. Under send outbound via choose proxy and enter the address of the gateway. 

5. Click OK and then click close. 


