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Conventions

Notes provide additional useful information.

Cautions signify information that could prevent service interruption or damage to 
equipment.

Warnings provide information that could prevent injury or endangerment to human 
life.
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1 Server Configuration Guide

Introduction
This guide is written for installers to configure the NetVanta Enterprise Communications Server or 
NetVanta Business Application Server at the customer site. It assumes that you have experience installing 
and programming communication systems and voicemail systems. It assumes knowledge of computer 
networks.

Installing UC Server on a Windows operating system allows you to manage the business communication 
system within a Microsoft IT environment. Integration with Active Directory allows IT administrators to 
manage the communication system using the same user accounts and security policies that are used in the 
Windows environment. The automatic integration requires no extra programming or special integration.

Before you run the UC Server Configuration Wizard, make sure you follow all the instructions in the 
NetVanta Enterprise Communications and Business Application Servers Installation Guide, including 
running the Server Installation Wizard.

This guide covers the following main topics:

• Preparing to Start the Server Configuration Wizard on page 7

• Starting the Server Configuration Wizard on page 15

Preparing to Start the Server Configuration Wizard
Before you start the UC Server Configuration Wizard, you can further prepare your system by doing the 
following:

• Setting up DHCP Records to Point to the File Server on page 8

• Obtaining Network and Security Information on page 10

• Verifying Requirements and Recommendations on page 11

• Incorporating the Server into the Customer Domain on page 11

• Gathering Server Configuration Wizard Information on page 12

• Creating an Authorization Store to Enable Active Directory Roles on page 12

• Polycom Phone Configuration Requirements on page 13

• Configuring UC Server Presence and Control on page 14

For ADTRAN documents, refer to the website at http://kb.adtran.com.
619510001-29A Copyright © 2009 ADTRAN, Inc. 7
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 Preparing to Start the Server Configuration Wizard Enterprise/Business Servers
Setting up DHCP Records to Point to the File Server
Using a DHCP server, SIP telephones can retrieve configuration information from the network and allow 
for automatic discovery and configuration. Using a DHCP server for automatic network configuration, 
network reconfigurations can be managed from a central location. 

Windows Server 2008 and Windows Server 2003 DHCP servers provide the required features and 
functionality to support automatic configuration of SIP telephones and gateways.

Manually configuring DHCP server for phones
You can manually set up the DHCP records to point to the provisioning server. The provisioning server can 
be either an FTP or TFTP server depending on the phone model. The DHCP server for the local network 
must have an extra record that points the telephones to the correct provisioning server to facilitate 
automatic detection and configuration of phones and gateways.

DHCP Scope and Purpose

To set up DHCP records using Server 2008 or SBS 2008

1. Select Windows Start > Control Panel.
• If the Control Panel view is in 2008 format, select System and Maintenance, select 

Administrative Tools, and select the DHCP shortcut in the right hand pane.
• If the Control Panel is in Classic View, select Administrative Tools, and select the DHCP 

shortcut in the right hand pane.

2. In the left hand pane of the DHCP Manager select the server, and expand by selecting the + symbol.

For simplified deployment of SIP telephones, we recommend the use of a DHCP server that 
extends the default scope options. Not following this recommendation requires manual 
configuration of SIP telephones.

The procedures below are general guidelines only. The procedures may vary depending on 
the type of phones you are using. Refer to the Server Configuration Wizard for information 
on specific phone types.

DHCP Scope Option Purpose

Option 66 UC Server IP address for FTP or TFTP Boot Server

Option 150 UC Server IP address for FTP or TFTP Boot Server

Option 2 Time Offset for time zone configuration

Option 4 Time Server IP address or resolve from host name

If customers are already using this option for configuring other devices, you might need to 
perform a more complex set-up process to make sure there are no conflicts. That process is 
beyond the scope of this document.
 8 Copyright © 2009 ADTRAN, Inc. 619510001-29A



Enterprise/Business Servers  Preparing to Start the Server Configuration Wizard
3. In the expanded view, right-click on Server options, and select Configure Options.

The Server Options dialog opens.

4. On the general tab scroll down the list to Option 66, and enable it.
This enables the data entry for the option.

5. Enter the IP address of the Provisioning Server.

To add option 150 for Cisco phones using Server 2008 or SBS 2008

1. Select Windows Start > Control Panel.
• If the Control Panel view is in 2008 format, select System and Maintenance, select 

Administrative Tools, and select the DHCP shortcut in the right hand pane.
• If the Control Panel is in Classic View, select Administrative Tools, and select the DHCP 

shortcut in the right hand pane.

2. In the left hand pane of the DHCP Manager select the server, and expand by selecting the + symbol.

3. In the expanded view, right-click on IPv4 and select Predefined Options.
This opens the Predefined Options and Values dialog.

4. Select Add.

5. On the Option Type dialog enter the following values:

6. After entering the information above, select ok to return to the Predefined Options and Values dialog.

7. Enter the IP address for the Cisco Phone boot server:

8. In the expanded view, right-click on Server options and select Configure Options to open the Server 
Options dialog.

9. On the general tab scroll down the list to Option 150 and enable the check box.
This enables the data entry for the option and enters the IP address of the Provisioning Server.

If you are using Windows Small Business Server (SBS) 2008, then select IPv4, select Scope 
Options, right-click and select Configure Options.

Class: Global
Name: Boot Server Host Name
Data type: String
Code: 150 (for Cisco phones)
Description: FTP boot server name

Value: IP Address of the FTP server 
(for example, 192.168.1.100)
619510001-29A Copyright © 2009 ADTRAN, Inc. 9



 Preparing to Start the Server Configuration Wizard Enterprise/Business Servers
To set up DHCP records using Windows 2003 Server

1. Select Windows Start > Settings > Control Panel.

2. Double-click the Administrative Tools icon.

3. Open the DHCP MMC snap-in.

4. Right-click the server object > Set Predefined Options.
The server object is located in the left-hand tree.

5. From the Option name list, select 066 Boot Server Host Name (or option 150 for Cisco phones).

6. If that option does not appear in the list, select Add.

7. Make sure all the configurations are as follows:

8. Select OK.

Obtaining Network and Security Information
Obtain network and server information from the customer prior to configuration, such as service accounts 
and administrative passwords.

For security reasons, some customers might be reluctant to provide passwords and network information in 
this manner. If that is the case, the customer should make sure that this information is readily available 
when you arrive on site to do the configuration.

Class: Global
Name: Boot Server Host Name
Data type: String
Array: Off
Code: 66 (or 150 for Cisco phones)
Description: FTP boot server name
Value: IP Address of the FTP server 

(for example, 192.168.1.100)

Alternatively, you can set up the DHCP option to apply only to specific scopes, or even 
specific addresses or reservations. The latter is more management effort, but might be 
required in certain sites, or to set up independent test environments for specific phones.
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Verifying Requirements and Recommendations
The UC Server application runs on the following operating systems:

• Microsoft Windows Server 2008 (x86, x64)
• Deployment on Server Core or Hyper-V is not supported.

• Microsoft Windows Server 2003 R2 SP2

• Microsoft Windows Server 2003 SP1, SP2

• Microsoft Windows Small Business Server 2003 SP1 or later SP

• Microsoft Windows XP Professional SP2 or later SP

To ensure security, UC Server accounts are given minimal permissions on the computer. The Server must 
be installed onto an NTFS partition on this server computer to make sure that proper security is in place.

The Exchange Server and UC Server computer must be members of the same Windows domain.

Consult the UC Server support website for additional up-to-date application or configuration notes.

Incorporating the Server into the Customer Domain
Incorporating the UC Server into the customer domain is required for Active Directory and Microsoft 
Exchange integration.

To incorporate the UC Server

1. On the desktop, right-click My Computer.

2. Select Properties.

3. Select the Computer Name tab.

4. Select the Change... button.

5. In the Member of section, select Domain, and enter the domain name.

It is not recommended that you run UC Server and the Exchange Server on the same system.

You require a domain administrator user name and password to complete this procedure.
619510001-29A Copyright © 2009 ADTRAN, Inc. 11
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Gathering Server Configuration Wizard Information
The UC Server Configuration Wizard provides a step-by-step guide for configuring your server. The 
Server Configuration Wizard is customized to configure the server according to the needs of your 
particular network configuration.

It is recommended that you have the information ready that you might need before you start the wizard. 
You need to know the following:

Creating an Authorization Store to Enable Active Directory Roles

The authorization store is typically created prior to running the Server Configuration Wizard.

The following conditions must be satisfied in order to create an authorization store:

• The UC Server computer platform must be integrated with the customer’s network.

• The UC Server Active Directory account must already be created on the customer’s domain.

• The user creating the authorization must be authenticated with the domain.

Message store type Local only or
Local and Exchange or
Lotus Notes/IMAP

Computer names Includes Networking information and computer names
Server Account The dedicated account for running the Server
Microsoft Exchange names Microsoft Exchange Server computer name

Mailbox name for Service Account
UC Server administrator 
password

The password that is used to configure the system. The default 
administrator login name is “admin.”

Dialing rules Used to specify the location from which you are dialing the dialing rules 
(for example, dial 9 for an outside line)

PBX type Avaya Communication Manager or DEFINITY, Merlin Magix, Nortel 
Norstar, IP Office or generic analog

CTI link options
(Merlin Magix)

Used to configure advanced PBX integration for calling line ID

Port Name and Identity Used to configure all the ports that are connected to the PBX
User information Used to create and configure all the user accounts
Email configuration Used to configure the services when sending notification by email. If you 

do not have Exchange, you can configure an SMTP Server for email 
notification.

Creating an authorization store is an optional step that applies to UC Server installations 
that are integrated with Active Directory. You can skip this step if you are configuring UC 
Server as stand-alone.
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If users were already created prior to creating an authorization, the administrator must assign a role to each 
configured Windows User. Users added after the authorization store is created have a default role Standard 
User assigned to their user profile.

To create an authorization store

1. Log in to the UC Server computer as a domain administrator.

2. Select Start > Run > CMD to launch a CMD window.

3. Navigate to the UC Server installation directory:
\ADTRAN\NetVanta UC Server\bin

4. Type the following:

manageazman +createxmlstore +admin <DOMAIN>\<UC SERVER SERVICE 
ACCOUNT>

5. Stop and restart the UC Server application service by doing the following:
• Open the service control panel application.
• Restart the service named NetVanta UC Server Application Services.

Polycom Phone Configuration Requirements
Some phone types such as Polycom require the use of a File Transfer Protocol (FTP) server for automatic 
phone configuration. SIP telephones that are configured by default to use FTP for provisioning will look 
for configuration files in the FTP server specified by option 66 in the DHCP server. The Phone Types 
Wizard automatically configures the FTP server (on the local machine) should a selected phone type 
require it. 

In some cases, the Phone Types Wizard is unable to automatically configure the FTP server, such as when 
UC Server is installed on a domain controller. If this occurs, then the Wizard issues a warning and the FTP 
server must then be configured manually. Refer to Appendix A The following sections describe the manual 
procedures for some tasks that are typically performed automatically by the UC Server Configuration 
Wizard. These procedures may be required to be performed manually, since there may be some information 
about your network and hardware that the wizard cannot determine automatically. The procedures are 
described below in case some manual configuration is required. on page 27 for details on how to manually 
configure the FTP server and enable support for a particular manufacturer’s line of phones.

If you have already followed the instructions in the NetVanta Enterprise Communications 
and Business Application Servers Planning and Deployment Guide for creating an 
authorization store, then you do not need to repeat the same steps below.

You can create the custom authorization store at any time, before, during or after 
installation. However, any Active Directory users and their associated authentications will 
have to be modified to include a role from the role list. Consult the NetVanta Enterprise 
Communications Server Administrator Guide for details on how to change the 
authentication role for individual user authentications.
619510001-29A Copyright © 2009 ADTRAN, Inc. 13
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Polycom Phones and Windows Small Business Server or Domain Controllers
If you are using Polycom phones and running UC Server on Microsoft Windows Small Business Server 
(SBS) or a domain controller, then particular configuration issues arise. Polycom phones automatically 
retrieve configuration files from an FTP server with the user "PlcmSpIp". UC Server manages the 
Microsoft Windows FTP server on the installed machine to store and update the Polycom configuration 
files. Typically, UC Server creates a local Windows user named PlcmSpIp and assigns the appropriate 
permissions to the Windows FTP Server.

However, domain controllers including Windows SBS, do not permit local users. In this case, the Wizard 
may create a domain account. Polycom requires the user name and password "PlcmSpIp". Thus, UC 
Server installations on a Windows SBS must use a Microsoft Active Directory user named PlcmSpIp to 
enable access to the Windows FTP server. However, Polycom's PlcmSpIp password does not meet the 
default password complexity policy for domain controllers, including SBS. In order for Polycom phones to 
retrieve configuration files from an FTP server on a domain controller or Windows SBS, a domain account 
must be created. To create the domain account user "PlcmSpIp" the default password policy must be 
temporarily disabled. Solutions to this issue are:

• Let the Wizard automatically create and configure the domain account.

• Manually create and configure the domain account. 

If you choose to manually create and configure the domain account, then the following requirements must 
be met:

• You must have the necessary privileges to create a domain account, for example, you must be logged in 
as Domain Administrator. 

• You must modify the group password policy to allow the simpler password. Once the domain account is 
created, the password policy can be reverted to the original policy. 

For instructions on manually configuring the system, refer to Appendix B, Manually Configuring Polycom 
SIP Phones on page 31. For further explanation of this issue refer to the NetVanta Enterprise 
Communications and Business Application Servers Planning and Deployment Guide regarding password 
requirements.

Configuring UC Server Presence and Control
If you installed the NetVanta Enterprise Communications Server, then you were prompted whether to 
install the UC Server Presence Components, which are required to run the optional ucCompanion - Live 
Attendant application. If you installed the UC Server Presence Components, then there are some 
configuration steps which must be performed prior to starting the Server Configuration Wizard. For 
instructions on configuring the UC Server Presence Components refer to the NetVanta Unified 
Communications Server Presence and Control Components Guide, available from the installation CD, or 
at http://kb.adtran.com.
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Starting the Server Configuration Wizard

Login Requirements
Make sure that a computer account is created in the customer’s network. If you are integrating with 
Microsoft Exchange, make sure that you are logged on as a domain user that has:

• Domain administrator privileges—must be able to add users to the domain

• Exchange Server administrator privileges—must be able to create mailboxes and set permissions on the 
Exchange server

Server Configuration Wizard Overview
The Server Configuration Wizard consists of several wizards that each become available after the 
successful completion of the previous wizard. The wizards are listed below:

1. Product Licensing Wizard on page 15 — enter your product and license key information

2. Windows Network Integration Wizard on page 15 — configure Windows Firewall, service account, 
and service connection point

3. Communication Systems Wizard on page 16 — configure your communications systems

4. Phone Types on page 16 — specify required phone types

5. Gateways on page 18 — specify required gateway types

6. Messaging Systems on page 20 — select message store type and configure account

7. Users on page 20 — add new or import existing users

8. Final System Configuration on page 26 — configure email notification system; create default user, 
operator and default mailbox; specify dialing rules and location

To start the Server Configuration Wizard
• Select Windows Start > Programs > NetVanta UC Server > Server Configuration Wizard.
The main wizard screen guides you through the rest of the configuration.

Product Licensing Wizard
Run this wizard to specify your product and license key information for UC Server. You can paste the 
product and license key, and the machine ID, into the appropriate wizard boxes. The product key is shipped 
with the product CD.

Windows Network Integration Wizard
You can configure your Windows account to work with UC Server. Create a service account: assign 
permissions to the directory, and assign the account to UC Server.
619510001-29A Copyright © 2009 ADTRAN, Inc. 15
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Create a service connection point. A service connection point is an advertised name that can be used to 
locate UC Server. When you start UC Client for the first time, the service connection point contains the 
name and IP address of the UC Server. The user does not have to type a name, the name automatically 
appears in the list.

Communication Systems Wizard
You can define and configure new communication systems. Select a communication system type from the 
list provided. The communication systems listed have the required hardware and a valid license. You 
cannot create a communication system that is invalid. 

You can select a UC Server SIP PBX, or you can select an existing PBX, which you can connect to UC 
Server through a Dialogic Media Gateway. For a list of PBXs supported by Dialogic, and for gateway 
configuration information, refer to the Dialogic website at www.dialogic.com. For more information on 
configuring the gateway to connect UC Server to an existing PBX, refer to Configuring the Dialogic 
Media Gateway technical note, available from at http://kb.adtran.com.

The options that are available depend on the communications system type selected, but may include 
configuring message waiting, configuring the CTI link, selecting and configuring ports, and selecting a 
network adapter for the communication services.

The Port Configuration page allows you to choose a device ID, to enable and attach a name and an 
extension number to. This page also displays for legacy communication systems.

Phone Types
Running this wizard allows you to specify the telephone types for your system. Select the devices that you 
are planning to use in your environment. The Server Configuration Wizard prepares UC Server for 
automatic detection and configuration of those devices. For more information refer to the following 
sections:

• Configuring FTP server on page 16

• Configuring TFTP service on page 18

Configuring FTP server
Some phone types require the use of a File Transfer Protocol (FTP) server for automatic phone 
configuration. SIP telephones that are configured by default to use FTP for provisioning will look for 
configuration files in the FTP server specified by option 66 in the DHCP server. The Phone Types Wizard 
automatically configures the FTP server (on the local machine), should a selected phone type require it. If 
the Phone Types Wizard is unable to automatically configure the FTP server, such as when UC Server is 
installed on a domain controller, then the Wizard issues a warning and the FTP server must then be 
configured manually. Refer to Appendix B “Manually configure the system for SIP telephones to retrieve 
their configuration information” on page 21 for details on how to manually configure the FTP server and 
enable support for a particular manufacturer’s line of phones.

There are specific configuration issues with regards to using Polycom phones with Microsoft Windows 
Small Business Server or a domain controller. If you have not already done so, refer to the Server 
Configuration Wizard Overview on page 15 section for more information to avoid having to configure the 
 16 Copyright © 2009 ADTRAN, Inc. 619510001-29A
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system manually, as outlined in Appendix B, This appendix describes the steps to manually configure the 
system to allow for Polycom SIP telephones to retrieve their configuration information. You must only 
manually enable support for a line of telephones if the Server Configuration Wizard was unable to do so. 
You will receive a warning from the Phone Types Wizard if this is the case. Typically, the wizard would be 
unable to automatically enable support for a line of telephones if UC Server is installed on a domain 
controller. If this is the case, then you must manually enable support for SIP telephones following the 
instructions in each section listed below. For more information refer to Phone Types on page 16. on 
page 31.

If a screen appears in the Configuration Wizard that tells you that the Microsoft Internet Information 
Services (IIS) subcomponent File Transfer Protocol (FTP) is not installed, you must install it.

To install the FTP sub-component to configure UC Server as an FTP server

1. On the Windows desktop, select Start > Control Panel.

2. Select Add or Remove Programs.

3. Select Add/Remove Windows Components.

4. In the Windows Components box, select Internet Information Services.

5. Select Details.

6. Select File Transfer Protocol (FTP) Service.

7. Select OK.

The FTP Publishing service must be set to Automatic. In the event of a restart, if the FTP Publishing 
service is off, then Polycom phones will not successfully reboot as a result.

To set the FTP Publishing service to Automatic

1. Select Start > Programs > Administrative Tools > Services.

2. Select FTP Publishing, right-click and select Properties.

3. Under Startup type select Automatic.

4. Under Service status select Start.

5. Select Apply, and then select OK.

If you are installing UC Server with a Windows Server 2003 configuration, then enable the 
Application Server check box and select Details.

When installing UC Server on Windows Small Business Server (SBS) 2008, the startup type 
for the FTP Publishing service is set to Manual by default. This must be changed to 
Automatic. If this was not changed during the UC Server installation process, then follow 
the steps below.
619510001-29A Copyright © 2009 ADTRAN, Inc. 17
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Configuring TFTP service
Some phone types require the use of a Trivial File Transfer Protocol (TFTP) service for automatic phone 
configuration. TFTP servers can also be used as a repository for configuration files for SIP Telephones. 
SIP telephones that are configured to use TFTP retrieve their configuration information using TFTP. UC 
Server includes a TFTP server.

Windows Firewall must be configured for the TFTP service, either automatically or manually. If you 
selected a phone type that requires a TFTP service, you can enable the system to automatically configure 
Windows Firewall for the TFTP service. Alternatively, you must manually configure Windows Firewall 
for the TFTP service.

Failure to configure the Windows Firewall correctly might impact the following features:

• Automatic detection and configuration of SIP devices (FTP, TFTP, HTTP)
• SIP telephone registration with NetVanta UC Server
• SIP PSTN gateways connecting to NetVanta UC Server
• SIP telephones cannot retrieve configuration information from UC Server’s FTP or TFTP server
• SIP telephones cannot receive or place telephone calls

To manually configure Windows Firewall

1. Select Start > Settings > Control Panel.

2. Select Windows Firewall.

3. Select the General tab.

4. Enable the On button.

5. Make sure that the Don't allow exceptions box is disabled.

6. Select the Exceptions tab.

7. Enable the check box beside each program or service that you want to set as an exception in Windows 
Firewall, specifically, NetVanta UC Server TFTP Service.

Gateways
Running this wizard allows you to select the gateway type that you are planning to use in your 
environment, such as PSTN, or SIP Peer. The Gateway Wizard prepares UC Server for configuration of the 
gateway. More than one gateway type can be added, but each gateway is configured separately. If you have 
more than one gateway, the gateways can be organized into groups.

For ITSP gateways, select PSTN gateway.
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PSTN gateways
UC Server can provide PSTN network access through SIP PSTN gateways. SIP PSTN gateways convert 
the SIP protocol (signaling and voice) to traditional PSTN (Time Division Multiplexing) technology. SIP 
PSTN gateways can use either analog or digital lines (T1 in North America).

To change PSTN gateway settings
• Enter the host name for the PSTN gateway.

SIP Peer Gateways
The SIP Peer allows for the networking of multiple UC Servers. 

To change SIP Peer gateway settings
• Enter the host name for the SIP Peer Gateway.

Gateway groups
If you have more than one gateway, you can organize them into groups. Dial plan entries route calls to 
alternate trunking facilities if the facilities are busy or unavailable. For example, if two trunking facilities 
are available, PRI and analog, the analog facilities can be used as a second choice when the PRI lines are 
busy or unavailable. A flexible dialing plan routes incoming and outgoing calls to individual or groups of 
gateways. A gateway group provides the following capabilities:

• Fault tolerance/Disaster Recovery - This provides overflow capability in the event that a gateway device 
is busy or unavailable.

• Least Cost Routing (LCR) alternatives - A gateway group can contain gateways that are connected to 
different carriers, such as local and long distance providers, or can contain gateways in different 
geographic locations. 

• Different technologies of trunking facilities can be combined seamlessly. Gateway groups can combine 
analog facilities, digital facilities, SIP trunking services, and SIP Peers.

To create a gateway group

1. From the Available gateways list, select a gateway and select Add to add the gateway to the gateway 
group. 

2. Select Next when you have finished creating your gateway group.

Configuring the gateway
Enter the configuration details for the gateway.

To configure the gateway

1. Enter a unique name for the gateway. 
This information is for display purposes only, on UC Server and in the database.
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2. Select the communication system for which the gateway is associated. 
The default is UC Server. 

3. Enter a brief description of the gateway.
This information is for display purposes only.

Messaging Systems
Use the Messaging Systems Wizard to select a message store type, such as Exchange, IMAP, or SMTP, and 
to configure the message store account.

Users
Use this wizard to add new users and import existing users from Active Directory, Microsoft Exchange 
Server, or from text files. The wizard allows you to select a location to import users from, and 
automatically generate and assign extensions. You can also change user information before you create 
users. For more information refer to the following sections:

• Importing users from Active Directory on page 20

• Importing users from Exchange Server on page 21

• Importing users from text files on page 22

Importing users from Active Directory
You can select a group of users to import from Active Directory, and you can also automatically assign an 
extension number for each user. 

User naming convention
If you import users with a display name only, without specifying the first and last name, then users are 
imported as follows:

• If a display name is delimited with spaces, then the last 'word' is the last name, for example, "Bob Jeff 
Thompson"

lastname = Thompson
firstname = Bob Jeff

• If a display name is delimited with commas, then everything after the comma is the first name, for 
example, "Thompson, Bob J.”

lastname = Thompson
firstname = Bob J.

To import Active Directory users

1. From the drop-down list, select the Active Directory domain from which you want to import users.

2. Select Browse to search Containers on your system for the users that you want to import. 
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3. If you specify a name prefix, the wizard imports users with names that begin with that prefix (this 
feature is not case sensitive). 

4. Enable the Create "Windows-enabled" Active Directory users check box if you want users to be 
able to use the single sign-on Active Directory feature.

5. Enable the Use Active Directory for messaging configuration check box to link users' mailboxes to 
their corresponding Exchange mailboxes.

To change users’ specifications
• To return the wizard to the specification page, select Stop search and refine criteria.

To stop importing users
• To stop the import, select Stop search and process users. 

The configuration page appears with only those users that were imported up to that point.

Importing users from Exchange Server

To import users from Exchange Server

1. From the list, select the location of the Microsoft Exchange Server from which you want to import 
users. 

2. If you specify a name prefix, the wizard imports users with names that begin with that prefix (this 
feature is not case sensitive). 
With the list of users, you can assign the Identities (typically extensions). The wizard extracts the first 
name and last name from the Exchange Server. The users are associated with the Personal Assistant 
(PA) user profile, and have the system operator as the default dial "0" location. 

3. Select whether you want the users that you are importing to be linked to Active Directory.

To change users’ specifications
• To return the wizard to the specification page, select Stop search and refine criteria.

To stop importing users
• To stop the import, select Stop search and process users. 

The configuration page appears with only those users that were imported up to that point.

If you are importing a large number of users, the process takes some time, and a progress 
page shows you how many users have been found so far.

If you are importing a large number of users, the process takes some time, and a progress 
page shows you how many users have been found so far.
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Importing users from text files
You can use Microsoft Excel to create a tab-separated text file to import Windows-enabled or local users. 
A Windows-enabled user is associated with an Active Directory user, while a local user is not. Local users 
are configured to use local message store (LMS), while Windows-enabled users are configured to use 
Microsoft Exchange Server if one exists. Some fields are required and others are optional, depending on 
whether you're importing local or Active Directory users. 

For more information refer to the following sections:

• Importing local users from text files on page 22

• Importing Windows-enabled users from text files on page 24

Importing local users from text files
To import users, enter the information for each user in a tab-separated text file. The format of the tab-
separated file must be similar to the following example, which shows all possible headings for local users. 
The order of the headings does not matter, and the headers are not case sensitive. To import local users, 
provide the displayname at a minimum.

Table 1-1. Tab-separated file format

For more information on importing users from text files, refer to Importing Users to UC 
Server technical note available at http://kb.adtran.com. A corresponding zip file also 
includes a Microsoft Excel file for importing users.

displayname extension givenname sn userfax pbx answeringmode phonemac phonetype

First1 Last1 3000 First1 Last1 UC Server PA
First2 Last2 3001 First2 Last2 UC Server PBA
First3 Last3 3002 First3 Last3 UC Server

The PBX name in the above example, UC Server, is the PBX name assigned to a PBX when 
you created it. Substitute the PBX name (if different) with the name you created for your 
location.
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To create a tab-separated file for importing local users using Microsoft Excel

1. Create a Microsoft Excel spreadsheet that has some or all of the following headings. At a minimum, 
the DisplayName must be specified.

2. Enter the customer-provided information into the relevant headings.

3. In Microsoft Excel, select File > Save As.

4. Type a name for the file.

5. In the Save as type list, select Text (Tab delimited)(*.txt).

6. Select Save.

7. Close Excel.

To import the user text file

1. When you run the User Import Wizard, choose to import user information from a text-based file.

2. Select Browse to select the location of the file.

displayname Name that appears in the Administration Users pane

extension Identity that is associated with the user. If this value is entered, it must be unique for 
each user, and cannot correspond to an existing identity.

givenname First name of the user

sn Last name of the user

userfax Incoming identity associated with DID fax. This is the fax number that callers dial to 
send faxes to the user. The user receives incoming faxes in their Inbox.

pbx Display name of the PBX that the user is associated with. By default, the name is “UC 
Server.”

answeringmode Call answering mode, either PA for Personal Assistant or PBA for Personal Business 
Assistant. If no value is specified, then the user becomes a PA user by default. PA 
and PBA are not case sensitive.

phonemac MAC address of the user's phone. The MAC address can be entered with or without 
dashes between octets.

phonetype The user's phone model name

The spelling of the phone types in the tab delimited file must match exactly the names used 
in the Server Configuration Wizard.
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3. The following options are valid only for importing Windows-enabled users, so for local users the 
check boxes are disabled:
• Create “Windows-enabled” Active Directory users
• Use Active Directory for messaging configuration

To stop importing users from a text file
• To return the wizard to the specification page, select Stop search and refine criteria.
• To stop the import, select Stop search and process users. The configuration page appears with 

only those users that were imported up to that point.

Importing Windows-enabled users from text files
To import Windows-enabled users, enter the information for each user in a tab- separated text file. For 
Windows-enabled users, the format of the tab-separated file headings must be similar to the following 
examples. The order of the headings does not matter, and the headers are not case sensitive. Include all of 
the required fields, and any of the optional fields that you want, into one file.

Table 1-2. Required fields for Windows-enabled users

Table 1-3. Optional fields for Windows-enabled users

If you are importing a large number of users, the process takes some time, and a progress 
page shows you how many users have been found so far.

displayname givenname sn legacyexchangedn objectguid objectsid userprincipalname

First1 Last1 First1 Last1
First2 Last2 First2 Last2
First3 Last3 First3 Last3

If you do not include all the required information for a Windows-enabled user, then a user 
will be imported as a local user instead.

extension userfax pbx answeringmode phonemac phonetype

3000 UC Server PA
3001 UC Server PBA
3002 UC Server

The PBX name in the above example, UC Server, is the PBX name assigned to a PBX when 
you created it. Substitute the PBX name (if different) with the name you created for your 
location.
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To create a tab-separated file for importing Windows-enabled users using Microsoft Excel

1. Create a Microsoft Excel spreadsheet that has the following headings (some are optional as noted 
above):

2. Enter the customer-provided information into the relevant headings.

3. In Microsoft Excel, select File > Save As.

4. Type a name for the file.

5. In the Save as type list, select Text (Tab delimited)(*.txt).

6. Select Save.

7. Close Excel.

displayname Name that appears in the Administration Users pane

extension Identity that is associated with the user. If this value is entered, it must be unique 
for each user, and cannot correspond to an existing identity.

givenname First name of the user

sn Last name of the user

userfax Incoming identity associated with DID fax. This is the fax number that callers dial 
to send faxes to the user. The user receives incoming faxes in their Inbox.

pbx Display name of the PBX that the user is associated with. 
By default, the name is “UC Server.”

legacyexchangedn Identifying string for the user’s Exchange Server, as defined in Active Directory

objectguid GUID of the object in Active Directory

objectsid SID of the user in Active Directory, in S-1-5... format

userprincipalname The user email address, for example, jmciverson@adtran.com.

answeringmode Call answering mode, either PA for Personal Assistant or PBA for Personal 
Business Assistant. If no value is specified, then the user becomes a PA user by 
default. PA and PBA are not case sensitive.

phonemac MAC address of the user's phone. The MAC address can be entered with or 
without dashes between octets.

phonetype The user's phone model name

The spelling of the phone types in the tab delimited file must match exactly the names used 
in the Server Configuration Wizard.
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To import the user text file

1. When you run the User Import Wizard, choose to import user information from a text-based file.

2. Select Browse to select the location of the file.

3. If you’ve included all the required field headings, then Create "Windows-enabled" Active 
Directory users is enabled for users to be able to use the single sign-on Active Directory feature.

4. Enable the Use Active Directory for messaging configuration check box to link users' mailboxes to 
their corresponding Exchange mailboxes.

To stop importing users from a text file
• To return the wizard to the specification page, select Stop search and refine criteria.
• To stop the import, select Stop search and process users. The configuration page appears with 

only those users that were imported up to that point.

Final System Configuration
The Final System Configuration Wizard allows you to configure the email notification system. You can use 
the wizard to create default users and operators, and default mailboxes. Run the wizard also to specify 
dialing rules and location.

Configuring UC Server Presence and Control
If you installed the UC Server SIP Edition, then you were prompted whether to install the UC Server 
Presence Components, which are required to run the optional ucCompanion - Live Attendant application. 
If you installed the UC Server Presence Components then there are some final configuration steps which 
must be performed once you have completed the Server Configuration Wizard, in order to run the 
ucCompanion - Live Attendant application. For instructions on configuring the UC Server Presence 
Components refer to the NetVanta Unified Communications Server Presence and Control Components 
Guide, available from the installation CD, or at http://kb.adtran.com.

If you misspell, or omit, any of the required headers in the tab-separated file, the check 
boxes noted above are unavailable and users can only be imported as local users.

If you are importing a large number of users, the process takes some time, and a progress 
page shows you how many users have been found so far.
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The information in this appendix is intended as reference material for the network administrator.

Before the installer arrives at your site, ensure that the required files for the configuration have already 
been installed on the UC Server computer. 

The following sections describe the manual procedures for some tasks that are typically performed 
automatically by the UC Server Configuration Wizard. These procedures may be required to be performed 
manually, since there may be some information about your network and hardware that the wizard cannot 
determine automatically. The procedures are described below in case some manual configuration is 
required.

• Configuring the UC Server User Account on page 27
• Configuring the Exchange Server Account and Permissions on page 28

Configuring the UC Server User Account
The Server Configuration Wizard typically creates a new user account on the computer network for UC 
Server. If this was not done automatically, then follow the steps below to create the account manually.

To manually create a user account for UC Server on the local machine (UC Server is not 
part of a domain)

1. Right-click My Computer on the desktop.

2. Select Manage.

3. Select Local Users and Groups.

4. Right-click Users.

5. Select New User.

6. In the New User dialog, enter the required user account information. 
The User name can be “UC Server” or a name that you choose.

7. Select Create.

To manually create a user account for UC Server in Active Directory (UC Server is part of a 
domain)

1. Select Start > Programs > Administrative Tools > Active Directory Users and Computers.

2. In the left pane, select Users > Action > New > User.

It is only necessary to follow the manual procedures below if the Server Configuration 
Wizard failed to do so automatically, or if you chose to do so manually in order to implement 
a custom configuration. For more information on some situations where manual 
configuration may be required, refer to Polycom Phone Configuration Requirements on 
page 13.
619510001-29A Copyright © 2009 ADTRAN, Inc. 27



 Manually Configuring Accounts and Permissions Enterprise/Business Servers
3. In the New User dialog box, enter the required user account information. 
The Logon Name can be “UC Server” or a name that you choose.

4. Select Next.

5. Enter the user password information, and select Next.

6. If you have Exchange on the computer, enable Create an Exchange Mailbox.

7. Select Next, and then select Finish.

Configuring the Exchange Server Account and Permissions
The UC Server user account provides a separate security context that does not require administrative 
permissions on the local computer or in the Domain Administrators Active Directory group. 

The UC Server account’s administrative privileges are limited to Microsoft Exchange Server mailboxes. 
The account must access Exchange user mailboxes in an administrative capacity because it uses them to 
store and retrieve messages.

Follow the relevant instructions below for configuring Exchange Server 2007, or configuring Exchange 
Server 2003/2000.

• Configuring Exchange Server 2007 on page 28
• Configuring Exchange Server 2003/2000 on page 29

Configuring Exchange Server 2007
To create a mailbox logon to the Exchange Server 2007 console with a Windows account 
with Recipient Permissions

1. Select Start > Program > Exchange Server 2007 > Exchange Management Console. 

2. Navigate to Microsoft Exchange > Recipient Configuration. 

3. Right select on Mailbox and select New Mailbox. 

4. Select User Mailbox and select Next. 

5. Select New user and select Next. 

6. Enter the information for the new user, enable the option User must change password at next logon, 
and select Next.

7. Select Next again, and select New.

To integrate with Exchange Server 2007, A Microsoft Exchange Server MAPI client be 
installed on the UC Server platform to permit connection. We recommend using Microsoft 
Exchange Server MAPI Client and Collaboration Data Objects 1.2. Microsoft Outlook 2007 
SP2 is not supported.
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To grant permissions to the Exchange Server 2007 message store from UC Server
• Type the following script replacing <SERVICE_ACCOUNT> with the Service Account name:
Get-MailboxServer | Add-ADPermission -User <SERVICE_ACCOUNT> -AccessRights 
GenericRead, GenericWrite -ExtendedRights Send-As, Receive-As, ms-Exch-Store-Admin

Configuring Exchange Server 2003/2000

To create an Exchange mailbox for an existing account on Exchange Server 2003/2000

1. Select Start > Programs > Administrative Tools > Active Directory Users and Computers.

2. In the left pane, select Domain and select the Users folder.

3. In the right pane, right-click the UC Server account.

4. Select Exchange Tasks to start the Exchange Tasks Wizard.

5. From the list of tasks, select Create Mailbox.

6. Select Next, and then select Finish.

To manually set rights and privileges on Exchange Server 2003/2000 

1. Select Start > Programs > Microsoft Exchange > System Manager.

2. In the left pane of the Exchange System Manager window, select the Exchange Server that you want 
to integrate with.

3. Select Action > Properties to open the Exchange Server Properties dialog box.

4. Select the Security tab, and select Add to open the Select Users, Computer or Groups dialog box.

5. From the Look In list box, select each of the following:
• the Domain name
• the UC Server account name

6. Select Add, and then select OK.

7. From the Permissions: Allow Deny list box, select Full control for the account that was just added.

8. Make sure that Allow inheritable permissions from parent to propagate to this object is enabled.

9. Select OK and then close the Exchange System Manager window.

The Exchange Role of “Server Data Permissions” is required when running the Server 
Configuration Wizard, in order to grant permissions to the Exchange Server 2007 message 
store from UC Server. If you do not have access to a Windows account with “Server Data 
Permissions,” then an Exchange Server Administrator must run the following script on the 
Exchange Server.
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This appendix describes the steps to manually configure the system to allow for Polycom SIP telephones to 
retrieve their configuration information. You must only manually enable support for a line of telephones if 
the Server Configuration Wizard was unable to do so. You will receive a warning from the Phone Types 
Wizard if this is the case. Typically, the wizard would be unable to automatically enable support for a line 
of telephones if UC Server is installed on a domain controller. If this is the case, then you must manually 
enable support for SIP telephones following the instructions in each section listed below. For more 
information refer to Phone Types on page 16.

• Creating Polycom SIP Telephone User Accounts for FTP Access on page 31
• Providing Access for Polycom SIP Telephone User Accounts to the FTP Server on page 33
• Enabling Support for Polycom Telephones on page 35

Creating Polycom SIP Telephone User Accounts for FTP Access
When Polycom SIP phones attempt to retrieve their configuration from the FTP server, they must first log 
in. Most SIP telephones have a default user name and password for this purpose, and so if the telephones 
are to be provisioned through an FTP server then it must be configured to allow access for these telephone 
user accounts. 

The following procedures describe how to set up the telephone user account using Windows XP Pro SP2 
and Windows 2003 Server. The procedures describe how to create a user account on a machine running UC 
Server, that is not part of an Active Directory domain, or that is part of an Active Directory domain. Follow 
the procedure that is applicable for your particular configuration.

To disable the password complexity policy in SBS 2008

1. Select Start > Administrative Tools > Group Policy Management.

2. Select Forest > Domains > and select your domain.

3. Select Default Domain Policy.

4. In the right pane select the Settings tab.

5. Select Security Settings.

The following steps are only required if the Server Configuration Wizard was unable to 
automatically enable support for SIP telephones using the Phone Types Wizard.

Typically, telephones have a default password. If this password does not meet the complexity 
requirements of the domain, such as the Polycom password “PlcmSpIp” then you must 
disable the requirements before the account is created. You can also manually program the 
password on each handset. Refer to the NetVanta Enterprise Communications and 
Business Application Servers Planning and Deployment Guide, for more information on 
disabling password complexity requirements.
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6. In the right pane, right-click and select Edit.
The Group Policy Management Editor dialog opens.

7. In the left pane select Computer Configuration > Policies > Windows Settings > Security Settings 
> Accounts Policies > Password Policy.

8. In the right pane double-click on Password must meet complexity requirements.

9. Select Disabled.

10. Select Apply, and then select OK.

To force the domain policies to update immediately

1. Open a command prompt. 

2. Enter the following text.
GPUPDATE

To create a user account on the local machine (UC Server is not part of a domain)

1. Right-click My Computer on the desktop.

2. Select Manage.

3. Select Local Users and Groups.

4. Right-click Users.

5. Select New User.

6. Type the following information in the New User dialog:
• User name—for example, PlcmSpIp, which is the Polycom user name
• Full name—for example, Polycom Phone Account
• Description—for example: This account is used by the Polycom phones.
• Password—for example, PlcmSpIp
• Confirm password—retype the password
• User must change password at next logon—Off
• User cannot change password—On
• Password never expires—On
• Account is disabled—Off

7. Select Create.

To create a user account in Active Directory (UC Server is part of a domain)

1. Select Start > Programs > Administrative Tools > Active Directory Users and Computers.
The instructions may differ slightly depending on the operating system you are running.

It may take some time for policies on a domain controller to update. Generally this may take 
a few minutes, but the larger the domain, the longer it will take for the policies to update. 
Follow the steps below if you want the policies to update immediately.
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2. In the left plane, select the Users folder.

3. Right-click and select New > User.
If you do not have the required permissions, the New option will not be available.

4. Type the following information in the New User dialog:
• First name—for example, Polycom
• Full name—for example, Polycom Phone Account
• User logon name—for example, PlcmSplp, which is the default Polycom user name.
• Select Next.
• Type in the password—for example, PlcmSplp
• User must change password at next logon—Off
• User cannot change password—On
• Password never expires—On
• Account is disabled—Off
• Create an Exchange mailbox—Off
If you have an Exchange Server, it is not necessary to create an Exchange mailbox.

5. Select Finish.

Providing Access for Polycom SIP Telephone User Accounts to the 
FTP Server
Telephone accounts permissions to the FTP server are typically automatically configured by the Server 
Configuration Wizard. If you did not configure the accounts permissions when you ran the wizard, or were 
unable to do so due to restrictions, then you must do so manually by following the procedures in this 
section.

To allow permission for telephone accounts to read/write files on the FTP server, you must:

• Change the properties of the FTP server to allow read/write access.
• Give permissions to the Polycom SIP telephone user account to access the files in the FTP server.
• Give permissions to the UC Server Service account to access the files in the FTP server.

To configure read/write access to the FTP server

1. Select Windows Start > Settings > Control Panel.

2. Double-click the Administrative Tools icon.

3. Open the Internet Information Services > expand computer > Default FTP site.

For Windows Small Business Server (SBS) 2008 and Windows Server 2008, select IIS 6.0 
Manager.
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4. Right-click the site object associated with the Default FTP Site.

5. Select Properties.

6. Select the Home Directory tab.

7. Make sure that the Read and Write options are enabled.

8. Select OK.

To give permissions to the FTP server for the Polycom SIP telephone user account

1. Using Windows Explorer, navigate to the FTP root folder.
Typically, the FTP root folder location is: C:\Inetpub\ftproot.

2. Right-click the folder and select Properties.

3. Select the Security tab.

4. Select the Add button.

5. In the Enter the object names to select box, type the name of the SIP telephone user account, and 
select OK.

6. From the list of groups and users, select the telephone account.

7. In the Permissions settings list box, make sure that Allow is enabled for the following:
• Modify
• Read & Execute
• List Folder Contents
• Read
• Write

8. Select OK.

9. Select Advanced.

10. Enable the Replace permission entries on all child objects with entries shown here that apply to 
child objects box, and select OK to update the permissions.

11. Select OK.

You can locate this file on the left of the screen, below the server, under FTP sites.

If you are using SBS 2008 then you do not need to complete steps 9 and 10.
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To give permissions to the FTP server for the UC Server Service account

1. Using Windows Explorer, navigate to the FTP root folder.
Typically, the FTP root folder location is: C:\Inetpub\ftproot.

2. Right-click the ftproot folder and select Properties.

3. Select the Security tab. 

4. Select the Add button.

5. In the Enter the object names to select box, type the name of the UC Server Service account, and 
select OK.

6. From the list of Group or user names, select the UC Server Service account.

7. In the Permissions list box, check Full Control, and select Advanced.

8. Enable Replace permission entries on all child objects with entries shown here that apply to 
child objects, and select OK to update the permissions.

9. Select OK.

Enabling Support for Polycom Telephones
Once the FTP server has been configured, it is necessary to enable support for Polycom telephones that use 
the FTP server for provisioning. This process allows UC Server to automatically detect, configure, and 
reload a particular line of Polycom SIP telephone configurations.

Step 1: Modify settings in attributes.xml

1. Using Windows Explorer, navigate to \ADTRAN\NetVanta UC Server\Data\System\PhoneTypes.

2. Open the folder for the line of telephones for which you would like to enable support, for example, 
Polycom.

3. Edit the file attributes.xml, and modify the following elements:
a enabled - Change this value from 0 to 1, for example:

<enabled>1</enabled>
b serverLocation - Add the fully qualified or UNC path to the FTP server folder, typically, 

C:\inetpub\ftproot. For example,
<serverLocation>c:\inetpub\ftproot</serverLocation>

4. Save and close the file.

Step 2: Restart the application services
Once the attributes.xml file has been updated as per the previous step, restart the UC Server 
Application Services.

If you are using SBS 2008 or Server 2008 then select the Edit button.
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1. Select Start > Programs > Administrative Tools > Services.

2. Right-click NetVanta UC Server Application Services, and select Restart. 

Until this service finishes restarting, all UC Server application services are temporarily 
unavailable.

You can apply special site-specific configurations to the system and per-phone configuration 
files. Refer to the technical note TN046 - Customizing the SIP Telephone Configuration 
Files, available at http://kb.adtran.com. Refer to the Polycom telephone manufacturer’s 
documentation for information about how to configure these files.
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