2 Replies Latest reply on Nov 24, 2014 4:17 PM by gregbailey

    IPv6 over T1 (HDLC) using NetVanta 3430

    gregbailey New Member

      Our ISP routes our IPv4 class C over our T1 circuit with HDLC encapsulation.  Recently ISP was asked to route, in addition, our newly acquired IPv6 /48 and claims to have finished the job.  Ha.  This led to my reading the "Configuring IPv6 in AOS" document wherein I found that all they had done was to address an unused (and admin downed) Ethernet interface:  eth 0/2 2620:7B:4000::1/48


      I went ahead and cabled that Ethernet interface to our LAN and administratively enabled it.  The other systems on the LAN can now see the 3430 via neighbor discovery and it is in fact advertising that net and address, and advertising itself by ND as a router, on the LAN.


      However the ISP had apparently done nothing to enable moving IPv6 over the T1 circuit.  My other systems think the 3430 is the default router for ::/0 but when they send it a packet trace shows the 3430 is in a loop (repeated traces at its LAN address as shown above.)


      The ISP told me it was unnecessary to provide a subnet for the point to point HDLC link so I tried doing what page 17 of the aforementioned document implied I should do (by analogy to PPP):


      Configuring from terminal, memory, or network? [terminal]
      ATHPR-908CHEYE-WY-I(config)#ipv6 unicast-routing

      ATHPR-908CHEYE-WY-I(config)#ipv6 route ::/0 hdlc 1
      % Invalid input detected at '^' marker.

      ATHPR-908CHEYE-WY-I(config)#ipv6 route ::/0 t1 1/1
      % Invalid input detected at '^' marker.


      Not very pleasing.  Previously I had tried enabling IPv6 over the T1 circuit with no luck:


      ATHPR-908CHEYE-WY-I(config)#interface hdlc 1

      ATHPR-908CHEYE-WY-I(config-hdlc 1)#ipv6

      % Invalid or incomplete command

      ATHPR-908CHEYE-WY-I(config-hdlc 1)#ipv6 address autoconfig

      % Unrecognized command

      ATHPR-908CHEYE-WY-I(config-hdlc 1)#exit

      ATHPR-908CHEYE-WY-I(config)#interface t1 1/1

      ATHPR-908CHEYE-WY-I(config-t1 1/1)#ipv6

      % Invalid or incomplete command

      ATHPR-908CHEYE-WY-I(config-t1 1/1)#ipv6 address autoconfig

      % Unrecognized command


      What am I overlooking???  ... Thanks in advance!