7 Replies Latest reply on Apr 7, 2017 8:18 AM by jayh

    Adtran 904 config issues

    norm New Member

      I have an off net customer for which I had to build a firewall in the 904, we keep all our devices on private internal statics so I don't do the firewalls. I did a down load of the test box I built before the customer roll out, I defaulted the adtran and tried a reload using the config I download from the Adtran. I boot stops at 4% of the config, I have looked it over and dont see the issue. Any help will be appreciated.

        • Re: Adtran 904 config issues
          jayh Hall_of_Fame

          I think there is something else going on. The configuration doesn't load until after bootup, and if there are errors in the configuration then they'll show on the console. A bad configuration should not prevent the unit from booting up.

           

          It sounds as if the software image in flash or flash itself is corrupt.

           

          Try the following:

           

          Power-cycle the box and hit the ESCAPE key immediately when you see console output. This should get you to a bootstrap# prompt.

           

          Type the following:

           

          bypass config

           

          <enter>

           

          boot

           

          <enter>

           

          This will cause the unit to boot without reading the configuration. If it finishes the boot sequence then you can paste in the configuration one line at a time looking for errors. My hunch is that it won't boot even with the configuration bypassed. You'll probably have to re-flash it from bootstrap according to this document https://supportforums.adtran.com/docs/DOC-1672 starting at the middle of page 27. Grab the latest firmware for your unit from the Adtran website. You say this is a 904, there are two generations, Gen. 1 and Gen. 2. Make sure that you are loading the correct firmware for your hardware. Gen. 1 is part number 4210904L1 and Gen. 2 is 4212904L1.

           

          I took a cursory look at your configuration and didn't see anything glaringly wrong but hanging during boot isn't likely to be a configuration problem.

            • Re: Adtran 904 config issues
              norm New Member

              As always Thanks Jayh, I did bootstrap the box a couple of times before I started this discussion. It locked up at the 4% mark of the config process each time but would boot to a non firewall version no problem. I just can see any issues in the config file. I will try a new config. Thanks again.

                • Re: Adtran 904 config issues
                  jayh Hall_of_Fame

                  Will it boot if you bypass config from bootstrap? The behavior you describe doesn't add up. Bad configuration shouldn't prevent booting.

                   

                  Edit: Is it actually failing to boot or do you just lose connectivity on a web/telnet/ssh session? It could be booting just fine but a firewall rule is preventing you from seeing it. Are you still connected on console? Is there an exception report generated?

                    • Re: Adtran 904 config issues
                      norm New Member

                      Yes, the odd part is it boots just fine with Bypass, I had to do it 3 times in the last few days. and it loads jus fine with the orignial config, just not with this modified config.

                        • Re: Adtran 904 config issues
                          jayh Hall_of_Fame

                          I was editing my previous reply when you replied.

                           

                          Is it actually failing to boot or do you just lose connectivity on a web/telnet/ssh session? It could be booting just fine but a firewall rule is preventing you from seeing it. Are you still able to connect on console? Is there an exception report generated?

                            • Re: Adtran 904 config issues
                              norm New Member

                              No, I hyper terminal into the box during boot and watch the process, that is where I see the 4% lock up and the box stops responding. I the have to  power cycle to boot strap in hyper treminal.

                                • Re: Adtran 904 config issues
                                  jayh Hall_of_Fame

                                  Could there be a "boot system" command in the configuration that references a file that doesn't exist in flash or isn't correct for the hardware? I didn't see one in the copy/paste you posted. "show system" and compare the image listed to what is in flash.

                                   

                                  That's about the only thing I can think of in a configuration that would keep it from booting. If that isn't it, probably time to open a case with Adtran.