4 Replies Latest reply on Feb 17, 2012 6:00 AM by johnevans

    Incorrect DHCP to wireless VAP's

    johnevans New Member

      Customer has a Netvanta 3448 with eight NV 150's connected to the switchports. They want to provide two SSID's, one called Corporate_wifi for Corporate users to access the corporate lan as well as the Internet, the other SSID called Guest_wifi is to provide Guests access to the Internet only.  The inetrnet is available through ethernet 0/1 IP Address 10.10.10.1/24.  The corporate lan is on ethernet 0/2  IP Address 172.16.0.1/16. Valn 1 is not shutdown, but has no ip address.  Vlan 2 has IP Address 192.168.1.1/24.  The 3448 has a DHCP Server pool for the Guest users delivering 192.168.1.0/24 with Default gateway 192.168.1.1, excluded addresses 192.168.1.1-192.168.1.10.  There is a DHCP server on the corporate Lan at 172.16.1.33  to provide corporate wireless users a dhcp address.   AWCP is enabled  and sees the NV150's as being controlled by the 3448. On switchport 0/1  an IP address 192.168.1.2 is sent to the unit and it is up and running.

       

      interface dot11ap 1 ap-type nv150

        access-point mac-address 00:A0:C8:xx:xx:xx

        name Corporate_AP1

        encapsulation 802.1q awcp-vlan 1 native priority 7

        event-history on

        event-history priority 6

      !

      !

      interface dot11ap 1/1 radio-type 802.11bg

        no shutdown

      !

      !

      interface dot11ap 1/1.1

        description Wiz_802.11BG_VAP

        ssid broadcast-mode "Corporate_wifi_

        client-separation

        security mode wpa tkip aes-ccmp psk xxxxxxxxxx

        no shutdown

      !

      interface dot11ap 1/1.2

        description Guest_wifi

        vlan-id 2

        ssid broadcast-mode "Guest_wifi"

        client-separation

        security mode none

        no shutdown

       

      Now the problem is when a PC connects wirelessly they can connect to SSID Corporate_wifi  just fine and get to the Internet, but they get an address 192.168.1.x,  I have not configured bridging between the switchports and the ethernet0/2 so it can't get an address 172.16.x.x yet but i didn't think it would get an address from the Guest_wifi pool 192.168.1.x.  Then when we try connecting to the SSID Guest_wifi it looks like it is trying to connect, but never gets an address. We have int dot11ap 1/1.2 configured with the Vlan-id 2 command and believe it should be assigned an address from the 192.168.1.x range.

       

      Can anyone help?

      Thank you,

      John Evans

        • Re: Incorrect DHCP to wireless VAP's
          Employee

          John,

           

          I'd be more than happy to help you. Could you provide the current configuration of the NetVanta 3448? Please be sure to remove any IP addresses and/or passwords that may be sensitive to your company.

           

          Thanks,

          Noor

           

          Message was edited by: Noor Ahmad

            • Re: Incorrect DHCP to wireless VAP's
              johnevans New Member

              Here is the config you requested.

               

              Thanks for your help.

              John

                • Re: Incorrect DHCP to wireless VAP's
                  Employee

                  John,

                   

                  Based on the configuration, your NetVanta 150 should be plugged into switchport 0/1 of the NetVanta 3448 since it is set as an access port for vlan 2. The rest of the switchports on the NetVanta 3448 are set as access ports for vlan 1. If you need to pass more than one vlan through the NetVanta 150, then the switchport and virtual access point should be set as a trunk. The configuration shows an example of this. In the case below, the native vlan is set to 1, while both vlan 1 and 2 will be passed through the trunk link:

                   

                   

                  !

                  interface switchport 0/1

                    spanning-tree edgeport

                    no shutdown

                    switchport mode trunk

                  !

                  interface dot11ap 1 ap-type nv150

                    access-point mac-address 00:A0:C8:69:3F:58

                    name _AP1

                    encapsulation 802.1q awcp-vlan 1 native priority 7

                    event-history on

                    event-history priority 6

                  !

                  !

                  interface dot11ap 1/1 radio-type 802.11bg

                    no shutdown

                  !

                  interface dot11ap 1/1.1

                    description Wiz_802.11BG_VAP

                    ssid broadcast-mode "xxxxxxxxxx"

                    client-separation

                    security mode wpa tkip aes-ccmp psk xxxxxxxx

                    no shutdown

                  !

                  interface dot11ap 1/1.2

                    description Guest_Wireless

                    vlan-id 2

                    ssid broadcast-mode "xxxxxxxxx_Guest"

                    client-separation

                    security mode none

                    no shutdown

                  !

                   

                  Let us know if you are still having issues or have any further questions. Please be sure to include the most recent config, if any changes have been made, and also please note which port the NetVanta 150 is plugged into.

                   

                  Thanks,

                  Noor