7 Replies Latest reply on Apr 4, 2012 1:22 PM by kennethfernandes

    Unable to reach n capable speeds

    tomd New Member

      My setup consists of Primary and secondary vWLAN controllers residing on a VMware environment. Three APs, type and firmware versions are:

      vWLAN firmware: 2.1.0.14

      AP's: w-bsap1840_1800v2-6.5.3-23_

       

      We have around 70 people concurrently connected to both the g/n radio and the a/n radios. Even though when at home using the same Macbook pro as i do with the Bluesocket setup i am able to reach wireless speeds of up to 18MB/s, i'm only able to reach a maximum of 3MB/s when connection to the Bluesocket vWLAN and its APs.

      One obvious difference is that what i'm at home using my Apple wireless base station i am seeing a transfer rate of 270. When connecting to the Bluesocket the maximum i reach is 130. From what i read that suggests i'm connected to the 'n' radio but at 2.4 MHz instead of the 5 MHz. I'm not sure if that translates to the Bluesocket environment.

       

      This problem is logged with my supplier and has been escalated to Bluesocket so i will update this as and when i make progress, and of course even better if there is a solution someone knows of

        • Re: Unable to reach n capable speeds
          kennethfernandes Employee

          The first thing that you must consider is that wireless is a shared medium. The more users connected to the radio, the less bandwidth available for each user. The next thing to consider is that while max data rate is 300 Mbps, actual throughput, in a best case scenario, is probably about half that. Now remember that all the clients that are connected to the radio are sharing that bandwidth. If you consider you have 70 connections on the AP assuming half are on each radio, 35 users are sharing 150 Mbps. That is a little over 4mbps per user. Nearby access points on the same or adjacent channels and legacy clients connected at low data rates could also drive those numbers down even further. Dynamic RF is going to pick the best channel but if you are in a city environment for example that best channel might still be congested. We have airtime fairness algorithms that help with the legacy clients but they are still going to reduce the overall throughput of the cell.

           

          Now in regards to you connecting at 130 Mbps vs 300 Mbps. You are likely connecting to the 2.4 GHz radio when you are connecting at 130 Mbps and the 5 GHz radio when you are connecting at 300 Mbps. An 802.11N feature called channel bonding or 40 MHz channel mode is disabled on the 2.4 GHz radio so max data rate on the 2.4 GHz radio is 130 Mbps. Although channel bonding can be enabled on the 2.4 GHz radio it is highly un-recommended. This is because there are only 3 non-overlapping channels on the 2.4 GHz spectrum. Bonding 2 Channels together when there are only 3 non-overlapping channels available could result in significant adjacent or co-channel interference. Now if max data rate is only 130 Mbps on the 2.4 GHz radio, and actual throughput is about half that, considering our example above with 35 clients on the radio, that’s about 2 Mbps per user. You must also consider that the 5 GHz spectrum is much “cleaner” than the 2.4 GHz spectrum. This is because there are many SOHO devices operating on the 2.4 GHz spectrum and also many non-802.11 interferers that run on that frequency as well such as cordless phones, baby monitors, wireless door chimes, microwaves, etc.

           

          So with all that said. Here are some things you could try to get some additional throughput/better results:

           

          -Try testing on the 5 GHz radio with a 300 Mbps data rate and a cleaner spectrum.

          -Try testing on an access point with less clients connected to it.

          -Try changing the channel.

          -Try enabling packet aggregation under your Wireless Template on each radio page. Packet aggregation is another 802.11N feature that provides a bit more throughput however it is disabled by default.

          -Try testing with a client server type tool such as iperf so that you can rule out the ISP.

          -Make sure there is no bandwidth throttling or negative bias configured in the user's role.

          -Make sure you are using an open system SSID or an SSID protected with WPA2/AES. SSIDs using TKIP and WEP are limited to legacy data rates.

          1 of 1 people found this helpful
            • Re: Unable to reach n capable speeds
              kennethfernandes Employee

              TomD

               

              I went ahead and marked this post as "assumed answered".  Feel free to mark any correct or helpful answers from this post.  If you still need assistance with this issue I would be more than happy to help, just let me know in a reply.

               

               

               

              Thanks,

               

              Ken

              • Re: Unable to reach n capable speeds
                tomd New Member

                Thanks for the reply kenneth, I've tried some of the points you have mentioned above and below are my results.

                 

                -Try testing on the 5 GHz radio with a 300 Mbps data rate and a cleaner spectrum.

                This is one of my stranger problems, in my vWLAN settings i have the ability to turn off either the b/g/n radio or the a/n, or of course leave them both on to work in tandem. Strangely when i disable the b/g/n radio i am unable to connect at all - almost as if the a/n radio is not active even though in the analysis pane it tells me that clients are connected via n.

                -Try testing on an access point with less clients connected to it.

                All my testing takes place with only my laptop connected to the AP, out of hours

                -Try enabling packet aggregation under your Wireless Template on each radio page. Packet aggregation is another 802.11N feature that provides a bit more throughput however it is disabled by default.

                Packet aggregation has made it possible to reach speeds close to 9MB/s, which although slower than i would hope would be sufficient considering i am in densely populated AP area. The problem with packet agg is that my AP's can't seem to 'handle' it. Once enabled, although i'm able to reach higher speeds the AP's periodically drop connection and turn red in the analysis pane.

                -Make sure there is no bandwidth throttling or negative bias configured in the user's role.

                Done, there are no limitations from roles or any other settings relating to bandwidth etc.

                -Make sure you are using an open system SSID or an SSID protected with WPA2/AES. SSIDs using TKIP and WEP are limited to legacy data rates.

                I have tried with all the possible auth settings, even with none set at all. My primary AP uses AES which had been suggested as being compatible with n

                  • Re: Unable to reach n capable speeds
                    tomd New Member

                    Also to add to the above, at no point have i been able to achieve a transfer rate above 130 which leads me to think that for some reason, as you mention i'm connecting via the 2.4 GHz radio

                    • Re: Unable to reach n capable speeds
                      kennethfernandes Employee

                       

                      This is one of my stranger problems, in my vWLAN settings i have the ability to turn off either the b/g/n radio or the a/n, or of course leave them both on to work in tandem. Strangely when i disable the b/g/n radio i am unable to connect at all - almost as if the a/n radio is not active even though in the analysis pane it tells me that clients are connected via n.


                       

                      You can disable the 2.4GHz radio under the wireless template(wireless>template) or the individual AP (wireless>AP) for testing purposes. Click the 802.11b/g/n tab and uncheck the box that says enable the radio. Then apply to the AP. Make sure you have the ssid configured on the 802.11a/n tab in the template or on the individual AP. Make sure you are configured to AP mode on the 802.11a/n tab in the template or on the individual AP. If you are still not able to connect then perhaps your client doesn't support the 5GHz a/n radio. N works on both the 2.4GHz b/g/n radio and the 5GHz a/n radio. You can see exactly what radio you are connected to under status>active connections>details>APs>click the binoculars on the appropriate AP to see details>where you will see associated clients to each radio.

                      Packet aggregation has made it possible to reach speeds close to 9MB/s, which although slower than i would hope would be sufficient considering i am in densely populated AP area. The problem with packet agg is that my AP's can't seem to 'handle' it. Once enabled, although i'm able to reach higher speeds the AP's periodically drop connection and turn red in the analysis pane.

                      Is that 9MBps or 9Mbps? Megabytes or megabits? To get Mbps from MBps multiply by 8. That would be 72Mbps unless you meant Mbps in the first place.

                    • Re: Unable to reach n capable speeds
                      tomd New Member

                      I've since spoke to my Bluesocket reseller who informs me we have a limitation in the UK which will stop me reaching anything above the 130 transmit rate. See below

                      You will not achieve higher than 130 transmit rate at present.  This is due to a regulatory restriction in the UK which the BlueSocket enforces a little more rigorously than some other vendors.  It’s linked to the use of 40Mhz bonded channels on 5Ghz,  you’ll see if you edit an AP that you cannot select 40Mhz on the a/n radio,  this is locked down once the ‘UK’ licence is added to the unit.

                      So does this also mean i'm limited to only achieving b/g 2.4 GHz speeds?