16 Replies Latest reply on Sep 27, 2012 9:19 AM by jessiebryan

    Wan to Lan throughput problem

    tpstech New Member

      I recently upgraded our WAN from a T1 to a 30mb broadband connection however the maximum download speed I can attain is 5mb.  When tested through another router I can attain the full 30mb.  I am using a very basic setup with one VPN connection, DHCP, a few Port mappings, and a guest LAN.  Any ideas what is slowing it down?  My upload speeds have full throughput at 3mb.

       

      Mike

       

      NetVanta 3120

      Firmware Ver. 17.08.01.00.E

        • Re: Wan to Lan throughput problem
          Employee

          Mike,

           

          Thank you for asking  your question Mike. I would suggest speaking to ADTRAN's Applications Engineers regarding what you are experiencing. They will be able to determine what kind of throughput you should expect based on your specific requirements. You can reach ADTRAN Applications Engineering by calling 888-423-8726 or sending an email to application.engineering@adtran.com .

           

          It also may be worth looking over your interface statistics to make sure you are not seeing any errors incrementing on your WAN or LAN interface. These can be viewed by issuing the "show interface" command. I would also be more than happy to review your configuration to see if anything stands out. Please remember to remove any information that may be sensitive to your network.

           

          Let us know if you have any questions.

           

          Thanks,

          Noor

            • Re: Wan to Lan throughput problem
              Employee

              Mike,

               

              I don't see anything out of the ordinary in your configuration. I see that you have turned on FFE, which should help with the throughput as this allows the 3120 to more efficiently process packets. Could you post the output to "show interface" as well? I would be curious to see what the interface statistics look like.

               

              As far as the firmware discrepancy goes, I think you may be viewing the firmware from a previously loaded config file of the 3120. The output to "show version" in the CLI should accurately state which firmware the 3120 is on. Try comparing that with what you are seeing in the "System Summary" page of the web interface. If the AOS versions don't match up there, please let us know.

               

              Thanks,

              Noor

                • Re: Wan to Lan throughput problem
                  tpstech New Member

                  Noor,

                   

                  Thanks for the reply.  show version in the CLI is correct.  Here are the 'show interface' results you requested.  Something has to be wrong somewhere in my config.  This router should be capable of 32mbps up/down simoultaneously.  I can't seem to do better than 5mbps.  That can't be right.

                   

                  NetVanta3120>show interface

                  Displaying interfaces...

                   

                   

                  modem 0/1 is admin down

                    Caller ID will be used to route incoming calls

                    Caller ID normal

                    Allow ring events

                    Last clearing of "show interface" counters: never

                    5 minute input rate 0 bits/sec, 0 packets/sec

                    5 minute output rate 0 bits/sec, 0 packets/sec

                      80 packets input, 80 bytes, 0 no buffer

                      0 runts, 0 giants, 0 throttles

                      0 input errors, 0 CRC, 0 frame

                      0 abort, 0 discards, 0 overruns

                      7 packets output, 51 bytes, 0 underruns

                   

                   

                  ppp 1 is administratively down

                    Configuration:

                      Keep-alive is set (10 sec.)

                      No multilink

                        MTU = 1500

                      No authentication

                      Neither bridge nor IP is configured

                    Last clearing of "show interface" counters: never

                    No links created for this PPP interface

                    Bundle information

                      Queueing method: weighted fair

                      HDLC tx ring limit: 0

                      Output queue: 0/0/684/64/0 (size/highest/max total/threshold/drops)

                        Conversations  0/0/256 (active/max active/max total)

                        Available Bandwidth 0 kilobits/sec

                   

                   

                  eth 0/1 is UP, line protocol is UP

                    Description: WAN

                    Hardware address is 00:00:00:00:00:00

                    Ip address is 111.111.111.111, netmask is 255.255.255.248

                    MTU is 1500 bytes,  BW is 100000 Kbit

                    100Mb/s, full-duplex

                    ARP type: ARPA; ARP timeout is 20 minutes

                    Last clearing of "show interface" counters: never

                    5 minute input rate 297616 bits/sec, 38 packets/sec

                    5 minute output rate 38920 bits/sec, 28 packets/sec

                      Queueing method

                          Configured Queueing Method: fifo

                          Effective  Queueing Method: weighted fair

                      Output queue: 0/1/684/64/0 (size/highest/max total/threshold/drops)

                        Conversations  0/1/256 (active/max active/max total)

                        Available Bandwidth 74200 kilobits/sec

                      Interface Shaper: NOT ENABLED

                   

                   

                  2012.05.03 14:01:33 FIREWALL id=firewall time="2012-05-03 14:01:33" fw=NetVanta3

                  120 pri=1 rule=7  proto=http src=192.168.100.109 dst=111.111.111.111 msg="Zero by

                  tes transferred for connection Src 49426 Dst 80 from Private policy-class on int

                  erface vlan 1" agent=AdFirewall     7245657 packets input, 1580277014 bytes

                      7235522 unicasts, 10128 broadcasts, 7 multicasts input

                      0 unknown protocol, 0 symbol errors, 0 discards

                      0 input errors, 9907 runts, 0 giants

                      0 no buffer, 0 overruns, 0 internal receive errors

                      0 alignment errors, 102543 crc errors

                      5668390 packets output, 1167107532 bytes

                      5667381 unicasts, 950 broadcasts, 0 multicasts output

                      0 output errors, 0 deferred, 0 discards

                      0 single, 0 multiple, 0 late collisions

                      0 excessive collisions, 0 underruns

                      0 internal transmit errors, 0 carrier sense errors

                      0 resets, 7 throttles

                   

                   

                  swx 0/1 is UP, line protocol is UP

                    Hardware address is 00:00:00:00:00:00

                    100Mb/s, negotiated full-duplex, configured full-duplex

                    input flow control is disabled, 0 pause frames received

                    ARP type: ARPA; ARP timeout is 20 minutes

                    Last clearing of "show interface" counters: never

                    5 minute input rate 45872 bits/sec, 34 packets/sec

                    5 minute output rate 299736 bits/sec, 40 packets/sec

                      Queueing method: fifo

                      Output queue: 0/256/0 (size/max total/drops)

                      Interface Shaper: NOT ENABLED

                      6744803 packets input, 1277754309 bytes

                      6015061 unicasts, 364399 broadcasts, 365343 multicasts input

                      0 symbol errors, 0 discards

                      0 input errors, 0 runts, 0 giants

                      0 alignment errors, 0 crc errors

                      7965606 packets output, 1613998911 bytes

                      7597293 unicasts, 94162 broadcasts, 274151 multicasts output

                      0 output errors, 0 deferred, 0 discards

                      0 single, 0 multiple, 0 late collisions

                      0 excessive collisions

                   

                   

                  swx 0/2 is UP, line protocol is UP

                    Hardware address is 00:00:00:00:00:00

                    100Mb/s, negotiated full-duplex, configured full-duplex

                    input flow control is disabled, 0 pause frames received

                    ARP type: ARPA; ARP timeout is 20 minutes

                    Last clearing of "show interface" counters: never

                    5 minute input rate 0 bits/sec, 0 packets/sec

                    5 minute output rate 5288 bits/sec, 5 packets/sec

                      Queueing method: fifo

                      Output queue: 0/256/0 (size/max total/drops)

                      Interface Shaper: NOT ENABLED

                      0 packets input, 0 bytes

                      0 unicasts, 0 broadcasts, 0 multicasts input

                      0 symbol errors, 0 discards

                      0 input errors, 0 runts, 0 giants

                      0 alignment errors, 0 crc errors

                      1097162 packets output, 117773424 bytes

                      84 unicasts, 457885 broadcasts, 639193 multicasts output

                      0 output errors, 0 deferred, 0 discards

                      0 single, 0 multiple, 0 late collisions

                      0 excessive collisions

                   

                   

                  swx 0/3 is UP, line protocol is UP

                    Hardware address is 00:00:00:00:00:00

                    100Mb/s, negotiated full-duplex, configured full-duplex

                    input flow control is disabled, 0 pause frames received

                    ARP type: ARPA; ARP timeout is 20 minutes

                    Last clearing of "show interface" counters: never

                    5 minute input rate 264 bits/sec, 0 packets/sec

                    5 minute output rate 6488 bits/sec, 5 packets/sec

                      Queueing method: fifo

                      Output queue: 0/256/0 (size/max total/drops)

                      Interface Shaper: NOT ENABLED

                      289826 packets input, 74159789 bytes

                      198284 unicasts, 89707 broadcasts, 1835 multicasts input

                      0 symbol errors, 0 discards

                      0 input errors, 0 runts, 0 giants

                      0 alignment errors, 0 crc errors

                      1203356 packets output, 180429629 bytes

                      197186 unicasts, 368576 broadcasts, 637594 multicasts output

                      0 output errors, 0 deferred, 0 discards

                      0 single, 0 multiple, 0 late collisions

                      0 excessive collisions

                   

                   

                  swx 0/4 is DOWN, line protocol is DOWN

                    Hardware address is 00:00:00:00:00:00

                    ?b/s, negotiated ? duplex, configured full-duplex

                    input flow control is disabled, 0 pause frames received

                    ARP type: ARPA; ARP timeout is 20 minutes

                    Last clearing of "show interface" counters: never

                    5 minute input rate 0 bits/sec, 0 packets/sec

                    5 minute output rate 0 bits/sec, 0 packets/sec

                      Queueing method: fifo

                      Output queue: 0/256/0 (size/max total/drops)

                      Interface Shaper: NOT ENABLED

                      0 packets input, 0 bytes

                      0 unicasts, 0 broadcasts, 0 multicasts input

                      0 symbol errors, 0 discards

                      0 input errors, 0 runts, 0 giants

                      0 alignment errors, 0 crc errors

                      0 packets output, 0 bytes

                      0 unicasts, 0 broadcasts, 0 multicasts output

                      0 output errors, 0 deferred, 0 discards

                      0 single, 0 multiple, 0 late collisions

                      0 excessive collisions

                   

                   

                  vlan 1 is UP

                    Hardware address is 00:00:00:00:00:00

                    vlan 1 Ip address is 192.168.100.1, netmask is 255.255.255.0

                    MTU is 1500 bytes, BW is 100000 Kbit

                    ARP type: ARPA; ARP timeout is 20 minutes

                    Last clearing of "show interface" counters: 5d 21:49:53

                    5 minute input rate 42352 bits/sec, 31 packets/sec

                    5 minute output rate 301040 bits/sec, 39 packets/sec

                      6435138 packets input, 1240469707 bytes

                      5981332 unicasts, 453806 broadcasts, 0 multicasts input

                      7566987 packets output, 1634055832 bytes

                      7562507 unicasts, 4480 broadcasts, 0 multicasts output

                      0 discards

                   

                   

                  vlan 2 is admin down

                    Description: Guest Interface

                    Hardware address is 00:00:00:00:00:00

                    vlan 2 Ip address is 10.0.0.1, netmask is 255.255.255.0

                    MTU is 1500 bytes, BW is 100000 Kbit

                    ARP type: ARPA; ARP timeout is 20 minutes

                    Last clearing of "show interface" counters: 5d 21:49:53

                    5 minute input rate 0 bits/sec, 0 packets/sec

                    5 minute output rate 0 bits/sec, 0 packets/sec

                      0 packets input, 0 bytes

                      0 unicasts, 0 broadcasts, 0 multicasts input

                      0 packets output, 0 bytes

                      0 unicasts, 0 broadcasts, 0 multicasts output

                      0 discards

                    • Re: Wan to Lan throughput problem
                      cj! Beta_User

                      Hi Mike:

                       

                      I don't know, our experience has been the same.  For what it's worth, we have seen a pretty low throughput ceiling on the 3120.  We used to install the 3120 often, when it was common for small office/home offices (SOHO) to connect via DSL or something just a couple Mbps fast.  Current broadband speeds burst pretty high and I think you'll do much better with a 3400-series product.  Maybe noor will have an ace up her sleeve... 

                       

                      While you're waiting, you can't go wrong running this by an ADTRAN Applications Engineer (pre-sales support):  888-4-ADTRAN

                       

                      CJ

                        • Re: Wan to Lan throughput problem
                          tpstech New Member

                          CJ,

                           

                          Thanks for the reply.  That's not good to hear, but it really helps to know that you've had the same experience.  I'll be looking for another router with a more robust throughput then.

                           

                          Mike

                            • Re: Wan to Lan throughput problem
                              dakotatim New Member

                              Are the CRC errors incrementing on eth0/1 as this indicates a problem there.

                                0 no buffer, 0 overruns, 0 internal receive errors

                                  0 alignment errors, 102543 crc errors

                                  5668390 packets output, 1167107532 bytes

                              1 of 1 people found this helpful
                                • Re: Wan to Lan throughput problem
                                  Employee

                                  Based on what dakotatim is saying, if those CRC errors are incrementing, you will want to see if there is a duplex mismatch between the eth 0/1 interface and the interface it is plugging into. Our suggestion is that both interfaces either be set to auto-negotiate, or they be hard-set to the same speed and duplex. If you find a mismatch, then correcting this should improve throughput. You may also want to try switching out cables if you have not done so.

                                   

                                  However, I also agree with cj! 's comment that the 3120 may not be able to perform at the full 30mbps up/down throughput you are looking to attain. I agree that it would be a good idea for you to contact Adtran's Applications Engineers so they can verify this for you.

                                   

                                  Thanks,

                                  Noor

                                  • Re: Wan to Lan throughput problem
                                    tpstech New Member

                                    The CRC errors are incrementing.  I swapped out the patch cable to no avail.  I am running 100mb/Full duplex from the adtran.  I can't get access to the SMCD3GN2 cable modem that Charter provided.  I suspect that it is in bridged mode and I don't know how to access the config.  I've tried 192.168.0.1 and 1.1 but no luck. (while connected directly to it with a static IP in the same range)

                                     

                                    I tried setting the Adtran eth/01 interface to auto, but it keeps defaulting back to 100mb/full duplex even after a save and a reboot with save.

                                     

                                    Any suggestions?

                                     

                                    thanks for the help.

                                    • Re: Wan to Lan throughput problem
                                      tpstech New Member

                                      Wow, how weird is that.  I finally realized I was clicking 'save' but not 'apply'.  I switched the eth/01 interface to Auto and after applying, it still connected at 100mb/full duplex, but no more CRC errors and my download speeds jumped to 25mb.  Thanks for stickin with me and helping out on this one.  Much Appreciated!

                                       

                                      Mike

                                • Re: Wan to Lan throughput problem
                                  megasmithers New Member

                                  Hey TPS, noticed you got that firewall message in the middle.

                                   

                                  I've found that entering "no event" in the CLI will disable those messages from spamming you during that session alone. Log out, log back in, and you can monitor the events again.

                                   

                                  So if you ever need a clean capture (or just need stuff to NOT scroll off your PuTTY session on a misbehaving router), give that a try!

                            • Re: Wan to Lan throughput problem
                              bcrinehart Past_Featured_Member

                              This does not relate to your problem but I would like to know, what tool are you using to measure throughput?

                              • Re: Wan to Lan throughput problem
                                jessiebryan New Member

                                We did some testing awhile ago on the 3120 platform, WAN to LAN varied with NAT on/off, but we were seeing anywhere from 15-18mbs throughput.