2 Replies Latest reply on Jul 6, 2012 2:41 PM by geo

    No outbound SIP

    maverick New Member

      Hi Guys,

      New to the Adtran product and taking a look at my first box the 644 for some ISDN to SIP trunking options.

      At this stage all I am looking to do is to get SIP standing to my SIP Gateway which is a non register trunk, I am pushing this out Gig 0/2 and can ping my SIP gateway but am not seeing the SIP keep alives or any SIP at all when I have debug SIP stack messages enabled, It has to be a config issue and being new to the box hopefully someone can point me in the right direction to start off with and tell me what mistakes I have in the config , config below.

       

      I would have though that I should be seeing the SIP keep alives on the trunk based

       

       

      WXC_Adtran#show run

      Building configuration...

      !

      !

      ! ADTRAN, Inc. OS version A5.02.06.E

      ! Boot ROM version A5.01.B1

      ! Platform: NetVanta 644, part number 1700144G1

      ! Serial number 0123456

      !

      !

      hostname "WXC_Adtran"

      enable password password

      !

      clock timezone +12-Auckland

      !

      ip subnet-zero

      ip classless

      ip routing

      ip domain-proxy

      !

      !

      no auto-config

      !

      event-history on

      no logging forwarding

      no logging email

      !

      no service password-encryption

      !

      username "admin" password "password"

      !

      banner motd #

       

              Important

            

      Web username/password is configured to admin/password.

      Enable and Telnet passwords are configured to "password".

      Please change them immediately.

       

      The gigabit-ethernet 0/1 interface is enabled with an address of 10.10.10.1

      Telnet/SSH access is also enabled.

      #

      !

      no ip firewall alg msn

      no ip firewall alg mszone

      no ip firewall alg h323

      !     

      ip dhcp-server pool "Private"

        network 10.10.10.0 255.255.255.0

        netbios-node-type h-node

        default-router 10.10.10.1

      !

      no ethernet cfm

      !

      interface gigabit-eth 0/1

        description

        ip address  10.10.10.1  255.255.255.0

        shutdown

      !

      !

      interface gigabit-eth 0/2

        description WXC SIP

        ip address  192.168.15.64  255.255.255.0

        media-gateway ip primary

        no shutdown

      !

      interface e1 0/1

        description PRA 1

        timing-domain 1

        system-timing primary

        sa4tx-bit 0

        tdm-group 1 timeslots 1-31 speed 64

        shutdown

      !

      interface e1 0/2

        timing-domain 1

        sa4tx-bit 0

        shutdown

      !

      interface e1 0/3

        timing-domain 1

        sa4tx-bit 0

        shutdown

      !

      interface e1 0/4

        timing-domain 1

        sa4tx-bit 0

        shutdown

      !

      !

      interface pri 1

        description PRA 1

        alias PRA1

        isdn name-delivery setup

        connect e1 0/1 tdm-group 1

        role network b-channel-restarts enable

        shutdown

      !

      !

      !

      !

      !

      !

      !     

      no ip tftp server

      no ip tftp server overwrite

      ip http server

      ip http secure-server

      ip snmp agent

      no ip ftp server

      no ip scp server

      no ip sntp server

      !

      !

      snmp-server contact "Phillip Moore"

      snmp-server contact phone "+64 9 xxxxxx"

      snmp-server contact email "xxxxxxxx"

      snmp-server location "Auckland"

      !

      !

      !

      !

      ip sip

      ip sip udp 5060

      no ip sip tcp

      !

      voice feature-mode network

      voice transfer-mode local

      voice forward-mode local

      !

      voice callerId-type Australia_FSK

      voice dial-plan 0 local NXX-XXXX

      !

      voice codec-list "WxC Default"

        codec g711alaw

        codec g711ulaw

        codec g729

      !

      voice trunk T01 type sip

        description "WxC Direct Connect"

        sip-server primary 58.xxx.xxx.xxx

        no registrar require-expires

      sip-keep-alive options 60

        max-number-calls 120

        codec-group "WxC Default"

      !

       

      voice grouped-trunk WXC

        description "WXC Direct Connect"

        trunk T01

        accept NXX-XXXX cost 0

        reject 976-XXXX

      !

      ip sip privacy

      !

       

      ip sip inbound-trunk-matching prefer trunk-routing

      !

      ip rtp quality-monitoring

      ip rtp quality-monitoring udp

      ip rtp quality-monitoring sip

      ip rtp quality-monitoring history max-streams 500

      !

      line con 0

        no login

      !

      line telnet 0 4

        login

        password password

        no shutdown

      line ssh 0 4

        login local-userlist

        no shutdown

      !

      !

      ntp server 58.xxx.xxx.xxx version 3 prefer

      !

      end

      WXC_Adtran#$ 

       

       

      Thanks in advance for any assistance.

       

      Regards

      Phil Moore

        • Re: No outbound SIP
          geo Employee

          Hello Maverick,

           

          Thank you for posting your question in our Support Community.  The sip-keep-alive options or sip-keep-alive info command can be put on a voice trunk or voice user.  The intended purpose is for the ADTRAN to respond to a keep-alive sent from the SIP Server/SBC during an active call.  The ADTRAN will not initiate a keep-alive or do anything when the trunk is idle.

           

          When debugging (debug sip stack message and debug sip cldu) do you see any messages from the sip server (sip-server primary 58.xxx.xxx.xxx)?  If you are not seeing any sip messages, we will want to verify if the sip destined for the ADTRAN is coming from 58.xxx.xxx.xxx.

           

          Regards,

          Geoff

            • Re: No outbound SIP
              geo Employee

              Hello Maverick,

               

              I went ahead and flagged this post as “Assumed Answered.” If any of the responses on this thread assisted you, please mark them as either Correct or Helpful answers with the applicable buttons. This will make them visible and help other members of the community find solutions more easily. If you still need assistance, please let us know in a reply.

               

              Regards,

              Geoff