9 Replies Latest reply on Jul 10, 2012 8:48 AM by dcorrea

    Ringback tone

    dcorrea Visitor

      Hello Guys,

       

      I was setting up my NV7100 for the main office, and I have a situation with some ringback tones that I don't have for some calls (more frecuently in cell phone calls). I'm using a softphone for made the calls. Do you have any idea for why I don't receiving my ringback tone?!

       

      Which debugs would be useful for you guys?

       

      Thanks in advance,

        • Re: Ringback tone
          unified Past_Featured_Member

          Are the calls going out a SIP trunk?

            • Re: Ringback tone
              dcorrea Visitor

              Hi,

               

              Yes the calls are going out across a SIP trunk

               

              Thanks,

                • Re: Ringback tone
                  unified Past_Featured_Member

                  When placing an outbound call see if the provider is sending back a "183 Session Progress" or "180 Ringing"

                  You can check this using "debug sip stack messages" on the Adtran or running a packet capture on the WAN.

                  If you want you can post either here and I will take a look at it.

                   

                  I have seen many lower end ITSPs take a long time to send these messages or not send them at all.

                  This will cause no ring back.

                    • Re: Ringback tone
                      dcorrea Visitor

                      Unified,

                       

                      I perform the debug sip stack messages and in there I wasn't able to see the "180 Ringing" I will set up a packet capture using Wireshark.

                       

                      Here's what I got from the debug:

                       

                      IPPBX#debug sip stack messages summary

                      IPPBX#

                      15:05:45.445 SIP.STACK MSGSUM  Rx: INVITE sip:xxxxxxxx@XX.XX.XX.XX SIP/2.0 (with SDP)

                      15:05:45.449 SIP.STACK MSGSUM  Tx: SIP/2.0 401 Unauthorized

                      15:05:45.552 SIP.STACK MSGSUM  Rx: ACK sip:xxxxxxxx@XX.XX.XX.XX SIP/2.0

                      15:05:45.586 SIP.STACK MSGSUM  Rx: INVITE sip:xxxxxxxx@XX.XX.XX.XX SIP/2.0 (with SDP)

                      15:05:45.590 SIP.STACK MSGSUM  Tx: SIP/2.0 100 Trying

                      15:05:45.887 SIP.STACK MSGSUM  Rx:

                       

                       

                      15:05:48.684 SIP.STACK MSGSUM  Tx: SIP/2.0 200 OK (with SDP)

                      15:05:48.860 SIP.STACK MSGSUM  Rx: ACK sip:XX.XX.XX.XX:5060;transport=UDP SIP/2.0

                      15:05:56.512 SIP.STACK MSGSUM  Rx: BYE sip:XX.XX.XX.XX:5060;transport=UDP SIP/2.0

                      15:05:56.515 SIP.STACK MSGSUM  Tx: SIP/2.0 200 OK

                       

                      Thanks in advance for the help.

                • Re: Ringback tone
                  dcorrea Visitor

                  Matt & Unified,

                   

                  Thanks for the help on here, as you mentioned before the problem was with the 180 Ringing between the ITSP and my rNV.

                   

                  Thanks for you valuable help,