11 Replies Latest reply on Feb 5, 2013 1:47 PM by matt

    Voicemail sent to email problem

    mwh New Member

      I have a netvanta 7100 that I have setup for voicemail to go to email accounts of some of my users. This feature has worked fine for about 1 year, but recently has stop working. I have check the user primary notification and schedule and that email notification has been enabled in logging. I can ping the email server by name from the netvanta.

       

      The only thing that has changed is that I recently upgraded the firmware to R10.3.1.E. I am not sure if the notification stopped after the upgrade or before.

       

      Here is what I get from debug after you leave a voicemail

       

      You have 10 new messages and 1 saved message.

      Mailbox space used (min:sec): 01:06

      Mailbox space available (min:sec): 28:54

      To SMTP server: 243 bytes of data

      To SMTP server:

      To SMTP server: 2 bytes of data

      To SMTP server: ----BOUNDARY-STRING--

      To SMTP server: 23 bytes of data

      To SMTP server: Content-Type: application/octet-stream; name='DefaultSIPUser_11152012_0318.wav'

      To SMTP server: 81 bytes of data

      To SMTP server: Content-Length: 26284

      To SMTP server: 23 bytes of data

      To SMTP server: Content-Transfer-Encoding: base64

      To SMTP server: 35 bytes of data

      To SMTP server:

      To SMTP server: 2 bytes of data

      To SMTP server: 35970 bytes of data

      SMTP socket write failed.

      SMTP Not enough info to send.

      SMTP Not enough info to send.

        • Re: Voicemail sent to email problem
          Employee

          mwh,

           

          Thanks for posting this question.  I am not aware of a current bug with this feature in R10.3.1.  Here is the generic configuration required for email notifications to work:

           

          !

          ip name-server <primary DNS server> <secondary DNS server>

          no logging email

          logging email receiver-ip <SMTP server> auth-username <account@domain.com>  auth-password <password>

          logging email sender <account@domain.com>

          !

          !

          voice user <extension>

            email <e-mail address>

            voicemail notify email attach-message pcm

            voicemail notify schedule Sunday 12:00 am

              notify email primary

          !

           

           

           

          If your configuration matches this I would need to see a complete configuration as well as the output from a debug system when leaving a voicemail message for a user setup for e-mail notifications.  You can also try changing from your mail server to use Yahoo by modifying these two lines to see if that works:

           

          logging email receiver-ip smtp.mail.yahoo.com port 587 auth-username <Yahoo-account>@yahoo.com  auth-password <Yahoo password>

          logging email sender <Yahoo-account>@yahoo.com

           

          If you would like to submit a full configuration and debug you can upload them to our FTP server from the instructions below:

           

          Open Internet Explorer web browser
          Type the following URL:  ftp://ftp.adtran.com

          Press Alt, click View, and then click Open FTP Site in Windows Explorer

          Double-click the "Incoming" folder
          Drag and drop files from PC into the Internet Explorer window

           

          If you place files on the FTP server I would need to know the file names in order to retrieve them.

           

          Thanks,
          Matt

            • Re: Voicemail sent to email problem
              mwh New Member

              Matt,

               

              Here is my debug and the config file.

               

              Thanks, Mike

               

               

              You have 10 new messages and 1 saved message.

              Mailbox space used (min:sec): 01:06

              Mailbox space available (min:sec): 28:54

              To SMTP server: 243 bytes of data

              To SMTP server:

              To SMTP server: 2 bytes of data

              To SMTP server: -


              BOUNDARY-STRING--

              To SMTP server: 23 bytes of data

              To SMTP server: Content-Type: application/octet-stream; name='DefaultSIPUser_11152012_0318.wav'

              To SMTP server: 81 bytes of data

              To SMTP server: Content-Length: 26284

              To SMTP server: 23 bytes of data

              To SMTP server: Content-Transfer-Encoding: base64

              To SMTP server: 35 bytes of data

              To SMTP server:

              To SMTP server: 2 bytes of data

              To SMTP server: 35970 bytes of data

              SMTP socket write failed.

              SMTP Not enough info to send.

              SMTP Not enough info to send.

                • Re: Voicemail sent to email problem
                  Employee

                  Mike,

                   

                  I did not get the configuration attachment.  Unless you filter all of your passwords, public IPs, hostnames, and other sensitive information from the configuration, the FTP server is a better method for submitting configurations and debugs for security reasons. 

                   

                  Did you try replacing your mail server settings with the Yahoo account example above?  That is a quick way to isolate it to the NetVanta 7100 or the mail server assuming you have a Yahoo account to use.  I just tested it on R10.3.1 and it worked properly.   

                   

                  There seems to be a lot of normal SMTP transactions missing from the debugs you supplied.  Can you supply a complete unfiltered debug along with your configuration to the FTP server?

                   

                  Thanks,
                  Matt

                    • Re: Voicemail sent to email problem
                      mwh New Member

                      Matt,

                       

                      I sent the config file to your FTP site. The file name is config.Reg_Steel_NV7100-11-28-2012.cfg.

                       

                      I also tried to use a Yahoo account and had no luck.

                       

                      Thanks, Mike

                        • Re: Voicemail sent to email problem
                          Employee

                          Mike,

                           

                          I just checked the site (ftp://ftp.adtran.com/incoming) and did not see that file name present.  Can you upload it again?  Also, if you can include the output from a show mem heap in that same text file or in this thread that may also be relevant.

                           

                          Thanks,
                          Matt

                            • Re: Voicemail sent to email problem
                              mwh New Member

                              Matt,

                               

                              I copied the new file with the show men heap. The file name is config.Reg-Steel_NV7100-11-28-2012.cfg

                               

                              Thanks, Mike

                                • Re: Voicemail sent to email problem
                                  Employee

                                  Mike,


                                  Thanks for submitting the file.  I reviewed it and noticed the logging email receiver-ip line was configured for port 2525.  Assuming the email server is using the default port of 25 you can omit the port <port number> parameter from the command.  Can you alter this and see if it resolves the issue?  It would look like this:

                                   

                                  logging email receiver-ip smtp.XXXX.net auth-username voicemail@XXXX.net auth-password XXXX

                                   

                                  You need to replace the "XXXX" portions above with the correct information.

                                   

                                  Thanks,
                                  Matt

                                    • Re: Voicemail sent to email problem
                                      mwh New Member

                                      Matt,

                                       

                                      The smtp port for the mail provider is 2525, but I have also tried just 25 and 587.

                                       

                                      Thanks, Mike

                                        • Re: Voicemail sent to email problem
                                          Employee

                                          Mike,

                                           

                                          Can you upload the output from a debug system when trying to connect with the Yahoo account on port 587 to the FTP server, as well as a the same debug on all three ports to your mail server?  If you can get a packet capture from the WAN of the 7100 at the same time as the debug that would help too. 

                                           

                                          Thanks,
                                          Matt

                                            • Re: Voicemail sent to email problem
                                              Employee

                                              Mike,

                                               

                                              Were you able to resolve this issue?   If so, please return to this post and update it with the resolution  If you are still having problems I would be happy to continue working with you, but I will need to see the requested debugs and packet captures from my last post if you can upload them to the FTP server.

                                               

                                              Thanks,
                                              Matt

                                                • Re: Voicemail sent to email problem
                                                  Employee

                                                  I went ahead and flagged this post as "Assumed Answered". If any of the responses on this thread assisted you, please mark them as Correct or Helpful as the case may be with the applicable buttons. This will make them visible and help other members of the community find solutions more easily. If you still need assistance, we would be more than happy to continue working with you on this - just let us know in a reply.

                                                   

                                                  Thanks,

                                                  Matt