5 Replies Latest reply on Dec 6, 2012 10:15 AM by david

    Is there a way to control which SIP trunk routes inbound calls on the TA 900?

    tjcam New Member

      I have multiple SIP trunks on a TA 900 to a Softswitch.  Trunk T01 is used for a SIP derived PRI.  Trunk T03 is a SIP Trunk that I'm using for analog FXS lines.

       

      For clarity:

      "INBOUND CALLS" are calls that a coming from the my Softswitch towards the TA900 and are either destined for the PRI or an FXS line.

      "OUTBOUND CALLS" are calls originating from the PBX/PRI or the FXS Line.

       

      I can control the "OUTBOUND CALL" just fine using trunk-lists and ani-lists.  But I'm not seeing a way to control "INBOUND CALLS".

       

      Inbound calls to my FXS line, that I would like to route using Trunk T03, always seem to default to Trunk T01 unless I busy out Trunk T01.  The inbound call to the FXS line sets up across Trunk T01 and works fine but I would prefer to force it to use the correct trunk.  Is is possible to configure the Trunks to use a different local SIP port?  For example: Configure Trunk T01 with a SIP Source port of 5060 and Configure Trunk T03 with a SIP Source Port of 5070?

        • Re: Is there a way to control which SIP trunk routes inbound calls on the TA 900?
          unified Past_Featured_Member

          Hi,

           

          Can you post a copy of your config?

            • Re: Is there a way to control which SIP trunk routes inbound calls on the TA 900?
              tjcam New Member

              ! ADTRAN, Inc. OS version A5.03.00.E

              ! Boot ROM version 14.05.00.SA

              ! Platform: Total Access 908e (2nd Gen), part number 4242908L1

              ! Serial number CFG0593794

              !

              !

              hostname "TA908e:TestLab"

              enable password encrypted 242ccd797106a6cfc921137a8783cc93e77d

              !

              clock timezone -6-Central-Time

              !

              ip subnet-zero

              ip classless

              ip routing

              !

              !

              ip name-server 2.2.2.2 2.2.3.2

              !

              !

              no auto-config

              !

              event-history on

              event-history priority warning

              logging forwarding on

              no logging email

              !

              service password-encryption

              !

              username "test" password encrypted "3038955de95912345ae9efc7fb1c319c1eec"

              !

              !

              !

              ip firewall

              no ip firewall nat-preserve-source-port

              no ip firewall alg ftp

              no ip firewall alg msn

              no ip firewall alg mszone

              no ip firewall alg pptp

              no ip firewall alg h323

              !

              aaa on

              ftp authentication LoginUseLocalUsers

              !

              !

              aaa authentication login default local

              aaa authentication login LoginUseTacacs group tacacs+

              aaa authentication login LoginUseRadius group radius

              aaa authentication login LoginUseLocalUsers local

              aaa authentication login LoginUseLinePass line

              !

              aaa authentication enable default enable

              !      

              !

              no dot11ap access-point-control

              !

              !

              !

              !

              ip dhcp-server excluded-address 10.10.10.100 10.10.10.199

              !

              ip dhcp-server pool "Private"

                network 10.10.10.0 255.255.255.0

                dns-server 66.39.214.253 66.39.214.254

                netbios-node-type h-node

                default-router 10.10.10.254

              !

              !

              !

              !

              !

              !

              qos map Test_QoS 10

                match dscp 24

                match ip rtp 49996 63996 all

                priority 960

                set dscp 24

              qos map Test_QoS 15

                match dscp 40

                match list allow-sip

                priority 320

                set dscp 40

              !

              !

              !

              !

              interface loop 1

                ip address  10.2.5.46  255.255.255.252

                no shutdown

              !

              interface eth 0/1

                ip address  10.10.10.254  255.255.255.0

                access-policy Private

                media-gateway ip primary

                shutdown

                no lldp send-and-receive

              !

              !

              interface eth 0/2

                no ip address

                shutdown

              !      

              !

              !

              !

              interface t1 0/1

                lbo short 200

                tdm-group 1 timeslots 1-24 speed 64

                no shutdown

              !

              interface t1 0/2

                shutdown

              !

              interface t1 0/3

                shutdown

              !

              interface t1 0/4

                shutdown

              !

              !

              interface fxs 0/1

                no shutdown

              !

              interface fxs 0/2

                shutdown

              !

              interface fxs 0/3

                shutdown

              !

              interface fxs 0/4

                shutdown

              !

              interface fxs 0/5

                shutdown

              !

              interface fxs 0/6

                shutdown

              !

              interface fxs 0/7

                shutdown

              !

              interface fxs 0/8

                shutdown

              !

              !

              interface fxo 0/0

                no shutdown

              !

              interface ppp 1

                description ppp 1

                ip address  1.1.1.2  255.255.255.252

                access-policy Public

                media-gateway ip primary

                peer default ip address 1.1.1.1

                max-reserved-bandwidth 85

                qos-policy out Test_QoS

                bandwidth 1536

                no shutdown

                cross-connect 1 t1 0/1 1 ppp 1

              !

              !

              !

              !

              !

              !

              timing-source t1 0/1

              !

              !

              !

              !

              !

              ip access-list standard nat-all

                permit any

              !

              !

              ip access-list extended allow-sip

                permit udp any  any eq 5060  

                permit udp any  any eq 5077  

              !

              !

              ip access-list extended fw-standard

                remark Allow list standard firewall

                permit ip any any

              !

              ip access-list extended eth-in

                deny   udp any  any eq netbios-dgm  

                deny   udp any  any eq netbios-ns  

                deny   udp any  any eq netbios-ss  

                deny   udp any  any eq snmp  

                deny   udp any  any eq snmptrap  

                deny   udp any eq netbios-dgm any   

                deny   udp any eq netbios-ns any   

                deny   udp any eq netbios-ss any   

                deny   udp any eq snmp any   

                deny   udp any eq snmptrap any   

                permit ip any  any   

              !

              ip access-list extended matchall

                permit ip any  any   

              !

              !

              ip access-list extended self

                remark Traffic to Netvanta

                permit ip any  any   

              !

              ip access-list extended t1-out

                deny   udp any  any eq 1433  

                deny   udp any  any eq 1434  

                deny   ip any  172.16.0.0 0.0.255.255     log

                deny   ip any  10.0.0.0 0.255.255.255     log

                deny   ip any  192.168.0.0 0.0.255.255     log

                permit ip any  any   

              !

              !

              ip policy-class Private

                allow list self self

                nat source list nat-all interface ppp 1 overload

              !

              ip policy-class Public

                allow list fw-standard self

              !

              !

              !

              !

              ip route 0.0.0.0 0.0.0.0 1.1.1.1

              ip route 192.168.1.0 255.255.255.0 10.100.100.2

              !

              ip ssh-server

              no ip tftp server

              no ip tftp server overwrite

              ip http authentication LoginUseLocalUsers

              no ip http server

              ip http secure-server

              no ip snmp agent

              no ip ftp server

              no ip scp server

              no ip sntp server

              !

              !

              !

              !

              !

              !

              ip sip

              ip sip udp 5060

              no ip sip tcp

              !

              !

              !

              voice feature-mode network

              voice forward-mode network

              !

              !

              !

              !

              !

              !

              !

              voice dial-plan 1 extensions NXX-NXX-XXXX

              !

              !

              !

              !

              voice codec-list g711

                codec g711ulaw

              !

              !

              voice trunk-list Digium2Meta

                trunk T02

              !

              voice trunk-list FXS2Meta

                trunk T01

                trunk T02

              !

              voice trunk-list Meta2Digium

                trunk T01

              !

              voice ani-list Meta2FXS

                ani $

              !

              !

              !

              voice trunk T01 type sip

                description "SIP To Softswitch"

                sip-server primary 172.16.159.129

                registrar primary ss.voipphone.net

                outbound-proxy primary 172.16.159.129 udp 5077

                authentication username "9999991000" password encrypted "3c34d8035412345d086615db806e6abc68da"

                domain "172.16.159.129"

                register 9999991000

                trust-domain

              !

              voice trunk T02 type sip

                description "SIP To Digium"

                sip-server primary 10.10.10.100

                trust-domain

              !

              voice trunk T03 type sip

                description "fxs_sip-trunk"

                sip-server primary ss.voipphone.net

                registrar primary ss.voipphone.net

                outbound-proxy primary 172.16.159.129

                domain "172.16.159.129"

                codec-group g711

                prefer trunk-routing

              !

              !

              voice grouped-trunk T01

                description "SIP To Softswitch"

                trunk T01

                accept $ cost 0

                permit list Digium2Meta

                !deny all other trunks

                !deny all other ani

              !

              !

              voice grouped-trunk T02

                description "To Interactive Intelligence"

                trunk T02

                accept $ cost 1

                permit list Meta2Digium

                !deny all other trunks

                !deny all other ani

              !

              !

              voice grouped-trunk SIPMAP

                trunk T03

                accept 9NXX-NXX-XXXX cost 200

                accept 91-NXX-NXX-XXXX cost 200

                accept 91-800-NXX-XXXX cost 200

                accept 91-888-NXX-XXXX cost 200

                accept 91-877-NXX-XXXX cost 200

                accept 91-866-NXX-XXXX cost 200

                accept 91-855-NXX-XXXX cost 200

                accept 91-900-NXX-XXXX cost 200

                accept 91-976-NXX-XXXX cost 200

                accept 9011-$ cost 200

                accept 9411 cost 200

                accept 9611 cost 200

                accept 9911 cost 200

                accept 90-NXX-NXX-XXXX cost 200

                accept 910-10-XXX-$ cost 200

                accept 9NXX-XXXX cost 200

                accept *XX cost 200

                accept *XXX cost 200

                accept NXX cost 200

                accept NXX-NXX-XXXX cost 200

                accept 1-NXX-NXX-XXXX cost 200

                accept 1-800-NXX-XXXX cost 200

                accept 1-888-NXX-XXXX cost 200

                accept 1-877-NXX-XXXX cost 200

                accept 1-866-NXX-XXXX cost 200

                accept 1-855-NXX-XXXX cost 200

                accept 1-900-NXX-XXXX cost 200

                accept 1-976-NXX-XXXX cost 200

                accept 011-$ cost 200

                accept 411 cost 200

                accept 611 cost 200

                accept 911 cost 200

                accept 0-NXX-NXX-XXXX cost 200

                accept 10-10-XXX-$ cost 200

                accept NXX-XXXX cost 200

                deny list FXS2Meta

                permit list Meta2FXS

                !deny all other trunks

                !deny all other ani

              !

              !

              voice user 9999991001

                connect fxs 0/1

                password encrypted "24209cc96b444d215061178c14ab5e607014"

                no special-ring-cadences

                sip-identity 9999991001 T03 register

                sip-authentication password encrypted "1c18c8833690f12345d7af7485d29c9883c"

                modem-passthrough

                no nls

                no echo-cancellation

                rtp dtmf-relay inband

                codec-group g711

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              ip sip qos dscp 40

              !

              !

              ip rtp qos dscp 24

              ip rtp udp 59994

              !

              !

              !

              line con 0

                login authentication LoginUseLocalUsers

              !

              line telnet 0 4

                login authentication LoginUseLocalUsers

                password encrypted 1b138fa41845d6a3ba730004ad78daa53a75

                no shutdown

              line ssh 0 4

                login authentication LoginUseLocalUsers

                no shutdown

              !

              !

              !

              !

              !

              end

            • Re: Is there a way to control which SIP trunk routes inbound calls on the TA 900?
              tjcam New Member

              I scrubbed the I addresses for security reasons.

              Thanks.

               

              ! ADTRAN, Inc. OS version A5.03.00.E

              ! Boot ROM version 14.05.00.SA

              ! Platform: Total Access 908e (2nd Gen), part number 4242908L1

              ! Serial number CFG0593794

              !

              !

              hostname "TA908e:TestLab"

              enable password encrypted 242ccd797106a6cfc921137a8783cc93e77d

              !

              clock timezone -6-Central-Time

              !

              ip subnet-zero

              ip classless

              ip routing

              !

              !

              ip name-server 2.2.2.2 2.2.3.2

              !

              !

              no auto-config

              !

              event-history on

              event-history priority warning

              logging forwarding on

              no logging email

              !

              service password-encryption

              !

              username "test" password encrypted "3038955de95912345ae9efc7fb1c319c1eec"

              !

              !

              !

              ip firewall

              no ip firewall nat-preserve-source-port

              no ip firewall alg ftp

              no ip firewall alg msn

              no ip firewall alg mszone

              no ip firewall alg pptp

              no ip firewall alg h323

              !

              aaa on

              ftp authentication LoginUseLocalUsers

              !

              !

              aaa authentication login default local

              aaa authentication login LoginUseTacacs group tacacs+

              aaa authentication login LoginUseRadius group radius

              aaa authentication login LoginUseLocalUsers local

              aaa authentication login LoginUseLinePass line

              !

              aaa authentication enable default enable

              !      

              !

              no dot11ap access-point-control

              !

              !

              !

              !

              ip dhcp-server excluded-address 10.10.10.100 10.10.10.199

              !

              ip dhcp-server pool "Private"

                network 10.10.10.0 255.255.255.0

                dns-server 66.39.214.253 66.39.214.254

                netbios-node-type h-node

                default-router 10.10.10.254

              !

              !

              !

              !

              !

              !

              qos map Test_QoS 10

                match dscp 24

                match ip rtp 49996 63996 all

                priority 960

                set dscp 24

              qos map Test_QoS 15

                match dscp 40

                match list allow-sip

                priority 320

                set dscp 40

              !

              !

              !

              !

              interface loop 1

                ip address  10.2.5.46  255.255.255.252

                no shutdown

              !

              interface eth 0/1

                ip address  10.10.10.254  255.255.255.0

                access-policy Private

                media-gateway ip primary

                shutdown

                no lldp send-and-receive

              !

              !

              interface eth 0/2

                no ip address

                shutdown

              !      

              !

              !

              !

              interface t1 0/1

                lbo short 200

                tdm-group 1 timeslots 1-24 speed 64

                no shutdown

              !

              interface t1 0/2

                shutdown

              !

              interface t1 0/3

                shutdown

              !

              interface t1 0/4

                shutdown

              !

              !

              interface fxs 0/1

                no shutdown

              !

              interface fxs 0/2

                shutdown

              !

              interface fxs 0/3

                shutdown

              !

              interface fxs 0/4

                shutdown

              !

              interface fxs 0/5

                shutdown

              !

              interface fxs 0/6

                shutdown

              !

              interface fxs 0/7

                shutdown

              !

              interface fxs 0/8

                shutdown

              !

              !

              interface fxo 0/0

                no shutdown

              !

              interface ppp 1

                description ppp 1

                ip address  1.1.1.2  255.255.255.252

                access-policy Public

                media-gateway ip primary

                peer default ip address 1.1.1.1

                max-reserved-bandwidth 85

                qos-policy out Test_QoS

                bandwidth 1536

                no shutdown

                cross-connect 1 t1 0/1 1 ppp 1

              !

              !

              !

              !

              !

              !

              timing-source t1 0/1

              !

              !

              !

              !

              !

              ip access-list standard nat-all

                permit any

              !

              !

              ip access-list extended allow-sip

                permit udp any  any eq 5060  

                permit udp any  any eq 5077  

              !

              !

              ip access-list extended fw-standard

                remark Allow list standard firewall

                permit ip any any

              !

              ip access-list extended eth-in

                deny   udp any  any eq netbios-dgm  

                deny   udp any  any eq netbios-ns  

                deny   udp any  any eq netbios-ss  

                deny   udp any  any eq snmp  

                deny   udp any  any eq snmptrap  

                deny   udp any eq netbios-dgm any   

                deny   udp any eq netbios-ns any   

                deny   udp any eq netbios-ss any   

                deny   udp any eq snmp any   

                deny   udp any eq snmptrap any   

                permit ip any  any   

              !

              ip access-list extended matchall

                permit ip any  any   

              !

              !

              ip access-list extended self

                remark Traffic to Netvanta

                permit ip any  any   

              !

              ip access-list extended t1-out

                deny   udp any  any eq 1433  

                deny   udp any  any eq 1434  

                deny   ip any  172.16.0.0 0.0.255.255     log

                deny   ip any  10.0.0.0 0.255.255.255     log

                deny   ip any  192.168.0.0 0.0.255.255     log

                permit ip any  any   

              !

              !

              ip policy-class Private

                allow list self self

                nat source list nat-all interface ppp 1 overload

              !

              ip policy-class Public

                allow list fw-standard self

              !

              !

              !

              !

              ip route 0.0.0.0 0.0.0.0 1.1.1.1

              ip route 192.168.1.0 255.255.255.0 10.100.100.2

              !

              ip ssh-server

              no ip tftp server

              no ip tftp server overwrite

              ip http authentication LoginUseLocalUsers

              no ip http server

              ip http secure-server

              no ip snmp agent

              no ip ftp server

              no ip scp server

              no ip sntp server

              !

              !

              !

              !

              !

              !

              ip sip

              ip sip udp 5060

              no ip sip tcp

              !

              !

              !

              voice feature-mode network

              voice forward-mode network

              !

              !

              !

              !

              !

              !

              !

              voice dial-plan 1 extensions NXX-NXX-XXXX

              !

              !

              !

              !

              voice codec-list g711

                codec g711ulaw

              !

              !

              voice trunk-list Digium2Meta

                trunk T02

              !

              voice trunk-list FXS2Meta

                trunk T01

                trunk T02

              !

              voice trunk-list Meta2Digium

                trunk T01

              !

              voice ani-list Meta2FXS

                ani $

              !

              !

              !

              voice trunk T01 type sip

                description "SIP To Softswitch"

                sip-server primary 172.16.159.129

                registrar primary ss.voipphone.net

                outbound-proxy primary 172.16.159.129 udp 5077

                authentication username "9999991000" password encrypted "3c34d8035412345d086615db806e6abc68da"

                domain "172.16.159.129"

                register 9999991000

                trust-domain

              !

              voice trunk T02 type sip

                description "SIP To Digium"

                sip-server primary 10.10.10.100

                trust-domain

              !

              voice trunk T03 type sip

                description "fxs_sip-trunk"

                sip-server primary ss.voipphone.net

                registrar primary ss.voipphone.net

                outbound-proxy primary 172.16.159.129

                domain "172.16.159.129"

                codec-group g711

                prefer trunk-routing

              !

              !

              voice grouped-trunk T01

                description "SIP To Softswitch"

                trunk T01

                accept $ cost 0

                permit list Digium2Meta

                !deny all other trunks

                !deny all other ani

              !

              !

              voice grouped-trunk T02

                description "To Interactive Intelligence"

                trunk T02

                accept $ cost 1

                permit list Meta2Digium

                !deny all other trunks

                !deny all other ani

              !

              !

              voice grouped-trunk SIPMAP

                trunk T03

                accept 9NXX-NXX-XXXX cost 200

                accept 91-NXX-NXX-XXXX cost 200

                accept 91-800-NXX-XXXX cost 200

                accept 91-888-NXX-XXXX cost 200

                accept 91-877-NXX-XXXX cost 200

                accept 91-866-NXX-XXXX cost 200

                accept 91-855-NXX-XXXX cost 200

                accept 91-900-NXX-XXXX cost 200

                accept 91-976-NXX-XXXX cost 200

                accept 9011-$ cost 200

                accept 9411 cost 200

                accept 9611 cost 200

                accept 9911 cost 200

                accept 90-NXX-NXX-XXXX cost 200

                accept 910-10-XXX-$ cost 200

                accept 9NXX-XXXX cost 200

                accept *XX cost 200

                accept *XXX cost 200

                accept NXX cost 200

                accept NXX-NXX-XXXX cost 200

                accept 1-NXX-NXX-XXXX cost 200

                accept 1-800-NXX-XXXX cost 200

                accept 1-888-NXX-XXXX cost 200

                accept 1-877-NXX-XXXX cost 200

                accept 1-866-NXX-XXXX cost 200

                accept 1-855-NXX-XXXX cost 200

                accept 1-900-NXX-XXXX cost 200

                accept 1-976-NXX-XXXX cost 200

                accept 011-$ cost 200

                accept 411 cost 200

                accept 611 cost 200

                accept 911 cost 200

                accept 0-NXX-NXX-XXXX cost 200

                accept 10-10-XXX-$ cost 200

                accept NXX-XXXX cost 200

                deny list FXS2Meta

                permit list Meta2FXS

                !deny all other trunks

                !deny all other ani

              !

              !

              voice user 9999991001

                connect fxs 0/1

                password encrypted "24209cc96b444d215061178c14ab5e607014"

                no special-ring-cadences

                sip-identity 9999991001 T03 register

                sip-authentication password encrypted "1c18c8833690f12345d7af7485d29c9883c"

                modem-passthrough

                no nls

                no echo-cancellation

                rtp dtmf-relay inband

                codec-group g711

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              ip sip qos dscp 40

              !

              !

              ip rtp qos dscp 24

              ip rtp udp 59994

              !

              !

              !

              line con 0

                login authentication LoginUseLocalUsers

              !

              line telnet 0 4

                login authentication LoginUseLocalUsers

                password encrypted 1b138fa41845d6a3ba730004ad78daa53a75

                no shutdown

              line ssh 0 4

                login authentication LoginUseLocalUsers

                no shutdown

              !

              !

              !

              !

              !

              end

              • Re: Is there a way to control which SIP trunk routes inbound calls on the TA 900?
                david Employee

                Mr. Campbell,

                 

                I believe we worked this issue over the phone and discussed the way that the Adtran unit determines which inbound SIP trunk is associated with the call.  In summary, if the SIP server IP address is the same for both trunks, we cannot distinguish the associated incoming SIP trunk.  However, we were able to get the call flow you desired.

                 

                I'm going to go ahead and mark this forum post as "Assumed Answered", but please let me know if you have further questions or I can help in any way.

                 

                Thanks!

                David