14 Replies Latest reply on Mar 18, 2013 6:19 AM by matt

    Taking over an Adtran system, and have issues...

    ets New Member

      Hi all,

       

      I've been searching and lurking, and have been able to get a transferred Netvanta 7100 and a bunch of IP712 phones installed and running, but am still having some problems that are stumping me...

       

      I'm the new IT guy on site, and have worked through a lot of issues in the last week.  The owners just switched services from Century Link analog to a Cox SIP trunk system.  We did the service cut-over last week, and the site is now taking inbound calls without much issue. Outbound calls work fine as well, for the most part.

       

      I'm seeing a few issues that I'm sure are all related, and can't find anything in the config guides that correlate to all the things I'm seeing.

       

      I'll try to keep my list short and descriptive, in the hopes that it will be easier to answer these questions I have...

       

      (1) Netvanta 7100

      A4.03.00.SC.E   ((Approved version by Cox))

       

      (10) IP712 phones

      App: 1.3.16

      Boot: 1.3.12

       

      Switch set to VLAN 2, and is ONLY used for IP phones, completely isolated from computer network.

       

       

      1.  When I try to forward to an outside number for after-hours answering, the system properly forwards to any number.  If I call the main biz number from INSIDE the building (a VoIP phone), everything is fine, call sounds great.  If I call from a mobile to the main biz #, call connects fine, but there is zero sound n either end of the call.  I'm guessing this has something to do with authentication and security.  As a side note, even with ANI subs filled out in the Trunk Account, the forwarded call still shows up as the mobile number instead of the biz number.  I've tried everything I can think of to get this fixed...

       

      2.  I've set up speed dials and other items in the Directories, but I can not get them to transfer to the phones.  I've followed the Admin guide and have run through setup and config many times to no avail.

       

      3.  (May be related to #2)  If I review ANY of the directory items on a phone's menu, NOTHING shows up in any of the menus.  They're all completely blank.  The desk I'm working at now (X101) is part of the main Ring Group (X200), and rings on every incoming call.  Not a single previous call shows up.

       

      4.  I can't call one extension from another.  I can't transfer a call from one extension to another.   

       

      5.  I have set up AA messages and VM prompts, but when calling in to test, there is ZERO audio.  If I try to leave a VM, it does register on the extension that I pointed to in the Ring Group Call Coverage (msg. light flashes).  There is apparently NO recorded audio.

       

      Normally, I'd just put my head down and work through these problems, and learn this system in and out by working through the issues. Right now, however, I'm sitting in a busy office with eyes piercing the back of my head...  As much as I'd like to tell the owners that they'd be better off using system xyz (because I can program it in my sleep), I'm stuck working with what I've been given. 

       

      I really appreciate any help in advance, and look forward to working with you guys.

       

      Thanks,

       

      Brandon

        • Re: Taking over an Adtran system, and have issues...
          markfreeman Employee

          Brandon,

          Let's just work on one of these at a time.

           

          1.  When I try to forward to an outside number for after-hours answering, the system properly forwards to any number.  If I call the main biz number from INSIDE the building (a VoIP phone), everything is fine, call sounds great.  If I call from a mobile to the main biz #, call connects fine, but there is zero sound n either end of the call.  I'm guessing this has something to do with authentication and security.  As a side note, even with ANI subs filled out in the Trunk Account, the forwarded call still shows up as the mobile number instead of the biz number.  I've tried everything I can think of to get this fixed...

           

          -If you go to Data > Firewall > security zones, do you have an entry for SIP provider? If you do verify that it is the IP address of the COX SIP Server addresss that you configured in the SIP Trunk Account for COX. This rule allows UDP packets 5060 to come only from your Provider.

          -What rule do you have in the ANI substitution template on the COX Trunk Account page.

           

          -Mark

            • Re: Taking over an Adtran system, and have issues...
              ets New Member

              Hey Mark,

               

              Thanks for getting back to me.  Please see below:

               

              -If you go to Data > Firewall > security zones, do you have an entry for SIP provider? If you do verify that it is the IP address of the COX SIP Server address that you configured in the SIP Trunk Account for COX. This rule allows UDP packets 5060 to come only from your Provider.

              -What rule do you have in the ANI substitution template on the COX Trunk Account page.

               

              ##  Firewall is DISABLED currently, as I thought that might be causing an issue.  There is currently NO entry for the SIP config.

              ##  In the ANI template, I have the BTN listed as 52X80X11XX in both the MATCH and SUBSTITUTION lines.  I tried the functions both With and WITHOUT the ANI sub, with no change in results.

               

              Thanks again for your help,

               

              Brandon

                • Re: Taking over an Adtran system, and have issues...
                  markfreeman Employee

                  Brandon,

                  Do you have an external firewall? What is siting between the 7100 and the Internet Connection from Cox? Something has to be NATing the traffic and sounds like the SIP or RTP is not getting routed properly.

                   

                  For the ANI, do you want all outbound calls to have the Caller number replaced with one company number?

                  -If you want that, then put $ in the Match Template field and in the Substitution field put the specified 10 digit number with no wild cards.

                   

                  -Mark

                    • Re: Taking over an Adtran system, and have issues...
                      ets New Member

                      Hey Mark,

                       

                      No external firewall.  The service comes in from the tap to the Cisco cable modem via coax.  From there, Ethernet to an Edgewater 4550 SBC.  From there, Ethernet direct to port 2 on the 7100.  I spent some time on the phone with Level 4 support @ Cox this afternoon, and they assured me that there's no firewall on their SBC to block signals.

                       

                      We had an intermittent outage yesterday with the SIP side as well as the internet connection (two separate modems).  The Cox tech came out and flashed firmware on both modems, and killed the SIP connection completely.  I worked with TS to get up and running again, which lasted to about 2AM.  Now, the problematic condition on forwarding from the 7100 has changed.  Previously, we had the issue where calling the BTN from an outside line when forwarded to the overnight answering service was set, there'd be connection but no sound on either end.  Now, I just get a slow busy beep.  NOTHING has changed in my config in the last few days.

                       

                      Cox seems to think there's an RTP failure as well.  Unfortunately, with the busy signal on external phone forward, they couldn't actually test the pass-through today.  I have RTP monitoring turned ON in the 7100/ Monitoring/ VQ menu, but there's NOTHING registering for inbound or outbound calls.  Tried from multiple extensions.

                       

                      With regards to the ANI sub, I added the (string) $ as a single character to the MT field as you directed.  I won't be able to verify here until I can figure out the busy tone on outbound forward.

                       

                      Thanks again,

                       

                      Brandon

                       

                      +++++++++++++++++++++++++++++++++

                       

                      I may have just found something.  I was reading through the Cox Config guide again, and found this (see link below, page 9):

                       

                      http://media.cox.com/cbsupport/print_media/phone/equipment/sip-config-guide-adtran-netvanta.pdf

                       

                      Caveats and Limitations

                       Adtran VetVanta 7100 hairpins both call legs during call transfer and call forward, meaning the

                      SIP sessions are not released after transfer or forward. The sessions are released when the calls

                      are released.

                       To make a call to the LD operator (9 +0) call please reference Section 6.4.2

                      Provisioning the Pilot number to be used as an extension causes Blind Transfer and Call Forward

                      type calls to have no talk path. All other DID’s work without problem when assigned to an

                      extension.

                       

                       

                      Hmmm...

                        • Re: Taking over an Adtran system, and have issues...
                          markfreeman Employee

                          Brandon,

                          Man 2am, i bet was no fun.

                           

                          1. Were you on the phone with Cox Support or ADTRAN support?

                           

                          2. Is your network setup like page 6 of the Cox config guide? So the SBC just goes into one of the front switch ports of the 7100?

                           

                          3. RTP monitoring will not work in the 7100 unless the firewall is turned on. That is why you are not seeing any calls. If you wanted to see this, you would enable the firewall and delete all security zones. You would have to do this from the CLI, not able to delete private or public from the GUI. Let me know if you want to do this and i will give you script to do it.

                           

                          4. How are you do have the 7100 configured for your afterhours forwarding?

                           

                          -Mark

                            • Re: Taking over an Adtran system, and have issues...
                              ets New Member

                              Mark,

                               

                              2AM is not fun, but it's the job...

                               

                              1.  Cox support.  I know you guys have been trying to call me as well, but I have been so stacked with work here that I haven't been able to call back.

                               

                              2.  Here's my layout:

                               

                              Incoming service --> cable modem --> Edge 4550 SBC --> NV7100 --> phones

                               

                              3.  I'll worry about RTP later, as I fixed the issue from #1 in OP last night. Here's what I found:

                               

                              As the office I'm working in now has a very basic layout, I have not set up an Operator group.  I set up ALL DID #s in the first extension (x200) in the Ring group, including the main BTN.  This property now has 20 available phone #s, but they only use the main BTN number for configuration. 

                               

                              After finding the function restriction on Cox's doc, I removed the BTN from the DID list for x200, and set it up in the System Parameters tab.  I then rebuilt x200 to be the main Ring group.  Forwarding to after-hours on an external number works without issue now, and I have solid communication in both directions.  Lesson learned...

                               

                              4.  With regards to the forwarding, I set up a simple schedule list for standard, nights, and weekends.  My plan is to test the function of the schedules tonight/ tomorrow, when there's nobody here in the office.

                               

                              Next, I need to figure out the Voicemail and Directory issues.

                               

                              Thanks again

                               

                              BL

                                • Re: Taking over an Adtran system, and have issues...
                                  markfreeman Employee

                                  Brandon,

                                  Were you able to test the schedule?

                                   

                                  Regarding the directories, did you go to IP Phone Configs and the update the directories? select all the phones and then go to other actions and then update directories. Then you need to Sync the Phones. YOu need to verify that the phone rebooted. then check

                                   

                                  directory.jpg

                                   

                                  Regarding the voicemail, do none of the users get voicemail?

                                  If you go to Voicemail settings, make sure that is enabled.

                                  Then go to System setup > call coverage list > and see how many users are assigned to the different coverages, Open up the one that is being used. What is the coverage details?

                                   

                                  -Mark

                                  Then open a user account that you are testing with

                                    • Re: Taking over an Adtran system, and have issues...
                                      ets New Member

                                      Hey Mark,

                                       

                                      I'll probably test the schedule this weekend.  Finding a time to shut the forwarding down when they have incoming calls at nearly a 24-hour cycle is tricky.

                                       

                                      Regarding the Directories, I have followed the Config guide to the tee, and have tried to push the Directory list to the phones at least a dozen times.  I ran through all the same steps as you listed above.  The one thing that I remember seeing in the Adtran documentation is that on the IP712 phones, the Sync command has some kind of issue (after Update and Rebuild are clicked in that order).  I have manually rebooted the phones, both using the phone buttons, and by unplugging the Cat6.  One thing that might give you some insight: when any phone is loading, one of the last things that displays on the screen is "Download Phonebook file failed) (or something like that).

                                       

                                      With regards to the VM settings, I have a total of (5) extensions online now.  They're all set as active in the Coverage list. 

                                       

                                      Here's how my layout is broken down:

                                       

                                      X1001 and x1002 are the "Receptionist desk" phones.  Inbound calls ring to those two extensions (group x2000) twice, and then ring to group x2001 (x1002 - x1005).  The main VM box is set @ x1001.  This layout, in my mind, is very simple, and I know I'm missing something really obvious.  I just can't figure this one out...

                                       

                                      Picture1.png

                                       

                                      Thanks again,

                                       

                                      Brandon

                                        • Re: Taking over an Adtran system, and have issues...
                                          markfreeman Employee

                                          Brandon,

                                          Sorry for late reply, been tied up teaching classes.

                                           

                                          Directory Problem

                                          do the following access CLI of 7100, then get to enable mode and do "debug ip ftp-server"

                                          go to adtran phone and press menu button, then 2 then 9 then select "Factory" and then "ok"

                                          The phone will reboot two times after the second reboot it will start downloading files look for this in the debug output, it will be near the end where you see the phone registering:

                                          FTP: USER command - Password required for 'polycomftp'.

                                          FTP: USER command -  User 'polycomftp' logged in .

                                          FTP: TYPE command - Type is set to I.

                                          FTP: CWD command - directory changed to 'ADTRAN'.

                                          FTP: PORT command - opening port from 10.10.20.4.

                                          FTP: BINARY data connection for ls (10.10.20.4,1042).

                                          FTP: NLST command - 'adtran_phonebook.csv' transfer complete.

                                          FTP: PORT command - opening port from 10.10.20.4.

                                          FTP: BINARY data connection for adtran_phonebook.csv (10.10.20.4,1043).

                                          FTP: RETR command - BINARY transfer complete.

                                          2013.01.30 09:47:29 IP.FTP SERVER (RETR) Transfer of file '/ADTRAN/adtran_phonebook.csv' complete for remote host '10.10.20.1'

                                           

                                          This is the SYSTEM directory for the phone. Let me know if that is successful or not.

                                          If successful, then after the phone comes up, press the MENU button, then 4 for Directories, then 2 for System and see if you see the SYSTEM directory entries.

                                           

                                          Voicemail Problem

                                          So all five users are using the "go_to_voicemail" coverage?

                                          What number are you calling to test this? The receptionist 1001 extension?

                                          I duplicated your setup and it worked fine for me. I called one extension, let it go to voicemail, then went to 2000 RG, then 2001RG, then to voicemail of 1001.

                                          Let me know what your calling to test this and then we can go from there. Like is this an inbound call on trunk into 7100 or you just calling from one extension to another locally?

                                          -Let me know exactly what is happening when you call and test this.

                                          -Next step is to get debug of 7100.

                                           

                                          -Mark

                                            • Re: Taking over an Adtran system, and have issues...
                                              ets New Member

                                              Good afternoon Mark,

                                               

                                              I followed your directions to a tee, and the phone only booted one time, but DID wipe the configuration.  I tested on a second phone with the same results.  I drilled into the menu on a phone, and manually configured network settings.

                                               

                                              Here's my Putty output:

                                               

                                              NV7100>enable

                                              Password:

                                              NV7100#debug ip ftp-server

                                              NV7100#

                                               

                                               

                                              This run is on the FIRST factory reboot:

                                               

                                              2013.02.01 15:05:45 INTERFACE_STATUS.eth 0/4 changed state to down

                                              2013.02.01 15:05:49 INTERFACE_STATUS.eth 0/4 changed state to up

                                              NV7100#

                                               

                                               

                                              This run is on the SECOND reboot, after I entered network configuration:


                                              NV7100#

                                              2013.02.01 15:08:11 INTERFACE_STATUS.eth 0/4 changed state to down

                                              2013.02.01 15:08:14 INTERFACE_STATUS.eth 0/4 changed state to upFTP: USER command - Password required for 'admin'.

                                              FTP: USER command -  User 'admin' logged in .

                                              FTP: TYPE command - Type is set to I.

                                              FTP: CWD command - directory changed to '/ADTRAN'.

                                              FTP: PORT command - opening port from 10.10.0.10.

                                              FTP: BINARY data connection for ls (10.10.0.10,1027).

                                              FTP: NLST command - 'adtran_00a0c84a5cc6.txt' transfer complete.

                                              FTP: PORT command - opening port from 10.10.0.10.

                                              FTP: BINARY data connection for adtran_00a0c84a5cc6.txt (10.10.0.10,1028).

                                              FTP: RETR command - BINARY transfer complete.

                                               

                                               

                                              2013.02.01 15:08:57 IP.FTP SERVER (RETR) Transfer of file '/ADTRAN/adtran_00a0c84a5cc6.txt' complete for remote host '10.10.0.10'.FTP: USER command - Password required for 'admin'.

                                              FTP: USER command -  User 'admin' logged in .

                                              FTP: TYPE command - Type is set to I.

                                              FTP: CWD command - directory changed to '/ADTRAN'.

                                              FTP: PORT command - opening port from 10.10.0.10.

                                              FTP: BINARY data connection for ls (10.10.0.10,1030).

                                              FTP: NLST command - 'adtran_firmware_712.txt' transfer complete.

                                              FTP: PORT command - opening port from 10.10.0.10.

                                              FTP: BINARY data connection for adtran_firmware_712.txt (10.10.0.10,1031).

                                              FTP: RETR command - BINARY transfer complete.

                                               

                                               

                                              2013.02.01 15:09:03 IP.FTP SERVER (RETR) Transfer of file '/ADTRAN/adtran_firmware_712.txt' complete for remote host '10.10.0.10'.FTP: USER command - Password required for 'admin'.

                                              FTP: USER command -  User 'admin' logged in .

                                              FTP: TYPE command - Type is set to I.

                                              FTP: CWD command - directory changed to '/ADTRAN'.

                                              FTP: PORT command - opening port from 10.10.0.10.

                                              FTP: BINARY data connection for ls (10.10.0.10,1033).

                                              FTP: NLST command - 'adtran_boot.txt' transfer complete.

                                              FTP: PORT command - opening port from 10.10.0.10.

                                              FTP: BINARY data connection for adtran_boot.txt (10.10.0.10,1034).

                                              FTP: RETR command - BINARY transfer complete.

                                               

                                               

                                              2013.02.01 15:09:04 IP.FTP SERVER (RETR) Transfer of file '/ADTRAN/adtran_boot.txt' complete for remote host '10.10.0.10'.FTP: USER command - Password required for 'admin'.

                                              FTP: USER command -  User 'admin' logged in .

                                              FTP: TYPE command - Type is set to I.

                                              FTP: CWD command - directory changed to '/ADTRAN'.

                                              FTP: PORT command - opening port from 10.10.0.10.

                                              FTP: BINARY data connection for ls (10.10.0.10,1036).

                                              FTP: NLST command - 'adtran_global.txt' transfer complete.

                                              FTP: PORT command - opening port from 10.10.0.10.

                                              FTP: BINARY data connection for adtran_global.txt (10.10.0.10,1037).

                                              FTP: RETR command - BINARY transfer complete.

                                               

                                               

                                              2013.02.01 15:09:05 IP.FTP SERVER (RETR) Transfer of file '/ADTRAN/adtran_global.txt' complete for remote host '10.10.0.10'.FTP: USER command - Password required for 'admin'.

                                              FTP: USER command -  User 'admin' logged in .

                                              FTP: TYPE command - Type is set to I.

                                              FTP: CWD command - directory changed to '/ADTRAN'.

                                              FTP: PORT command - opening port from 10.10.0.10.

                                              FTP: BINARY data connection for ls (10.10.0.10,1039).

                                              FTP: NLST command - 'adtran_customer.txt' transfer complete.

                                              FTP: PORT command - opening port from 10.10.0.10.

                                              FTP: BINARY data connection for adtran_customer.txt (10.10.0.10,1040).

                                              FTP: RETR command - BINARY transfer complete.

                                               

                                               

                                              2013.02.01 15:09:06 IP.FTP SERVER (RETR) Transfer of file '/ADTRAN/adtran_customer.txt' complete for remote host '10.10.0.10'.FTP: USER command - Password required for 'admin'.

                                              FTP: USER command -  User 'admin' logged in .

                                              FTP: TYPE command - Type is set to I.

                                              FTP: CWD command - directory changed to '/ADTRAN'.

                                              FTP: PORT command - opening port from 10.10.0.10.

                                              FTP: BINARY data connection for ls (10.10.0.10,1042).

                                              FTP: NLST command - 'Language_English.xml' transfer complete.

                                              FTP: PORT command - opening port from 10.10.0.10.

                                              FTP: BINARY data connection for Language_English.xml (10.10.0.10,1043).

                                              FTP: RETR command - BINARY transfer complete.

                                               

                                               

                                              2013.02.01 15:09:13 IP.FTP SERVER (RETR) Transfer of file '/ADTRAN/Language_English.xml' complete for remote host '10.10.0.10'.FTP: USER command - Password required for 'admin'.

                                              FTP: USER command -  User 'admin' logged in .

                                              FTP: TYPE command - Type is set to I.

                                              FTP: CWD command - directory changed to '/ADTRAN'.

                                              FTP: PORT command - opening port from 10.10.0.10.

                                              FTP: NLST command - 'adtran_system.csv' cannot access.

                                              FTP: USER command - Password required for 'admin'.

                                              FTP: USER command -  User 'admin' logged in .

                                              FTP: TYPE command - Type is set to I.

                                              FTP: CWD command - directory changed to '/ADTRAN'.

                                              FTP: PORT command - opening port from 10.10.0.10.

                                              FTP: BINARY data connection for ls (10.10.0.10,1047).

                                              FTP: NLST command - 'iconpixmap.bmp' transfer complete.

                                              FTP: PORT command - opening port from 10.10.0.10.

                                              FTP: BINARY data connection for iconpixmap.bmp (10.10.0.10,1048).

                                              FTP: RETR command - BINARY transfer complete.

                                               

                                               

                                              2013.02.01 15:09:23 IP.FTP SERVER (RETR) Transfer of file '/ADTRAN/iconpixmap.bmp' complete for remote host '10.10.0.10'.

                                               

                                               

                                              I connected to FTP on the 7100, and here's the actual info from the csv file (in the ADTRAN folder):

                                               

                                              Personal data omitted...

                                               

                                              First Name,Last Name,E-mail Address,Home Phone,Mobile Phone,Business Street,Business Street 2,Business Street 3,Business City,Business Postal Code,Business State,Business Country,Business Phone,Business Fax,Company,Job Title

                                              Station 1,,,,,,,,,,,,1001,,,

                                              Station 2,,,,,,,,,,,,1002,,,

                                              Station 3,,,,,,,,,,,,1003,,,

                                              Station 4,,,,,,,,,,,,1004,,,

                                              Sandra ,M,,,,,,,,,,,1005,,,

                                              Dr. Vxxxxxxxx,,,,,,,,,,,,5xxxxxxxxx,,,

                                              Sandra M,,,,,,,,,,,,5xxxxxxxxx,,,

                                              Maria W,,,,,,,,,,,,5xxxxxxxxx,,,

                                              Hacxxxxx,,,,,,,,,,,,5xxxxxxxxx,,,

                                              Life Care Cxxxxx,,,,,,,,,,,,5xxxxxxxxx,,,

                                              La Sxxxxx,,,,,,,,,,,,5xxxxxxxxx,,,

                                              Quxxxxx,,,,,,,,,,,,5xxxxxxxxx,,,

                                               

                                               

                                              So, the phone can connect to the FTP and TFTP without an issue, and downloads everything EXCEPT for the csv file.  The csv file, as far as I know, is in the correct folder, and has the correct data.  The one thing that I did notice is that in the Putty debug, the phone is looking for "adtran_system.csv".  The only csv file that I can find in the entire file structure on the 7100 is "adtran_phonebook.csv".  With this, in my mind, either I have an issue with file naming, or am missing a core file somewhere.

                                               

                                              What's your diagnosis, Dr.?

                                               

                                              Thanks,

                                               

                                              Brandon

                            • Re: Taking over an Adtran system, and have issues...
                              Employee

                              I went ahead and flagged this post as "Assumed Answered". If any of the responses on this thread assisted you, please mark them as Correct or Helpful as the case may be with the applicable buttons. This will make them visible and help other members of the community find solutions more easily. If you still need assistance, we would be more than happy to continue working with you on this - just let us know in a reply.

                               

                              Thanks,

                              Matt