5 Replies Latest reply on Feb 11, 2013 2:03 PM by erik

    Customized logon form

    vmaxdawg05 Past_Featured_Member

      I've upgraded (installed from scratch) vWLAN 2.2.  The customized form that worked on vWLAN 2.1 no longer works on the 2.2 version.  The HTML is displayed, but the log on never gets processed.  It just drops me back into the form.

       

      I'm hoping that someone has already run into this.  My guess is that the form field names have changed or something like that.

       

      The attached is my form's custom html.

        • Re: Customized logon form
          erik Employee

          Thanks, vmaxdawg05. There is one edit that is required in your custom code for 2.2.1.x. At line 89, you will want to define the special attribute division for "!--USERS--" as "<div style="display:none;"><!--USERS--></div>." See the diff below, with the edited code in the left pane:

           

          diff.png

           

          Next, you will want to make sure that "Allow user logins" is enabled (which it is not by default) in the vWLAN configuration for this form, as is shown below:

           

          vwlan.png

           

          I tested this code change and the form is working on my vWLAN. Please make the change and see if this resolves it for you too.

           

          Regards,

          Erik

            • Re: Customized logon form
              vmaxdawg05 Past_Featured_Member

              Just checking the box “Allow user logins” made it work, but now it displays login and password fields on the left of the screen.  It actually uses the hidden ones in my code, but it is still displaying new fields on my form.  See attached.

                • Re: Customized logon form
                  erik Employee

                  Yes, without adding "<div style="display:none;"><!--USERS--></div>" in the code, the username and password fields will be exposed, even with "Enable complete customization..." enabled. Are you saying your current code has the "<div style="display:none;"><!--USERS--></div>" division tag, yet you are still seeing the credential fields? If so, please post this most recent code.

                   

                  Thanks,

                  Erik

                    • Re: Customized logon form
                      vmaxdawg05 Past_Featured_Member

                      This worked.  I was able to hide the output with the following html.

                       

                       

                       

                           

                      <!USERS></div>

                        • Re: Customized logon form
                          erik Employee

                          I went ahead and flagged this post as “Assumed Answered.”  If any of the responses on this thread assisted you, please mark them as either Correct or Helpful answers with the applicable buttons.  This will make them visible and help other members of the community find solutions more easily as well as award points to the users that helped you.  If you still need assistance, I would be more than happy to continue working with you on this - just let me know in a reply, but I think it sounds like you're good.

                           

                          Thanks,

                          Erik