2 Replies Latest reply on Feb 28, 2013 11:24 AM by david

    TA 924 Analog SIP Trunk

    voiptek New Member

      Greetings,

       

      I m beating my head against the wall with this one folks.

       

      We have deployed a TA 924 to a customers site. It is termination for a SIP trunk established on our SBC. Here is how it flows.

       

      Inbound call to DID >INVITE SBC > SBC INVITES Softswitch > Softswitch INVITES service port > service port invites public resource (public wan IP) on SBC > SBC Invites the TA 924 > TA924 Voice Trunk to FXO ports

       

      Everything works, with exception to the voice ring-group. When I dial the ring group number, it rings linear to the first unit and then the next. However, when I try to pick up the call, I get a dial tone.

       

      Here is the config.

       

      hostname "Example"

      enable password woot

      !

      clock timezone -8

      !

      ip subnet-zero

      ip classless

      ip routing

      !

      !

      ip domain-name "xxxxxx"

      ip domain-proxy

      ip name-server  4.2.2.2 10.0.58.10

      !

      !

      no auto-config

      !

      event-history on

      no logging forwarding

      no logging console

      no logging email

      !

      no service password-encryption

      !

      username "admin" password "xxxx"

      !

      banner motd #

      ==============================================================

      | This network is for the use of authorized users only.      |

      | Users (authorized or unauthorized) should have no explicit |

      | or implicit expectations of privacy.  Individuals using    |

      | this network system without authority, or in excess of     |

      | their authority, are subject to having all of their        |

      | activities on this network monitored, recorded, and        |

      | disclosed by system personnel. In the course of            |

      | monitoring individuals improperly using this network,      |

      | or in the course of system operation or maintenance or     |

      | for the purpose of protecting the rights or property of    |

      | the system provider, the activities of authorized users    |

      | may be monitored, recorded, and disclosed. Anyone using    |

      | this network expressly consents to such monitoring,        |

      | recording, and disclosure and is advised that if such      |

      | monitoring reveals possible evidence of criminal activity, |

      | system personnel may provide the resulting evidence to     |

      | law enforcement officials.                                 |

      ==============================================================

       

       

      #

      !

      !

      ip firewall

      no ip firewall alg msn

      no ip firewall alg mszone

      no ip firewall alg h323

      !

      !

      !

      !

      !

      no dot11ap access-point-control

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      qos map QMAP_LAN-IN 10

        match list ACL_OUTGOING-TO-WAN-TRUSTED-SUBNETS

        match list ACL_SRC-PROTO-xxxx-RTP

        set dscp 46

      qos map QMAP_LAN-IN 20

        match list ACL_OUTGOING-TO-WAN-TRUSTED-SUBNETS

        match list ACL_SRC-PROTO-xxxxx-SIP

        set dscp 26

      !

      qos map QMAP_WAN-OUT 10

        match dscp ef

        priority unlimited

      qos map QMAP_WAN-OUT 20

        match dscp af31

        priority unlimited

      !

      !

      !

      !

      interface eth 0/1

        description WAN

        ip address  192.168.44.22  255.255.255.0

        access-policy PCLASS_WAN-ZONE

        media-gateway ip primary

        traffic-shape rate 10000000

        qos-policy out QMAP_WAN-OUT

        no awcp

        no shutdown

      !

      !

      !

      !

      !

      !

      interface fxs 0/1

        no shutdown

      !

      interface fxs 0/2

        no shutdown

      !

      interface fxs 0/3

        no shutdown

      !

      interface fxs 0/4

        no shutdown

      !

      interface fxs 0/5

        no shutdown

      !

      interface fxs 0/6

        no shutdown

      !

      interface fxs 0/7

        no shutdown

      !

      interface fxs 0/8

        no shutdown

      !

      !

      !

      !

      !

      !

      !

      !

      !

      ip access-list extended ACL_DST-PROTO-VOXOX-RTP

        permit udp any  any range 2000 20000

      !

      ip access-list extended ACL_DST-PROTO-VOXOX-SIP

        permit udp any  any range 5060 5090

      !

      ip access-list extended ACL_INCOMING-FROM-WAN-TRUSTED-SUBNETS

        permit ip xxxxxx  any

        permit ip xxxxxxxxxxxx  any

        permit ip xxxxxxxxxxxx  any

        permit ip xxxxxxxxxx  any

        permit ip xxxxxxxxxxxx  any

        permit ip xxxxxxxxxxxxx  any

      !

      ip access-list extended ACL_OUTGOING-TO-WAN-TRUSTED-SUBNETS

        permit ip any  xxxxxxxxxxxxx

        permit ip any  xxxxxxxxxxxxx

        permit ip any xxxxxxxxxxxxx

        permit ip any  xxxxxxxxxxxxx

        permit ip any  xxxxxxxxxxxxx

        permit ip any  xxxxxxxxxxxxx

      !

      ip access-list extended ACL_PERMIT-ICMP

        permit icmp any  any

      !

      ip access-list extended ACL_SRC-PROTO-xxxx-RTP

        permit udp any range 2000 20000 any

      !

      ip access-list extended ACL_SRC-PROTO-xxxxx-SIP

        permit udp any range 5060 5090 any

      !

      !

      ip policy-class PCLASS_WAN-ZONE

        allow list ACL_INCOMING-FROM-WAN-TRUSTED-SUBNETS self

      !

      !

      !

      ip route 0.0.0.0 0.0.0.0 192.168.44.1

      !

      no ip tftp server

      no ip tftp server overwrite

      ip http server

      ip http secure-server

      ip snmp agent

      no ip ftp server

      no ip scp server

      no ip sntp server

      !

      !

      snmp-server community public RO

      !

      !

      !

      !

      ip sip

      ip sip udp 5060

      no ip sip tcp

      !

      !

      !

      voice feature-mode network

      voice flashhook mode transparent

      voice forward-mode network

      voice call-appearance-mode single

      voice conferencing-mode local

      !

      !

      !

      voice spre 1 *XX

      !

      !

      !

      !

      voice dial-plan 1 local NXX-NXX-XXXX

      voice dial-plan 2 long-distance 1NXX-NXX-XXXX

      voice dial-plan 3 international 011[]

      !

      !

      !

      !

      voice codec-list VOXOX_Default

        default

        codec g722

        codec g711ulaw

        codec g729

      !

      !

      !

      voice trunk T01 type sip

        description "VoIP Trunk To xxxxx"

        sip-server primary xxxxxx

        dial-string source to

        codec-group xxxx_Default

      !

      !

      voice grouped-trunk xxxxTRUNKGROUP

        trunk T01

        accept $ cost 0

      !

      voice user 12132850798

        connect fxs 0/1

        password "1234"

        sip-authentication password "1234"

        codec-group xxxxx_Default

      !

      voice user 12132850799

        connect fxs 0/2

        password "1234"

        sip-authentication password "1234"

        codec-group xxxxx_Default

      !

      voice ring-group 8001

        type linear

        description Main Ring Group

        num-rings 3

        max-inbound 8

        did "12132850889"

        member 12132850798

        login-member 12132850798

        member 12132850799

        login-member 12132850799

        no prefix

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      ip sip grammar request-uri host domain

      ip sip grammar from host domain

      ip sip grammar p-asserted-identity host domain

      ip sip grammar to host domain

      !

      !

      !

      ip rtp udp 19560

      ip rtp symmetric-filter

      !

      ip sdp grammar hold rfc3264

      !

      !

      line con 0

        no login

      !

      line telnet 0 4

        login local-userlist

        password xxxxx

        no shutdown

      line ssh 0 4

        login local-userlist

        no shutdown

      !

      sntp server xxxxx

      !

      !

      !

      !

      end

       

       

       

      So, the only thing I cannot configure correctly is the voice ring-group. Both phones ring if in "ring all" type or linear, but when the call is picked up, the phone provides a dial tone.

      Any and all assistance is very highly appreciated.

        • Re: TA 924 Analog SIP Trunk
          david Employee

          Voiptek,

           

          Thanks for posting!  Below is an example of the supported configuration for a hunt/ring group on a Total Access 900 series.

          voice forward-mode local

          !

          voice dial-plan 1 extensions 2000X

          !

          voice user 1001

            connect fxs 0/1

          !

          voice user 1002

            connect fxs 0/2

          !

          voice user 1003

            connect fxs 0/3

          !

          voice ring-group 6351

            type linear

            num-rings 4

            member 1001

            login-member 1001

            coverage internal 20002

            coverage internal 20003

          !

          voice ring-group 20002

            type linear

            num-rings 4

            member 1002

            login-member 1002

          !

          voice ring-group 20003

            type linear

            num-rings 4

            member 1003

            login-member 1003

          In this example, 6351 is inbound dialed number that goes into the linear hunt group.  The important details would be that only one voice user is applied to each ring group, all calls start with a primary ring group, and the other ring groups are reached via a coverage statement within the primary ring group.  "Ring all" ring groups are not supported on the Total Access 900 series, so any feature like that would need to be handled on the SIP server.  For further information regarding this configuration, reference Configuring Hunt Groups in SIP IPBGs. Feel free to respond to this email with any questions you may have.


          Thanks!

          David

          • Re: TA 924 Analog SIP Trunk
            david Employee

            Voiptek,

             

            I went ahead and flagged the "Correct Answer" on this post to make it more visible and help other members of the community find solutions more easily. If you don't feel like the answer I marked was correct, feel free to come back to this post and unmark it and select another in its place with the applicable buttons.  If you still need assistance, we would be more than happy to continue working with you on this - just let us know in a reply.

             

            Thanks,

            David