9 Replies Latest reply on Nov 19, 2013 4:48 AM by vmaxdawg05

    Slowwww https access from external IP

    holbor New Member

      I have two 7100 and a 7060, and when accessing them via the external IP address the interface is horribly slow.

      I thought perhaps it was an mtu issue or other?? but that does not seem to be the case.  NAT through the device likewise doe not seem to have issues.

      They are all using a sip trunk on the external interface,calls are fine, just the https interface (both admin and phone manager are horrible. 

       

      Thoughts?

       

      ADTRAN, Inc. OS version R10.7.0.E

        Checksum: CC54E250, built on Fri Apr 05 16:14:54 2013

      Hardware version 10A

      Boot ROM version A2.06.B1

        Checksum: E213, built on: Thu Jun 17 10:50:21 2010

      Copyright (c) 1999-2010, ADTRAN, Inc.

      Platform: NetVanta 7100, part number 1200796E1

      Serial number LBADTN1133AF989

      Flash: 33554432 bytes  DRAM: 134217728 bytes

       

      The interface shows no errors:

      eth 0/0 is UP, line protocol is UP

        Hardware address is 00:A0:C8:80:94:54

        Internet address is 123.231.123.231, netmask is 255.255.255.0  (via DHCP)

        IP MTU is 1500 bytes

        BW is 100000 Kbit

        100Mb/s, negotiated full-duplex, configured full-duplex

        ARP type: ARPA; ARP timeout is 20 minutes

        Last clearing of "show interface" counters: never

        5 minute input rate 49736 bits/sec, 99 packets/sec

        5 minute output rate 1448 bits/sec, 1 packets/sec

          Queueing method: fifo

          Output queue: 0/256/0 (size/max total/drops)

          Interface Shaper: NOT ENABLED

          91078 packets input, 6575042 bytes

          3603 unicasts, 87475 broadcasts, 0 multicasts input

          149 unknown protocol, 0 symbol errors, 0 discards

          0 input errors, 0 runts, 0 giants

          0 no buffer, 0 overruns, 0 internal receive errors

          0 alignment errors, 0 crc errors

          5543 packets output, 2499751 bytes

          5535 unicasts, 8 broadcasts, 0 multicasts output

          0 output errors, 0 deferred, 0 discards

          0 single, 0 multiple, 0 late collisions

          0 excessive collisions, 0 underruns

          0 internal transmit errors, 0 carrier sense errors

          0 resets, 0 throttles

        • Re: Slowwww https access from external IP
          holbor New Member

          Just for grins I added http access with the following:

            permit tcp 123.231.123..0 0.0.0.255  host 123.231.123.231 eq http

          nice quick response, but:

            permit tcp 123.231.123..0 0.0.0.255  host 123.231.123.231 eq https

          is horribly slow.

           

          Nobody??

          • Re: Slowwww https access from external IP
            charles Employee

            holbor

             

            Thank you for reporting this behavior.  This is a known AOS issue that is currently under investigation by our design engineering group.  The fix for this issue will be included in a future release for your product, but I do not yet know what specific software revision will contain this fix.  You can subscribe to Software (NV-7000) to receive email notifications about new software releases.  Until this fix is available, use HTTP for quicker access when managing this device.

             

            Thanks,

            Charles

            • Re: Slowwww https access from external IP
              charles Employee

              holbor

               

              I would also recommend trying different browsers for the HTTPS management.  I have found that Chrome, in particular, is significantly slower for this type of connection.

               

              Thanks,

              Charles

              • Re: Slowwww https access from external IP
                charles Employee

                holbor I went ahead and flagged the "Correct Answer" on this post to make it more visible and help other members of the community find solutions more easily. If you don't feel like the answer I marked was correct, feel free to come back to this post and unmark it and select another in its place with the applicable buttons.  If you still need assistance, we would be more than happy to continue working with you on this - just let us know in a reply. Thanks, Charles

                • Re: Slowwww https access from external IP
                  fiberman New Member

                  Has this problem been fixed yet, and if so in what release? Any recommendations? Does this affect all AOS products, or just the 7000 series?

                    • Re: Slowwww https access from external IP
                      charles Employee

                      fiberman

                       

                      Our design engineering team is still investigating this problem.  We have seen problems related to the browser type and version being used with the browser client opening up an large number of TCP connections to the AOS HTTPS server. 

                       

                      Can you provide some more information on the problem you are seeing and what are the browser type and version that is being used?

                       

                      Thanks,

                      Charles

                        • Re: Slowwww https access from external IP
                          fiberman New Member

                          I have this problem all the time. Using the latest version of AOS, and the latest version of Chrome. Issue is on TA908e's, Netvanta 3120's, and other AOS product. This has been an ongoing issue for over 2 year now I believe. Box is fast when accessing the web admin through the LAN, but slow as **** over the internet connection even when the box is connected to ultra fast fiber internet connections.

                            • Re: Slowwww https access from external IP
                              charles Employee

                              fiberman

                               

                              Thanks you for providing this information.  I have a few follow-up questions.

                               

                              Are you seeing this behavior with other browser types (firefox, IE, etc.)?

                               

                              Are you seeing the slow connection when using both HTTP and HTTPS over the Internet connection to the AOS device?

                               

                              When you say "Box is fast when accessing the web admin through the LAN", is that with both HTTP and HTTPS access?

                               

                              Thanks,

                              Charles

                            • Re: Slowwww https access from external IP
                              vmaxdawg05 Past_Featured_Member

                              I experience the same problem.  I temporarily enabled HTTP admin access to see if it is the same.  Actually, it is not nearly as slow as the HTTPS interface.  I would not suggest using HTTP for public admin access, but I will say that the HTTPS access is much slower than HTTP either on the LAN or WAN.  It's been like that for a long time.  Fortunately, SSH is super fast on both.