5 Replies Latest reply on Jun 28, 2013 8:58 AM by david

    No ringback on forwarded call from Comcast to Sprint

    ned New Member

      Comcast is delivering a PRI via Adtran TA908e. Everything is working fine except there is no ringback tone when we forward a PBX extension to a Sprint cell phone number. The Sprint cell phone rings but the caller doesn't hear anything until the call routes to the cell phone's voicemail. We can successfully forward calls to any other carrier. I am the PBX vendor trying to get it to work.

       

      Here are PRI logs from the PBX during an unsuccessful forward (Sprint):

       

      03/12/13 00:30:19.532 FALC==> Dchan 0: Layer3 (In), CRV=0x8001 PROCEEDING

      03/12/13 00:30:19.532 FALC==> Dchan 0:        IE(18): len=0x03 CHANNEL ID a9839700 00000000

      03/12/13 00:30:19.532 FALC==> T020323 02.1:23 Progress Indication, CutThru=0x1

      03/12/13 00:30:19.532 FALC==> T020323 02.1:23 Proceeding Indication, CutThru=0x1

      03/12/13 00:30:19.548 FALC==> Dchan 0: Layer3 (Out), CRV=0x846d PROGRESS

      03/12/13 00:30:19.548 FALC==> Dchan 0:        IE(1e): len=0x02 PROGRESS INDICATOR 80810000 00000000

      03/12/13 00:30:20.892 FALC==> Dchan 0: Layer3 (In), CRV=0x8001 ALERTING

      03/12/13 00:30:20.892 FALC==> Dchan 0:        IE(1e): len=0x02 PROGRESS INDICATOR 82880000 00000000

      03/12/13 00:30:20.892 FALC==> T020323 02.1:23 Alerting Indication, CutThru=0x1

      03/12/13 00:30:20.907 FALC==> T020301 02.1:01 Ringback not being sourced to network

      03/12/13 00:30:20.907 FALC==> Dchan 0: Layer3 (Out), CRV=0x846d ALERTING

       

      Here are PRI logs from the PBX during a successful forward (Non-Sprint):

       

      03/12/13 00:34:42.188 FALC==> T020323 02.1:23 Progress Indication, CutThru=0x1

      03/12/13 00:34:42.188 FALC==> T020323 02.1:23 Proceeding Indication, CutThru=0x1

      03/12/13 00:34:42.188 FALC==> Dchan 0: Layer3 (Out), CRV=0x846f PROGRESS

      03/12/13 00:34:42.188 FALC==> Dchan 0:        IE(1e): len=0x02 PROGRESS INDICATOR 80810000 00000000

      03/12/13 00:34:43.751 FALC==> Dchan 0: Layer3 (In), CRV=0x8001 PROGRESS

      03/12/13 00:34:43.751 FALC==> Dchan 0:        IE(1e): len=0x02 PROGRESS INDICATOR 82880000 00000000

      03/12/13 00:34:43.751 FALC==> T020323 02.1:23 Progress Indication, CutThru=0x1

      03/12/13 00:34:43.751 FALC==> Dchan 0: Layer3 (Out), CRV=0x846f PROGRESS

      03/12/13 00:34:43.751 FALC==> Dchan 0:        IE(1e): len=0x02 PROGRESS INDICATOR 80810000 00000000

       

      Is there anything that can be done from the Adtran side of things?

        • Re: No ringback on forwarded call from Comcast to Sprint
          jwable Frequent Visitor

          Ned,

              Just out of curiosty what happens if you call the same Sprint number from a different phone (like a cellphone or analog phone), I am wondering if they have some sort of special ring back tone and Comcast is not returning a proper ringing message back to the Adtran because of it and in turn the Adtran is not able to notify the PBX of the ringing status.  The audio portion of the call does not kick in until the call is established so any special ring back tones would not be heard on the PBX side.  To verify all this from the Adtran perspective we would need to see a debug sip stack messages from the Adtran during an active call to the number in question, that will show if the Adtran is recieving the proper SIP message from the carrier or not.

           

          John Wable

            • Re: No ringback on forwarded call from Comcast to Sprint
              ned New Member

              It rings like normal if I call from a cell phone or analog phone. Actually they have configured a custom ringtone on the cell phone until we can get the issue fixed. The callers that are forwarded hear the custom ringtone every time. I don't have access to the actual logs at this moment, but here is some info from the Comcast engineer that I have been working with:

               

               

              No ring:

               

              When  we receive a SIP:180 ringing without SDP on the forward leg we send an ALERT message with Progress Indicator (In band Audio) (IAD generated ringback) to the PBX.  The PBX sends an Alert without PI (No in-band-audio) to the originating side.  The IAD does not respond to that and setup a 180 ringing without SDP to the originating end because,  when the Initial setup was sent to the PBX, it sent us a PROGRESS message with PI (Not End to End ISDN) which is another way of saying In Band Audio.  At that point we
              expect audio from the PBX for the duration.

               

               

              (Ring)Works:

               

              When we receive a SIP:180 ringing with SDP on the forward leg, we send a PROGRESS message with PI (In band audio) (far end ringback) to the PBX. The PBX sends a PROGRESS message with PI (Not End to End ISDN) to the originating side and ringback is heard.

               

              Action Items:

               

                    1.  Have the customer see if they can change the PBX to not send that Not End to End ISDN progress indicator when receiving the original call. Hopefully, this will fix the issue.

               

                   2. Have the customer work with their vendor/manufacturer to determine why the PBX is not passing the audio through to A side Alerting with PI received on the B side.

               

                   3. Open ticket with Sprint to see if they can always send a 180 ringing with SDP to us. You will probably need to work with them live and give them where the call is going out via when we get the 180 without SDP.  Some of the previous traces may have that.

               

               

              That is all the suggestions I have at this time.  If they ask why it was working before and is not
              working now, they may have been sending progress message all the time whereas
              we send the alert based on where the ringback is from.  Both methods are
              correct and the PBX should properly work with either one.

            • Re: No ringback on forwarded call from Comcast to Sprint
              david Employee

              Ned,

               

              I wanted to check in with you to see if you found a solution to this problem.  If not, please call Adtran Technical Support at 888-423-8726.  We will likely need to see the complete configuration on the unit and the following debug commands for a test call.

               

              debug sip stack message

              debug voice verbose

              debug isdn L2-formatted

               

              We also may need to get a DSP capture from the unit for any to record any inband audio.  This process is described in the document, How to Perform a DSP capture .

               

              Thanks!

              David