1 Reply Latest reply on Sep 26, 2013 2:10 PM by matt

    Network two 7100 together with VPN/GRE IPSEC

    touristsis Visitor

      Hi,  I'm trying to network 2 7100 together with VPN/GRE IPSEC.  I can't seems to get the rtp to work.  Any help is appreciated.

      Here is what I did.

      I created a vpn

      Then set it to GRE over VPN

      I've created a loopback ip for both system.

      Then I tie the system together. (I've used it loopback ip the sip server).

       

      Here is where I think the problem is.

      Every ip interface has ip media gateway.

       

      Public interface - what should the ip media gateway be set to?

      Tunnel interface - what should the ip media gateway be set to?
      Prinvate interface - what should the ip media gateway be set to?

        • Re: Network two 7100 together with VPN/GRE IPSEC
          Employee

          There are a couple of ways to make this work.  If you use a loopback interface you will want to assign it an unused IP address from the voice vlan with a 32 bit mask. You can have the tunnel 1 and private interface point to the loopback interface with the media-gateway ip loopback 1 command.  If you do that, the SIP trunk configuration on the remote unit would need to point to the local loopback 1 interface IP address.  The SIP server configured on the local phones (IP Phone Configs > select a phone and click edit > go to the Phone Settings tab) would also need to point to the local loopback 1 interface IP address.  The public interface would not matter in this case unless a public SIP trunk is used.  This approach is outlined in our SIP Networking Guide here:

          Configuring SIP Trunking and Networking for the NetVanta 7000 Series

           

          Alternatively, you can omit the use of a loopback interface since the tunnel has its own IP address that can be used for media.  If this method is used the tunnel 1 interface would be configured with the normal media-gateway ip primary command. The private interface would also be configured with the media-gateway ip primary command. The remote SIP trunk would need to point to the local tunnel 1 interface IP address (not the tunnel source address), and the SIP server for the local phones would need to be configured for the local voice vlan IP address.

           

          Thanks,
          Matt