18 Replies Latest reply on Sep 23, 2013 6:41 AM by matt

    T1 clock source question

    touristsis Visitor

      Hi,

       

      I have a customer with a 7100.  They have 3 T1 card in the system.  T1 1/1, T1 2/1, and T1 2/2.

      T1 2/1 and T1 2/2 are bonded together.

      T1 1/1 are not in use.

      However under T1 1/1, there are two commands.  system-timing primary and system-timing secondary.

      Is this correct?

       

      They are reporting very slow connection and latency problem.  Can this be the cause?

       

      What does clock source through mean?  It's clocking off another system?  I've seen this on a few other 7100 that they have.

        • Re: T1 clock source question
          jayh Hall_of_Fame

          touristsis wrote:

           

          Hi,

           

          I have a customer with a 7100.  They have 3 T1 card in the system.  T1 1/1, T1 2/1, and T1 2/2.

          T1 2/1 and T1 2/2 are bonded together.

          T1 1/1 are not in use.

           

          To what are the bonded T1 2/1 and T1 2/2 connected?

           

          However under T1 1/1, there are two commands.  system-timing primary and system-timing secondary.

          Is this correct?

           

          Are you sure those are under T1 1/1 and not global commands?

           

          They are reporting very slow connection and latency problem.  Can this be the cause?

           

          It could be.  Try the command "show interface t1 2/1 performance" and the same for 2/2 and look for slip seconds.

           

          Here's the deal.  T1 circuits are by nature point-to-point and synchronous. 

           

          • A T1 interface can either source timing (clock) or recover it from the T1 line.
          • Every T1 circuit should have exactly one interface sourcing clock, the other end should recover it from the T1 line.
          • If a circuit is connected to a carrier's equipment such as a Telco PRI or Internet router, then that side almost always will be providing an accurate clock.
          • If a circuit is ordered as a point-to-point to connect two customer sites, then neither side will usually provide clock.

           

          Case 1:  Bonded T1 interfaces T1 2/1 and T1 2/2 are coming from a carrier such as an ISP or Telco-provided PRI, then you want the system timing to be primary to T1 2/1 and secondary to 2/2.  This ensures that the system is in sync with what is being sent by the carrier.  The carrier will provide clock on its interface and the Adtran will recover that clock from T1 2/1.  Should T1 2/1 fail, then the carrier clock on T1 2/2 will be used.  Because they're bonded and coming from the same carrier, the clock on T1 2/1 and 2/2 will be identical.  Same deal with a single telco T1, set your device to take system timing from that interface.

           

          Case 1a:  Just like Case 1 but you also deliver PRI service to a customer PBX.  Set your timing as above.  Your local Adtran will recover the clock from the carrier and source it to the customer PBX.  Tell the customer to set the PBX to recover clock from your PRI.

           

          Case 2:  No external T1 interface connects to a carrier or ISP.  The only T1s in the system are the Adtran device itself providing T1/PRI service to a customer's PBX on premise.  Set system timing to "Internal".  Because there is no carrier-sourced clock, you'll generate one internally.  Tell the customer to set the PBX to recover clock from your PRI.

           

          Case 3:  Two Adtran devices (or one and a Cisco, etc.) connected to no external carriers with only a T1 between them.  Set one side to internal and the other to system timing from the T1 connected to the line.  It doesn't matter which end is which, but one side must be internal and the other line.

           

          Problem cases:

           

          If both ends of a circuit provide clock and both are not connected to a high-accuracy source such as an atomic standard, then there will be slips as the clocks fight each other.  These slips result in corrupt data, clicks in audio, and fax transmissions that print slanted.

           

          If neither end of a circuit provides clock, the circuit will probably come up but then gradually drift either too high or too low in frequency for the electronics to handle, then go down and retrain.  This may occur once every minute or once every six months and can be tough to troubleshoot.

           

          Good practice:


          Treat every T1 as a point-to-point circuit with two ends.  Ensure that exactly one end provides the clock timing and the other recovers it from the T1 circuit.  If a T1 is connected to equipment at a carrier or telco, its clock timing will likely be more accurate than what you can generate internally.  Ask the provider if they are providing clock and set your gear to recover from the carrier.

            • Re: T1 clock source question
              touristsis Visitor

              Thanks Jay, that was very helpful.

               

              The bonded T1 2/1 and 2/2 are connected to ISP MPLS Circuit.

               

              I'm 100% sure the command is under T1 1/1 and not global command.

              see below

              interface t1 1/1

                description LEC ID: XXXXXXXXXXXXX

                system-timing primary

                system-timing secondary

                tdm-group 1 timeslots 1-24 speed 64

                no shutdown

                • Re: T1 clock source question
                  jayh Hall_of_Fame

                  Are you seeing slips on T1 2/1 and T1 2/2?

                   

                  Try the following:

                   

                  interface t1 1/1

                    description unused

                    no system-timing primary

                    no system-timing secondary

                    shutdown

                   

                  interface t1 2/1

                    system-timing primary

                   

                  interface t1 2/2

                    system-timing secondary

                    • Re: T1 clock source question
                      touristsis Visitor

                      The error looks clean.  Any other recommendation to look at?

                        • Re: T1 clock source question
                          jayh Hall_of_Fame

                          If no slip seconds or errors on the T1s, the problem is likely not clocking.

                           

                          Other things to check:

                           

                          • 2 x T1 is only 3 mbits/s of bandwidth.  Is the utilization excessive?
                          • Verify multilink fragmentation and interleave match the other side.  For T1 and above I usually disable fragmentation and interleave.

                           

                          What is the customer expecting and what are you experiencing?

                            • Re: T1 clock source question
                              touristsis Visitor

                              I’M so confused.  How is this even working?

                               

                              Under system clock, it is set to T1 1/1 for both Primary and Secondary.


                              T1 1/1 is not even alive?


                              How can this even work?


                              Can you just glance at the errors and config file for me attached?


                              I’ve ran the command show int t1 2/1 and 2/1 performance and yet nothing.


                              I’ve also ran SHOW INT1 T1 1/1


                              Show int t1 2/1

                               

                              Show int t1 2/2

                               

                              And show running-config

                               

                              Can you tell me if anything is way out of line?

                                • Re: T1 clock source question
                                  jayh Hall_of_Fame

                                  touristsis wrote:

                                   

                                  I’M so confused.  How is this even working?

                                   

                                  Under system clock, it is set to T1 1/1 for both Primary and Secondary.

                                   

                                  T1 1/1 is not even alive?

                                   

                                  How can this even work?

                                   

                                  That determines what the system will use for clocking any TDM resources it uses itself.  Because you don't have any outbound PRI or T1 interfaces anywhere else it isn't critical.  However, it's probably best to set the system clock to 2/1 primary and 2/2 secondary, and have each of them clock from line as described earlier.

                                • Re: T1 clock source question
                                  touristsis Visitor

                                  How can I find out if the bandwidth is maxing out? Is there a way to calculate?

                                  I think fragmentation and interleave is already off.

                                    • Re: T1 clock source question
                                      jayh Hall_of_Fame

                                      touristsis wrote:

                                       

                                      How can I find out if the bandwidth is maxing out? Is there a way to calculate?

                                      I think fragmentation and interleave is already off.

                                      Verify that interleave/fragmentation is off on the other end as well by checking with the carrier. 

                                       

                                      Bandwidth saturation can be estimated by the 5-minute averages. In the example you provided it doesn't seem excessive, but could be if bursty.  You may need to employ QoS to prefer certain types of traffic.  Specifically what is the customer complaint? 

                                       

                                      From the zip file you posted, I would suggest:

                                       

                                      interface t1 2/2

                                        clock source line


                                      as well as the clock commands I suggested earlier for the interfaces.

                                       

                                      Also, change all of the passwords on the device, and add the line

                                       

                                      service password-encryption

                                       

                                      to the config. You may want to strip passwords from configurations before posting them in the future. 

                                        • Re: T1 clock source question
                                          touristsis Visitor

                                          Wow, that's the first time I see the password on the config file.  It normally are just *****

                                          Good thing we caught that.

                                          I didn't realize that file was sent to the post and not just support.

                                          I've remove the file already.

                                          That router is not accessible from outside, so not to big of a deal.
                                          I will still change password and service password-encryption.

                                          Thanks.

                                            • Re: T1 clock source question
                                              jayh Hall_of_Fame

                                              OK, based on the T1 performance error counts not showing slips or excessive errors, I don't think you have a clocking or timing issue.  T1 2/2 is taking its clock from T1 2/1 which works as they're from the same source but isn't optimum as it will cause problems if T1 2/1 goes down, so make the change to time 2/2 from line. 

                                               

                                              What is the customer's specific complaint? 

                                                • Re: T1 clock source question
                                                  touristsis Visitor

                                                  Namely major delay on the network.  Even when no one except the IT Admin is using the network after hours.  Excessive delay when pinging.

                                                    • Re: T1 clock source question
                                                      jayh Hall_of_Fame

                                                      OK, you'll probably want to get some traceroutes and more detail to troubleshoot that.  If this is an MPLS network with no split-tunneling and he is going to the Internet he may have latency based on speed-of-light delay to the remote firewall and back to the source.

                                                       

                                                      Verify fragmentation and interleave is disabled on the other end of the T1 circuit and you can probably rule out that link as the source of the problem.

                                                       

                                                      Also a pair of T1s which was considered huge bandwidth a few years ago may seem slow compared to some residential cable connections today. 

                                                        • Re: T1 clock source question
                                                          touristsis Visitor

                                                          How can I verify that fragmentation and interleave is disabled on the Adtran?  How about the other end of the T1 circuit?  Ask the ISP?

                                                            • Re: T1 clock source question
                                                              jayh Hall_of_Fame

                                                              touristsis wrote:

                                                               

                                                              How can I verify that fragmentation and interleave is disabled on the Adtran?

                                                              interface ppp 1

                                                                 no ppp multilink fragmentation

                                                                 no ppp multilink interleave


                                                              How about the other end of the T1 circuit?  Ask the ISP?

                                                               

                                                              Yes.  Also ask if they're seeing errors on their side.

                                                               

                                                              You'll likely need MTR or some other tools to identify the source of the latency or performance issues.  I suspect from what you've supplied so far that the trouble isn't with the T1 links. 

                                      • Re: T1 clock source question
                                        Employee

                                        touristsis,

                                         

                                        Were you ever able to resolve this issue?  If so, please come back to this post and provide an update so others can benefit from the solution.  Also, please make sure to select a correct answer and any helpful answers from the replies in this post with the applicable buttons. 

                                         

                                        Thanks,
                                        Matt

                                        • Re: T1 clock source question
                                          Employee

                                          I went ahead and flagged this post as "Assumed Answered". If any of the responses on this thread assisted you, please mark them as Correct or Helpful as the case may be with the applicable buttons. This will make them visible and help other members of the community find solutions more easily. If you have any additional information on this that others may benefit from, please come back to this post to provide an update. If you still need assistance, we would be more than happy to continue working with you on this - just let us know in a reply. 

                                           

                                          Thanks,

                                          Matt