5 Replies Latest reply on Oct 18, 2013 6:42 PM by mrkylewood

    Netvanta 6355 and HP Procurve 2530-48G

    mrkylewood New Member

      I am trying to to pass vlan 1 and vlan 3 (vlan 1 for computers 192.168.1.0 and vlan 3 for guest wireless 192.168.5.0) thourgh the gigabit port on the 6355.

      a

      On the hp, I have port 48 tagged in vlan1 and vlan 3, but once I connect port 48 of the hp switch to the gigabit port on the netvanta, no traffic is passed from the netvanta the switch.  The switch becomes isolated.

       

      Here is the config for the HP

       

       

      ; J9775A Configuration Editor; Created on release #YA.15.10.0003

      ; Ver #03:03.17.27:30

      hostname "HP-2530-48G"

      snmp-server community "public" unrestricted

      vlan 1

         name "DEFAULT_VLAN"

         no untagged 41-43

         untagged 1-40,44-52

         tagged 48

         ip address 192.168.1.253 255.255.255.0

         exit

      vlan 3

         name "Guest VLan"

         untagged 41-43

         tagged 48

         no ip address

         exit

      no dhcp config-file-update

      password manager

       

       

      Here is the config for the netvanta:

       

       

       

       

                                                                         

                                                                         

                                                 

      !

      !

      ! ADTRAN, Inc. OS version R10.6.0.E

      ! Boot ROM version A2.06.B1

      ! Platform: NetVanta 6355, part number 1200740E1

      ! Serial number LBADTN1248AK213

      !

      !

      hostname "NAACP_One_Voice"

      enable password encrypted

      !

      !

      clock timezone -6-Central-Time

      !

      ip subnet-zero

      ip classless

      ip routing

      ipv6 unicast-routing

      !

      !

      domain-proxy

      name-server 66.175.*.* 66.175.*.*

      !

      !

      no auto-config

      auto-config authname adtran encrypted password

      !

      event-history on

      no logging forwarding

      no logging email

      !

      service password-encryption

      !

      username "admin" password encrypted ""

      username "polycomftp" password encrypted ""

      !

      !

      ip firewall

      ip firewall stealth

      no ip firewall alg msn

      no ip firewall alg mszone

      no ip firewall alg h323

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      no dot11ap access-point-control

      !

      !

      !

      !

      !

      !

      ip dhcp database local

      !

      ip dhcp pool "LAN_pool"

        network 192.168.1.0 255.255.255.0

        dns-server 192.168.1.1

        netbios-node-type h-node

        default-router 192.168.1.1

        ntp-server 192.168.1.1

        timezone-offset -6:00

        option 157 ascii TftpServers=0.0.0.0,FtpServers=10.10.20.1:/ADTRAN,FtpLogin=polycomftp,FtpPassword=password,Layer2Tagging=True,VlanID=2

      !

      ip dhcp pool "VoIP_pool"

        network 10.10.20.0 255.255.255.0

        dns-server 10.10.20.1

        netbios-node-type h-node

        default-router 10.10.20.1

        ntp-server 10.10.20.1

        timezone-offset -6:00

        option 66 ascii http://

      !

      ip dhcp pool "Guest Wireless"

        network 192.168.5.0 255.255.255.0

        dns-server 192.168.5.1

        default-router 192.168.5.1

        ntp-server 192.168.5.1

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      vlan 1

        name "Default"

      !

      vlan 2

        name "VoIP"

      !

      vlan 3

        name "Guest Wireless"

      !

      !

      interface eth 0/0

        description wan

        ip address  76.8.*.*  255.255.255.248

        ip access-policy Public

        media-gateway ip primary

        no awcp

        no shutdown

        no lldp send-and-receive

      !

      !

      interface eth 0/1

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/2

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/3

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/4

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/5

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/6

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/7

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/8

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/9

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/10

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/11

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/12

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/13

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/14

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/15

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/16

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/17

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/18

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/19

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/20

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/21

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/22

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/23

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      interface eth 0/24

        spanning-tree edgeport

        no shutdown

        switchport voice vlan 2

      !

      !

      !

      interface gigabit-eth 0/1

        spanning-tree edgeport

        no shutdown

        switchport mode trunk

      !

      !

      interface gigabit-eth 0/2

        spanning-tree edgeport

        no shutdown

        switchport mode trunk

      !

      !

      !

      !

      interface vlan 1

        ip address  192.168.1.1  255.255.255.0

        ip access-policy Private

        media-gateway ip primary

        no shutdown

      !

      interface vlan 2

        ip address  10.10.20.1  255.255.255.0

        ip access-policy Private

        media-gateway ip primary

        no shutdown

      !

      interface vlan 3

        ip address  192.168.5.1  255.255.255.0

        ip mtu 1500

        ip access-policy Private

        media-gateway ip primary

        no shutdown

      !

      !

      interface fxs 0/1

        no shutdown

      !

      interface fxs 0/2

        no shutdown

      !

      !

      interface fxo 0/1

        no shutdown

      !

      interface fxo 0/2

        no shutdown

      !

      !

      !

      !

      !

      !

      !

      !

      ip access-list standard wizard-ics

        remark Internet Connection Sharing

        permit any

      !

      !

      ip access-list extended InterVLAN

        permit ip 10.10.10.0 0.0.0.255  10.10.20.0 0.0.0.255  

        permit ip 10.10.20.0 0.0.0.255  10.10.10.0 0.0.0.255  

      !

      ip access-list extended self

        remark Traffic to NetVanta

        permit ip any  any     log

      !

      ip access-list extended SIP

        ! Implicit permit (only for empty ACLs)

      !

      ip access-list extended web-acl-3

        permit tcp any  any eq https   log

        permit tcp any  any eq ssh   log

      !

      ip access-list extended web-acl-6

        permit tcp any  any eq https   log

        permit tcp any  any eq ssh   log

        permit icmp any  any  echo   log

      !

      ip access-list extended web-acl-7

        permit tcp any  any eq 5060   log

        permit udp any  any eq 5060    log

      !

      !

      !

      !

      ip policy-class Private

        allow list self self

        nat source list wizard-ics interface eth 0/0 overload

      !

      ip policy-class Public

        allow list web-acl-6 self

        allow list web-acl-7 self

      !

      !

      !

      ip route 0.0.0.0 0.0.0.0 76.8.*.*

      !

      tftp server

      tftp server overwrite

      http server

      http secure-server

      no snmp agent

      ip ftp server

      ip ftp server default-filesystem flash

      no ip scp server

      ip sntp server

      ip sntp server send-unsynced

      !

      !

      !

      !

      !

      !

      !

      auto-link

      auto-link server

      !

      !

      ip sip

      ip sip udp 5060

      no ip sip tcp

      !

      !

      !

      voice feature-mode network

      voice forward-mode network

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      ip sip proxy

      ip sip proxy transparent

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      line con 0

        login

        password encrypted

      !

      line telnet 0 4

        login

        password encrypted

        no shutdown

      line ssh 0 4

        login local-userlist

        no shutdown

      !

      sntp server time.nist.gov

      !

      !

      !

      !

      !

      !

      end

        • Re: Netvanta 6355 and HP Procurve 2530-48G
          mrkylewood New Member

          Any suggestions?

          • Re: Netvanta 6355 and HP Procurve 2530-48G
            david Employee

            Mrkylewood,

             

            Thanks for posting.  By default, the Adtran assumes VLAN 1 is untagged on trunk ports.  I've never configured an HP switch, but I think you will want to change VLAN 1 to "untagged" on port 48.

             

            vlan 1

               untagged 48


            Let me know if this fixes the issue.

             

            Thanks!

            David

              • Re: Netvanta 6355 and HP Procurve 2530-48G
                mrkylewood New Member

                David,

                 

                If I understand correctly, Adtran's terminology "trunk" is the same thing as HP's "tag" which means a port that is carrying vlan data.

                 

                Does the adtran have to specify on the trunk ports that they are "trunking" as well as what vlan/s (vlan 1, vlan 3 etc) they are passing?

                 

                Also, is there a way to force the adtran to tag vlan 1 traffic on the trunk port?

                 

                Sorry if these questions aren't making a ton of sense, I did a crash course of Vlan's this past weekend.

                 

                All I am wanting to do is have a 3 vlans:  Vlan 1 for computers, Vlan2 for voice, Vlan 3 for guest.  I want to pass this vlan information to my hp procur\rve switch so I may use vlan capable devices through the HP switch.

                  • Re: Netvanta 6355 and HP Procurve 2530-48G
                    david Employee

                    Mrkylewood,

                     

                    I think the next piece we need to discuss is the concept of a "native VLAN".  Essentially, the native VLAN is the only VLAN on an 802.1q trunk that is sent "untagged".  It is somewhat standard practice that VLAN 1 is considered the native VLAN on a trunk port, and this is our default setting shown below.

                     

                    interface eth 0/1

                      switchport mode trunk

                      switchport trunk native vlan 1

                    If you want VLAN 1 to be tagged on that link, you could create a new VLAN and mark is as native.  In other words, if you didn't want to change your settings on the HP, you might add something like this to your Adtran unit's comfiguration.

                     

                    vlan 20

                      name "vlan20"

                    !

                    interface gigabit-eth 0/1

                      vlan  switchport mode trunk

                      vlan  switchport trunk native vlan 20


                    In this case, we are essentially creating a "dummy" VLAN and setting it to native.  This way, all your other defined VLANs will be tagged on this port.

                    Hope this help clear things up,

                    David