2 Replies Latest reply on Nov 8, 2013 1:54 PM by quazar66

    SIP Alias to Fax machine issue

    quazar66 New Member

      After upgrading to R10.8.1.E we are having a problem with incoming faxes.  The phone number is an SIP alias from our SIP provider.  The FAX machine is hooked to FXS 2/4.  If I put an analog phone on the the FXS port, the phone does ring, but the FAX machine does not pickup.  Is there some option or feature that I need to set on this User Account so that the FAX machine will detect the call?

       

      Here is the user config:

       

      Nettech_NV7100#show running-config voice user 394
      Building configuration...
      !
      !
      !
      voice user 394
        connect fxs 2/4
        cos "normal_users"
        first-name "Fax"
        last-name "Nettech-Main"
        password "1234"
        no call-waiting
        no fwd-courtesy
        no special-ring-cadences
        no message-waiting
        num-rings 6
        sip-identity 8148365228 T05
        sip-authentication password "1234"
        modem-passthrough detection-time 0
        t38
        no alc
        no nls
        no echo-cancellation
        codec-list g711_first
        no voicemail new-user
        voicemail auth-mode password
        no voicemail auto-play
        no voicemail envelope-play
        voicemail password "1234"
        voicemail notify schedule Sunday 12:00 am
      !
      !
      end

        • Re: SIP Alias to Fax machine issue
          markfreeman Employee

          First thing is try changing the Detection Timespan from 0 to 8 seconds. The default should be 8, so not sure why yours it set to 0.

           

          If that doesn’t work, then you might want to disable Modem Passthrough and manually set up the port to receive a fax.

           

          Create a G.711ulaw only codec list and assign it to the interface and then  make sure VAD and Echo Cancellation are turned off.

           

          That should take care of it. Post back was fixed it.

           

          More info on those settings;

           

          Modem Passthrough

          When Modem Passthrough is enabled and an existing call detects a modem or fax tone, the

          unit will automatically renegotiate with the far end to be modem-compatible (switch to

          G.711 codec automatically, echo cancellation and VAD are disabled). When connecting

          analog port to a fire alarm system, DO NOT use modem passthrough. Manually assign a

          G711 only codec, then disable VAD and echo cancellation.

          Detection Timespan

          Specifies the fax and/or modem detection time length value. Recommend starting with 8

          seconds. Range is 0-8 Seconds

           

          -Mark