3 Replies Latest reply on Jan 24, 2014 11:46 AM by jayh

    There is a speed/duplex mismatch on port swx 0/1

    ajenns New Member

      Hi guys,

       

      I am new to this product and not an established network wizard by any means so I could use some help.  My situation is that my ADTran router 3448 is throwing an error:

       

      There is a speed/duplex mismatch on port swx 0/1 with ProCurve Switch 2520G-24-PoE.

        Local: 100M Full Duplex

        Neighbor: 1G Full Duplex


      Besides this error, I do not actually have the ProCurve 2520 switch plugged into my router.  I have another unmanaged switch in between the two.  I have port 1 of my ADTran router going into a unmanaged ProCurve 1410 16G switch.  Then from port 18 there going into port 20 on a Procurve 2520G managed switch.  I have confirmed that my swx 0/1 on the router is set to 100/Full, and I have confirmed that Port 20 on the ProCurve 2520 is also set to automatic.


      I am not totally sure why I am getting this error.  The real issue I am trying to solve is that I am not getting the full bandwidth after my router, but I am before the router.  I have noticed there is QoS rules setup, but I want to first solve the error before trying to figure that out.


      Thanks

        • Re: There is a speed/duplex mismatch on port swx 0/1
          jayh Hall_of_Fame

          ajenns wrote:

           

          Hi guys,

           

          I am new to this product and not an established network wizard by any means so I could use some help.  My situation is that my ADTran router 3448 is throwing an error:

           

          There is a speed/duplex mismatch on port swx 0/1 with ProCurve Switch 2520G-24-PoE.

            Local: 100M Full Duplex

            Neighbor: 1G Full Duplex

           

          This is a common problem with Adtran switches and both Polycom phones and some other devices.  There is a later-2 protocol called LLDP by which directly-connected devices exchange information.  Adtran's implementation of it doesn't always agree with other vendors in terms of speed and duplex reporting, so you get these errors.

           

          Inserting an unmanaged switch between two LLDP-speaking devices will also often trigger this error.  The easiest fix is to just disable LLDP on that port.  Go into the 3448 and do the following:

           

          config t

          interface sw 0/1

            no lldp send-and-receive

           

          This will stop the spew.  The error message really doesn't make sense when you think about it.  If one side is gigabit and the other side is 100-megabits the link won't come up at all.  Adtran should stop generating these errors with regard to speed.  Reporting duplex errors makes sense, but the speed mismatch error reports are 100% bogus if the link is up. 

           

          There is something else that's troublesome....

           

            I have confirmed that my swx 0/1 on the router is set to 100/Full, and I have confirmed that Port 20 on the ProCurve 2520 is also set to automatic.

          You shouldn't manually set one side of an interface speed/duplex and leave the other automatic.  Either set both sides to 100/full (or gigabit/full if both support it) or let both sides auto-negotiate.  If both support auto and behave well, then do that. 

           

          When one side of a link is manually configured for speed/duplex, it stops attempting to negotiate with the other side.  The other side then will default to half-duplex and you'll have slow speeds and lots of errors that show up as collisions, runts, and CRC errors.  So either set both to full-duplex at the highest compatible speed, or if possible set both to auto speed and duplex and ensure that both come up full-duplex at the fastest mutually-accepted speed.  This may solve your performance issue. 

           

          As far as full bandwidth, not all devices with 100-mbit or gigabit physical ports are capable of routing packets at those speeds.  The data sheets will give some indication as to what you're likely to get, but full wire-speed on layer-3 routers and switches requires some fairly beefy (and pricey) hardware.

           

          I bet that fixing the duplex mismatch will solve the problem.