4 Replies Latest reply on Apr 7, 2014 9:40 AM by levi

    "no ip ftp server" doesn't work

    royh New Member

      I have NV3448 running NV3448A-R10-9-1-E.biz.  The default setting after I "write erase" to clear the startup config and then reload is "ip ftp server default-filesystem flash".  I am trying to remove this setting by running the "ip ftp server" but it doesn't take.

      =================

      Router(config)#do sh ru | be http server

      no http server

      no http secure-server

      no snmp agent

      no ip ftp server

      ip ftp server default-filesystem flash

      no ip scp server

      no ip sntp server

      !

      <skip a few lines>

      !

      Router(config)#no ip ftp server

      Router(config)#do sh ru | be http server

      no http server

      no http secure-server

      no snmp agent

      no ip ftp server

      ip ftp server default-filesystem flash

      no ip scp server

      no ip sntp server

      =================

       

      Is there something wrong here?

        • Re: "no ip ftp server" doesn't work
          jayh Hall_of_Fame

          You're applying the command "no ip ftp server" in your command copy-paste example but state in the narrative that you're applying "ip ftp server". 

           

          Are you trying to enable or disable FTP on the device?

           

          This command allows the device to send files by FTP, for example to configure a phone or download to a backup server.

           

          If you are just trying to pull files from an external FTP server to the Adtran then you don't need FTP server running.

           

          Specifically what are you trying to accomplish? 

            • Re: "no ip ftp server" doesn't work
              royh New Member

              My bad, it should have read "no p ftp server".  I am trying to disable the ftp server for security reasons.

                • Re: "no ip ftp server" doesn't work
                  jayh Hall_of_Fame

                  Does the device listen on TCP 21?  (Is there actually an FTP server running?)

                   

                  Try the more specific no ip ftp server default-filesystem flash and see if that removes it.

                   

                  Some of the default configuration lines that are there do nothing unless enabled by another command and will just be cosmetic unless enabled.  Another example:

                   

                  !

                  no auto-config

                  auto-config authname adtran encrypted password 2e281c6133856db572ab92d4ad8ddb4dbeae

                  !


                  Try to get rid of the "auto-config authname adtran..." line.  You can't.  But it doesn't do anything unless you turn on auto-config. Same situation likely exists with the FTP server.

                  1 of 1 people found this helpful
              • Re: "no ip ftp server" doesn't work
                levi Employee

                royh:

                 

                I went ahead and flagged the "Correct Answer" on this post to make it more visible and help other members of the community find solutions more easily. If you don't feel like the answer I marked was correct, feel free to come back to this post and unmark it and select another in its place with the applicable buttons.  If you still need assistance, we would be more than happy to continue working with you on this - just let us know in a reply.

                Thanks,

                 

                Levi