6 Replies Latest reply on Dec 16, 2014 7:02 AM by cj!

    CNA not happening

    cj! Beta_User

      We have experienced trouble with Captive Network Assistance (CNA) working consistently.  We recently figured out CNA depends on CRL and OCSP cert verification (see CNA dependent on vWLAN SSL cert verification) but now we're stuck without the iOS client popping up the guest login page automatically.  I know you can open mobile Safari and browse somewhere to make it show up, but it's expected to be automatic and this ends up being a pain in the butt for users.

       

      I have enabled CNA in the AP template (we use only 'default') and applied the AP configuration.  APs are UpToDate.  We have a third-party SSL cert in place.  Redirect to hostname is enabled in platform settings.

       

      I should mention that we re-keyed our SSL cert yesterday due to Heartbleed and updated vWLAN with the new cert.  Also, we just changed from the default form to a custom page based on the article single vWLAN Single Click Customized Login Page.  I'm not sure if these could have any negative effect on CNA, however, it was working prior to them.

       

      How can we get CNA to work?

       

      Thanks,

      Chris

        • Re: CNA not happening
          briangonyer New Member

          what about on Windows 7/8 or OS X, those os's will show a popup bubble or open a window automatically on detecting a cna captive portal.

          1 of 1 people found this helpful
            • Re: CNA not happening
              cj! Beta_User

              Good idea.  We'll give that a try.

              • Re: CNA not happening
                cj! Beta_User

                A Windows 8.1 client automatically popped open the default web browser and displayed the login form.  We just tested again with iOS and we had to manually open Safari.  Something change in a recent iOS update that you know of?

                  • Re: CNA not happening
                    daniel.blackmon Employee

                    It probably goes without saying, but the Apple website should have all the changes listed. I know I was able to find information when iOS 6 introduced support for 802.11k and 802.11r although I also knew what I was looking for. After very quick search, I could not find any information for captive network assistance (CNA); you may have more luck though.

                     

                    I can also verify that Windows 8.1 and Android versions 4.2 and 4.3 (Jelly Bean) as well as 4.4 (KitKat) worked properly with CNA-like functionality.

                     

                    Edited to correct the iOS version that introduced support for 802.11k and 802.11r.

                    • Re: CNA not happening
                      net11 New Member

                      cj!,

                       

                      Have you discovered a fix or cause for this iOS CNA problem?

                        • Re: CNA not happening
                          cj! Beta_User

                          Nope, unfortunately.  We instruct iOS users to open Mobile Safari after associating to the wireless network.  My iOS devices seem to automatically display captive portal pages very well when visiting other networks.  Bluesocket doesn't seem to behave the same way.

                           

                          I'm un-marking this question as 'answered.'  Anyone have similar experiences?  Insight into a fix?

                           

                          Chris