2 Replies Latest reply on May 12, 2014 3:08 PM by jayh

    Analysis of failed unit exception report - what steps to take?

    jayh Hall_of_Fame

      This is primarily directed at the Adtran folks and/or anyone who has had a similar problem where a TA900 loses its boot hint.

       

      Scenario: 

       

      Customer has second generation TA924e which has been service for some time running R10.5.2. Unit is supplying PRI and analog lines from SIP trunk, not used for data.  Customer called in this morning reporting all phones down, T1 lights red, box unresponsive.  They tried power-cycling with no effect.

       

      I programmed a spare unit from RANCID backup and swapped it out.  Customer back in service.

       

      Brought old unit back, on the bench it comes up in bootstrap# mode.

       

      TA924e (4242924L1)

      Executing bootstrap...

      ram: 134217728 bytes of RAM detected.

      Serial Number: CFG0610778

      Bootstrap version: 14.05.00.SA, checksum: F343, Thu Jun 21 13:58:08 2007

      vfs: NONVOL: 248 tracks, 128 sectors/track, 1024 bytes/sector.

      eth0/1: initializing...

      eth0/1: MAC address is 00:A0:C8:32:C9:26

      bootstrap: Checking boot configuration...

      bootstrap: Boot configuration not found.

      bootstrap: Upload a new image using the 'copy' command

                 or specify the correct primary/backup images using the

                 'boot system flash <filename> <backup_filename>' command.

      bootstrap: Error in boot configuration!!!  Checking backup boot configuration.

      bootstrap: Boot configuration not found.

      bootstrap: Invalid boot configuration, entering bootstrap mode...

      cli: starting user interface

       

       

      Press '?' for help.

      bootstrap#

      bootstrap#sh ver

      Boot ROM version 14.05.00.SA

      Checksum: F343, built on: Thu Jun 21 13:58:08 2007

      Copyright (c) 1999-2007, ADTRAN, Inc.

      Platform: Total Access 924e, Part number 4242924L1

      Serial number CFG0610778

       

      Note that there isn't a boot hint.

       

      bootstrap#sh flash

         207599 exception-report-20140422214754

          15367 startup-config

          15401 startup-config.bak

      13802545 T900E2A-R10-5-2-E.biz

      14048895 bytes used, 17720160 available, 31769055 total

       

      Exception report from last night so the unit crashed...

       

      I tell it to boot from the image in flash:

       

      bootstrap#boot system flash T900E2A-R10-5-2-E.biz


      Primary image: NONVOL:/T900E2A-R10-5-2-E.biz

      Backup image:  none

      bootstrap#boot

      bootstrap: Primary image is 'NONVOL:/T900E2A-R10-5-2-E.biz'.

      bootstrap: Booting 'NONVOL:/T900E2A-R10-5-2-E.biz'

      bootstrap: Reading 13802545 bytes of code, stand by...

      bootstrap: Inflating, stand by...

      .............................................................


      And all is now just fine.  Power cycle unit, it is happy, boots consistently.  But can I trust it, and what caused it to lose its boot configuration?  Should I try to RMA the box?  It's working fine now so probably not. 

       

      What is the exception report file?  I haven't tried to download or open it, is this the type of thing that Adtran support would want to see, or can mere mortals decipher it?  Is there a hardware issue and can I trust this unit?