9 Replies Latest reply on Jul 10, 2014 2:08 PM by marcus

    ATLAS 550 DNIS Subst #

    bsabu New Member

      We have an ATLAS 550 and are wanting to accept an incoming call on 6460 and send it out an FXO port as 0100010050061. We thought utilizing the Dial Plan >> User Term >> FXO port Subst Templ >> DNIS Orig # 6460 >> DNIS Subst # 0100010050061 would work. However, it does not seem to be passing correctly. Is there a special syntax this needs to be in order for the atlas 550 to pass the literal string? Is the leading zero being truncated?

        • Re: ATLAS 550 DNIS Subst #
          patrick Employee

          Thank you for using the ADTRAN Support Community Forums.

           

          Since the FXO port is the output from the ATLAS, this is the correct configuration. Under the IFCE CONFIG for the FXO port (under DIAL PLAN > USER TER > IFCE CONFIG) what is the "DID Digits Transferred" set to? It looks like you need to transmit 13 digits. The zeros are considered normal digits, so there is no issue there.

           

          You can verify the substitution is taking place by going under SYSTEM CONFIG, and into EVENT LOGGING, and setting the SWITCHBOARD events to INFO. You can then view the events under SYSTEM STATUS, in the EVENT LOG.

           

          Hope this helps,

          Patrick

            • Re: ATLAS 550 DNIS Subst #
              bsabu New Member

               

              When viewing the event log it looks as if the substitution is happening. However, I'm getting a busy signal.

                • Re: ATLAS 550 DNIS Subst #
                  patrick Employee

                  Your "DID Digits Transferred" is still set to "4".  So even though you are substituting 0100010050061, you are only transmitting the last 4 digits (0061). You need to change the "DID Digits Transferred" to 13 (if I counted that correctly).

                   

                  Thank you,

                  Patrick

                    • Re: ATLAS 550 DNIS Subst #
                      bsabu New Member

                      Thank you. We still are experiencing an issue and receiving a busy signal. I have changed the "DID Digits Transferred" to 13.

                       

                       

                      ATLAS 550 L2[ADTRAN]:ISDN|Slt2|1|Call to '6460' disconnected by far end.

                      ATLAS 550 L2[ADTRAN]:ISDN|Slt2|1|Busy destination: USER_BUSY : Loc=U

                      ATLAS 550 L2[ADTRAN]:ISDN|Slt2|1|Call to '6460' busy after switchboard has connected it.

                      ATLAS 550 L2[ADTRAN]:ISDN|Slt2|1|Incoming call to '6460' accepted

                      ATLAS 550 L2[ADTRAN]:Switchboard|Slt2|1|6460 Pri. accepted: slot Slt3, port 1

                      ATLAS 550 L2[ADTRAN]:Switchboard|Slt0|0|ANI 1112291190 / DNIS 6460   

                      ATLAS 550 L2[ADTRAN]:Switchboard|Slt0|0|0100010050061 substituted for DNIS 6460

                      ATLAS 550 L2[ADTRAN]:ISDN|Slt2|1|Call to ATLAS:'6460' from '1112291190'.

                        • Re: ATLAS 550 DNIS Subst #
                          patrick Employee

                          If the DID digits transferred is set to 13, then this looks "normal." The line is busy after the ATLAS transmits the DID digits. Can you find out why the end equipment is not accepting the number?

                            • Re: ATLAS 550 DNIS Subst #
                              bsabu New Member

                              I hooked a butt set to the FXO port on the adtran and I do not hear any tones being passed to the far device. Should I hear tones going to the far device?

                                • Re: ATLAS 550 DNIS Subst #
                                  bsabu New Member

                                  The adtran FXO port is connected to a device generating tone (FXS port). This device in returns takes the 13 digit string specified on the DNIS Subst # 0100010050061 and parses it as an IP address 10.1.5.6 port 1 and uses SIP to call the far end device. However, the head end device connected to the FXO port is not receiving the 0100010050061 string from the adtran FXO port. At this point it returns a busy signal.

                                    • Re: ATLAS 550 DNIS Subst #
                                      patrick Employee

                                      A butt-set connected to the ATLAS FXO port is not a valid test, because neither the butt-set nor the FXO port provide battery. The FXO configured for DPT requires battery reversal from the end device in order to indicate the call is answered. It could be that the ATLAS is not receiving the battery reversal.

                                       

                                      You will have to set the "DP Outgoing Signaling" to INFO, or monitor the port status under MODULES to see if it ever goes offhook.

                                       

                                      If your FXS device does not provide battery reversal, and is a standard FXS interface (and does not support DID lines) providing dial tone, then the FXO ports will need to be configured as NETWORK TERM (you will still need to do the DNIS Substitution).

                                       

                                      So if the "FXS" interface supports DID lines and is able to provide battery reversal then this should work, if it is a standard FXS line providing dial tone then the FXO port in the ATLAS needs to be configured as a NETWORK TERM entry.

                        • Re: ATLAS 550 DNIS Subst #
                          marcus Employee

                          Since we haven't heard anything back from you, I'm going to mark this question as "assumed answered". If you have additional questions feel free to continue the discussion.