4 Replies Latest reply on May 16, 2014 10:41 AM by ws6jay

    Remote Phone Park/Pickup not working

    ws6jay New Member

      We inherited a client with an Adtran NetVanta 7100 a few months ago. We have become very familiar with the system and like it. However, we are facing an issue and i'm not sure where to go with it.

       

      They had a need for setting up 7 simple remote phones, no VPN. We followed the documentation for setting up the remote phones and they are able to make/receive calls just fine. However, most of the phone features did not work with default programming. The phones are Adtran IP706 and IP712. Features that weren't working initially:

      - Messages button

      - Park

      - Pickup

       

      They use the softkeys for parking/picking up calls. When I looked at the phone config I was able to fix the messages button by changing it from *98@wanip to just *98, however i'm not sure if this will let the user know there is a new message.

      For 1 user they are able to park calls using *77x and pickup using *78x. However the other 6 cannot. We have been doing some trial and error with 3 of the remote users, each have different routers and we have checked to make sure the SIP ALG is not enabled however I don't think that would apply using a non-standard SIP Port (in our case 25125).

       

      I don't have the exact response but when you try to pickup a call from park it says something along the lines of there is not a call to pickup. It's like it can't see that there is a parked call available, but if you use a local phone it can pickup the call just fine.

       

      Does anyone have any suggestions or has anyone faced this issue with simple remote phones? Anything I could try? I have already tried reprogramming the PickupZoneUri.0 to *78 and this also does not work.

       

      According to the manual, the only provisioning profile changes I needed to make was adding:

      RegServer.0.Port.1 25125

      ProxyServer.0.Port.1 25125

       

      So that's really all i've done other than changing the messages callback and reg.0.voicemail to *98.

       

      Any help would be greatly appreciated!

       

      NetVanta is on firmware R10.8.0.E and phones are on 2.4.1

        • Re: Remote Phone Park/Pickup not working
          ws6jay New Member

          Can anyone help please? I've run out of things I know to try, can't seem to figure this one out and it's really the only thing that isn't working and they use it heavily.

          • Re: Remote Phone Park/Pickup not working
            ws6jay New Member

            New development, if I set everything back to defaults and just add:

            RegServer.0.Port.1 25125

            ProxyServer.0.Port.1 25125

            To the end of the config file, and then in the public zone I add a traffic selector to allow ALL traffic from the remote IP, everything works. So apparently there are some ports that need to be forwarded other than the SIP port. I had to forward UDP 10000-15000 to get audio to work already. Does anyone know what ports I need to forward in order for the Messages and Call Pickup to work??

            • Re: Remote Phone Park/Pickup not working
              ws6jay New Member

              From a packet trap I can see that when the messages button or Pickup button are pressed, it is trying to use Port 5060. I even manually changed SipUdpPort to 25125 and SipTransport to UDP on the phone settings manually. The packet trap shows the source port is 25125, but the destination gets changed to 5060?? Since we don't have 5060 approved through the firewall, it's not going through. So why is it trying to send the signaling to 5060? What am I missing here??

              packet.jpg

              • Re: Remote Phone Park/Pickup not working
                ws6jay New Member

                Figured it out!

                 

                All I had to do was use the default configuration, make the changes noted in the remote phone setup guide and then add 2 more lines and everything works.

                 

                So I added:

                RegServer.0.Port.1 25125

                ProxyServer.0.Port.1 25125

                 

                Then I went back and added:

                OutboundProxy.0.Address.1 000.000.000.000

                OutboundProxy.0.Port.1 25125

                 

                That forced it to use port 25125 for all outbound communication. Messages, Park, and Pickup all work flawlessly.