2 Replies Latest reply on May 14, 2014 3:37 PM by m1c4ael

    atlas 550 send 10 digits out the dual pri card

    m1c4ael New Member

      Hello,

      I have an atlas 550 with a PRI in Network slot 1 that is receiving 10 digits from the carrier. I also have a dual t1/pri in slot 1 that will a shoretel system connected to port 1 and an NEC system connected to port 2.

      The shoretel is set to receive 10 digits and the NEC set to receive 7 digits. Im having issues with setting up the 550 to receive 10 on network 1 and send 10 digits out slot 1 port 1 and 7 digits out slot 1 port 2.

      Originally In (shoretel port) dial plan/user term/in#accept = 2514XXXXXX, in the interface config, the called digits transferred is set to all. didn't work

      Originally In (NEC port) dial plan/user term/in#accept =  2513XXXXXX, in the interface config the called digits transferred is set to all. didn't work

      Changed the inaccept to 4xxxxxx and entered a substution pattern of 2514XXXXXX, this still didnt work for the shoretel.

      Changed the inaccept to 3XXXXXX and this did work for the NEC.

      I brought up a monitoring tool on the shoretel and saw that we were only receiving the 7 digits from the adtran and not the full 10 from slot 1 port 1.

      The called digits transferred on the network side is set to all.

      Can the substitution template be used to send the 10 digits needed and if so does it need to be applied to the user side, network side, or both?

      I really don't want to rebuild the Shoretel trunks and all the DIDs associated with it. Any input would be greatly appreciated!

        • Re: atlas 550 send 10 digits out the dual pri card
          patrick Employee

          Thank you for using the ADTRAN Support Community Forums.

           

          To answer your question on the Substitution Template first, the Sub Template CAN be used to send 10 digits to the end equipment if another quantity of digits is received. The Sub Template works on the egress, so you use it on the interface the call is leaving the ATLAS.

           

          From what you wrote, I believe you need to look under the DIAL PLAN in the GLOBAL PARAM and make sure the "Area or City Code" is blank. If the area code is in there, the ATLAS will usually strip off the area code and only pass the 7-digit number.

           

          You can verify the digits the ATLAS is receiving on the inbound call by going to SYSTEM CONFIG and then to EVENT LOGGING and setting "ISDN Events" to INFO. You can then view the events under SYSTEM STATUS in the EVENT LOG. You should see something line "Call to ATLAS 2565551212" where "2565551212" is the phone number received. (Remember that if the area code of 256 is listed in the "Area or City Code" then the ATLAS will still recieve "2565551212" but will then strip off the area code before processing the call through the Switchboard.)

           

          Hope this helps,

          Patrick

          • Re: atlas 550 send 10 digits out the dual pri card
            m1c4ael New Member

            Thanks Patrick! All seems to be working now.