14 Replies Latest reply on Nov 15, 2015 12:40 AM by relmer

    UC Server with exchange 2013 MWI

    alext55 New Member

      Hi,

       

       

      When a message arrive in the the user mailbox on Exchange 2013, the MWI turn ON, but need to delete the message in the mailbox for turning OFF the MWI. If I mark read the message, the MWI still ON.

       

      Have you ever seen this?

       

      Thank you

       

      Alex

        • Re: UC Server with exchange 2013 MWI
          markfreeman Employee

          From the UC Server Admin interface, go to Tools > Synchronize All Message Waiting Lights.

           

          See if that helps.

           

          -Mark

            • Re: UC Server with exchange 2013 MWI
              alext55 New Member

              I have already do that... the message waiting indicator still ON. But, if I delete the message the MWI turn off. Once have voice message in a mail box (read or unread) , the light turns on. We need to delete all voice mail.

               

              Exchange with EWS configuration.

                • Re: UC Server with exchange 2013 MWI
                  markfreeman Employee

                  I will check on this and get back with you.

                   

                  -Mark

                  • Re: UC Server with exchange 2013 MWI
                    markfreeman Employee

                    Alex,

                    I need a couple things from you. Thanks for patience in this issue.

                     

                    1.  Can you go to Tools > Options and then select the "Message Waiting Light" tab and let me know what the options are set to.

                     

                    2. I need a copy of the swlog.txt file. I need you to delete the file in the C:\ADTRANLogs path. Then I need you to duplicate the issue by leaving a voicemail for a user, then marking the message as read. Then grab the file and attach it to your reply to this post.

                     

                    I will then forward this over to our Engineering team for further investigation.

                     

                    Thanks,

                    Mark

                      • Re: UC Server with exchange 2013 MWI
                        alext55 New Member

                        Mark,

                         

                        This is my Message Wainting Light Option:

                         

                        2014-12-30 14-48-37.jpg

                         

                        In attachment, you have the file. My extension is 223.

                         

                        Thank you for your help.

                          • Re: UC Server with exchange 2013 MWI
                            markfreeman Employee

                            Thanks Alex! I will let you know once I hear back from Engineering.

                             

                            -Mark

                            • Re: UC Server with exchange 2013 MWI
                              markfreeman Employee

                              Alex,

                              In that debug you sent me for 223. Did the light turn off after you deleted the message?

                               

                              Can you verify that you have no other voice messages or fax messages in your inbox.

                               

                              Thanks,

                               

                              -Mark

                                • Re: UC Server with exchange 2013 MWI
                                  alext55 New Member

                                  Hi Mark,

                                   

                                  Yes, if I read the message, the light stays on. When I removed the message, the light turned off.

                                   

                                  I dont have any other wav/uc messages in my mailbox.

                                   

                                  Thank You

                                   

                                  Alex

                                    • Re: UC Server with exchange 2013 MWI
                                      markfreeman Employee

                                      Thanks Alex, passing your info on. Will provide more when I hear back from our Engineering team.

                                       

                                      -Mark

                                      • Re: UC Server with exchange 2013 MWI
                                        markfreeman Employee

                                        Alex,

                                        When you get a chance, can you grab another copy of the swlog.txt file.

                                         

                                        1. Verify that there are no voice or fax messages in your inbox. Delete the swlog.txt file.

                                        2. Leave only 1 voice message in the Inbox. Ensure that it arrives in the Inbox. There should be only one unread message in the Inbox.

                                         

                                        3. Playback the voice message using the TUI(Telephone User Interface), that is play the message from the phone itself) to ensure the light goes off (I believe it works correctly from the TUI) If it does not turn off the light, then stop and let me know. If it does turn off then proceed.

                                        4. Leave 3 new voice messages for that same phone extension.

                                        5. Then… do what you were doing to the voicemails in the Inbox…  Please let us know what you were doing, were you marking them read or were you actually opening the email to view the voiceform??

                                        6. Capture/copy the swlog.txt file  and attach the file to your reply. Let me know what phone extension was used to test with.

                                         

                                        Thanks again for working with us to resolving this issue.

                                         

                                        -Mark

                                          • Re: UC Server with exchange 2013 MWI
                                            alext55 New Member

                                            Hi Mark,

                                             

                                             

                                            I do more tests. When I leave a message in my voicemail, I receive a email with the message in my outlook. I use my phone to take the message, but I don't delete the voicemail. The email turn to read in outlook, but the light stay ON and when I return in my voicemail with the phone, I still have 1 unread message...

                                             

                                            Tell me if I need to do other steps.

                                             

                                            Thank you

                                              • Re: UC Server with exchange 2013 MWI
                                                markfreeman Employee

                                                Thanks Alex,

                                                I will forward your reply on.

                                                 

                                                -Mark

                                                • Re: UC Server with exchange 2013 MWI
                                                  markfreeman Employee

                                                  Alex,

                                                  Can you duplicate the steps below and provide us with the swlog.txt file.

                                                  Make sure you have no other VMs before you start.

                                                  Delete the log prior to your test.

                                                   

                                                  Can you also provide us with some additional information

                                                   

                                                   

                                                  1.      What version of Exchange 2013 are you running?  What service pack?

                                                   

                                                  2.      What version of your MAPI CDO 1.2.1 are you running? On the UC Server go to uninstall programs and you should see “Messaging API and Collaboration Data Objects 1.2.1” scroll to the right and it will list the version.

                                                   

                                                  3.      What version UC server are you running?

                                                   

                                                  4.      What is your PBX? Are you running ECS? UCS to an external PBX? BCS with NV7100 PBX?

                                                   

                                                  5.      What rights does your Active Directory Service Account for the UC Server have on the Exchange server?

                                                   

                                                  Thanks,

                                                   

                                                  -Mark

                                  • Re: UC Server with exchange 2013 MWI
                                    relmer New Member

                                    Did you ever find a solution to this? I am having the exact same issue and I am stuck. I am running BCS with a NV7100 and everything else is working fine except for marking voicemail messages as read and the MWI light not turning off unless the message is actually deleted. I can also mark it as read and then when I listen to the messages over the phone it tells me there are no unread messages and then the MWI light is turned off at that point.

                                     

                                    Thanks,

                                    Roger