2 Replies Latest reply on Feb 12, 2015 8:30 AM by mnorton

    SIP Trunk via TA908e Adtran to NEC sv8100 - has anyone ever set this up successfully? I am having issues keeping the Outbound calls established.

    vnet New Member

      Here is a copy of my config in the TA908e, I have adjusted some parameters because I don't want them publicized:

       

      !

      !

      ! ADTRAN, Inc. OS version R10.9.0.E

      ! Boot ROM version 14.05.00.SA

      ! Platform: Total Access 908e (2nd Gen), part number 4242908L1

      ! Serial number CFG1132575

      !

      !

      hostname "TA908e_Seamless_SIP_Trunk_297000075"

      enable password encrypted 3b31a5e9d474533016e98c03c44aac98bda6

      !

      !

      clock timezone -6-Central-Time

      !

      ip subnet-zero

      ip classless

      ip default-gateway 10.80.0.106

      ip routing

      ipv6 unicast-routing

      !

      !

      domain-name "ms.companydomain.net"

      name-server xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx

      !

      !

      no auto-config

      auto-config authname adtran encrypted password

       

       

      4046f0ba5cdf72bf460b8f2203161619f745

      !

      event-history on

      no logging forwarding

      no logging email

      !

      service password-encryption

      !

      username "admin" password encrypted

       

       

      "252dd7132e35be4597f3834f6a8f51cf3304"

      username "Valu-Net_user" password encrypted

       

       

      "3e37c8c225df5f2cfc0a8454016850c211a3"

      !

      banner login #

      **************************************************************

       

       

      *****************

      *                                                             

       

       

                      *

      *                              WARNING NOTICE                 

       

       

                      *

      *                                                             

       

       

                      *

      * This system is restricted solely to ValuNet authorized users

       

       

      for legitimate  *

      * business purposes only.  The actual or attempted

       

       

      unauthorized access,        *

      * use, or modification of this system is strictly prohibited

       

       

      by ValuNet.       *

      * Unauthorized users are subject to Company disciplinary

       

       

      proceedings and/or    *

      * criminal and civil penalties under state, federal, or other

       

       

      applicable       *

      * domestic and foreign laws.  The use of this system may be

       

       

      monitored and      *

      * recorded for administrative and security reasons.  Anyone

       

       

      accessing this     *

      * system expressly consents to such monitoring and is advised

       

       

      that if          *

      * monitoring reveals possible evidence of criminal activity,

       

       

      ValuNet may       *

      * provide the evidence of such activity to law enforcement

       

       

      officials.  All     *

      * users must comply with ValuNet Information Security policy

       

       

      regarding the     *

      * protection of ValuNet information assets.                   

       

       

                      *

      *                                                             

       

       

                      *

      **************************************************************

       

       

      *****************

      #

      !

      !

      ip firewall

      no ip firewall alg msn

      no ip firewall alg mszone

      no ip firewall alg pptp

      no ip firewall alg h323

      !

      !

      !

      !

      aaa on

      aaa authentication banner #

      **************************************************************

       

       

      *****************

      *                                                             

       

       

                      *

      *                              WARNING NOTICE                 

       

       

                      *

      *                                                             

       

       

                      *

      * This system is restricted solely to ValuNet authorized users

       

       

      for legitimate  *

      * business purposes only.  The actual or attempted

       

       

      unauthorized access,        *

      * use, or modification of this system is strictly prohibited

       

       

      by ValuNet.       *

      * Unauthorized users are subject to Company disciplinary

       

       

      proceedings and/or    *

      * criminal and civil penalties under state, federal, or other

       

       

      applicable       *

      * domestic and foreign laws.  The use of this system may be

       

       

      monitored and      *

      * recorded for administrative and security reasons.  Anyone

       

       

      accessing this     *

      * system expressly consents to such monitoring and is advised

       

       

      that if          *

      * monitoring reveals possible evidence of criminal activity,

       

       

      ValuNet may       *

      * provide the evidence of such activity to law enforcement

       

       

      officials.  All     *

      * users must comply with ValuNet Information Security policy

       

       

      regarding the     *

      * protection of ValuNet information assets.                   

       

       

                      *

      *                                                             

       

       

                      *

      **************************************************************

       

       

      *****************

      #

      ftp authentication LoginUseLocalUsers

      !

      !

      aaa authentication login default local

      aaa authentication login LoginUseTacacs group tacacs+

      aaa authentication login LoginUseRadius group radius

      aaa authentication login LoginUseLocalUsers local

      aaa authentication login LoginUseLinePass line

      !

      aaa authentication enable default enable

      !

      !

      no dot11ap access-point-control

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      qos map Valunet_QoS 10

        match dscp 46

        match ip rtp 16384 32767 all

        priority 2200

        set dscp 46

      qos map Valunet_QoS 15

        match dscp 24

        match ip list allow-sip

        priority 384

        set dscp 24

      !

      !

      !

      !

      interface eth 0/1

        description Private to Switch/SBC

        ip address  10.80.0.106  255.255.254.0

        ip access-policy standard-fw

        ip access-group t1-out out

        media-gateway ip primary

        max-reserved-bandwidth 95

        qos-policy out Valunet_QoS

        no awcp

        no shutdown

        no lldp send-and-receive

      !

      !

      interface eth 0/2

        description to Seamless Asterisk SIP Trunk

        ip address  192.168.10.2  255.255.255.0

        ip access-policy Private

        ip access-group eth-in in

        media-gateway ip primary

        no shutdown

      !

      !

      !

      !

      interface t1 0/1

        shutdown

      !

      interface t1 0/2

        shutdown

      !

      interface t1 0/3

        shutdown

      !

      interface t1 0/4

        shutdown

      !

      !

      interface fxs 0/1

        shutdown

      !

      interface fxs 0/2

        shutdown

      !

      interface fxs 0/3

        shutdown

      !

      interface fxs 0/4

        shutdown

      !

      interface fxs 0/5

        shutdown

      !

      interface fxs 0/6

        shutdown

      !

      interface fxs 0/7

        shutdown

      !

      interface fxs 0/8

        shutdown

      !

      !

      interface fxo 0/0

        no shutdown

      !

      !

      !

      !

      !

      !

      !

      !

      ip access-list standard nat-all

        permit any

      !

      !

      ip access-list extended allow-sip

        permit udp any  any eq 5060

      !

      ip access-list extended eth-in

        deny   udp any  any eq netbios-dgm

        deny   udp any  any eq netbios-ns

        deny   udp any  any eq netbios-ss

        permit ip any  any

      !

      ip access-list extended self

        remark Traffic to

        permit ip any  any

      !

      ip access-list extended t1-out

        deny   udp any  any eq 1433

        deny   udp any  any eq 1434

        permit ip any  any

      !

      ip access-list extended ValuNet-standard

        permit tcp any range 0 65535 any range 1024 65535

        permit udp any range 0 65535 any range 1024 65535

        permit icmp any  any  echo-reply

        permit ip any  any

      !

      !

      !

      !

      ip policy-class Private

        allow list self self

        nat source list nat-all interface eth 0/1 overload

        allow list self self

        nat source list nat-all interface eth 0/1 overload

        allow list self self

        nat source list nat-all interface eth 0/1 overload

        allow list self self

        nat source list nat-all interface eth 0/1 overload

      !

      ip policy-class standard-fw

        allow list ValuNet-standard self

        allow list ValuNet-standard self

        allow list ValuNet-standard self

        allow list ValuNet-standard self

      !

      !

      !

      ip route 0.0.0.0 0.0.0.0 10.80.0.1

      !

      no tftp server

      no tftp server overwrite

      http server

      http secure-server

      no snmp agent

      no ip ftp server

      no ip scp server

      no ip sntp server

      !

      !

      !

      !

      snmp-server enable traps snmp

      snmp-server community public RO

      snmp-server host xxx.xxx.xxx.xxx traps version 2c public snmp

      !

      !

      !

      !

      sip

      sip udp 5060

      no sip tcp

      !

      !

      !

      voice feature-mode network

      voice forward-mode network

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      voice codec-list g711

        codec g711ulaw

      !

      voice codec-list g729

        codec g729

        codec g711ulaw

      !

      !

      !

      voice trunk T01 type sip

        description "SIP To Metaswitch"

        sip-server primary ms.companydomain.net

        registrar primary xxx.xxx.xxx.xxx

        outbound-proxy primary xxx.xxx.xxx.xxx

        domain "xxx.xxx.xxx.xxx"

        register xxxxxxxxxx

        trust-domain

        codec-list g711 both

        authentication username "xxxxxxxxxx" password encrypted

       

       

      "2c2bde0082139d59e5c8b57565b9b766ed74"

      !

      voice trunk T02 type sip

        description "SIP to Asterisk PBX"

        sip-server primary 192.168.10.200

        trust-domain

        codec-list g711 both

      !

      !

      voice grouped-trunk SIPMAP

        trunk T01

        accept 9NXX-NXX-XXXX cost 200

        accept 91-NXX-NXX-XXXX cost 200

        accept 91-800-NXX-XXXX cost 200

        accept 91-888-NXX-XXXX cost 200

        accept 91-877-NXX-XXXX cost 200

        accept 91-866-NXX-XXXX cost 200

        accept 91-855-NXX-XXXX cost 200

        accept 91-900-NXX-XXXX cost 200

        accept 91-976-NXX-XXXX cost 200

        accept 9011-$ cost 200

        accept 9411 cost 200

        accept 9611 cost 200

        accept 9911 cost 200

        accept 90-NXX-NXX-XXXX cost 200

        accept 910-10-XXX-$ cost 200

        accept 9NXX-XXXX cost 200

        accept *XX cost 200

        accept *XXX cost 200

        accept NXX cost 200

        accept NXX-NXX-XXXX cost 200

        accept 1-NXX-NXX-XXXX cost 200

        accept 1-800-NXX-XXXX cost 200

        accept 1-888-NXX-XXXX cost 200

        accept 1-877-NXX-XXXX cost 200

        accept 1-866-NXX-XXXX cost 200

        accept 1-855-NXX-XXXX cost 200

        accept 1-900-NXX-XXXX cost 200

        accept 1-976-NXX-XXXX cost 200

        accept 011-$ cost 200

        accept 411 cost 200

        accept 611 cost 200

        accept 911 cost 200

        accept 0-NXX-NXX-XXXX cost 200

        accept 10-10-XXX-$ cost 200

        accept NXX-XXXX cost 200

        accept *XX$ cost 200

        accept NXX-XXX-XXXX cost 200

      !

      !

      voice grouped-trunk T01

        description "SIP To Metaswitch"

        trunk T01

        accept $ cost 0

      !

      !

      voice grouped-trunk T02

        description "To PBX"

        trunk T02

        accept $ cost 1

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      sip proxy domain "     "

      !

      !

      !

      !

      !

      !

      !

      !

      !

      sip qos dscp 24

      !

      !

      !

      ip rtp udp 16384

      !

      !

      !

      line con 0

        login authentication LoginUseLocalUsers

      !

      line telnet 0 4

        login authentication LoginUseLocalUsers

        password encrypted 262e62f350fac67818df30ef9ce2abebb767

        no shutdown

      line ssh 0 4

        login authentication LoginUseLocalUsers

        no shutdown

      !

      sntp server xxx.xxx.xxx.xxx version 3

      !

      !

      !

      !

      end