3 Replies Latest reply on Jan 16, 2015 9:18 AM by cahollow

    Problems with DNIS translation on FXO trunk

    cahollow New Member

      Good morning!

       

      I have a newly installed Netvanta 7100 in which the client wants to be able to dial from their missed calls menu.  To do this I applied a translation to the analog trunk as shown below.  However, when I dial out the number never gets matched and on the debugs (shown below the trunk) I can see that the system is only ever offering the 10 digit number to the trunks and it is never expanded.

      I've also included the local dialplan

       

      Incidentally even though there is a trunk access number (9), calls outbound without it still work.  This doesn't seem right to me (I come mostly from the Cisco VoIP world and am a little new to Adtran) as what is the point of a trunk access number if you can access the trunks without it?

       

      voice trunk T01 type analog supervision loop-start

        description "FXO Inbound Trunk"

        no reject-external

        caller-id

        trunk-number 820

        trunk-number lunch "822"

        trunk-number night "821"

        connect fxo 1/1

        connect fxo 1/2

        connect fxo 1/3

        connect fxo 1/4

        match dnis "NXX-NXX-XXXX" substitute "1-NXX-NXX-XXXX"

        rtp delay-mode adaptive

       

       

      10:04:47.900 PM.105 Ca:0 SipPM_Trying         sent: SA->Appearance On

      10:04:47.900 SA.105 Ca:0 Idle                 rcvd: AcctPhoneMgr_appearance(ON) from PM

      10:04:47.901 SA.105 Ca:0 Idle                 State change      >> Idle->DigitGathering (CAS_ReqDigits)

      10:04:47.901 SA.105 Ca:0 DigitGathering       sent: AcctPhoneMgr_cachg(CAS_ReqDigits) to PM

      10:04:47.901 PM.105 Ca:0 State change      >> SipPM_Trying->SipPM_Pending

      10:04:47.901 PM.105 Ca:0 SipPM_Pending        sent: SA->Dial Digit

      10:04:47.902 SA.105 Ca:0 DigitGathering       rcvd: AcctPhoneMgr_dialDigit(828XXXXXXX#) from PM

      10:04:47.902 SA.105 Ca:0 DigitGathering       Named-digit-timeout waiting 0 seconds for more digits

      10:04:47.902 SA.105 Ca:0 DigitGathering       State change      >> DigitGathering->DigitGathering (CAS_Active)

      10:04:47.903 SA.105 Ca:0 DigitGathering       sent: AcctPhoneMgr_cachg(CAS_Active) to PM

      10:04:47.903 SA.105 Ca:0 DigitGathering       sent: call to SB

      10:04:47.903 SA.105 Ca:0 DigitGathering       State change      >> DigitGathering->CallPending (CAS_Active)

      10:04:47.903 SB.CALL 375 Idle                 Called the call routine with 828XXXXXXX

      10:04:47.904 SB.CALL 375 Idle                 No LOCAL station matched dialed number (828XXXXXXX)

      10:04:47.904 SB.CALL 375 Idle                 No TRUNK accepted dialed number (828XXXXXXX)

      10:04:47.904 SB.CALL 375 Idle                 No routable destination found on call from (105) to (828XXXXXXX)

      10:04:47.904 SB.CALL 375 State change      >> Idle->CallIdlePending

      10:04:47.905 SA.105 Ca:0 CallPending          rcvd: callResponse from SB

      10:04:47.905 SA.105 Ca:0 CallPending          State change      >> CallPending->Idle (CAS_Idle)

      10:04:47.905 SA.105 Ca:0 Idle                 sent: AcctPhoneMgr_cachg(CAS_Idle) to PM

      10:04:47.908 PM.105 Ca:0 SipPM_Pending        call-leg (P:0x5aede00 S:0x0) -> Disconnected (Local Reject)

      10:04:47.908 PM.105 Ca:0 SipPM_Pending        CallLegStateChanged to Disconnected.

       

       

       

       

      911Local Emergency
      9-911Local Emergency
      0Internal Operator
      MXXExtensions
      9NXX-XXXXLocal
      91-NXX-NXX-XXXXLong Distance
      91-800-NXX-XXXXToll Free
      91-888-NXX-XXXXToll Free
      91-877-NXX-XXXXToll Free
      91-866-NXX-XXXXToll Free
      91-855-NXX-XXXXToll Free
      90-NXX-NXX-XXXXOperator Assisted
      9011-$International
      91-900-NXX-XXXX900
      91-NXX-976-XXXX900
      9976-XXXX900
        • Re: Problems with DNIS translation on FXO trunk
          cahollow New Member

          I got this sorted out on my own.  The issue was with the Permission/Restriction Call Templates under the Trunk Group.  Once I added the pattern NXX-NXX-XXXX with a cost as a permitted call I was able to get it working.  This also explains why I am able to make outbound calls without the trunk access code.

          • Re: Problems with DNIS translation on FXO trunk
            markfreeman Employee

            Hollow,

            You had the right idea just wrong location. Instead of doing it on the Analog trunk which is modifying all  to outbound modification, you want to apply it globally which is applied to inbound calls. You will need to add a 9 as shown since you are doing trunk access codes.

             

            Remove the command you added to the analog trunk and add the following command from global configuration mode (config)# prompt

             

            voice match ani "NXX-NXX-XXXX" substitute "9-NXX-NXX-XXXX"

             

            You can just cut and paste it.

             

            If your other post if you leave that template in the permit option then calls will not be required for the trunk access code.

             

            What I put is the recommended way to return missed calls and still force trunk access codes for outbound calls.

             

            Hope that makes sense.

             

             

             

            -Mark

            1 of 1 people found this helpful