11 Replies Latest reply on Jul 14, 2015 11:08 AM by milehijones

    Poor performance (BSAP-1920's)

    milehijones New Member

      Folks - I have an Adtran Wireless Environment that consists of 11 BSAP-1920's that connect through an Adtran NetVanta 1534P directly through to a Cisco 5515-x Firewall with a full 1 Gig Fiber connection.  The BSAP's are managed by an Adtran Bluesocket controller.  My understanding of the capabilities of the BSAP-1920 is they are capable of 802.11 a/n (5 Ghz) speeds, so going by the book, maximum speeds of 450 Mbps.  I have poured through the configurations of all of these devices and no where along the path do I have bandwidth limits setup.  I have checked each role in the Bluesocket controller and QoS Rate In and QoS Rate Out is set to 0 (set to 0 for no bandwidth limit), the NetVanta is only participating in layer 2 VLAN switching - no QoS or bandwidth limits on each trunk going to the BSAP's, and the Cisco 5515-x has no speed limiting either.  In fact, when I hard wire directly into the NetVanta with 1 gig connection, I get approx. 945 Mbps synchronously consistently.   Yet my best speeds for my wireless clients is around 25-30 Mbps no matter how many clients are on each BSAP.


      Todays testing showed I had 11 clients on the BSAP I was testing from, and those 11 clients were idle for the most part.  So I connected up both my Macbook Pro (with up to 802.11 a/c capability) and my iPhone 6 (with up to 802.11 a/c capability) and consistently I would get right around 25 Mbps through to the same speed test site from each device.

       

      Where else should I check to see where the bottleneck might be in this wireless network?  Any thoughts would be much appreciated!

       

      Best regards,

      Brian

       

      Edit:  I should mention the BSAPs are running software 6.8.0-18 / the Bluesocket is running V2_4_0_12

        • Re: Poor performance (BSAP-1920's)
          cj! Beta_User

          Hi milehijones:

           

          Do you have gigabit fiber Internet, or does the fiber connect to another site or office (perhaps where an Internet connection is located)?  Whatever the Internet connection, what speeds are provisioned from the ISP?

           

          In your AP Template, it may help to enable packet aggregation and also set the 5 GHz radio to 40 MHz.  Remember to execute the pending domain task (see the top right corner of the web page).

           

          Are you confident that your clients are associating with 5 GHz radios?  The client list should reveal this.  Consider creating an SSID which is assigned only to the5 GHz radios (done in the AP Template).  Associate your client with the 5-only SSID and test.

           

          Are your 1920 BSAPs linking to the switch at 1 Gbps?  I've seen a case where 100 Mbps was consistently negotiated.  I believe new BSAP firmware corrected the issue.  You might want to perform an upgrade on your BSC and APs anyway, given the cool new features, enhancements and fixes.  Upgrading BlueSocket vWLAN Controllers and Access Points

           

          Best,

          Chris

            • Re: Poor performance (BSAP-1920's)
              milehijones New Member

              Hey Chris - Thanks for taking the time to respond - I appreciate it! I will check out packet aggregation when I get back onsite for sure.  I do know clients are connecting at 5 Ghz, and am thinking now I should just disable 2.4 Ghz altogether now - I very, very rarely see a 2.4 Ghz connection.  I also know those BSAP's are definitely getting a full 1 Gbps connection to the NetVanta - I set the speed and duplex on both ends to make sure of that - I have learned my auto-negotiation lessons in the past ;-)  Although given this is a single vendor solution, auto-negotiation probably would have worked just fine, I still manually set it :-)

               

              Best regards,

              Brian

            • Re: Poor performance (BSAP-1920's)
              dougfravel Employee

              Hi Brian,

              The BSAP 1920 is a 2x2:2 802.11n AP. With 2 streams (:2), it has a max link rate of 300 Mbps. The 300 Mbps max link rate is based on a 40 MHz channel. The 40 Mhz channel is normally only done on the 5GHz radio (AP Template Setting) and not recommended on the 2.4 GHz radio.

               

              Actual throughput for a 802.11n 2 stream client connecting to a 802.11n 2 or 3 stream AP is 40-60% of the max link rate in a very clean environment. WiFi has a lot of overhead. Most use 50% for throughput planning. That makes 150 Mbps throughput for 1 client in a perfect environment. The 150 Mbps for this 1 AP is shared by all clients connected.

               

              The other part of this is the RF spectrum. It is also shared. If there are any other APs (including neighbors) on the same channel in the same area, they have to wait their turn to communicate in that spectrum space. Take a look at the Status / Adjacent APs menu to see APs that are seen by the Bluesocket APs. If you see other APs on the same channel as the AP you are testing with, set your AP to a channel that is not seen (or seems to have the lowest signal strength. You can set the AP channel under the Configuration / Wireless / Access Points menu.

               

              Another AP Template setting that could effect the throughput numbers is Packet Aggregation. Depending on your environment, you may want to enable Packet Aggregation (if not already enabled) for your throughput testing.

               

              You did not mention what you were using for throughput testing. Speedtest.net involves a number of other areas to consider (switchport(is it at GIG speed), routing performance, WAN bandwidth, ISP, speedtest server, etc...)  iperf(jperf) is a good tool to use for testing wireless throughput because it can be kept local.

               

              For your next test I would use a simple OPEN Authentication SSID. When doing encryption though, you want to use WPA2-PSK with AES encryption to get close to the expected rates.

               

              1) Download iperf/jperf on a laptop that will connect to a switchport that AP is connected to. Same VLAN as AP for the throughput test if possible. Run iperf in Server mode.

              2) Download iperf/jperf on your wireless client

              3) Associate client to SSID and run iperf as client - testing throughput to your iperf/jperf server. ( Be at least 5 feet from the AP when performing test)

               

              Hope this helps,

              Doug

              1 of 1 people found this helpful
                • Re: Poor performance (BSAP-1920's)
                  milehijones New Member

                  Doug - Thanks for the response!  That seems like an incredible amount of overhead - not a percentage I have heard most wireless solutions use as a standard.  That's good to know about, for future planning if Adtran is going to be amongst the solutions talked about.  I know when the solution was installed, the Adtran provider spoke of around 20 - 30% overhead for a connection but 50% seems awfully high to me.  I will definitely look at packet aggregation in the AP Template when I get back onsite - that sounds like it should help for sure.

                   

                  I am using http://internethelp.centurylink.com for speed testing as it is a century link circuit. And given I am using the same site for the wired clients, I wanted to keep that variable the same.  True to what the site states, if I have a 1 Gig fiber connection, I can expect to get around 800 Mbps - I have consistently been getting 925 Mbps on a daily basis during business hours so its pretty solid.  I have noticed from most of the clients in the building (being Macs) I can hold down the option key while clicking on the airport icon in the dock - I do see they are getting solid Tx Rates of right around 300 Mbps.  Which is why it seems odd to me that when it comes to actual speed tests, it so dang low. 

                   

                  Screen Shot 2015-06-29 at 4.58.39 PM.pngScreen Shot 2015-06-29 at 4.44.01 PM.png

                    • Re: Poor performance (BSAP-1920's)
                      daniel.blackmon Employee

                      Well to expand on what Doug is saying, 802.11 technology defines a shared, half-duplex medium. When you see the advertised rate, what you see is aggregate data rates. So you can only ever expect half of the aggregate data rate just by definition of the standard. Also like Doug pointed out, the BSAP 1920s are 2x2:2 meaning they have 2 transmit antennas, 2 receive antennas, and they support 2 spatial streams. You can take that and compare it against the Modulation and Coding Scheme Index (MCS Index, Modulation and Coding Index 11n and 11ac) for High Throughput (HT) wireless networks, which is what 802.11n is, to see that the 1920s are only capable of 300 Mbps aggregate data rates, meaning you will only ever get 150 Mbps max. The 802.11ac standard defines Very High Throughput wireless networks, or VHT. Just make sure you keep track of the correct columns and rows on the table. Now is when you take the frame overhead into account. So just like a 1 Gbps link is never going to actually get a full 1 Gbps data rate, a wireless connection is never going to get the full 150 Mbps we are talking about here.

                       

                      Another thing you will notice on that table which Doug and Chris have both alluded to, is that you must use 40 MHz wide channels to get the highest data rates from 802.11n. The 802.11ac amendment further increases these channel widths. Packet aggregation is used to combine smaller frames into a larger frame which reduces additional overhead introduced by the physical and virtual carrier sense mechanisms of wireless networks. The CSMA/CA mechanism in 802.11 networks is what makes this whole thing work. Unlike LAN technologies which have collision detection, WLAN technologies use collision avoidance, hence more overhead. I hope that sheds some light on the "overhead" part of this.

                       

                      That is a lot of information to take in, so if you got to this point basically I just want to confirm that Chris and Doug have given you some excellent suggestions. Use a 5 GHz only SSID with both 40 MHz channel mode and packet aggregation enabled. If you have a decent RF environment and minimal clients on the AP, then you should get much higher data rates.

                      1 of 1 people found this helpful
                        • Re: Poor performance (BSAP-1920's)
                          cj! Beta_User

                          Thanks for the expert info, dougfravel and daniel.blackmon.  My experience with 1920 BSAPs using 40 MHz mode on the 5 GHz radio has been positive, but I'm hoping we can pick up a couple of 802.11ac BSAPs for "internal testing." 

                           

                          Chris

                            • Re: Poor performance (BSAP-1920's)
                              daniel.blackmon Employee

                              Thanks to you for being an active member on the forums. The suggestions you gave above were spot on, so hopefully the additional information helps if you're ever faced with these questions again. With 802.11ac wave 2 things are going to get even more interesting. That will introduce MU-MIMO and 160 MHz channels. The latter is basically going to do to the 5 GHz spectrum what 40 MHz channels did to the 2.4 GHz spectrum, but in the right deployment wireless speeds will see some significant improvements. If I had any sway over who got test equipment, then you would be on the list of invitees.

                            • Re: Poor performance (BSAP-1920's)
                              milehijones New Member

                              Folks - I went through and disabled the 2.4 Ghz Radio mode - no clients were using that.  The 5 Ghz configuration had "Enable 40 Mhz Mode" already enabled but it did not have "Packet Aggregation" enabled so I enabled that and applied that. 

                               

                              I will do some testing when I get onsite again to see if it helps.

                               

                              Thanks!  More to come....

                               

                              Brian

                              • Re: Poor performance (BSAP-1920's)
                                milehijones New Member

                                Well - I had to re-enable the 2.4 Ghz Radio mode for some users who simply refuse to upgrade their devices, but having "Packet Aggregation" enabled makes a huge difference.  Why would that little beauty of a setting be enabled by default?

                                 

                                Screen Shot 2015-07-14 at 11.34.11 AM.png

                                  • Re: Poor performance (BSAP-1920's)
                                    daniel.blackmon Employee

                                    Packet aggregation was disabled historically because some legacy clients may have a negative impact when it is enabled. It is easier to suggest enabling it for speeds than disabling it for other reasons. At least that has been my experience. So in saying that, if you have people who refuse to upgrade their devices, you might want to be careful using packet aggregation on the 2.4 GHz radio. The 5 GHz radio should work just fine with packet aggregation enabled.

                                     

                                    In any case, I'm glad we got you some helpful answers. Would you be so kind as to mark the helpful responses or even possibly a correct answer so that other users can find the useful information more easily? Possibly even mark it answered if you feel like you have gotten the information you needed.