11 Replies Latest reply on Mar 9, 2016 5:45 AM by mrkurt

    Routing calls with International Call Prefixes

    mrkurt New Member

      I have an Atlas 550 with a number type template set for international calls as Prefix '00', Pattern 'X$'.

       

      I would like keep the '00' prefix and country code on incoming international calls when I route them over one of my two outgoing T1s. Is this possible?

       

      Thanks for any help!

        • Re: Routing calls with International Call Prefixes
          patrick Employee

          Thank you for using the ADTRAN Support Community Forum.

           

          When your NETWORK TERM PRI is configured with "Outgoing Number Conv." set to "As Dialed" the ATLAS will use the NUMBER TYPE TEMPLATE under the DIAL PLAN and GLOBAL PARAM.

          In the NUMBER TYPE TEMPLATE, anything in the PREFIX column is not passed. So in order to send the "00" out your other T1s you need to leave the PREFIX column empty and put the "00" as part of the PATTERN. So your pattern will become "00X$" instead of "X$" with "00" in the PREFIX.

           

          Hope this helps,

          Patrick

            • Re: Routing calls with International Call Prefixes
              mrkurt New Member

              Hi Patrick,

              Thanks I do understand that. So my question in other words is: Is there anyway to make an exception for the T1 so that the 00 prefix is sent to it and not on the E1 (or other T1)? Number Type Templates being a 'Global Param' indicates that this is not possible but I am interested if there is a work around.

               

              Kind Regards,

              Dave

                • Re: Routing calls with International Call Prefixes
                  patrick Employee

                  If the "other T1 or E1" is another NETWORK TERM entry, then you try changing the OUTGOING NUMBER CONV. on it to NATIONAL, or one of the other options besides "As Dialed".

                  If it is not a NETWORK TERM entry then your only option is to set up a SUBSTITUTION TEMPLATE, but I don't know if the number pattern is consistent enough for you to specify which numbers get a "00" added to the beginning and which do not. If all outbound numbers need the "00" added then the DNIS ORIGINAL NUMBER can be "$" and the SUBSTITUTE NUMBER can be "00$".

                  1 of 1 people found this helpful
                    • Re: Routing calls with International Call Prefixes
                      mrkurt New Member

                      The international calls come in on the NETWORK TERM E1, and I want to send them out a USER TERM T1. So I will see what I can do with Substitution.

                      Would you be able to review the attached logs to double check that the International calls are correctly going out as an International Number Type?

                        • Re: Routing calls with International Call Prefixes
                          patrick Employee

                          In the log, the call is FROM an international number but the called party number is a 6-digit number tagged as an UNKNOWN number type.

                          The ATLAS then sends both the CALLING and CALLED party numbers as number types of NATIONAL (and only sends a 3-digit CALLED PARTY NUMBER). So I do not believe it is doing what you want.

                            • Re: Routing calls with International Call Prefixes
                              mrkurt New Member

                              The call is going to the right place. ( the 3-digit CALLED PARTY NUMBER is its where i need it to go). How can I get the Atlas to send call as International?

                                • Re: Routing calls with International Call Prefixes
                                  patrick Employee

                                  Are you saying you need the 3-digit number presented with a CALL TYPE of International?

                                    • Re: Routing calls with International Call Prefixes
                                      mrkurt New Member

                                      The 6-digit number is the DNIS of the incoming call from a ISDN trunk. I am substituting the 6-digit DNIS for a 3-digit DNIS which is a extension on the PBX. What is important is that when calls arrive at the destination the National calls can be differentiated from the International calls. So International calls need to forward on with a CALL TYPE of International (or with an ANI of 00+Country Code).

                                        • Re: Routing calls with International Call Prefixes
                                          patrick Employee

                                          Thank you. I was trying to figure out WHAT needed to be a NUMBER TYPE of INTERNATIONAL. The ATLAS is not receiving the "00" in the ANI so there isn't a good way to add it on the outgoing call.

                                          Would you mind attaching a copy of the ATLAS 550 configuration for me to look over? I need to look and see why the number type was changed from INTERNATIONAL to NATIONAL by the ATLAS. There must be a pattern in the NUMBER TYPE TEMPLATE that it is matching.

                                           

                                           

                                          Thanks,

                                          Patrick

                                          • Re: Routing calls with International Call Prefixes
                                            patrick Employee

                                            I looked over your configuration, and it's not making any sense. The ATLAS doesn't appear to be following the NUMBER TYPE TEMPLATE at all. Verify the firmware the ATLAS is running is FW=C.09.04. When the PRI can be taken down, change the OUTGOING NUMBER CONV (change it to anything else), back out to the main menu, then go back into the NETWORK TERM and change it back to AS DIALED, and back out to the main menu again. Each time you make a change to the IFCE CONFIG it will reset the D-channel, so be aware.

                                             

                                            After that if the ATLAS is still setting the NUMBER TYPES to NATIONAL, then try setting up a new pattern with nothing in the prefix column, and "X$" as the PATTERN, with the TYPE set to INTERNATIONAL.

                                              • Re: Routing calls with International Call Prefixes
                                                mrkurt New Member

                                                The firmware the ATLAS is running is FW=C.09.04.

                                                I then tried changing and returning the the OUTGOING NUMBER CONV to AS DIALED. But nothing changed, same problem.


                                                Then as you advised I added new pattern with nothing in the prefix column, and "X$" as the PATTERN, with the TYPE set to INTERNATIONAL and that did the trick!


                                                I have since changed the pattern to XXXXXXXXX$ to avoid internal extensions matching as International. But thanks for the help on this one!