3 Replies Latest reply on Mar 28, 2016 8:51 AM by jlanning

    PRI Delay

    jlanning New Member

      First let me thanks for any help I can get here.  I have a 908e and am very new with the Adtran brand.  What I am trying to accomplish is receiving a SIP connection from my carrier and then pass off a PRI to my Asterisk server (going to be a shortel system eventually).  I have things working kind of but I get a 2 second or so delay when dialing in, and all audio is delayed for 2 seconds at least.

       

      Here is my config. any help would be greatly appreciated.

       

      interface t1 0/1

        fdl none

        tdm-group 1 timeslots 1,24 speed 64

        no shutdown

       

      interface pri 1

        description pri 1

        connect t1 0/1 tdm-group 1

        no shutdown

       

      isdn-group 1

        connect pri 1

       

      no tftp server

      no tftp server overwrite

      http server

      http secure-server

      no snmp agent

      no ip ftp server

      no ip scp server

      no ip sntp server

       

      sip

      sip udp 5060

      no sip tcp

       

      voice feature-mode network

      voice forward-mode network

       

      voice dial-plan 2 local NXX-NXX-XXXX

       

      voice trunk T01 type sip

        description "Carrier 1"

        sip-server primary x.x.x.x

        max-number-calls 24

       

      voice trunk T02 type isdn

        description "PRI"

        resource-selection circular descending

        connect isdn-group 1

        rtp delay-mode adaptive

       

      voice trunk T03 type sip

        description "Carrier 2"

        sip-server primary x.x.x.x

       

      voice trunk T04 type sip

        description "Carrier 3"

        sip-server primary x.x.x.x

       

      voice grouped-trunk TRUNK

        trunk T01

        accept $ cost 0

       

      voice grouped-trunk TRUNKPRI

        trunk T02

        accept $ cost 0

        • Re: PRI Delay
          jayh Hall_of_Fame

          Try adding the following two commands to the PRI interface:

           

          interface pri 1

            isdn name-delivery setup

            calling-party name-facility-timeout 1


          This kind of delay on a PRI connection is often due to the Adtran device waiting on CNAM from the PBX that is never sent. The above should greatly reduce or eliminate it.

            • Re: PRI Delay
              jlanning New Member

              My device doesn't have the calling-party name-facility-timeout command in it.  Here is the Adtran version I am running.

               

               

              TA908e#show version

              ADTRAN, Inc. OS version R11.10.1.E

                Mainline Version: ENM.15.156

                P4 Changelist: 234321

                Checksum: f3e5fce24e832d633530f06d03366b3ad08cdbef92bd6090d4430cbb1a3e71ef

                Built on: Tue Jan 26 17:46:49 CST 2016

              Hardware version R.1.5.0.0-0

              Boot ROM version R10.9.3.B2

                Built on: Mon Jul  6 16:47:40 CDT 2015

                Compatibility Version: 1

              Copyright (c) 1999-2016, ADTRAN, Inc.

              Platform: Total Access 908e (3rd Gen), part number

              Serial number

              Flash: 97120256 bytes  DRAM: 509648896 bytes

               

               

              TA908e uptime is 0 days, 0 hours, 4 minutes, 6 seconds

               

               

              slot 0, DSP 1

                DSP software version: G3.R1.3..0-R

                DSP hardware version: Freescale BSC9131

                Total channels: 60

               

               

              System returned to ROM by Soft Reset

              Current system image file is "T900E3A-R11-10-1-E.biz"

              Boot system image file is "T900E3A-R11-10-1-E.biz"

              Primary system configuration file is "startup-config"

            • Re: PRI Delay
              jlanning New Member

              After having issues with getting a license error after upgrading the firmware so I called support.  They found that the Adtran was trying to send calls from one SIP trunk to another SIP trunk and that was causing the delay.  to do this we had to add a permit and deny to each trunk group.

               

              Thanks for your help.