5 Replies Latest reply on May 9, 2017 8:14 AM by jayh

    Polycom IP 650 Issues with handsfree tone

    nathanscott New Member

      When a user on Polycom IP 650 try's to use hands free dialing with the spree code **, the phone will show the two digits as a +.  When the hands free call establishes a connection there is not tone before the call completes.  This started happened after updating the Polycoms IP 650, Adtran 712, VXX 400, and the Adtran 7100 to the newest firmware's provided by Adtran and Polycom.  Handfree calls between Adtrans, and call between Adtran to VXX400 are producing the hands free tone, and this problem is isolated to just the IP 650 to other phones on the system.

       

      Polycom IP 650 Firmware: 4.0.9.1191

      Adtran 7100 Firmware: R11.10.7.HA.E

       

      Thank you,

      --Nate

        • Re: Polycom IP 650 Issues with handsfree tone
          jayh Hall_of_Fame

          This is a new Polycom feature to send a "+" representing the e.164 "country code follows" dial plan. It's described in their release notes.

           

          35157 Added ability to dial '+' character by pressing '*' twice for international dialing.

           

          The same feature is found on most cell phones with a long press of the "0" key.

           

          I don't immediately see a way to disable it in the Polycom XML but this may be possible. You'll have to ask Polycom.

           

          Can you re-map SPRE ** to something else?

          1 of 1 people found this helpful
            • Re: Polycom IP 650 Issues with handsfree tone
              nathanscott New Member

              Its been a while since I have done a re-map of SPRE codes, could you send me a KB or example on how too.  I found the following but want to confirm that it is correct: Configuring SPRE Mapping in AOS

               

              Thank you,

              --Nate

              • Re: Polycom IP 650 Issues with handsfree tone
                alanb New Member

                I'd also like to know how to remap the ** for handsfree dialing.  We need this capability.

                 

                I've referred to the ADTRAN OPERATING SYSTEM (AOS) Command Reference Guide for AOS Version R10.1.0 and do not see an entry for hands free dialing in the voice spre-map list so I'm not even sure what the function name for Handsfree Dialing is.

                  • Re: Polycom IP 650 Issues with handsfree tone
                    nathanscott New Member

                    Hey Alan,

                     

                    I ended up modifying the adtran_customer.txt file to resolve my issues with hands free.

                     

                    Before:

                    SntpServer XXX.XXX.XXX.XXX

                    BackLight 120

                    DialDelayPBX 10

                    GmtOffset -0500

                    HfaaiEnable True

                    HfaaiBeep True

                    SpreHfaai **

                    RingerLevels 410,579,817,1154,1631,2303,3254,4596,6492,9170

                    ToneDefine 1,0,0,0,0,0,0,0,0,1,00x0000,10,1,0,10,0,0

                    ToneMap Wait,1

                     

                    After:

                    SntpServer XXX.XXX.XXX.XXX

                    BackLight 120

                    DialDelayPBX 10

                    GmtOffset -0500

                    HfaaiEnable True

                    SpreHfaai **

                     

                    I'm do not know witch one of these settings removed fixed the issue because of my lack of knowledge of the features removed.  I don't know if Jay or other could shed some light on these features and what may have resolved the issue.

                     

                    --Nate

                      • Re: Polycom IP 650 Issues with handsfree tone
                        jayh Hall_of_Fame

                        nathanscott wrote:

                         

                         

                        I'm do not know witch one of these settings removed fixed the issue because of my lack of knowledge of the features removed. I don't know if Jay or other could shed some light on these features and what may have resolved the issue.

                         

                        --Nate

                        I suspect that you just got lucky and that there's a timing issue or race condition that caused it to work. In my opinion the correct fix would be to edit the Polycom XML configuration file to remove the new feature mapping ** to the leading + for e.164 international dialing. You would need to consult Polycom literature for that and modify the configuration that the phones pull via TFTP on startup.

                         

                        While the ability to insert the + character into a dial string may be a nice-to-have feature, it will be little used unless the user of that Polycom phone regularly transports the physical phone between countries with different dial plans. People manually dialing normally just use the "Country code follows" string when placing an international call, for example, 0-1-1 in NANPA countries and 0-0 in much of Europe.