0 Replies Latest reply on Jun 21, 2017 7:44 AM by ehouser

    2030 AP randomly sending Deauth packet to STAs not associated to it with reason code 6

    ehouser New Member

      I have a customer with an issue with client laptops who frequently roam being disconnected from their apps.  We attached a Fluke Airtouch device to assist in troubleshooting and using MetaGeek EyePA to capture the traffic.  The VWLAN is version 2.9.0.HA build 269529 and APs are version 2.9.0-HB-635318.  This problem has been occurring since 2.5 and not new to 2.9.  The test I am running is an AP Range Test where the test equipment connects to a specified AP and will not roam intentionally to test the range for one specific AP.  During this test the device will continuously PING a device to get feedback such as re-transmissions, connection PHY rate etc.  During this test, it will just lose all L3 connectivity and PINGs drop to zero but still show associated.  After looking at the capture, I notice a DEAUTH packet coming from a neighboring AP with reason code 6.  This will happen each and every time and easily replicated but I do not understand why the AP will send the DEAUTH.  I cannot say for sure, but if this is what is happening to roaming devices such as Apple devices and laptops, this would definately cause what they are seeing.  The reason code specifies a "class 2 frame was received from a non-authenticated device" when in fact I am authenticated.

       

      Anyone else ever see this or have input for the probable cause?