3 Replies Latest reply on Jul 10, 2017 5:40 AM by alanb

    DND disabled in COS does not work

    alanb New Member

      Recently, I had an issue with one of our operator desk sets accidentally placed in DND.  The desk set is a Polycom VVX400.  There are two on the counter and, because if this, the operator sometimes cannot see the red X displayed when the phone is in DND.

       

      Since there is never an instance when these desk sets should be set to DND, I decided to create a new Class of Service which does not have DND enabled and apply that COS to each of the operator consoles.  I double checked that I'd applied the new COS to the accounts but the setting does not seem to have an effect.

       

      7100 Series running R11.10.7.HA.E.

       

      (I am aware of the Polycom config feature.doNotDisturb.enable="0" but prefer to handle in the Adtran.)

       

      Can anyone else confirm this?

       

      Thanks!

        • Re: DND disabled in COS does not work
          jayh Hall_of_Fame

          alanb wrote:

           

          (I am aware of the Polycom config feature.doNotDisturb.enable="0" but prefer to handle in the Adtran.)

           

          Can anyone else confirm this?

           

          Thanks!

          You really need to do both. Polycom phones have a built-in DND feature on the phone itself regardless of whether it is implemented in the PBX. If you disable it in the 7100, the user can still locally set DND on the phone.

           

          Then when a call comes in the 7100 processes the call and  sends it to the phone but it simply doesn't ring because of the local Polycom DND implementation regardless of the setting on the 7100.

           

          On the Polycom XML, set:

           

          feature.doNotDisturb.enable="0"

           

          in addition to disabling it on the 7100.

           

          There are other settings that can just hide the DND softkey, but these are rather model and firmware specific on the Polycom.

           

           

          • Re: DND disabled in COS does not work
            dmac New Member

            We played with this a year or so back. We are using Polycom VVX300 phones and people would accidently hit the DND button and then place a helpdesk call that their phone doesn't receive incoming calls. We have tried educating the users to check the DND before opening a ticket but it didn't help. fo a while we just remotely re-booted the phone but the best workaround I have found is to remove the DND button from the main home screen on the phone. It is still available by going through the menu. In order to do this we had to install a newer version of the firmware, ver5.2.0 that for some reason Adtran doesn't support anything above 4.1.8. Search on "Remove DND Softkey on Polycom VVX300". The biggest downside is that you need to change the Polycom admin password on the phones otherwise there is a warning indicator that flashes where the time is displayed which is requesting that the password be changed from the default 456 password. The user complained about the warning message also.This is part of the newer firmware as a security measure. You can change the admin password in the "IP Phone Globals" under the "Boot Settings" tab. Change it in both the "Local Phones" and "Remote Phones". I have not seen any other issues using the newer firmware.

             

                    Doug

            • Re: DND disabled in COS does not work
              alanb New Member

              Thanks to both you for those answers.

               

              dmac, I experienced everything you said in my attempts to get this working.  After including above referenced XML feature tag in the [ext]-[macid].cfg file with no change, I tried incrementally upgrading a test VVX-300 phone to get feature.doNotDisturb.enable="0" working with the 7100 and found that some versions were very problematic.  The phone would appear (ie.:  it would register with the 7100 and the buttons would appear on the display) but further inspection would reveal that, while internal calls seemed to function OK, external calls were intermittent - audio would be on some calls but not others.  I believe this was Polycom version 5.3.1.0436.  The very latest version fetched from the Polycom servers (5.5.2.8571) seems to function well with the 7100, however.  (As I remember, the DND disable feature did start working around Polycom version 5.2 or so as dmac claims.)

               

              Other than the admonishment for leaving the admin password set to default, web access is also restricted by default to https:// only.  Since the admin password is so commonly available on the Internet, some might be better off changing it and that's what I did.  (I did have issues with doing so via the web browser so I did it locally on the phone.)  If you have no problem with using non-secure web access, that restriction can be turned off on the phone allowing http:// access again.

               

              Thanks for both your answers, jayh and dmac.  They were both correct and helpful.