3 Replies Latest reply on Sep 29, 2017 1:19 PM by tgordon78

    908e and cisco vwic3

    tgordon78 New Member

      Hi Group,

       

      I am working with a customer that is switching their telephone company.  They are going from a traditional T1/PRI connected to a smart jack.  New connection is SIP based to a 908e, with T1/PRI interface.  No issues connecting to the traditional PRI(no errors, slips, etc).  The card in the cisco router is a vwic3-mft-t1/e1 configured as t1.  When we connect the interface to the Adtran(tried t1 crossover and straight) the link does not come up.  After a reboot on the cisco router, the link came up using a t1 crossover, but if we unplug the interface and plug it back in, it never comes back.  The customer had an older router with a VWIC2-mft-t1/e1, and that card worked without any issues in the same router.  They have 2 sites, and they both act the same exact way, so it seems to be specific to the VWIC3 card.  I have no visibility into the 908e, but the cisco side just shows line code errors incrementing at a very quick rate.  Both sides configured B8ZS and ESF.  Again, VWIC2 works fine with the same exact configuration, so I don't think it is a configuration issue.  Anyone every seen anything like this.


      Thanks in Advance,

      Tom

        • Re: 908e and cisco vwic3
          jayh Hall_of_Fame

          This sounds like a compatibility or configuration problem on the Cisco side. You didn't specify the Cisco router model or IOS version, this may be useful.

           

          I'd look at (usual stuff...):

           

          * Triple-check the integrity of your T1 crossover cable

          * Verify card type setting on Cisco is T1 and not E1

          * channel-group set correctly for timeslots 1-24

          * Verify timing is set as internal on one side and line on the other

          * Cisco typically numbers channels 0-23 so D-channel should be on 23 for Cisco

          * One side ISDN role network, other user

           

          Does the T1 physical not come up, or is the T1 up but not the PRI? Will it come up on the Cisco with a loopback plug? Any useful debug messages on either side?

            • Re: 908e and cisco vwic3
              tgordon78 New Member

              Thanks for the response.

               

              T1 and PRI comes up after the router is rebooted.  If the t1 cable is unplugged and plugged back in, it never comes back up until a reboot.  When we use a vwic2 instead of a vwic3 in the same router with the same exact configuration it works fine, so I would assume the cable is good.  The vwic3 works fine when connected to the current Telco which utilizes a traditional T1 over smartjack.  Loopback works fine on both sides.  It really seems to be a compatibility issue with the vwic3 and the 908e.  No debug info on the cisco side other than line code errors.  Router is 2921 with 154-3-M5. I searched on cisco's bug toolkit and could not find any bugs.

               

              Thanks again for the assistance

                • Re: 908e and cisco vwic3
                  tgordon78 New Member

                  Seems like there is a workaround on the cisco router to address this.  After searching the cisco bug toolkit again using different keywords, I was able to find a bug.  Seems to be if the T1 is slightly out of the t1.403 specifications this happens.  And the bug affects the vwic3 card and not vwic2 card, so it matches our symptom.  I am just waiting on the customer to see if this does fix the issue.  Info is below in case anyone stumbles across this thread with the same issue.

                   

                  CSCua50697

                  Symptom:

                  After unplugging and reconnecting a T1 cable, the T1 controller remains down or report continuous errors. After a router reload, the T1 controller remains up until the cable is disconnected again.

                   

                   

                  Conditions:

                  This symptom affects only the following cards: HWIC-xCE1T1-PRI,NM-8CE1T1-PRI, VWIC3-xMFT-T1/E1, and GRWIC-xCE1T1-PRI. Also, the T1 signal must be somewhat out-of-specification according to T1.403 standards.

                   

                   

                  Workaround 1: Reload the router with the T1 cable plugged in.

                   

                   

                  Workaround 2:

                    Step 1)  Upgrade to a fixed-in Cisco IOS version.

                    Step 2)  Issue the following commands (hidden, so tab complete will not work):

                   

                      enable

                      config t

                      controller  ! ( example: controller t1 0/0/0 )
                      hwic_t1e1 equalize

                   

                    Step 3)  Shut/no shut the T1 controller, or reload the router to allow the CLI to take effect.