1 Reply Latest reply on Sep 6, 2018 3:28 PM by geo

    Cannot get DoNotDisturb SPRE code to work.

    marks-iw New Member

      Hello,

       

      I searched the forum for posts about SPRE and just couldn't find something that applies to my case enough to help me.

       

      I have a 924e, 2nd Gen, running ADTRAN, Inc. OS version R13.2.2.E . I have POTS phones connected to the FXS ports. They connect to a SIP trunk I have with another system. I don't think the SIP trunking really applies a whole lot yet, though, because I am trying to handle the DND SPRE code locally. As I understand it, if I get the SPRE DND code to work, it basically will just refuse calls to the extension in question. And if I get it to work, then when the extension has DND ENABLED, it will look like this:

      iw-apsdim-testadtran#show voice ext

       

       

      AccountID     Idle/Ring/Busy    Available       DND      FWD

      --------------------------------------------------------------------------------

      7001002602         Idle             *            *        -

       

      and when the extension has DND DISABLED, it will look like this:

      iw-apsdim-testadtran#show voice ext

       

       

      AccountID     Idle/Ring/Busy    Available       DND      FWD

      --------------------------------------------------------------------------------

      7001002602         Idle             *            -        -

       

      (In other words the DND status will show a * instead of a - in the "show voice ext" output)

       

      I've tried a lot of combinations of dial plan entries and SPRE IDs and SPRE remapping and just can't get anything to work. Initially I wanted to remap this so dialing *78 would toggle DND, but even the default of *39 doesn't work.
      I feel like there is some fundamental thing I am getting wrong, or misunderstanding. Perhaps I am just totally wrong in thinking that this is what SPRE is for? Or maybe the DND feature is not something my unit can do or that I have enabled or something? At my wits end with this thing. I can post configs and try any suggestions of course...would love to see a config someone has where this functionality works.

        • Re: Cannot get DoNotDisturb SPRE code to work.
          geo Employee

          Hello and thanks for posting.

           

          ADTRAN IPBGs can only handle a few SPRE codes locally:

           

          Currently, the only SPRE codes that can be supported locally on an ADTRAN IPBG are:

           

          *22 Conference (R10.9.4 and later)

          *67 Block Caller-ID delivery for this call only (A2.03.00 and later)

          *69 Call Return (A2.03.00 and later)

          *70 Disable Call Waiting on a per call basis (A2.03.00 and later)

          *72 Call last dialed number (A2.03.00 and later)

          *88 Transfer (R10.9.4 and later)

           

          I believe you are correct in thinking *39 is for DND.  I am not sure how your phones work/interact with the SIP Server, but the only thing the ADTRAN can do with *39 is pass it out the SIP trunk.

           

          Let me know if you have further questions.

           

          Regards,

          Geoff